View Full Version : P4wnP1 A.L.O.A. 2022.03 - UDC driver not found when deploying USB settings. Fix found.

2022-10-23, 21:26

As the title says. When using the P4wnP1 A.L.O.A 2022.03 image on a pi zero w from https://www.kali.org/get-kali/#kali-arm, it doesn't let me deploy any USB configuration, instead reverting to last configuration everytime with a message saying "couldn't find a working UDC driver".

I plugged the MicroSD card into my PC and explored the boot partition. Inside it are two files, "cmdline.txt" and "config.txt". I added "modules-load=dwc2" after "rootwait" into the former, and added "dtoverlay=dwc2" under "[all]" into the latter.

After that I booted the pi. Got into the admin page, tried changing values and settings. Deployed. It worked.

Will this be fixed or is it intended behavior? If not intended, the fix that worked for me is written right there.


Edit: Fixed my mistake. It's "cmdline.txt", not "commandline.txt"

Jim Ko
2022-11-19, 04:00
Hello, I am also facing the similar issue.

When I try to deply the USB Gadget setting, I receive the following error message

rpc error: code = Unknown desc = Deploying new gadget settings failed, reverted to old ones: couldn't find working

UDC driver

So I following your step and change the txt file below.

In the cmdline.txt (I cannot find the commandline.txt), I change the command to;
console=serial0,115200 console=tty1 root=PARTUUID=d0a4e52d-02 rootfstype=ext4 fsck.repair=yes modules-load=dwc2 rootwait net.ifnames=0

In the config.txt file, I added the #dtoverlay=dwc2 according to your suggestion.


However, I still received the same error message. Do you have any idea?

Thank you

Fred Sheehan
2022-11-22, 02:19
Leave out the hash sign # at the front of your change;


a hash in front means it is a code comment and so will be ignored!

2022-11-22, 05:13
Yeah, my bad, it is indeed "cmdline.txt".

You should place modules-load=dwc2 AFTER rootwait.

You should also remove the "#" from #dtoverlay=dwc2 in config.txt, since the "#" turns the line into a comment, which will then be ignored and thus not activated/loaded.

Best of luck.


2023-01-03, 06:02
I added both of those lines to their respective files but I keep getting "Unknown USB Device (Device Descriptor Request Failed)" in Windows Device Manager. I can't deploy HID scripts because of this. I've tried different computers, different cables, different USB ports, and changing the product ID but I can't get my computer to recognize the Pi Zero W. Ever come across this?

2023-01-09, 18:03
I fixed the issue. Turns out it wasn't software related. I had a USB stem soldered on to the zero. When I took a picture of the pads with my phone I noticed I didn't clean up the pads well enough when I removed the stem. A little rework with some wick and the zero is working great now.

2023-02-06, 13:32
It seems like you've already found a solution to your issue, which is adding the "modules-load=dwc2" line to the cmdline.txt file and the "dtoverlay=dwc2" line to the config.txt file. It's likely that this was a known issue that has since been resolved in later versions of the P4wnP1 A.L.O.A image. However, if you continue to experience this issue in future versions, the fix you found should still work.