View Full Version : NetHunter for OnePlus Nord CE ?

2022-11-01, 09:11
Hi everybody,

I'm a newbie in this forum and in this theme.
I use a OnePlus Nord CE with lineage.os 18.1 and have installed Nethunter.
Well. it works, but I ran in some problems with the dns inside the terminal.
After I asked for help in another forum, I was told that Nethunter is not official released for the Nord CE, even for the normal Nord and that would be the reason for my issues.

Is that right?
And is there any hope to make a release for the Nord CE?

Thanks a lot in advanced,


Fred Sheehan
2022-11-07, 04:14
If you have a Lineage OS then your rooted and so nethunter should work well, you don't need it to be compiled specifically for your device.

You didn't say what the DNS problems you had were, worthy of note however, is that nethunter gets a virtual internet connection bridged from the host OS (your lineage install)...

2022-11-09, 22:00
Hi Fred,
thank you for your answer.
This is the description of the problem:

When I use ifconfig everything seems ok, I got an IP address from my router.
It's just inside the terminal. Everything else where I need an internet connection is working fine.
Also for example nmap scan of the open ports is working. It answered first with a warning that there is no DNS, but it worked. After I use the --dns-servers attribute (forgot the right word for it) the message didn't come again.

Next strange thing: The ping
I'm not able to ping anything inside or outside the network.
I got this message:
ping: socket: permission denied (but of course I am root)
Sometimes it worked when I use sudo before ping, but only when I try to ping the Gateway and then I get the same failure with the dns.
When I use nmap for a ping it looks like it is working.
Even a portscan works fine.

Do you have any idea?


Fred Sheehan
2022-11-15, 13:14

2022-11-16, 13:32
Hi Fred,

that unfortunatelly doesn't work.
The errormessage I got:
First with systemctl restart ...
"Running in chroot, ignoring command 'restart' "

Then I tried:
service restart NetworkManager
"restart unrecognized service"