View Full Version : Chromebook reboots during dd to sdcard

2013-03-14, 18:13
I downloaded and gunzipped the chromebook image on my chromebook (in dev mode) and used the command in the documentation (http://docs.kali.org/armel-armhf/install-kali-samsung-chromebook)to try to put the image on a Lexar class 10 micro SD card in a Nexxtech sd adaptor. I used /dev/mmcblk1 as that is the device for sd cards on the chomebook. (making sure any existing partitions are unmounted)

Enter after being in dev mode, open the browser, press Ctrl + Alt + T to get a terminal
Then the commands are:

sudo su -
cd /home/chronos/user/Downloads
gunzip kali-linux-1.0-armhf-chrome.img.gz
umount /dev/mmcblk1*
dd if=kali-linux-1.0-armhf-chrome.img of=/dev/mmcblk1 bs=512k

After issuing that command, about 4-5 minutes into the write, the chromebook reboots.
I Log back into it and the chrome browser complains it was not closed properly.

So couple questions...
Is this process tested on the chromebook itself?
Is that supposed to happen? :)
Am I supposed to do it on another linux system?
Anyone having success or similar troubles?

2013-03-14, 21:44
I don't know why this happened. I tried it more than once. I have tried a different SD Card since then and it still happens. (when doing the dd on the chromebook itself)

But if I do the DD process on my laptop running Ubuntu 12.04 it transfers fine and then I finish the process as described in the documentation with good results.
The system then boots and I have the system running. Very nice so far BTW

2013-03-14, 23:49
I saw the same thing. I ended up using win32 imager on my windows box to image the SD card.

2013-03-19, 03:19
I also had this issue. I believe it has something to do with some sort of automated logout due to inactivity in the terminal. I was in the process of using dd to place the image on an SD card and my entire screen blanked. It rebooted and the ChromeOS came up fine, the dd process wasn't completed though. I went through the same process again and during the dd copy process I kept running my finger across the Touch Pad every few minutes. The second time it worked.

2013-09-01, 02:02

This issue plagued me constantly until recently. Try running "stop powerd" before the dd. Should work like a charm and then you can run the entire kali sdcard install process without leaving the chromebook.

2013-09-01, 16:16
So although I was sure that worked for me in the past, it now seems a bit premature. While trying to reproduce the process last night I was in random reboot ****. Now I've found a legit process to prevent those horrible reboots during the dd. "stop powerd" will prevent the chromebook from sleeping and thus is necessary to keep things running without constant supervision. Since this issue is indicative of a hard fail with the reboot, I assumed there was an I/O conflict somewhere. I initially tried with the nonblock flags but still got the old nasty reboot. Trying again with the dsync flags worked!

dd if=kali-linux-1.0.4-armhf-chromebook.img iflag=dsync of=/dev/mmcblk1 oflag=dsync bs=512k

suck it robots.