View Full Version : Working with Kali ARM Images

2013-02-01, 15:03
Kali ARM images are built using live-build, and are compressed in a squashfs image. Some arm installations require that you extract the ARM image filesystem on to a USB drive or SD card.

To read the full document, check our Working with Kali ARM Images (http://docs.kali.org/armel-armhf/working-with-kali-arm-images) article.

If you have any issues with this procedure, please post them in this thread.

2013-03-13, 23:23

Error 404...

2013-03-28, 05:05
Try this one and see if this is what you are looking for:

Top level on docs site:

Preparing a Kali Linux ARM chroot:

2013-04-02, 11:01
When i try to unzip the armel i get an error while extracting. I am using Ubuntu 12.10 on a dell inspiron 1545. I had no problems running under VM (not that it relates). Just the armel is giving me issues. Any further direction on how to compile the armel to an SD for use with my nokia n900 would be very helpful, just so i don't brick up my devise.


get output with ~$ gunzip (file.gz)-----> gzip: kali-linux-1.0-armhf.img.gz: unexpected end of file. Might their be tools i am missing or am just missing something right in front of my face. Any help or facepalm would be great i belive i am the only person looking for this info. PST ASAP

2013-04-07, 00:29
I used Ubuntu 12.04 to unpack this and didn't have any issues. I know that doesn't really help, sorry.

2013-04-08, 10:19
What was the method,you used, for unziping and were you working with the kali iso or the armel/hf

2014-01-18, 13:56
How can i boot N900(arm cortex-A8) on to KALI?
I installed u-boot and extract arm image on SD card.

2015-08-14, 11:44
have you guys eve tried to run the arm version on ubuntu touch?

2017-01-25, 02:24
@PWN900: When you downloaded something check the MD5Sum or SHA1Sum to avoid execration problems.

2020-11-06, 03:09
I have been using Linux on raspberry pi to expand the images. The instructions on the web site say to just dd the image to the SD card, but what works for me is

xzcat mimagefile | dd of=/dev/sda bs=16M

Progress indicators are nice.

To check things, I run

fdisk /dev/sda

And print the partition table without writing it. If it finds a partition table the process probably went well. I should have caught that the image was compressed from the name, and realized that the web page needs to be updated.