View Full Version : wifi problem. "hard blocked: yes"

2023-02-20, 22:06
Hi, mates!

I've a problem with my wifi. Actually, I'm using the Kali Linux on the VirtualBox. My main operacional system is w10. I've bought alfa ralink awus036nh, it does work on w10. But, when I start kali, the ralink doesn't work. wlan0 doesn't show at "ifconfig". it does appear at "iwconfig":

EEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry short long limit:2 RTS thr:off Fragment thr:off
Power Management:off

I've add the Ralink at the USB setup, too.
By the way, when I log the kali linux, the internet connection is lost. It does comes up again just after exit the kali.

With "rfkill list all" it shows "hard blocked: yes". I've tried to "rfkill unblocked all" it still doesn't work.
Should I try something at the BIOS? I don't know what to do!
Please, help!

Fred Sheehan
2023-03-13, 22:20
first off, if you want the usb adapter to be connected to kali, don't plug it in until after kali is running.
If it prompts ypu in virtual box, 'connect this USB to virtual machine'.
It may even be an option in the settings.
If its beiong 'passed through' to kali, then lsusb should show and list usb devices.

At this stage, you may well have to install the linux drivers for your usb adapter to be usuable by kali..
output from lsusb please

Fred Sheehan
2023-03-19, 17:09
You need to leave the USB adapter out of your system completely until you have launched windows, started virtual box and launched Kali and are at the desktop.
Then when youy plug in adapter, virtual box should ask where to connect it, windows or Kali VM..

2023-08-16, 15:31
It seems like you're facing connectivity issues with your Alfa Ralink AWUS036NH USB adapter on Kali Linux within VirtualBox. The adapter appears in "iwconfig" but not in "ifconfig", and you've encountered a "hard blocked" status when using "rfkill list all." To address this:

First, ensure that the Alfa Ralink adapter is properly recognized by the VirtualBox guest. You've mentioned adding it to the USB follow (https://bit.ly/3QJ1rnt) setup, but double-check that it's correctly passed through to the VM.

Verify that the necessary drivers are installed within Kali Linux. Sometimes, additional drivers are required to enable proper functionality.

Since the "hard blocked" status is present, it's worth checking if the adapter's wireless functionality is disabled at the BIOS level. Access your computer's BIOS settings and ensure that the relevant hardware components are enabled.