View Full Version : Bootable USB FAILS except Win32 Disk Imager.

2013-04-05, 17:50

I've tried making bootable usb but failed. First I imaged my 8GB usb with dd method as per Kali documentation. It shows No Installation Media Found error after booting from USB. After that I tried Unetbootin, YUMI and Universal USB Installer but it fails. Only the windows tool mentioned in documentation named "Win32 Disk Imager" works.

Any clue why other methods didn't worked for me?

2013-04-06, 00:58
The "dd" linux utility should have worked. The others don't work that is why the Kali documentation recommends Win32 Disk Imager: http://docs.kali.org/installation/kali-linux-live-usb-install

2013-04-06, 16:56
I have a 16gb USB Flash memory, and as good debianist, I used the dd command to have the iso in the usb, 3 pieces of USB (corsair, kingston and PYN), they all worked fine.

Certainly there must be something wrong with the Filesystem in the usb, and I do not mean the type, I mean that sometimes you have to "fix your USB" by re-creating a new partition abd then format it..

Even if memory is new, never take something for granted.

Do not use any graphical method, use fdisk, create a new partition and then mkfs to format it.


2013-04-07, 05:15
Also, make sure when your format the USB, before putting Kali on that its not NTFS (I've made that mistake before), fat32 should be ok.

2013-04-07, 16:59
I have found that I have to use diskpart to clean the usb thumb before some system will recognize the drive as bootable. If you use unetbootin beaware that the resulting syslinux.cfg is not valid. It would explain that failure. See http://forums.kali.org/archive/index.php/t-195.html on how to fix that issue.

To clean a usb thumb drive in windows:
cmd (run as administrator)
list disk
select disk # where # is the thumb drive
create part prim
format fs=fat32 quit

then use whichever method you want to copy the iso files to the thumb drive.

2013-04-11, 06:39
I've used gparted and mkfs to format as FAT32 beforing imaging with dd but it didn't worked. I can try that again.

@sickness: Please update the documentation and add a note about formatting usb with FAT32 before using dd.