View Full Version : Cannot ssh into raspberry pi zero W

2023-04-27, 18:47
Hi, I was trying to run raspberry pi zero W on kali Linux (https://www.kali.org/get-kali/#kali-arm, Raspberry Pi Zero W) via ssh.
As usual, I created wpa_supplicant.conf and filled out the details, and created an empty file named "ssh" to enable ssh.
raspberry pi zero W connected to WiFi and, after finding out his address using Avast antivirus, tried to ssh into it Code:

ssh kali@(ip_address)

As usual, I needed a password to ssh into it. I tried the password "kali" but I got an error like this: Code:


which I think is about the wrong password. What are your thoughts?

2023-05-27, 14:11
To SSH into your Raspberry Pi Zero W running Kali Linux, you can follow these steps:

Ensure that your Raspberry Pi Zero W is connected to the same Wi-Fi network as your computer.
Find the IP address of your Raspberry Pi Zero W on the network. You mentioned using Avast antivirus to discover the IP address, so you can use that information.
Open a terminal or command prompt on your computer.
Use the SSH command to connect to your Raspberry Pi. Replace <IP_ADDRESS> with the actual IP address of your Pi. The default username is "root" and the default password is "toor" for Kali Linux.

ssh root@<IP_ADDRESS>

If this is your first time connecting to the Raspberry Pi, you may see a security warning asking if you want to continue connecting. Type "yes" to proceed.
Enter the password when prompted (default password: "toor") and press Enter.

After completing these steps, you should be connected to your Raspberry Pi Zero W via SSH, and you can interact with it through the command line remotely.
techbusinesinsider (https://techbusinesinsider.com/)