View Full Version : Kali for raspberry pi zero w not working

2023-06-24, 00:00
Hello there, I'm not sure if this is the correct place to post but I will shoot my shot.

For three days I have been trying to get my raspberry pi zero w to work and connect to my phone hotspot or wifi without succes. I used the Raspberry pi imager and flashed the latest kali version for the board I'm using and I even tried the pi tail version with the pre determined wifi settings in order to see if my wpa_supplicant was the problem. Neither of them ever connected to my phone or wifi. Now I'm not even sure if the os is running correctly. I have flashed the sd card 4 times now to see if there may be a installation error. Currently I am running the borad headless since I dont have a mini hdmi to hdmi. The phone hotspot is from a samsung galaxy s22 i tried both 5 ghz and 2.4. I know 2.4 is the correct one but why not try all I can. The protocols i tried on the phone were: Open, wpa2-personal, and wpa2/wpa3 personal which none of them worked. If this post gets removed or I don't manage to fix it is the only way to check the os to get a mini hdmi to hdmi? I would assume the error is with connecting to the wifi but could be the os since I don't really have a way to check it.

If any kind soul wants to help me or need more information in order to help me solve my case I'm happy to provide more information.

Sorry if the post is a bit messy or not correct I guess it will be removed if it is.