View Full Version : Problem with the Nethunter upgrade from Store

2023-08-24, 11:53
Hello everyone,

I have noticed an issue for the update of the Nethunter version from the Apps Store. I have Nethunter 2023.2 installed on a Oneplus 7 (Oxygen OS 10.0.11, Magisk 26.1, TWRP installed, all this following the tutorial of Kali website).

Since a couple of days the Nethunter version 2023.3 is available, along with the Nethunter Terminal 2023.3. I tried to upgrade if from the App store but I get the error below : "The setup failed for an unknown reason".

I tried to uninstall Nethunter and the Treminal from Android. If I install it manually after that, I can install Nethunter but then the Treminal setup fails with the same error. If I do the opposite and start with the Terminal setup it works but then it is Nethunter that fails to setup with the same error.

(I reintstalled it with the image zip Nethunter2023.2 and it works well as long as I don't update it).

I got the same issue on a Nexus 7 2013 (Lineageos 15.1, Magisk 26.1) : I tried to install the store, and to install Nethunter then from the store, and I got the same error. If I try the setup differently and I flash the image zip of Nethunter for Nexus 7 from Magisk (as a module) the setup works, but then I cannot upgrade to 2023.3 with the same error message.

Also there are some apps that don't want to be installed from the store (ex. Snoopsnitch or Intercept ng: nothing happens when I click on "Install") while some other applications install without problem (Hijacker for instance). However I managed to install these apps by getting the apk from the web, and it installed without problems.

Do you have an idea of what culd cause these problems?

I can run any kind of tests on my devices if it can be helpful to troubleshoot these jobs, let me know if there is some information I can grab to help.

I thank you in advance for your kind help!


2023-08-24, 22:34
Hi poussin42 and community!
I have the same problem on my Oneplus 7T Pro with Oxygen and Nethunter 2023.2. When trying to update Nethunter or terminal to 2023.3 I get the error failed to install due to a unknown problem ??
Is there a log somewhere to look at and to figure out where the problem lies ?
Hope someone is willing to help.

All the best to you all!

2023-08-25, 13:24
I got the the same error as you trying update Nethunter 2023.2 and Terminal 2020.4 to 2023.3 on my Oneplus 7TPro and Oxygen
Hoping for a solution.
All the best to you and the community!

2023-08-26, 14:24
For me, the same version 2023.1 worked fine, and updates came out and I installed 2023.3 and I want to update the applications and writes an error ... I thought there was one, well, no, and you have the same problem as mine.It remains only to wait for new updates and everything will probably be fixed and everything will be fine.