View Full Version : Hashcat problems

2013-04-10, 13:43
Hi all guys...
I have a problem using hashcat with my kali linux...I tried to crack my own shadow file with john and hashcat...with john there is non problem...it recognize the hash and crack it (and about john I would know what is its standard algorithm when is called with no wordlist file)...It says me that these hashs seem to be sha512crypt...after that I tried to crack the same file with hashcat, and it does'nt recognize the hash salt, so I have isolated the digest in a separated file and run again hashcat with -m 1800, but it says me something like:

Initializing hashcat v0.44 by atom with 8 threads and 32mb segment-size...

Added hashes from file test2.pwd: 1 (1 salts)
Activating quick-digest mode for single-hash with salt

NOTE: press enter for status-screen

/usr/bin/hashcat: line 3: 5342 Floating point exception /usr/share/hashcat/hashcat.bin "$@"

I can't anderstand where I'm wrong, so I analize the hash with hash-identifier and it says me that probably is a sha256 digest...I don't think so...I think that linux saves the sha512 of the passwords, not sha256, right?In fact if I run hashcat with -m 1400 (for sha256) it can't load the digest...so the hash is sha512crypt...help me please...