View Full Version : Root screen locking

2013-04-10, 14:25
This is how to make your root screen lock works. Just follow simple steps :D
Open up your terminal:

apt-get remove gnome-screensaver
apt-get source gnome-screensaver
cd gnome-screensaver-3-4.1/src
nano setuid.c

now find

if (getuid () == (uid_t) 0) {
reason = g_strdup ("running as root");
ret = FALSE;
goto out;
and change it this way

/*if (getuid () == (uid_t) 0) {
reason = g_strdup ("running as root");
ret = FALSE;
goto out;
close nano ( ctrl + x) and save changes.

cd ..

if there are any dependencies install them with apt-get..
when all dependencies are installed:

now it will tell you that there are some changes in the source code so you have to type:

dpkg-source --commit
now you have to name your change, name it how you want it and hit enter, after that it will open some text file just type in :q and hit enter.
after that type again:

wait until it's done

cd ..
dpkg --install gnome-screensaver_3.4.1-1_i386.deb

and make sure that /etc/pam.d/gnome-screensaver looks like this:

@include common-auth
auth optional pam_gnome_keyring.so
And that's it, enjoy :D

2013-04-10, 14:40
> apt-get source gnome-screensaver

hmmm, that want's to deinstall "gnome-core", sounds like it might break something?

2013-04-11, 06:27
UPDATE: This bug has been assigned and updated is expected soon. http://bugs.kali.org/view.php?id=245

2013-04-11, 10:56
not working bro :(

2013-04-11, 13:19
Is worked fine for me but when I did apt-get update and apt-get upgrade, it stopedt working...

2013-04-12, 08:52
Bug has been resolved. Patch to arrive soon http://bugs.kali.org/view.php?id=245

2013-04-12, 10:11
I think we should wait for Kali Update to fix this bug

2013-04-12, 13:27
It's fixed just perform apt-get update and apt-get upgrade.

2013-04-12, 13:44
I know this isn't much help, but I'm using KDE 32Bit (self built, no special options), and there are no problems with the Lock Screen.
Edit* Oops just read in the bug link, that they were able to fix it yesterday, perhaps it has been rolled out already, or soon.

2013-04-13, 11:44
what if you get locked out !! username and password not working after Gph install.. live dvd worked great .. something went wrong after grub install.. any suggestions fellas?

2013-04-14, 07:03
Thanks @system_crash it works after update

2013-05-15, 08:13
Is this an issue where when you lock root it doesnt actually lock? I've noticed if i lock my root account and then move the mouse (even after waiting) it doesnt actually lock which is a slight concern. I'm assuming this will fix it?.