View Full Version : ARM Chromebook not booting from USB

2013-03-15, 15:55
I have followed the directions completely, but nothing happens when I hit ctrl+alt+U. When I use just ctrl+U I get a dialogue screen listing my devices and the error GPT:Primary header thinks Alt. head is not at the end of the disk. So far I have not been able to launch Kali from a USB. Any thoughts?

2013-03-16, 17:28
Ctrl-U is the right command. I had the same problem running from usb. It would start to boot and then get hung up on the partitions. I was able to get it running from an sd card, but the wifi isnt working yet and the browser crashes when start it.

2013-03-18, 13:50
I figured I'd mention as well that attempting to boot from USB leads me to the same error. I'll try SD in the interim.

2013-03-18, 14:04
I can't get my Chromebook to boot from the SD either.

* I have a Samsung Chromebook with an arm architecture.
* It is in developer mode
* Firmware is --mode=todev
* crossystem dev_boot_usb=1 dev_boot_signed_only=0

But when I dd my chromebook image to the eight gig SD card and run the cgpt commands, pressing Ctrl+U on bootup only produces a loud, annoying sound.

Of interest: When I ran cgpt show /dev/mmcblk1, I didn't get the same output as in the guide. Namely, both the ChromeOS Kernel partitions and the Linux partition was missing. To add them, I had to run the commands from the instructions along with the -t -b and -s options. I tried doing both this and only the commands from the instructions, but neither work.

2013-03-19, 03:14
I ran into the exact same error when trying to boot from USB at ~ 3 seconds into the boot. The boot process hangs. I was able to get Kali up and running on an SD card though.

2013-03-31, 19:31
Just thought I'd add my own experience info here. After struggling for a couple days I was able to get my Chromebook, ARM Samsung to boot Kali from USB.

The instructions aren't exactly clear in a couple of places... All of the instructions have to be done on the Chromebook itself, so you'll need to download the Kali .img.gz file to your Chromebook. It should default to saving in the Downloads folder.

For the next steps you have to get the Chromebook into developer mode first. To do this, hold ESC and the refresh button, and tap the power button. This will cause Chromebook to boot into recovery mode. When the boot screen comes up saying something like the OS verification is on/off, press space bar to turn on/off...You want it OFF. At that screen hold down Ctrl and hit the D key. I've also seen some places saying hold Ctrl+Alt and hit the D key, but I think just Ctrl+D worked for me.

It should boot up like normal and land you on the GUI screen to setup the Chromebook for the first time (entering recovery mode and doing this wipes your saved settings and resets to factory default). Don't worry about setting up the Chromebook. To get to the command line from this point hold Ctrl+Alt and press F2, it looks like a right arrow "->" and is two keys right of the ESC key. If you need to go back to the GUI (and I did quite a bit during the process) just hold Ctrl+Alt and press the F1 key, looks like the left arrow "<-" right next to the F2 key (go back to GUI, go forward to Command Line). Once on the command line, login as chronos and set your password (instructions for this will appear on the screen). Remember the password, you will be required to enter it from now on every time you run a sudo command, and you'll be doing that a lot.

Now, navigate to the folder where the Kali .img.gz file is (might want to move around a bit to familiarize yourself with the file structure tree). Chromebook already has gzip, so use the ungzip command to decompress the file into the Kali .img file. Here is where you need your USB stick. This part really made me stumble until I tried the USB stick in the 3.0 port (I used a Patriot Rage 3.0, 32 GB stick). You'll need a decent USB stick at least 8 GB (The Kali img is actually around 5 GB). I know everywhere says to use the USB 2.0 port and yes you HAVE to boot from that port, but for this step it was a **** of a lot easier to use the 3.0 port for me because I couldn't figure out where it was mounting the USB 2.0 port.

On my system the USB stick came up as /dev/sda. Make Sure You do NOT use the dd command on the incorrect storage drive or you could wipe the Chrome OS off of your Chromebook! If you aren't sure, you can use the 'mount -l' and/or 'lsusb' commands to help you identify where the USB device is mounted.

Now use the dd command (you'll have to put sudo before it and enter your password when prompted) to copy the Kali .img file to the USB drive. Assuming you typed it all in correctly and had your file path and device path correct everything should go smoothly and you'll be back at a prompt (this will take awhile! Wait!). Unfortunately, I found that I couldn't go back a command so if you screw it up you'll have to re-type the entire command again. Look closely before hitting enter to avoid heart-ache!

Now you'll have to use the cgpt command (using sudo again) to repair the disk. You must use cgpt to repair the partition table on the USB or it won't work! Then use the cgpt command again to set your boot priority to the USB. I simply set the KERN-A (for SD card boot) priority to 5 and the KERN-B (for USB boot) priority to 10. This means the kernel on the USB stick will now know to boot like it's booting from a USB stick rather than an SD card, otherwise it won't know and it won't boot!

Again, if all goes well you get the prompt and the typical unix no-response. Turn off the Chromebook, or reboot. You can enter the reboot command from the command line here if you prefer. Now you put the USB stick in the 2.0 port, turn on the Chromebook like normal and wait for the white boot screen saying something like OS verification is OFF, press spacebar to turn on (Leave it off of course!). At that screen hit Ctrl+U to boot from the USB stick and wait.

Several of these steps may take awhile to complete! Wait! If it doesn't generate an error right away, then it's working correctly. It will take time to ungzip the Kali .img file, and it will take even longer to dd the file onto the USB stick. After entering each command don't do anything to the Chromebook until you see the prompt come up again.

It does work. If you can't get it to work, then you aren't doing something right. It took me awhile to get it working properly. I know some of this is a bit newbish, but I had trouble and I know I'm not the only one. I hope this helps someone. Good luck.

2013-04-24, 03:33
@Stahna Thanks for your help! i followed your steps and when i finally went to the final step which is booting kali from the USB by pressing CTRL+U it wouldnt boot, i did a google search and found a solution that could help others that run into this.

I was missing the Developer-mode BIOS which was a critical step in telling chrome OS to boot another operating system regardless if the laptop is in developer mode. this is the second level of developer access

it was a simple and easy fix

i went back into the command line and typed the following commands

localhost login: chronos
chronos@localhost $ sudo bash
localhost chronos # chromeos-firmwareupdate --mode=todev

that was it

heres the link explaining more on the Developer-mode BIOS


also i managed to get the alfa wireless card to work on the chromebook by adding an extra power source "portable USB battery pack" to the alfa card as the chromebook doesnt seem to supply enough power to other devices connected to it...

enjoy guys hope this helps

2013-05-15, 23:31
Ahh, j0k3rr Thank you soo much! I had forgotten that step and had to re-do the entire process from step 1 after Power-washing my Chromebook. I couldn't get it to boot. Yea, I needed to set my BIOS to dev mode too. That's an important step. Thank you!!!

2014-03-11, 18:42
Finally got mine to work on an SD, Samsung Chromebook Model Code XE303C12-A01US (if that makes a difference to anyone).

Followed Stahna's directions, and j0k3rr's addendum.

One thing that caused me a big problem: the "Official" directions on http://docs.kali.org/armel-armhf/install-kali-samsung-chromebook says run
"cgpt add -i 1 -S 1 -T 5 -P 10 -l KERN-A /dev/sdb".
On the laptop that I was using to follow the directions, the "-S 1" looks like "-s 1" with a lowercase "s".

That's an instant project killer right there. A lowercase "s" refers to size, while the uppercase "S" refers to the "successful Flag" being 0 or 1.