View Full Version : Failure of Desktop Sharing service to respond after changing IP

2013-05-30, 16:01
I am using Kali version 1.0 32-bit with Linux Debian kernel 3.7-trunk-686-pae and GNOME 3.4.2 with 3.9GiB RAM.

I am asisting with an audit in another country and have been using the Desktop Sharing option from the Internet menu for remote control with excelent results. Yesterday I asked to local technician to change the machine to another location with a different network addressing scheme (assigned by DHCP) and though the system responds to ping, it no longer accepts VNC connections. I have asked the technician to connect while on the LAN to eliminate other variables and his client PC reports "Connection refused (10061)" using a windows client. Does anyone have any knowledge as to what this could be related to or how we could proceed with diagnostics? I am not that well versed in Linux and would appreciate any assistance.

2013-05-31, 13:10
Is there any firewall blocking the VNC port in that network ? to check if the service is running on kali try the following command:

netstat -an | grep 5900

2013-05-31, 16:19
root-boy, thanks for your response.

There is no firewall blocking ports, as well as myself working over the WAN, the local technician has the same responses working in the local network.

Here are the results of our tests to date. We ran the netstat command as you mentioned and the service is running on kali as it should, reporting tcp 0 5900 listening. I also asked the technician to run the command "ls -l /etc/init.d/network-manager and received the reponse -rwxr-xr-x 1 root root 1751 Jan 30 01:13 /etc/init.d/network-manager" as response. As well I had the technician run "cd /usr/lib/vino" then "./vino-server" and it reported the desktop sharing services is already running.

I asked him to move the machine to the data center and connect it to a KVM. I connected with the KVM and began checking for errors. The only thing I found so far is the network manager app reports "device not managed". So I modified the /etc/NetworkManager/NetworkManager.conf file to managed=true then rebooted. At first it would not respond to VNC. So I connected with the KVM and then tried to connect with VNC, just to see, and it worked just fine. Figuring it was a coincidence I tried with a change and the same effect repeated itself. I could not connect with the VNC with no success until I connected with the KVM. I just need to make the connection. I can immediately disconnect or leave it connected and either way the VNC will work.

The problem arrises in the I need to move this machine to other VLANs and in other areas physically apart, so I can run the scans (LAN vuln-pen tests as well as WLAN test. The KVMs are not available in other areas.

Any ideas would be greatly appreciated.