View Full Version : Problems setting up persistence with Kali.

2013-06-08, 21:44
Hello everyone,
This is my first post on this forum, and also the first time I try to set up Kali.

I am setting up Kali from Backtrack 5 R3, if that's relevant, and I am using DD and following the procedure on the Kali site, however, I encounter a problem. Just like the site says, I install Kali using DD which doesn't seem to be problematic, the problem is when I try to set up persistence. I open up gParted on the USB drive I'm using and create a Primary ext4 partition named "persistence", per the guide, however, when I try to mount the partition in the Terminal to complete the set-up, it says there is a problem:

Error mounting: mount: wrong fs type, bad option, bad superblock on /dev/sdc2, missing codepage or helper program, or other error. In some cases useful info is found in syslog - try dmesg | tail or so

If I look at the new partition in gParted, it shows a warning sign with a ridiculously long message that I can't copy. I've tried creating the partition with fdisk, I've tried deleting both partitions and restarting from scratch, and also I've tried looking it up on Google. No such luck. If anyone can help me with this, it will be greatly appreciated.

P.S. I'm trying to install it on a 32Gb Class 10 MicroSD card in a USB card reader. Not sure if that changes anything though.

Thanks in advance,