View Full Version : Retina Macbook Pro 2013 10,2 OSX Dual / Triple Booting

2013-06-10, 07:47
Hi Guys,

After much research I've been able to create a workable live USB of Kali Linux that will work on a Macbook (or my Macbook at least).

I had no such luck making this bootable USB with Terminal in OSX or unetbootin.. Instead I had to rely on a free windows tool called "Rufus" available at http://rufus.akeo.ie

Step 1 - Have a working legal copy of windows XP, 7 or 8
Step 2 - Open Terminal in OSX and type sudo nano then paste this into it and save it as grub.cfg

# Config file for GRUB2 - The GNU GRand Unified Bootloader
# /boot/grub/grub.cfg

# Linux Grub
# -------------------------
# /dev/fd0 (fd0)
# /dev/sda (hd0)
# /dev/sdb2 (hd1,2)
# /dev/sda3 (hd0,3)
# root=UUID=dc08e5b0-e704-4573-b3f2-cfe41b73e62b persistent

set menu_color_normal=yellow/blue
set menu_color_highlight=blue/yellow

function load_video {
insmod efi_gop
insmod efi_uga
insmod video_bochs
insmod video_cirrus
insmod all_video

set gfxpayload=keep

# Timeout for menu
set timeout=5

# Set default boot entry as Entry 0
set default=0
set color_normal=yellow/blue

menuentry "Kali - Boot Non Persistent Mode" {
set root=(hd0,1)
linuxefi /live/vmlinuz boot=live noconfig=sudo username=root hostname=kali
initrdefi /live/initrd.img

menuentry "Kali - Boot Persistent" {
set root=(hd0,1)
linuxefi /live/vmlinuz boot=live noconfig=sudo username=root hostname=kali persistence
initrdefi /live/initrd.img

menuentry "Kali Failsafe" {
set root=(hd0,1)
linuxefi /live/vmlinuz boot=live config memtest noapic noapm nodma nomce nolapic nomodeset nosmp nosplash vga=normal
initrdefi /live/initrd.img

menuentry "Kali Forensics - No Drive or Swap Mount" {
set root=(hd0,1)
linuxefi /live/vmlinuz boot=live noconfig=sudo username=root hostname=kali noswap noautomount
initrdefi /live/initrd.img

menuentry "Kali Graphical Install" {
set root=(hd0,1)
linuxefi /install/gtk/vmlinuz video=vesa:ywrap,mtrr vga=788
initrdefi /install/gtk/initrd.gz

menuentry "Kali Text Install" {
set root=(hd0,1)
linuxefi /install/vmlinuz video=vesa:ywrap,mtrr vga=788
initrdefi /install/initrd.gz

Step 3 - Boot into Windows (make sure to bring the grub.cfg file with you) and download the amd64 (for 64bit machines) copy of Kali Linux
Step 4 - Download Rufus http://rufus.akeo.ie
Step 5 - Download the EFI boot64.efi which will allow the OSX EFI to read the USB and make it bootable
Step 6 - Get a USB flash drive, 8GB should be sufficient
Step 7 - Insert USB and launch Rufus
Step 8 - Keep default settings, select Kali Linux iso and use fat32 as the filesystem
Step 9 - After Rufus has finished making the bootable open the drive in windows explorer and create the file path /EFI/Boot
Step 10 - Copy the boot64.efi and the grub.cfg file into the /EFI/Boot file path
Step 11 - You should now have a working bootable USB copy of Kali Linux for your Mac.
Step 12 - Make sure when you hold down option on startup that you select "windows" in the orange/yellow color rather than the EFI option.

I take no responsibility for damage done by the user or anyone else to their or anyone else's machine.

2013-07-31, 11:22
Hi Sam,

Thanks for your explanation, I feel i'm almost there making this work on my macbook pro Retina late 2012 13-inch. I followed the procedure you outlined, downloaded the amd64 image, burned it to my USB using rufus, put the grub.cfg and bootx64.efi file in the /EFI/Boot/ directory of the windows partition and restarted my macbook with the option key pressed. After the reboot I get two bootable options called "Windows" and "EFI/Boot". When I select the windows option I see activity on the stick and then get a black screen with the text "Boot error". It doesn't seem to be going to the grub loader at all.

I got the bootx64.efi image from the fedora website as described on another post on the kali forums (http://forums.kali.org/showthread.php?271-How-to-EFI-install-Kali-Linux). I noticed you mentioned a boot64.efi file in your post (so without the x), could that be the problem? I'm also not 100% sure if the directories and filenames have to be case-sensitive although I tried several variations already.

I also tried re-imaging the stick again to no avail. When I put the stick into an older laptop (dell latitude) it boots just fine using the defailt configured loader from the image so the image itself seems to be working just fine.

Does anyone have an idea where the problem can be? :confused: