View Full Version : Kali amd64 install macbook pro 8,3 os x 10.8.4 dual boot with rEFIT boot loader used

2013-06-12, 19:51
I had previously had my mbp setup with 10.8.4 os x and bt5r3 with rEFIT as the boot loader.

I am able to go all the way through the process installing kali on macbook pro 8,3 ... kali dvd ejects from the drive, the mbp restarts. I click the linux icon and says to insert bootable with a flashing hdd icon in the screen. So I wiped the entire HDD clean, erasing mac os x and all and went to install on the entire hard drive... I get all the way through the install process of kali amd64 on the dvd... dvd ejects, starts reboot and only have a flashing hard drive icon in center of the screen.

I am burning i386 kali now to see if that makes a difference. Can anyone help me? Is my issue the boot loader? grub installs during the process! Am I using the wrong architecture? BackTrack 5 r3 worked great on this computer along side of os x.

Thanks for any and all help!

2013-06-13, 18:27
Had the same problem and blackbird's post solved it for me:


check it out. And let me know if you manage to install nvidia drivers!

2013-06-14, 03:08
I retreated back to the comfort of bt5r3 for now. After erasing entire computer, I just finished setting it back up like i used to have it (for the most part). Thanks for the link. If i am feeling froggy, ill jump on that and let you know. Btw... Got openvpn running on bt5r3... Pretty nice!

2013-06-27, 20:52
I have tried to do this according to blackbird's instructions. I get to a screen to test media. I am coming up with an error of: images/pxeboot/vmlinuz not found

also how do i find out my uuid= for --set=root and root=UUID as I am using the pre-modified grub.cfg file which is set to:

menuentry 'Fedora 18' --class fedora --class gnu-linux --class gnu --class os {
linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2018\x20x86_64
initrdefi /images/pxeboot/initrd.img
menuentry 'Test this media & start Fedora' --class fedora --class gnu-linux --class gnu --class os {
linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2018\x20x86_64 quiet rd.live.check
initrdefi /images/pxeboot/initrd.img

how can i fix this?

2013-07-05, 18:43
got it fixed!
from internet recovery, i used disk utility to partion HD.
1. efi
2. machd
3. free space

put os x on machd and installed refit
put kali on free space and istalled grub to /dev/sda1
put kali disc back in after kali install and grabbed grub.cfg file and put it on the efi
restart a few times til refit boot manager starts up... select partition tool and sync refit and grub... yes
you are back at refit menu... select kali and it's up and running.