View Full Version : AWUS036NHR...yet more

2013-06-22, 07:48
I know there are a few people that are asking, but nobody seems to actually have an answer. All i can find is people saying "read the install.txt.", "check the website for how-tos"

The problem is not how to start the installation process....

There is an Install.sh in the folder! Its pretty simple...even for mac users

The problem is as follows

CC [M] /root/#Backups/Drivers/RTL8192CU_8188CUS_8188CE-VAU_linux_v3.0.2164.20110715/driver/rtl8192_8188CU_linux_v3.0.2164.20110715/core/rtw_cmd.o
In file included from /root/#Backups/Drivers/RTL8192CU_8188CUS_8188CE-VAU_linux_v3.0.2164.20110715/driver/rtl8192_8188CU_linux_v3.0.2164.20110715/core/rtw_cmd.c:24:0:
/root/#Backups/Drivers/RTL8192CU_8188CUS_8188CE-VAU_linux_v3.0.2164.20110715/driver/rtl8192_8188CU_linux_v3.0.2164.20110715/include/osdep_service.h:49:29: fatal error: linux/smp_lock.h: No such file or directory
compilation terminated.
make[4]: *** [/root/#Backups/Drivers/RTL8192CU_8188CUS_8188CE-VAU_linux_v3.0.2164.20110715/driver/rtl8192_8188CU_linux_v3.0.2164.20110715/core/rtw_cmd.o] Error 1
make[3]: *** [_module_/root/#Backups/Drivers/RTL8192CU_8188CUS_8188CE-VAU_linux_v3.0.2164.20110715/driver/rtl8192_8188CU_linux_v3.0.2164.20110715] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.7-trunk-amd64'
make: *** [modules] Error 2
Compile make driver error: 2, Please check error Mesg
And before you mention it, i have ran the driver form /root/ and i still get the same issue, just ran this from my #backups folder to get the error msg

I downloaded the latest driver from the alfa website. Unpacked it, and ran the install.sh in terminal. I think this is telling me that the make file cant find the required files/fodlers to edit/replace. Short of learning to script to re-write the make file i am lost...

I check the alfa site again and found THIS (http://www.alfa.com.tw/press_c_show.php?sn=5). Its a set of instructions for installing the NHR on backtrack 5. Obv this cant be used for kali as their based on 2 totally seperate distros.

But i wonder if someone out there can use this to help us get this supposedly great usb adapter working.

2013-06-22, 15:56
Yeah i think i found this issue when i tried to install the drivers a while back on my old machine, I'm not 100% sure but i think it was that the header "smp_lock.h" is missing because it was obsolete in the new 3.x kernels and was deprecated late in the2.x kernel series. I think that's the issue, im not sure. But I think that's why it is missing.

So if you are going to use this script it would best be on 2.6.x kernel, would be my best guess.

2013-06-24, 10:51
Its kali. So obviously i am installing as root.

bobdole is right its the "smp_lock.h" that gets flagged up as missing or not found. But i dont know enough to figure out how to solve this issue.

There is no install instructions in the driver folder other than click the install.sh. It was a known issue with Backtrack 5 to the point that ALFA`s own website has instructions on correct installation, but this is kali and no longer ubuntu based so that fix doesn`t work


2013-06-26, 12:32
yes i have updated with apt-get, thats the first thing to try with any error.
i am cd`d into the correct directory, i have tried using the make file and tried using the install.sh
i have tried cd into the install.sh`s directory, the make files directory, i have ran the install.sh as exec, i have ran it from cd to its directory and i have tried dragging it into the terminal..

I dont get what your saying "Your post is very vage and not info other then it doesn't work"

Thats the exact point, i have tried to install it, both from the install.sh and from the make file as i have said. i gave a copy of the error code, and have mentioned that it was a known error on backtrack 5 and therefore common sense dictates that its still an error on kali too. i was hoping someone with a bit more knowlege than me could look at the help page i have refferenced from ALFA`s website and maybe figure out a guide to making this thing work on kali

2013-06-27, 02:31

change osdep_service.h (line 49) linux/smp_lock.h to linux/smp.h

Change file rtw_io.h (line 36) linux/smp_lock.h to linux/smp.h