View Full Version : Use a system wide proxy

2013-07-12, 11:26
Hello I am inside a LAN network which uses a squid proxy as a gateway to the internet.
I can run Iceweasel with the proxy (address: port:3128) because it has manual proxy settings.
I want to know how to set up my entire system to use the proxy to connect to the internet.
There was such an option available on BackTrack and I also changed the proxy in Applications->System Tools->Preferences->System Settings->Network->Network Proxy. I also set the environment variables all_proxy, ALL_PROXY, http_proxy, HTTP_PROXY, ftp_proxy, FTP_PROXY, https_proxy, HTTPS_PROXY to but still without success. I cant even ping www.google.com
I can ping my gateway and the proxy server(
I also set up proxychains in strict mode to use and still cant ping or nmap
Xchat also doesnt work with manual proxy settings
Is there anything I'm doing wrong or can someone please help me?

2013-08-01, 03:29
create apt.conf file at etc/apt/
and then
write out it at apt.conf file
Acquire::http::Proxy "http://username:proxy@IP:port";


2014-06-09, 14:48
I have a slightly different problem.
I have a corporate script .PAC and its content shows me an HTTP proxy on 8080.
After setting up the Automatic proxy on System Settings > Network I can browse the web using my credentials asked by Iceweasel
However bash isn't working. After some research I could find the export command (export http_proxy=http://user: pass@server: port).
Unfortunately it would store a plain version of my corporate password, what isn't acceptable.
Setting up just the server also doesn't work. It don't ask me for credentials as I thought it could do.
Any suggestions? Thx.