View Full Version : Reaver v1.4 - Failed to associate with [BSSID]

2013-07-15, 20:32
Hi guys!

I am new to Kali Linux forums, but was active at BackTrack forums.
A great period of time have passed when I stopped to deal with Linux and BackTrack, but now I have "little" problem.

I have installed Kali Linux to Virutal machine (VMware Workstation), and now I want to protect my router well. Namely, my neighbours have a bit more knowledge than me, so they are trying to steal my Wi-Fi.

So I started to deal with Reaver v1.4, and my router is downstairs. The power in dB is showing around 60-70. I am getting error something like this:
[!] Failed to associate with BSSID XX:XX:XX:XX:XX (essid: my_router_name)

Can you guys please help me? Yes, i have unlimited GB at my IP, but they are constantly slowing my surf speed down.

Thanks, I hope you guys can help!

2013-07-16, 19:27
Please guys, help me if you can. I would really appreciate it.

2013-10-30, 10:51
Reaver exploits WPS. So if your router lacks this feature, you're immune to Reaver. However if you do have WPS, a few things can be done.

1. Look for a newer firmware for your specific router. Manufacturers may offer the ability to disable WPS or offer additional options.
2. See if your router is compatible with DD-WRT/OpenWRT/Tomato. I know for my router, DD-WRT completely takes away the WPS function and changes what the WPS button does.

2013-10-31, 04:22
1. Run Kali as a live CD, rather than in a virtual machine.
2. Make sure your wlan0 and mon0 interfaces have the same MAC address.
3. Make sure your power and RXQ are good. If your receive quality is poor, you're going to have problems associating.

As far as preventing your neighbors from hacking into your WLAN, use WPA2 with a good password like 4(8^yIo0:k4T&, and make sure you have WPS disabled. You could also hide your ESSID (network name) and do MAC address filtering, but those can be gotten around.