View Full Version : TP-LINK TL-WN722N USB Wireless Card on Samsung ChromeBook XE303C12-A01US

2013-07-22, 04:08
Hello all,

Running Kali Linux 1.0 for Samsung Chromebook ARM, booted from a 16GB SanDisk SD Card. Since the internal wireless on the ChromeBook doesn't support packet injection, and for some reason the Alfa AWUS036H can only seem to receive packets on this box (I can use it for Kismet and Wireshark, but not aircrack-ng nor to to associate to a WAP - power attenuation on wire may be too much) I figured I'd try the TP-LINK TL-WN722N (USB VID=0cf3, PID=9271). Been reading some of the BackTrack forums and trying their suggested solutions with no success. As follows (rebooted after each try):

- Downloaded and replaced the /lib/firmware/ files ar9271.fw and htc9271.fw.
- Ran the following commands to configure the kernel:
- Tried using Erick Birbe's TL-WN722N installation script (http://erickcion.wordpress.com/2012/05/08/linux-installer-for-tp-link-tl-wn722n-usb-wifi-antenna/). Script failed saying make: *** /lib/modules/3.4.0/build: No such file or directory, but trying to create it with mkdir says file exists.

Command outputs:


root@kali:~# lsusb
Bus 001 Device 002: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 003: ID 0424:3503 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 2232:1037


root@kali:~# dmesg | grep -i 9271
[ 1.772829] usb 1-1: New USB device found, idVendor=0cf3, idProduct=9271

root@kali:~# dmesg | grep -i firmware
[ 1.467494] Firmware Version: 2.13
[ 4.873665] s5p_mfc_alloc_and_load_firmware:45: Firmware is not present in the /lib/firmware directory nor compiled in kernel
[ 4.904470] s5p_mfc_alloc_and_load_firmware:45: Firmware is not present in the /lib/firmware directory nor compiled in kernel

(Hmmm, it sees the device, can correctly identify, not sure the firmware replace worked).

card configs

root@kali:~# ifconfig
lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

root@kali:~# iwconfig
mlan0 IEEE 802.11abgn ESSID:off/any
Mode:Managed Access Point: Not-Associated
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on

lo no wireless extensions.

root@kali:~# ifconfig wlan0 up
wlan0: ERROR while getting interface flags: No such device

(tried wlan1-5 too, since one of the posts said it might be assigned to a higher number)

Version info

root@kali:~# cat /etc/*-release
PRETTY_NAME="Kali GNU/Linux 1.0"
NAME="Kali GNU/Linux"
root@kali:~# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux Kali Linux 1.0
Release: Kali Linux 1.0
Codename: n/a
root@kali:~# uname -a
Linux kali 3.4.0 #5 SMP Sun Mar 10 18:26:14 EDT 2013 armv7l GNU/Linux
root@kali:~# cat /proc/version
Linux version 3.4.0 (root@kali) (gcc version 4.6.2 20111004 (prerelease) (Linaro GCC 4.6-2011.10) ) #5 SMP Sun Mar 10 18:26:14 EDT 2013

Posts I have read on similar issues are here:

Thank you for any help, it is greatly appreciated.

2013-07-22, 07:35
How about trying "mlan0" ? Is that another wireless card than the one you are trying to make work ?

2013-07-22, 16:02
How about trying "mlan0" ? Is that another wireless card than the one you are trying to make work ?

Yep, got the internal wireless card working on mlan0 (after a quick change to /etc/network/interfaces so it could get a DHCP lease). Kali sees the USB card in dmesg but doesn't want to assign it to an interface.

2013-11-17, 22:28
Did you manage to get this working? I'm considering purchasing both the chromebook and WN722N.

2014-02-08, 19:04
If you can, dont buy this adapter... im on I have a TL-WN722N wifi adapter and Im running Kali Linux in VMware virtual machine. I go to removable devices in VMware and in ATHEROS USB2.0 WLAN choose CONNECT. The virtual machine recognize usb wireless antena and all the near wifi lans are listed in Network connections. But here come the strange situation. I can connect even in my own wifi lan (keeps me asking for the wireless key when I know and I put for certain the right key). In the other hand I run, vg, Wifite, and the wireless card cant connect and extract IVS and brake any wep key like with backtrack 5 and the same software and hardware cracks without a problem. Is weird. The so detects card but no action can be performed.

2015-01-25, 12:06
Hi All,

I was having trouble installing an external usb wifi adapter in order to use promiscuous/monitoring mode, being as the internal wifi on chromebook doesn't support it.
Lots and lots of assing about trying different things, finally I just plugged in an 'EasyAcc' USB 3.0 hub with ethernet, and plugged in a TP-Link USB wifi adapter into the EasyAcc. Both the ethernet (Eth0) and wifi (wlan0) then show up in in ifconfig (you might need to enter 'ifconfig wlan0 up') and wlan0 can be put into monitor mode with 'airmon-ng start wlan0'.
Also found I was able to use the internal wifi (mlan0) for connectivity while using wlan0 for monitoring.

2015-01-31, 11:10
you should try to replace the compat wireless package and will also need kernel header to carry out this process as well as some patches which are used in official Kali
I suggest you take a look at the kernel source package and the linux wireless homepage for details https://wireless.wiki.kernel.org/ ...
I think I have a how to written for this somewhere I might post some instructions if I'll find it ;)