View Full Version : Can't install from USB/DVD

2013-07-28, 15:51

I'm trying to install kali on my laptop, but I can't boot it.

I've first tried using my USB, copied the image using win32diskimager, and while booting, I'm stuck at a black screen, and in my top left corner all I can see is "boot:" . It can't even get to the install menu.
I hangs there, I've waited more than 15 minutes, and nothing is happening.

Then I tried to burn the image to DVD, and I encounter the same problem.

Please help.

2013-07-28, 16:57
Hi psylight,

I've just installed Kali but have quite a bit of experience with BackTrack (its predecessor). Kali is by no means a "beginner" Linux OS and will require a bit of research on your part to use.

Obviously you are encountering some sort of trouble with booting from the USB drive, but it's tough to say exactly what is causing your problem. Some things to think about are whether you are using the correct version for your architecture (x86 vs 64 bit).

You could also check to make sure that you created the key correctly, it takes more to make a drive bootable than simply copying an ISO file. I use UNetbootin when I create a bootable Linux thumb drive in Windows.

If you finally do get it working, be careful with partitions so you don't nuke your laptop if you want to dual boot :)


2013-07-28, 20:21
Try hitting enter when you see boot it does it to me also sometimes.

2013-07-28, 22:47
I've tried hitting enter, escape, almost every other key on the keyboard.
Still nothing.

2013-07-29, 00:11
if you are using the 64 bit version try the x86 and try using linux live usb creater.

2013-07-29, 00:27
shaberu, I'm using the i386 version, which is 32bit.

Jack, I'm not a beginner in Linux OS, I'm using ubuntu/xubuntu/elementaryOS as my main OS for ~4 years. I am sure that the USB is bootable, because I tested it on another PC and a had no problems.
I've even installed in on a USB using Virtualbox, but it was running too slow and I wanted to do hard disk install.
I get the same error while trying to boot from USB and from CD.

2013-07-29, 06:20
okay just going on a whim here try downloading plop boot manager (http://www.plop.at/en/bootmanager/download.html) and boot it off of cd run it and you'll get a boot menu. plug in your usb with kali on it highlight the usb hold shift and hit enter see if you can boot from this. also if you have a old system that dont support usb boot you can use plop for it also.

2013-07-29, 09:43
Another thing you may want to look at is to see if your download wasn't corrupted by checking the MD5.

2013-07-29, 11:02
Another thing you may want to look at is to see if your download wasn't corrupted by checking the MD5.

You mean SHA1 hash. But i agree, make sure the image is 100% correct.

2013-07-29, 14:59
Already checked the SHA1, it's OK.
Like I said, I am able to boot the USB/CD on another computer. So the image is ok.
I've also tried other linux distributions and the all boot on the laptop. That's how I installed the OS I'm using right now, so the laptop can boot from USB.
I guess I'll have to try with the mini ISO, but that's going to happen next month after I get more bandwidth.

2013-07-29, 18:08
Did you try creating a key with Unetbootin though? Just curious because that's what I used and I've had no problems installing to a few different laptops.

2013-08-01, 15:28
Today I tried Unetbootin, LiLi, win32diskimager, dd, with no success.

When I try to boot from the USB I get this message:
SYSLINUX 4.04 EDD 2011-04-18 Copyright (C) 1994-2011 H. Peter Anvin et al

when using Unetbooin or LiLi.

When using dd or win32diskimager I get:


2013-08-01, 15:37
It seems to be a video issue. Try to disable kms (modeset=0). What type of video card you have?


2013-08-01, 16:21
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])

How to disable kms ?
I don't even get to the menu, that message appears before that.

2013-08-03, 13:45
When loading GRUB select your kernel and press "tab" in the end of stirng add "i915.modeset=0" for disabling KMS. Press Enter to boot. I have the same problem with "Toshiba NB100" on Kali 1.0.1-1.04. After loading i have blank screen. Disabling KMS solve this problem

2013-08-04, 20:00
My problem was that I never even saw the GRUB menu.

Anyway, I finally installed it. After I got tired from trying, I put the CD again, and strangely it booted. The first time I tried it I got the same error as with USB.

2013-08-05, 05:23
1st... Try to write "kali-linux-1.0.4-i386-mini.iso" image on USB via "win32diskimage" (in image type select "all" for selecting ISO)
2nd... Try to write image with latest "Universal USB installer"