PDA

View Full Version : ARM Xserver configuration X11



l0tek
2013-08-25, 01:19
So I have set up my box and configured SSH and assigned a static IP.

I can Remote (PuTTY) into the device.
I have installed Xming
I get this...


root@kali:~# startx
hostname: Name or service not known
xauth: (stdin):1: bad display name "kali:1" in "add" command


X.Org X Server 1.12.4
Release Date: 2012-08-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32 armv5tel Debian
Current Operating System: Linux kali 3.6.11+ #7 PREEMPT Mon Mar 11 16:46:44 EDT 2013 armv6l
Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=1680 bcm2708_fb.fbheight=1050 bcm2708.boardrev=0xf bcm2708.serial=0xe3d7a371 smsc95xx.macaddr=B8:27:EB:D7:A3:71 sdhci-bcm2708.emmc_clock_freq=100000000 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000 dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait
Build Date: 29 November 2012 08:57:05PM
xorg-server 2:1.12.4-4 (Julien Cristau <jcristau@debian.org>)
Current version of pixman: 0.26.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Thu Jan 1 00:41:11 1970
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"



The GUI appears on the monitor where the device is hooked into, however it does not appear on my Windows computer.

Forum diving has lead to, http://elinux.org/RPi_VNC_Server

Device: Raspberry PI


Thanks for the help!

zerocool
2013-11-05, 22:25
I two am having the same issue today, when i type startx i get this, after 5 mins or so it does load but lan doesnt work.


host name: name or service not known

Have tried changing my host name, nothing still the same.