View Full Version : Kali Linux ARM (Raspberry PI) X Server problem

2013-09-25, 15:31
http://i.imgflip.com/3u6os.jpg (http://imgflip.com/i/3u6os)

For real though, my class uses three PIs and we threw on Kali Linux onto all three of them. For some reason, some config file broke and when we run startx at the terminal, only the cursor is drawn and not the whole Xfce environment. My teacher went home with the PIs and reinstalled Kali on them and came back and it worked. This time, I went ahead and forgot to close everything before I did a hard reboot. After I rebooted and ran startx, the remaining Thunar window I forgot to close popped up. I opened a terminal from within Thunar and I ran startx again. Xfce loaded again with a new configuration setup. I went ahead with the default again. I opened a terminal and did a hard reboot again and once I logged in and ran startx the Thunar session from the session I forgot close it in popped up again. I pulled up a terminal again and ran startx. This time the terminal I didn't close popped up.

So it seems as though in order to get into Xfce I have to log in, startx, open terminal here from thunar, and startx again in order to get into Xfce. Does anyone have a solution? I would love to hear back.