View Full Version : Kali doesnt boot on my wm8850 netbook with ARM Cortex A9 processor

2014-01-24, 17:17
I run several armhf Linux systems on my wm8850 netbook ( e.g. Debian, Xubuntu, Picuntu, Raspian... )

I tried my method to boot the systems with the 1.0.6 armhf image offered in the download section.
I prepared my SD card as always and put the rootfs as usual to the second partition ( ext3 formatted ).
On the first partition ( fat32 ) I have my usual boot stuff ( kernel etc. )

When I try to boot the screen doesnt react - remains dark, no cursor appearing, no console messages...

What I noted was that in the Kali rootfs there was no /etc/sftab file.
Also i noted that the dev directory contains very few entries : I added some for mmcblk0p1,2,3,4

My kernel boot args are : mem=512M root=/dev/mmcblk0p2 noinitrd rootwait rw console=tty1 init=/sbin/init rootfstype=ext3

I suspect that the /dev/mmcblk0p2 is not mounted (?) ans so the init doesnt/cant start (???).

Can someone explain why it doesnt work with Kali but with all other systems I tested ?

2014-01-25, 23:33
I had a look at the rootfs of Kali I dd-ed to a auxiliary SD card.

To my surprise e.g. /etc/rc2.d and /etc/rcS.d are empty !

I understand not how such a system can boot then ?