View Full Version : Kali Linux doesn't work on my Raspberry Pi

2014-03-01, 14:45
I just bought Raspberry Pi Model B and 32GB Class 10 Samsung SD card. I downloaded the Kali Linux 1.06a Raspberry Pi image from this website: http://www.offensive-security.com/kali-llnux-vmware-arm-image-download/
Because I have dual-booted my laptop as Windows 8 and Ubuntu 12.04, I opened my Ubuntu, and checked the partition in which my SD card was located. It showed the partition name as "mmcblk0", and my SD var was in "/dev/mmcblk0p1" partition. So, I ran the command: "sudo dd if=kali-linux-1.0.6a-rpi.img of=/dev/mmcblk0p1 bs=512k", and waiting for it do finish it's job. Then, when I inserted my SD card to my Raspberry Pi, and connected it with my monitor using HDMI, and powered on, it couldn't connect with monitor. I guess simply, because it couldn't read anything inside the SD card. I though, maybe my Raspberry Pi or the SD card was faulty so tried downloading the NOOBS from Raspberry Pi's official website, formatting my SD card with SDFormatter and extracting NOOBS to my SD card. When I did all this, and plugged my Pi with monitor and powered on, it was working just fine. So, I guess it is either something with the Kali image that I downloaded or with linux command. Can anyone help me?

2014-03-02, 19:30
Well, I solved this one. I installed kali linux 1.0 armel image. Then I updated it, but during the upgrade process I get "timeout waiting for hardware interrupt" and similar errors. It works for some time, then I get that error. I unplug the power cable and re-plug it, and do dpkg --configure -a, then apt-get update, and apt-get dist-upgrade, it again does some work, and again "timeout waiting for hardware interrupt". Anyone can help about it?

2014-03-02, 23:30
The dd command to run is "sudo dd if=kali-linux-1.0.6a-rpi.img of=/dev/mmcblk0 bs=512k" - the image is an sdcard image, not a partition image, so leave the p1 off of it.

2014-03-03, 18:11
Yes, I noticed it. And corrected. But I read that the image 1.0.6a is not that good. That's why I started using 1.0 armel image. But as I wrote in my previous reply, while upgrading I get "timeout waiting for hardware interrupt" error message. Any help with that?