View Full Version : unable to boot into kali linux after dual boot install

2013-03-16, 08:17
Hi , today i downloaded the kali linux i386 from official site http://www.kali.org/downloads/
and installed it in dual boot with windows 8 by following the official instaructions from here :

and followed each step

“now my boot menu shows me three options”
1. Debian GNU/Linux, with linux 3.7
2. Debian GNU/Linux, with linux 3.7 (recovery mode)
3. windows vista boot loader
windows is booting properly without having any problem but when i boot into kali linux it gives me a black screen after boot. i waited even 20 minutes and hopped that it will boot up but it doesn't :confused:
i was using backtrack 5 r3 in dual boot with windows 8 but it never gave me this error
“my hardware is hp mini notebook 1000”
I used “Win32DiskImager” to make bootable flash drive.
any help is appreciated... thanks in advance

2013-03-25, 14:21
I am also facing the same problem dual boot with windows 7 whenever i run kali it starts and suddenly all screen disappear. Moreover found no solutions from 3 days searching on google. Anybody have any solution for it or i re install or remove it and go back to backtrack 5 r3 as i was using before.

2013-03-29, 18:42
Hey finally i got the solution for this problem when the screen get black or disappear full the brightness of your laptop you will get the display back :D

2013-03-31, 00:17
I believe it has to do with screen/monitor detection. As suggested above is a quick fix but I suspect it will need further correction as I have the same problem with one of my machines but there is no brightness control

2013-04-16, 00:50
I had this issue as the screen was black with a single cursor....but it was frozen. Could not boot into anything.
Then I booted into the recovery mode and emptied the trash. Once I emptied the trash I was able to load the regular Kali.

My problem was I creating a wordlist for att Uverse routers. As they are only numeric passkeys . My wordlists were nearing 100gb.

2013-05-11, 06:30
1. Boot in to kali terminal (Just turn on the computer).
2. Log in to root.
3. type in "vim /etc/default/grub" (no quotes)
4. find a line that looks similar to this: GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791"
5. Move your cursor on top of the last quote on that line and press the letter 'i' on your keyboard (this turns vim in to inserting mode)
6. Add a space between vga=791 and the quote then type in i915.modeset=1 (The new line should look like this: GRUB_CMDLINE_LINUX_DEFAULT="text splash vga=791 i915.modeset=1")
7. Hit escape on your keyboard and type in ':x' (with out the quotes.. Just hit the keys) and press enter. This will close the editor.
8. In your console type in 'update-grub' (no quotes)
9. Wait
10. Restart
11. ????
12. Log in to root, and type in startx...
let us know if it works for you ..