View Full Version : Kali-Linux-Wireless rfcat dependancy error on armhf image.

2014-06-18, 01:44
I have been running into this problem while putting together my armhf image to use on my tablet:

The following packages have unmet dependencies:
kali-linux-wireless : Depends: rfcat but it is not installable
E: Unable to correct problems, you have held broken packages.

I have been getting this error message each time I try to install the meta package "Kali-Linux-Wireless" on armhf version of Kali-Linux on my tablet.
Being that the error is depending on rfcat, I have installed rfcat from source as follows:

root@cyborg-kali:/rfcat/rfcat-130515# python setup.py install
running install
running build
running build_py
creating build
creating build/lib.linux-armv7l-2.7
creating build/lib.linux-armv7l-2.7/rflib
copying rflib/cc1111client.py -> build/lib.linux-armv7l-2.7/rflib
copying rflib/chipcondefs.py -> build/lib.linux-armv7l-2.7/rflib
copying rflib/ccspecan.py -> build/lib.linux-armv7l-2.7/rflib
copying rflib/cc111Xhparser.py -> build/lib.linux-armv7l-2.7/rflib
copying rflib/chipcon_nic.py -> build/lib.linux-armv7l-2.7/rflib
copying rflib/intelhex.py -> build/lib.linux-armv7l-2.7/rflib
copying rflib/bits.py -> build/lib.linux-armv7l-2.7/rflib
copying rflib/ccrecvdump.py -> build/lib.linux-armv7l-2.7/rflib
copying rflib/__init__.py -> build/lib.linux-armv7l-2.7/rflib
copying rflib/rflib_version.py -> build/lib.linux-armv7l-2.7/rflib
creating build/lib.linux-armv7l-2.7/vstruct
copying vstruct/primitives.py -> build/lib.linux-armv7l-2.7/vstruct
copying vstruct/builder.py -> build/lib.linux-armv7l-2.7/vstruct
copying vstruct/__init__.py -> build/lib.linux-armv7l-2.7/vstruct
creating build/lib.linux-armv7l-2.7/vstruct/defs
copying vstruct/defs/win32.py -> build/lib.linux-armv7l-2.7/vstruct/defs
copying vstruct/defs/kdcom.py -> build/lib.linux-armv7l-2.7/vstruct/defs
copying vstruct/defs/elf.py -> build/lib.linux-armv7l-2.7/vstruct/defs
copying vstruct/defs/pe.py -> build/lib.linux-armv7l-2.7/vstruct/defs
copying vstruct/defs/__init__.py -> build/lib.linux-armv7l-2.7/vstruct/defs
running build_scripts
creating build/scripts-2.7
copying and adjusting rfcat -> build/scripts-2.7
copying and adjusting rfcat_server -> build/scripts-2.7
copying and adjusting CC-Bootloader/bootload.py -> build/scripts-2.7
changing mode of build/scripts-2.7/rfcat from 644 to 755
changing mode of build/scripts-2.7/rfcat_server from 644 to 755
changing mode of build/scripts-2.7/bootload.py from 644 to 755
running install_lib
creating /usr/local/lib/python2.7/dist-packages/vstruct
creating /usr/local/lib/python2.7/dist-packages/vstruct/defs
copying build/lib.linux-armv7l-2.7/vstruct/defs/win32.py -> /usr/local/lib/python2.7/dist-packages/vstruct/defs
copying build/lib.linux-armv7l-2.7/vstruct/defs/kdcom.py -> /usr/local/lib/python2.7/dist-packages/vstruct/defs
copying build/lib.linux-armv7l-2.7/vstruct/defs/elf.py -> /usr/local/lib/python2.7/dist-packages/vstruct/defs
copying build/lib.linux-armv7l-2.7/vstruct/defs/pe.py -> /usr/local/lib/python2.7/dist-packages/vstruct/defs
copying build/lib.linux-armv7l-2.7/vstruct/defs/__init__.py -> /usr/local/lib/python2.7/dist-packages/vstruct/defs
copying build/lib.linux-armv7l-2.7/vstruct/primitives.py -> /usr/local/lib/python2.7/dist-packages/vstruct
copying build/lib.linux-armv7l-2.7/vstruct/builder.py -> /usr/local/lib/python2.7/dist-packages/vstruct
copying build/lib.linux-armv7l-2.7/vstruct/__init__.py -> /usr/local/lib/python2.7/dist-packages/vstruct
creating /usr/local/lib/python2.7/dist-packages/rflib
copying build/lib.linux-armv7l-2.7/rflib/cc1111client.py -> /usr/local/lib/python2.7/dist-packages/rflib
copying build/lib.linux-armv7l-2.7/rflib/chipcondefs.py -> /usr/local/lib/python2.7/dist-packages/rflib
copying build/lib.linux-armv7l-2.7/rflib/ccspecan.py -> /usr/local/lib/python2.7/dist-packages/rflib
copying build/lib.linux-armv7l-2.7/rflib/cc111Xhparser.py -> /usr/local/lib/python2.7/dist-packages/rflib
copying build/lib.linux-armv7l-2.7/rflib/chipcon_nic.py -> /usr/local/lib/python2.7/dist-packages/rflib
copying build/lib.linux-armv7l-2.7/rflib/intelhex.py -> /usr/local/lib/python2.7/dist-packages/rflib
copying build/lib.linux-armv7l-2.7/rflib/bits.py -> /usr/local/lib/python2.7/dist-packages/rflib
copying build/lib.linux-armv7l-2.7/rflib/ccrecvdump.py -> /usr/local/lib/python2.7/dist-packages/rflib
copying build/lib.linux-armv7l-2.7/rflib/__init__.py -> /usr/local/lib/python2.7/dist-packages/rflib
copying build/lib.linux-armv7l-2.7/rflib/rflib_version.py -> /usr/local/lib/python2.7/dist-packages/rflib
byte-compiling /usr/local/lib/python2.7/dist-packages/vstruct/defs/win32.py to win32.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/vstruct/defs/kdcom.py to kdcom.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/vstruct/defs/elf.py to elf.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/vstruct/defs/pe.py to pe.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/vstruct/defs/__init__.py to __init__.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/vstruct/primitives.py to primitives.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/vstruct/builder.py to builder.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/vstruct/__init__.py to __init__.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/rflib/cc1111client.py to cc1111client.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/rflib/chipcondefs.py to chipcondefs.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/rflib/ccspecan.py to ccspecan.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/rflib/cc111Xhparser.py to cc111Xhparser.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/rflib/chipcon_nic.py to chipcon_nic.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/rflib/intelhex.py to intelhex.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/rflib/bits.py to bits.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/rflib/ccrecvdump.py to ccrecvdump.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/rflib/__init__.py to __init__.pyc
byte-compiling /usr/local/lib/python2.7/dist-packages/rflib/rflib_version.py to rflib_version.pyc
running install_scripts
copying build/scripts-2.7/rfcat -> /usr/local/bin
copying build/scripts-2.7/rfcat_server -> /usr/local/bin
copying build/scripts-2.7/bootload.py -> /usr/local/bin
changing mode of /usr/local/bin/rfcat to 755
changing mode of /usr/local/bin/rfcat_server to 755
changing mode of /usr/local/bin/bootload.py to 755
running install_egg_info
Writing /usr/local/lib/python2.7/dist-packages/rfcat-1.0.egg-info

The rfcat python installation script completes without error, and the important files:



and rflib


I do not have any of the supported usb dongles to use with rfcat so I have not compiled the firmware that comes with the package, but the program rfcat is installed and will run, I can run the command rfcat -r for example and the program runs, therefore I feel like it should be seen by apt-get and the dependancy should be met. But as I see I still get the same error and can not install the full meta package, and for now I have to settle for just installing the individual packages that do not require rfcat....

The Kali-Linux armhf image I compiled on Linux Mint 16 Petra amd64 following the detailed instructions at: kali-linux-arm-chroot (http://docs.kali.org/armel-armhf/kali-linux-arm-chroot)

The rootfs image worked perfectly and I am able to boot up Kali-Linux on my arm-pc board with Cortex-a9 armv7 dual core 1Ghz and run Kali-Linux, however I can not install the packages that require the dependancy rfcat even though I have installed rfcat from source because it is not installable through apt-get install. I am not a real linux guru, though I do use Linux Mint as my main OS of choice, using other closed source OS choices secondary only for those few things I have not yet found compatability solutions for, yet, that list is fast shrinking every day :) But I do know a thing or two, hehe.

Any way, before I start rambling... I was wopndering if anyone else has had this issue, and if it has been solved yet?

Also If you need any further details to help come to a solution please ask, and I can get any, and all details of my situation. I Have tried several times to rebuild the armhf image and install the meta package Kali-Linux-Wireless and always get the same dependancy error for rfcat and have not solved it yet, even after installing rfcat from source.
Again any help would be greatly apreciated in solving this so I can have the Kali-Linux Wireless tools for use on my tablet.

Sorry for my inability to always explain eactly what my issue is, I know I tend to run on and dont always hev the greatest sentence structure, lol..., I do much better when answering direct questions about my problem. Then I can get the pertinent information to a person of expertise, that can relay the information back to me that will send me in the direction I am seeking to go. I do try to get the right stuff up, but am not always the most sucessfull every time, I am always working to improve.

My goal, to have a working Kali-Linux, withh all of the wireless, and all other tools as one of my boot options on my tablet is what I do want very much to achieve.

This would be awesome - the power of Kali-Linux Offensive-Security Software, hand held portable on my tablet - I think it would be an excelent!

Thanks - Kaiji

2014-08-19, 13:35
change your /etc/apt/sources.list as follows:

deb http://http.kali.org/kali kali-dev main non-free contrib
deb http://security.kali.org/kali-security kali/updates main contrib non-free
## Source repositories
deb-src http://http.kali.org/kali kali-dev main non-free contrib
deb-src http://security.kali.org/kali-security kali/updates main contrib non-free
finish with

apt-get update
apt-get upgrade
apt-get dist-upgrade