PDA

View Full Version : (Guide) Installing Nvidia + Bumblebee + CUDA for Optimus enabled Laptops



Pages : [1] 2

staticn0de
2014-07-07, 09:18
Updated for Kali 2.0 Sana

Hey guys, I'm rewriting this to use the repo as Kali Sana looks to have up-to-date nvidia drivers straight out of the gate.



NVIDIA Driver 352.21
CUDA 7.5.18 (the repo has 6.0.37-5, it's a bit old so I'm manually installing 7.5.18)
VirtualGL 2.4.90
Pyrit v308 (optional)
cudaHashcat (optional)


Couple of points

1. This guide and all GPU passthrough software such as cuda_pyrit and cudahashcat will never work if run from within a Virtual Machine. Please don't post that it does not work for you in a VM because you should have read this.

2. I'm going to assume that you are either on a fresh install of Kali or have the skills to clean up any conflicting software.

3. I run 64bit software. If you don't, change the files you download to match what you use. (Edit: CUDA does not support 32bit anymore)

4. If you have any issues or if something does not work, follow the template linked here (https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=35242&viewfull=1#post35242) and post the results of all commands.

Lets get started.

1. Update Kali


apt-get update && apt-get upgrade && apt-get dist-upgrade


2. Download VirtualGL and install it. Grab the latest non-beta


http://sourceforge.net/projects/virtualgl/files/

Install with:
cd ~
dpkg -i virtualgl*.deb


3. Download CUDA 7.5. Grab the x64 or 14.04 *.run file (should be 1.1gb)


https://developer.nvidia.com/cuda-downloads


5. Install linux headers for your kernel


apt-get install linux-headers-$(uname -r)


6. Install dependencies we will need later. The first two are for CUDA and the last is for pyrit


apt-get install freeglut3-dev libxmu-dev libpcap-dev


7. Update system PATH. Notice that the PATH references CUDA 7.5. If you have a different version, change it to match.


nano ~/.bashrc

Add the following line and then save and close bashrc
export PATH=$PATH:/opt/VirtualGL/bin:/usr/local/cuda-7.5/bin


8. Export the system path. We export the path from terminal so we can take advantage of it without restart. Run the following in terminal


export PATH=$PATH:/opt/VirtualGL/bin:/usr/local/cuda-7.5/bin


9. Install bumblebee-nvidia and primus. Just press enter when the messages appear and ignore the warning about rrmod.


apt-get install bumblebee-nvidia primus


10. Edit the bumblebee config file so bumblebee knows we are using the NVIDIA driver. Change the 'Driver=' value. Should be line 22. The module from the repo driver is 'nvidia-current' but we set 'nvidia' here so that the nvidia section of bumblebee.conf is called.


nano +22 /etc/bumblebee/bumblebee.conf

Make it read:
Driver=nvidia

check line 55 and make sure it reads:
KernelDriver=nvidia-current

Save and close


11. Run the following and record the PCI address of your video card. It will look similar to 03:00.0


lspci | egrep 'VGA|3D'


12. Edit the xorg.conf.nvidia file so it knows the PCI address of your video card. Note that the last group of numbers is now seperated with a ":" instead of a ".". We are editing under the area 'Section "Device"'


nano /etc/bumblebee/xorg.conf.nvidia

Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:03:00:0"


14. Reboot


shutdown -r now


15. Now we have restarted, test the driver. glxsheres64 will test the driver and modinfo nvidia will show the version loaded.


optirun glxspheres64

modinfo nvidia


16. Prepare CUDA for install


cd ~
chmod +x cuda*.run


17. Run the CUDA install


./cuda*.run

Accept the EULA
Select yes to unsupported configuration
No to graphics driver
Yes to the toolkit
Accept default location
Yes to symbolic link
Yes to samples
Yes to default samples location
The toolkit will install


18. Set up the dynamic linker for CUDA. Notice that this is slightly different than the path added for .bashrc


nano /etc/ld.so.conf

Match the contents below

include /etc/ld.so.conf.d/*.conf
/usr/local/cuda-7.5/lib64


19. Excute the following to load our changes


ldconfig


20. Install libcuda1. You will get an incorrect driver version error if you don't.


apt-get install libcuda1


21. Build the NVIDIA samples so we can confirm CUDA is working with optirun


cd /root/NVIDIA_CUDA-7.5_Samples/1_Utilities/deviceQuery/
make


22. Run deviceQuery and then post your pass! If you see a pass, it all worked out! If not, follow the link at the start of the guide and post everything asked.


optirun ./deviceQuery

staticn0de
2014-07-07, 09:23
Optional Installs - cudaHashcat and Pyrit

This section is for optional installs. If you installed CUDA on Kali, Im tipping these are both applications you are interested in.

Points

1. If you have any issues installing any of this, post the complete output of any commands entered.

cudaHashcat

You have two options, download the archive from the hashcat website and install it manually (sorry, I'm not going into that. If you need instructions, check their wiki)

The second option is download my deb file. You can install it with a single command and then call cuda hashcat with either 'cudahashcat64' (for 64bit) or 'cudahashcat32' (for 32bit). Grab and install it from the link below.

Disclaimer
While some forum members make use of my deb, I am not a member of either the hashcat team or the Kali dev team. I could have edited the contents of the deb in any way (including maliciously). Take care when downloading from unknown sources. I provide no warranty and do not claim that it is fit for any purpose, including that which it is intended.

I repackaged the hashcat binary in accordance with their EULA so it would install easily on Kali. I also removed non-linux binaries.

1. cudahashcat 2.01


https://mega.nz/#!sZFngKJR!njrug2Y4nxs0aHemQg-SKKGAmXiK1XeALTtnP8IGYNU

dpkg -i cudahashcat-2.01.deb


2. cudahashcat 1.36


https://mega.co.nz/#!gAtAQDJY!x9FIs2ssQ66HmlXMdGDUiPI-l45el0dAFUpaGTm_P-0

dpkg -i cudahashcat-1.36.deb


3. cudahashcat 1.35


https://mega.co.nz/#!dN8ESI7D!-jxoTZBwVddzKZ2r0MuQ5T4sDJZ5NSOnkrNvxpDuNNg

dpkg -i cudahashcat-1.35.deb


4. cudahashcat 1.34


https://mega.co.nz/#!0Z9DHBob!0QA3clJqszGEExTKlKTBPLJEoDvXIiBwBepiYgW Zbew

dpkg -i cudahashcat-1.34.deb


5. cudahashcat 1.33


https://mega.co.nz/#!oQNQhRyT!gTSxCEB5APkMgdaJl_k91h_9lgwK4LWUfwfTdGH AbEU

dpkg -i cudahashcat-1.33.deb


6. cudahashcat 1.31 (seems to be faster than 1.33)


https://mega.co.nz/#!kFMC2RQC!D1ccQYAwsWyGKD0CaV4W7n5Ghtc-YKFFxs7Qj1pgcw0

dpkg -i cudahashcat-1.31.deb


The deb sums are


cudahashcat 2.01
md5sum = 69a9289e05a6e4b25728d5738a48f76c

cudahashcat 1.36
md5sum = f4ea04116a8495ea3e850fc993220554

cudahashcat 1.35
md5sum = ccdc7ebf4c4a947d14fa663a982e3c10

cudahashcat 1.34
md5sum = e611e16ab1f3c42c5e98d3ef615a0cd4

cudahashcat 1.33
md5sum = 82f4975f02af1288de058c93552b981d

cudahashcat 1.31
md5sum = b753c393264b3c40e51f057a96f3f6e9


Test it with


optirun cudahashcat64 -t 32 -a 7 example0.hash ?a?a?a?a example.dict


To remove it


dpkg -r cudahashcat-2.01

and check the following directories and files are removed

/usr/bin/cudahashcat32 (file)
/usr/bin/cudahashcat64 (file)
/usr/share/cudahashcat (directory)


Pyrit

The following instructions are slightly modified from the pyrit google code page here


https://code.google.com/p/pyrit/wiki/Installation


1. Move to your home directory (I'm installing it there) and then check out the pyrit trunk


cd ~

svn checkout http://pyrit.googlecode.com/svn/trunk/ pyrit_svn


2. Build and install pyrit


cd pyrit_svn/pyrit/
python setup.py build
python setup.py install


3. Add CUDA support


cd ../cpyrit_cuda/
python setup.py build
python setup.py install


4. Test pyrit


optirun pyrit benchmark

staticn0de
2014-07-07, 09:25
Reporting your issues

Most issues people have are a simple typo in their config files. Double check them before posting. I know this is a lot of commands to go through, but many users are new and experience delays in posting. Not giving enough information can result in multiple day turn arounds.

1. Use the [*CODE] brackets to paste the output of commands (the open and close code brackets are [*CODE] and [*/CODE] without the *. Put all the text between them.

Commands to execute

1.

lspci | egrep 'VGA|3D'

2.

modprobe nvidia

3.

modprobe nvidia-uvm

4.

optirun glxspheres64

5.

dmesg | tail -n 100

6.

echo $PATH

7.

cat /etc/bumblebee/bumblebee.conf

8.

cat /etc/bumblebee/xorg.conf.nvidia

9.

service bumblebeed restart

10.

modinfo nvidia

11.

find 2> /dev/null / -name nvidia*.ko

Quest
2014-07-08, 01:37
Great guide staticn0de!




- This post edited with download links for an OFF-Line installation on Kali 1.1.0 -


Download CUDA, VirtualGL, Nvidia, CudaHashcat, from previous posts above.
This does not include Kali Linux updates or Headers. Just the extra packs required for this guide.
All links point to Debian wheezy(stable) packages whenever possible or equivalent/default.

Scroll down the page at Debian and choose your architecture under "Download".
Choose a server to download from.

All packs go in Home, the /root directory. Remove them when installation is done.
Install from root with

dpkg -i name.deb



(6.) Download and Install dependencies for CUDA and Pyrit.

freeglut3-dev
https://packages.debian.org/wheezy/freeglut3-dev

libxmu-headers
https://packages.debian.org/wheezy/libxmu-headers

libxmu-dev
https://packages.debian.org/wheezy/libxmu-dev

libpcap-dev
https://packages.debian.org/wheezy/libpcap-dev



(9.) Download and Install bumblebee and primus.

linux-headers (another "linux headers")(mine was linux-headers-amd64_3.18+63+kali2.1_amd64.deb)
http://ftp.tku.edu.tw/kali/pool/main/l/linux-latest/

dkms
https://packages.debian.org/wheezy/dkms

bbswitch-dkms
https://packages.debian.org/wheezy-backports/bbswitch-dkms

bumblebee
https://packages.debian.org/wheezy-backports/bumblebee

primus-libs
https://packages.debian.org/wheezy-backports/primus-libs

primus
https://packages.debian.org/wheezy-backports/primus



Optional. Download and Install Pyrit and add-on for Nvidia CUDA.

pyrit_svn 0.4.1-dev svn r308

From Linux, enter in a console;

svn checkout http://pyrit.googlecode.com/svn/trunk/ pyrit_svn
That will download a folder in /root (Home) named, pyrit_svn
That folder is pyrit 0.4.1 svn r308. You can then save that folder for later off-line installations.

Built and install Pyrit and add CUDA support.


cd pyrit_svn/pyrit/
python setup.py build
python setup.py install

cd ../cpyrit_cuda/
python setup.py build
python setup.py install



Total: 11 packs. 2,05 Mb

staticn0de
2014-07-08, 06:51
Great guide staticn0de!

Everyting worked well, until...




my output was
:(

Any advice?

Many thanks staticn0de I'm getting closer! ;)

I'm not sure what's causing that, but let's see if we can get you sorted out.

To start, run:
diff /usr/src/nvidia-current-331.67/Module.symvers /usr/src/nvidia-current-331.67/uvm/Module.symvers

Any feedback from the above command means you need to delete the Module.symvers from the folder on the right and copy from the directory on the left into the directory on the right again. Once copied, run make in the uvm/ folder and copy it to /lib/modules/3.14-kali1-amd64/updates/dkms/

Post the feedback from below:
echo $PATH

Post the feedback from:
cat /etc/modprobe.d/nvidia.conf

Post the feedback from:
ls /lib/modules/3.14-kali1-amd64/updates/dkms

Run modprobe nvidia-uvm and then run dmesg right after. Post the output in code brackets.

Run lsmod and post output in code brackets

You could also try modprobe nvidia and then modprobe nvidia-current and then modprobe nvidia-uvm

Edit: Some other cool stuff you could try is a:
depmod -a
modprobe nvidia-uvm

and then post the output of:
cat /lib/modules/3.14-kali1-amd64/modules.dep | grep -i nvidia

Quest
2014-07-08, 14:21
the odds are that it was the operator(me), though I would like to reassure you that I fallowed your guide precisely, on a fresh installation of Kali 1.0.7 x64. I can even point out a small mistake in a syntax(induced by LibreOffice auto correction)
First, install the linux headers. We need this so we can compile bbswitch later
apt-get install linux-headers-$(uname –r) I did however strugeled alot with the nano console, as I did not know how to save changes. Save with F2, then Y, then "File Name to Write: xxxxxx, Enter

Last night I decided to re-install, so I will do it again, then if I still encounter the same problem, I will proceed with post#5 and report back.

Thank you my friend

staticn0de
2014-07-08, 19:40
Good pickup! I've fixed it now.

As for nano, control + x, then y and then enter will save your changes and then close the file.

Quest
2014-07-08, 22:31
Exact ame results as yesterday.


root@kali:~# rm /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko
root@kali:~# cp /usr/src/nvidia-current-331.67/uvm/nvidia-uvm.ko /lib/modules/3.14-kali1-amd64/updates/dkms/
root@kali:~# modprobe nvidia-uvm
ERROR: could not insert 'nvidia_uvm': No such device

i ran into this last night when search for a possible solution. This is recent 2 May 2014. Could there be a bug with versions nvidia-graphics-drivers/331.67-1, nvidia-graphics-drivers/331.67-2, nvidia-graphics-drivers/331.79-1 ?

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=746643 OpenCL not supported by lastest NVIDIA driver



These are the my outputs:



00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 630M] (rev ff)




root@kali:~# optirun glxspheres64
Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: GeForce GT 630M/PCIe/SSE2
243.416053 frames/sec - 204.644744 Mpixels/sec
246.672039 frames/sec - 207.382117 Mpixels/sec
195.415671 frames/sec - 164.289863 Mpixels/sec
170.460050 frames/sec - 143.309173 Mpixels/sec
171.786163 frames/sec - 144.424063 Mpixels/sec
167.925432 frames/sec - 141.178269 Mpixels/sec
166.438969 frames/sec - 139.928570 Mpixels/sec
168.091304 frames/sec - 141.317721 Mpixels/sec
171.926627 frames/sec - 144.542154 Mpixels/sec
170.618800 frames/sec - 143.442638 Mpixels/sec
168.957864 frames/sec - 142.046256 Mpixels/sec
174.145734 frames/sec - 146.407802 Mpixels/sec
172.519375 frames/sec - 145.040489 Mpixels/sec
169.868780 frames/sec - 142.812081 Mpixels/sec




===========
= Summary =
===========

Driver: Not Selected
Toolkit: Installed in /usr/local/cuda-5.5
Samples: Installed in /root/NVIDIA_CUDA-5.5_Samples

* Please make sure your PATH includes /usr/local/cuda-5.5/bin

* Please make sure your LD_LIBRARY_PATH
* for 32-bit Linux distributions includes /usr/local/cuda-5.5/lib
* for 64-bit Linux distributions includes /usr/local/cuda-5.5/lib64:/lib
* OR
* for 32-bit Linux distributions add /usr/local/cuda-5.5/lib
* for 64-bit Linux distributions add /usr/local/cuda-5.5/lib64 and /lib
* to /etc/ld.so.conf and run ldconfig as root

* To uninstall CUDA, remove the CUDA files in /usr/local/cuda-5.5
* Installation Complete

Please see CUDA_Getting_Started_Linux.pdf in /usr/local/cuda-5.5/doc/pdf for detailed information on setting up CUDA.




root@kali:~# rm /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko
root@kali:~# cp /usr/src/nvidia-current-331.67/uvm/nvidia-uvm.ko /lib/modules/3.14-kali1-amd64/updates/dkms/
root@kali:~# modprobe nvidia-uvm
ERROR: could not insert 'nvidia_uvm': No such device



- CONTENT OF dkms.conf -

# DKMS configuration for the NVIDIA kernel module. -*- sh -*-

# The version is replaced at build time by dh_dkms invoked in debian/rules.
PACKAGE_NAME="nvidia-current"
PACKAGE_VERSION="331.67"

BUILT_MODULE_NAME[0]="nvidia"
DEST_MODULE_NAME[0]="$PACKAGE_NAME"
DEST_MODULE_LOCATION[0]="/updates/dkms"
AUTOINSTALL=yes

MAKE[0]="env CCACHE_DISABLE=1 \
make -C . SYSSRC=${kernel_source_dir}"
CLEAN="make -C . SYSSRC=${kernel_source_dir} clean"

BUILT_MODULE_NAME[1]="nvidia-uvm"
BUILT_MODULE_LOCATION[1]="uvm/"
DEST_MODULE_LOCATION[1]="/updates/dkms"
MAKE[0]+="; env CCACHE_DISABLE=1 \
make -C uvm SYSSRC=${kernel_source_dir}"
CLEAN+="; make -C uvm SYSSRC=${kernel_source_dir} clean"

- END OF CONTENT -





root@kali:~# diff /usr/src/nvidia-current-331.67/Module.symvers /usr/src/nvidia-current-331.67/uvm/Module.symvers
root@kali:~#
NO FEEDBACK


root@kali:~# echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/VirtualGL/bin


root@kali:~# cat /etc/modprobe.d/nvidia.conf
alias nvidia nvidia-current
remove nvidia-current rmmod nvidia


root@kali:~# modprobe nvidia-uvm
ERROR: could not insert 'nvidia_uvm': No such device

root@kali:~# lsmod
Module Size Used by
nls_utf8 12456 1
nls_cp437 16553 1
vfat 17185 1
fat 57965 1 vfat
nfnetlink_log 17241 0
nfnetlink 12989 1 nfnetlink_log
bbswitch 12866 0
binfmt_misc 16949 1
loop 26605 0
dm_crypt 22731 0
joydev 17108 0
snd_hda_codec_hdmi 45004 1
snd_hda_codec_realtek 54360 1
snd_hda_codec_generic 59079 1 snd_hda_codec_realtek
btusb 25619 0
bluetooth 243618 2 btusb
6lowpan_iphc 16588 1 bluetooth
x86_pkg_temp_thermal 12965 0
intel_powerclamp 17159 0
arc4 12543 2
snd_hda_intel 39656 3
i915 743012 2
snd_hda_codec 99921 4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_c odec_generic,snd_hda_intel
iTCO_wdt 12831 0
iTCO_vendor_support 12649 1 iTCO_wdt
snd_hwdep 13148 1 snd_hda_codec
lpc_ich 20768 0
ir_rc6_decoder 12433 0
ir_jvc_decoder 12433 0
iwldvm 130998 0
mac80211 488308 1 iwldvm
iwlwifi 87784 1 iwldvm
drm_kms_helper 39998 1 i915
drm 240557 3 i915,drm_kms_helper
i2c_algo_bit 12751 1 i915
intel_rapl 17344 0
snd_pcm 88538 3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_timer 26606 1 snd_pcm
snd 61039 14 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_ codec_hdmi,snd_pcm,snd_hda_codec_generic,snd_hda_c odec,snd_hda_intel
soundcore 13026 1 snd
mei_me 13446 0
i2c_i801 16963 0
mei 50039 1 mei_me
i2c_core 24265 5 drm,i915,i2c_i801,drm_kms_helper,i2c_algo_bit
cfg80211 436618 3 iwlwifi,mac80211,iwldvm
ir_sony_decoder 12435 0
ir_sanyo_decoder 12437 0
ir_lirc_codec 12675 0
ir_mce_kbd_decoder 12574 0
ir_nec_decoder 12433 0
lirc_dev 16951 1 ir_lirc_codec
ir_rc5_decoder 12433 0
coretemp 12854 0
kvm_intel 138949 0
kvm 404503 1 kvm_intel
rc_rc6_mce 12396 0
ene_ir 21814 0
rc_core 18235 12 lirc_dev,ir_lirc_codec,ir_rc5_decoder,ir_nec_decod er,ir_sony_decoder,ene_ir,ir_mce_kbd_decoder,ir_jv c_decoder,ir_rc6_decoder,ir_sanyo_decoder,rc_rc6_m ce
psmouse 86464 0
serio_raw 12849 0
evdev 17489 13
rtsx_pci_ms 12802 0
memstick 13696 1 rtsx_pci_ms
mxm_wmi 12515 0
toshiba_acpi 18063 0
sparse_keymap 12760 1 toshiba_acpi
rfkill 18902 5 cfg80211,toshiba_acpi,bluetooth
toshiba_bluetooth 12641 0
battery 13101 0
processor 28221 0
ac 12678 0
video 17804 1 i915
thermal_sys 27685 4 video,intel_powerclamp,processor,x86_pkg_temp_ther mal
wmi 17339 2 toshiba_acpi,mxm_wmi
button 12944 1 i915
ext4 489943 1
crc16 12343 2 ext4,bluetooth
mbcache 13082 1 ext4
jbd2 86788 1 ext4
dm_mod 89276 1 dm_crypt
hid_generic 12393 0
usbhid 44481 0
hid 94062 2 hid_generic,usbhid
sg 30043 0
sr_mod 21898 0
cdrom 39232 1 sr_mod
sd_mod 44346 5
crc_t10dif 12431 1 sd_mod
usb_storage 52037 4
rtsx_pci_sdmmc 17076 0
mmc_core 93950 1 rtsx_pci_sdmmc
crct10dif_pclmul 13348 1
crct10dif_common 12356 2 crct10dif_pclmul,crc_t10dif
crc32_pclmul 12915 0
crc32c_intel 21809 0
ghash_clmulni_intel 12978 0
ahci 29195 0
aesni_intel 151423 0
libahci 27103 1 ahci
aes_x86_64 16719 1 aesni_intel
lrw 12757 1 aesni_intel
gf128mul 12970 1 lrw
glue_helper 12690 1 aesni_intel
ablk_helper 12572 1 aesni_intel
cryptd 14560 3 ghash_clmulni_intel,aesni_intel,ablk_helper
libata 169163 2 ahci,libahci
scsi_mod 186841 5 sg,usb_storage,libata,sd_mod,sr_mod
rtsx_pci 33623 2 rtsx_pci_ms,rtsx_pci_sdmmc
mfd_core 12601 2 lpc_ich,rtsx_pci
r8169 64490 0
mii 12675 1 r8169
ehci_pci 12472 0
xhci_hcd 111830 0
ehci_hcd 48517 1 ehci_pci
usbcore 166472 6 btusb,usb_storage,ehci_hcd,ehci_pci,usbhid,xhci_hc d
usb_common 12440 1 usbcore
root@kali:~#


root@kali:~# modprobe nvidia
root@kali:~# modprobe nvidia-current
ERROR: could not insert 'nvidia_current': No such device
root@kali:~# modprobe nvidia-uvm
ERROR: could not insert 'nvidia_uvm': No such device


root@kali:~# depmod -a
root@kali:~#

root@kali:~# cat /lib/modules/3.14-kali1-amd64/modules.dep | grep -i nvidia
kernel/drivers/net/ethernet/nvidia/forcedeth.ko:
updates/dkms/nvidia-uvm.ko: updates/dkms/nvidia-current.ko kernel/drivers/i2c/i2c-core.ko
updates/dkms/nvidia-current.ko: kernel/drivers/i2c/i2c-core.ko

staticn0de
2014-07-09, 00:33
I don't believe a bug is causing this as It's working here. Like all things linux, it will be a one liner somewhere that will fix it.

Would you please post your /etc/bumblebee/bumblebee.conf and xorg.nvidia.conf in the same directory.

The way it works is that nvidia-uvm depends on the nvidia-current module. We know that works because you can use optirun glxspheres.

Did you have any useful dmesg feedback from after the modprobe?

Did you add the cuda libraries and then run ldconfig? I'm sure you did, but I was just going through the feedback you posted (I assume you omitted doing it because I didn't ask for it)

Hopefully we can get this sorted out soon

Quest
2014-07-09, 02:24
xD yes it definitely feels like the setup is missing a line somewhere.


Here is the output of bumblebee.conf and xorg.conf.nvidia..

bumblebee.conf
# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
# bbswitch - new in BB 3, recommended if available
# switcheroo - vga_switcheroo method, use at your own risk
# none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-current
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

xorg.conf.nvidia
Section "ServerLayout"
Identifier "Layout0"
Option "AutoAddDevices" "false"
Option "AutoAddGPU" "false"
EndSection

Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:01:00:0"

# If the X server does not automatically detect your VGA device,
# you can manually set it here.
# To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
# as you see in the commented example.
# This Setting may be needed in some platforms with more than one
# nvidia card, which may confuse the proprietary driver (e.g.,
# trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
# BusID "PCI:01:00:0"

# Setting ProbeAllGpus to false prevents the new proprietary driver
# instance spawned to try to control the integrated graphics card,
# which is already being managed outside bumblebee.
# This option doesn't hurt and it is required on platforms running
# more than one nvidia graphics card with the proprietary driver.
# (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
# If this option is not set, the new Xorg may blacken the screen and
# render it unusable (unless you have some way to run killall Xorg).
Option "ProbeAllGpus" "false"

Option "NoLogo" "true"
Option "UseEDID" "false"
Option "UseDisplayDevice" "none"
EndSection


I can't remember if I had any useful dmesg feedback from after the modprobe.

I did add the cuda libraries and then run ldconfig. Yes. I can reinstall again and copy the info from ldconfig and modprobe if need be.



Let me know if I can provide anything else for the investigation ;)

Quest
2014-07-09, 04:55
you know what, everything is fine until that step..


Now to fix the nvidia-uvm module (You don't know this yet, but it's broken.)

cd /usr/src/nvidia-current-331.67
make

cp Module.symvers uvm/

cd uvm/
make

Can you confirm that:
1. capital 'M' in "Module.symvers uvm/" syntax
2. the nvidia-uvm module is really broken, and needs fixing

I will try without fixing tomorrow see what happens. Now I'm going to dream about using piryt and hashcat :)

Quest
2014-07-09, 18:21
Nevermind the above post.


After a 3rd reinstall. Same results.

Here are some interesting bits, that might have nothing to do with it(?)


root@kali:~# uname -r
3.14-kali1-amd64





depmod....

DKMS: install completed.
Setting up nvidia-driver (331.67-2kali1) ...
Setting up bumblebee-nvidia (3.2.1-4~bpo70+1) ...
update-alternatives: using /usr/lib/mesa-diverted to provide /usr/lib/glx (glx) in manual mode
[ ok ] Restarting bumblebeed: bumblebeed.
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.14-kali1-amd64
cryptsetup: WARNING: failed to detect canonical device of /dev/sdb5
331.67-2 !!?? There are two version of the same. Really?


root@kali:~# apt-get install nvidia-glx
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
nvidia-glx
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 119 kB of archives.
After this operation, 158 kB of additional disk space will be used.
Get:1 http://http.kali.org/kali/ kali/non-free nvidia-glx amd64 331.67-2kali1 [119 kB]
Fetched 119 kB in 6s (19.1 kB/s)
Selecting previously unselected package nvidia-glx.
(Reading database ... 343139 files and directories currently installed.)
Unpacking nvidia-glx (from .../nvidia-glx_331.67-2kali1_amd64.deb) ...
Setting up nvidia-glx (331.67-2kali1) ...
root@kali:~#



root@kali:~# apt-get install nvidia-glx
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
nvidia-glx
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 119 kB of archives.
After this operation, 158 kB of additional disk space will be used.
Get:1 http://http.kali.org/kali/ kali/non-free nvidia-glx amd64 331.67-2kali1 [119 kB]
Fetched 119 kB in 6s (19.1 kB/s)
Selecting previously unselected package nvidia-glx.
(Reading database ... 343139 files and directories currently installed.)
Unpacking nvidia-glx (from .../nvidia-glx_331.67-2kali1_amd64.deb) ...
Setting up nvidia-glx (331.67-2kali1) ...
root@kali:~#




root@kali:~# lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 630M] (rev ff)
root@kali:~#




root@kali:~# apt-get install libcuda1
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
nvidia-smi
Suggested packages:
nvidia-cuda-mps
Recommended packages:
libcuda1-i386
The following NEW packages will be installed:
libcuda1 nvidia-smi
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 5,688 kB of archives.
After this operation, 14.5 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://http.kali.org/kali/ kali/non-free libcuda1 amd64 331.67-2kali1 [5,480 kB]
Get:2 http://http.kali.org/kali/ kali/non-free nvidia-smi amd64 331.67-2kali1 [207 kB]
Fetched 5,688 kB in 31s (178 kB/s)
Selecting previously unselected package libcuda1:amd64.
(Reading database ... 343147 files and directories currently installed.)
Unpacking libcuda1:amd64 (from .../libcuda1_331.67-2kali1_amd64.deb) ...
Selecting previously unselected package nvidia-smi.
Unpacking nvidia-smi (from .../nvidia-smi_331.67-2kali1_amd64.deb) ...
Processing triggers for man-db ...
Setting up libcuda1:amd64 (331.67-2kali1) ...
Setting up nvidia-smi (331.67-2kali1) ...
root@kali:~#


CUDA

Do you accept the previously read EULA? (accept/decline/quit): accept
You are attempting to install on an unsupported configuration. Do you wish to continue? ((y)es/(n)o) [ default is no ]: y
Install NVIDIA Accelerated Graphics Driver for Linux-x86_64 319.37? ((y)es/(n)o/(q)uit): n
Install the CUDA 5.5 Toolkit? ((y)es/(n)o/(q)uit): y
Enter Toolkit Location [ default is /usr/local/cuda-5.5 ]:
Install the CUDA 5.5 Samples? ((y)es/(n)o/(q)uit): y
Enter CUDA Samples Location [ default is /root/NVIDIA_CUDA-5.5_Samples ]:
Installing the CUDA Toolkit in /usr/local/cuda-5.5 ...

WAIT.............


===========
= Summary =
===========

Driver: Not Selected
Toolkit: Installed in /usr/local/cuda-5.5
Samples: Installed in /root/NVIDIA_CUDA-5.5_Samples

* Please make sure your PATH includes /usr/local/cuda-5.5/bin

* Please make sure your LD_LIBRARY_PATH
* for 32-bit Linux distributions includes /usr/local/cuda-5.5/lib
* for 64-bit Linux distributions includes /usr/local/cuda-5.5/lib64:/lib
* OR
* for 32-bit Linux distributions add /usr/local/cuda-5.5/lib
* for 64-bit Linux distributions add /usr/local/cuda-5.5/lib64 and /lib
* to /etc/ld.so.conf and run ldconfig as root

* To uninstall CUDA, remove the CUDA files in /usr/local/cuda-5.5
* Installation Complete






root@kali:~# ldconfig
root@kali:~#
NOTHING HAPPENS



AFTER SETUP I RUN optirun glxspheres64 again and...


root@kali:~# /etc/init.d/bumblebeed restart
[ ok ] Restarting bumblebeed: bumblebeed.
root@kali:~# optirun glxspheres64
[10223.471114] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[10223.471198] [ERROR]Aborting because fallback start is disabled.
root@kali:~#

dmesg modprobe (Notice the interesting bit at the end):


root@kali:~# dmesg
CANNOT POST THE WHOLE THING

...
[Package] (20131218/nsarguments-95)
[ 6170.453345] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6170.453385] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6176.843757] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6178.305207] bbswitch: disabling discrete graphics
[ 6178.305228] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6178.318591] pci 0000:01:00.0: Refused to change power state, currently in D0
[ 6550.299909] bbswitch: enabling discrete graphics
[ 6550.757766] bbswitch: disabling discrete graphics
[ 6550.757788] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6561.213529] bbswitch: enabling discrete graphics
[ 6561.651014] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns =none
[ 6561.651157] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 331.67 Fri Apr 4 13:48:39 PDT 2014
[ 6561.681517] nvidia 0000:01:00.0: irq 49 for MSI/MSI-X
[ 6561.692369] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6561.692454] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6561.692501] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6561.692543] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6561.692584] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6561.692624] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6561.692690] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6561.692731] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6568.469916] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6657.371547] bbswitch: disabling discrete graphics
[ 6657.371569] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 6657.384771] pci 0000:01:00.0: Refused to change power state, currently in D0
[ 8142.331643] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns =none
[ 8142.331723] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0de9)
[ 8142.331723] NVRM: installed in this system is not supported by the 331.67
[ 8142.331723] NVRM: NVIDIA Linux driver release. Please see 'Appendix
[ 8142.331723] NVRM: A - Supported NVIDIA GPU Products' in this release's
[ 8142.331723] NVRM: README, available on the Linux driver download page
[ 8142.331723] NVRM: at www.nvidia.com.
[ 8142.331795] nvidia: probe of 0000:01:00.0 failed with error -1
[ 8142.331853] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 8142.331855] NVRM: None of the NVIDIA graphics adapters were initialized!
[ 8142.332042] NVRM: NVIDIA init module failed!
root@kali:~#

Quest
2014-07-09, 18:41
post too long continued here...


The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0de9)
installed in this system is not supported by the 331.67
NVIDIA Linux driver release. Please see 'Appendix
A - Supported NVIDIA GPU Products' in this release's
README, available on the Linux driver download page OH really? Let's go and see...

http://us.download.nvidia.com/XFree86/Linux-x86_64/331.67/README/supportedchips.html


Note that the list of supported GPU products provided below and on the driver download page is provided to indicate which GPUs are supported by a particular driver version. Some designs incorporating supported GPUs may not be compatible with the NVIDIA Linux driver: in particular, notebook and all-in-one desktop designs with switchable (hybrid) or Optimus graphics will not work if means to disable the integrated graphics in hardware are not available. Hardware designs will vary from manufacturer to manufacturer, so please consult with a system's manufacturer to determine whether that particular system is compatible.


10de:0de9 is not supported by the 331.67 NVIDIA Linux driver release :(

rastamouse
2014-07-09, 18:52
This worked perfectly for me. Thanks staticn0de.

Quest
2014-07-09, 19:13
Let me understand something here... Why are we working with driver 331.67, and only that version. Is it because of bumblebee? (I'm quite stubborn and still looking for a solution, even within an obvious failure framework).

In any case, thank you staticn0de :)

staticn0de
2014-07-09, 20:17
Let me understand something here... Why are we working with driver 331.67, and only that version. Is it because of bumblebee? (I'm quite stubborn and still looking for a solution, even within an obvious failure framework).

In any case, thank you staticn0de :)

Hi there Quest,

You don't have to use that driver version. That is just what is in the wheezy backports repo.

I have not tried a newer version on Kali (I've used 337 on Ubuntu with bumblebee - that had its own issues)

To install a newer version, you will need to add the Jessie or Sid repo.

Jessie is the testing repo and has the 337.19-1 driver under the name nvidia-driver or the transitional package Nvidia-glx.

Sid is the unstable repo and has nvidia 331.79-1 under the same names as that above.

These should work if you want to try them. I'm sure you understand how easily you can break Kali with unsupported repos (wheezy backports is not much better I'm sure)

deb http://http.debian.net/debian sid main contrib non-free

Or

deb http://http.debian.net/debian jessie main contrib non-free

siste
2014-07-10, 17:43
See this article I was very moved when I thank staticn 0. Thank you. notebook can be normal working the

staticn0de
2014-07-11, 09:39
For those interested, much to my amazement I was able to get Nvidia 340.24 working on Kali


root@kali:/proc/driver/nvidia# cat version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 340.24 Wed Jul 2 14:24:20 PDT 2014
GCC version: gcc version 4.7.2 (Debian 4.7.2-5)

It was a bit of an "unclean" install as I kind of had to force it on there, but glxspheres64 and optirun is working. I'll try and get CUDA 6 working and keep you posted. If I get it, i'll clean up the process and post that too.

Edit:

It's looking promising!


deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 6.5, CUDA Runtime Version = 6.0, NumDevs = 1, Device0 = GeForce GT 740M
Result = PASS

London
2014-07-11, 14:22
staticn0de, thankyou for the work that went into this write up. It worked really well. I did have one issue but solved it here: https://wiki.archlinux.org/index.php/bumblebee

Quest
2014-07-11, 16:30
that's cool :)

even though most can figure it out for themselves, I was thinking that maybe(?) it would be nice to have all the command lines, and links to, an OFF_LINE installation. There's nothing wrong with this procedure as is, but we already DLing CUDA (and now probly new NVIDIA drivers), so maybe DL everything and than install?

I'm not a big fan of being dependent on the Internet for installations, for one, and I've had my connexion cut or network manager shut down my connexion while fallowing this guide more than once. Nothing bad happened as a result, but it made me think that I'd be better off-line.

So without changing this guide(because it works beautifully), an 'off-Line Annex' would be appreciated. Just a link in the first post pointing to another post with the command lines/links to firstly DL everything and then the command lines to install from Home *if I have everything I need in Home maybe the whole installation can be scripted hmmm [evil laugh]* Just saying.

London
2014-07-11, 23:12
staticn0de, thank you for the write-up!

I did everything succesfully and the tests worked, but I'm unsure about a few things.
1. If the nVidia driver automatically removes nouveau then why is there a xorg.conf.nouveau file in the /etc/bumblebee directory?
2. How can I make sure the nVidia driver is the default driver at startup?
3. Lastly, when I lsmod | grep nvidia there is no output, when I lsmod | grep nouveau there is also no output. Shouldn't at least one of them show something?

staticn0de
2014-07-12, 03:27
staticn0de, thank you for the write-up!

I did everything succesfully and the tests worked, but I'm unsure about a few things.
1. If the nVidia driver automatically removes nouveau then why is there a xorg.conf.nouveau file in the /etc/bumblebee directory?
2. How can I make sure the nVidia driver is the default driver at startup?
3. Lastly, when I lsmod | grep nvidia there is no output, when I lsmod | grep nouveau there is also no output. Shouldn't at least one of them show something?

Hi there, don't mistake my guide as making me an expert on bumblebee, but i'll try and answer your question.

1. The nvidia driver does not remove nouveau, bumblebee changes between the graphics card which includes disabling one driver and enabling the nvidia driver. Both remain on the system. The xorg.conf.nouveau does not matter as it is only called if you set driver=nouveau in the bumblebee.conf file.

2. You don't set nvidia to start at start up. The reason bumblebee is used is so you can benefit from the power saving of having the intel card in use when the graphics card is not needed. When you use optirun glxspheres64 (for example) the nvidia card is enabled which uses more power so that the graphicly demanding application has a performance boost.

3. Unless you have used optirun, the nvidia modules will not be loaded. For example, run the command lsmod | grep -i nvidia and you will receive nothing. Run optirun glxspheres64 and while it is running use lsmod | grep -i nvidia and it will display the nvidia modules are the driver has loaded to use the discrete card.

London
2014-07-12, 13:37
Thank you! that really brings it all together for me. I usually have to run the optispheres64 command twice before it works, but everything is working perfectly other than that. Really appreciate it!

staticn0de
2014-07-13, 09:57
that's cool :)

even though most can figure it out for themselves, I was thinking that maybe(?) it would be nice to have all the command lines, and links to, an OFF_LINE installation. There's nothing wrong with this procedure as is, but we already DLing CUDA (and now probly new NVIDIA drivers), so maybe DL everything and than install?

Hmmm I like the idea, it would save some effort. My concern is that bumblebee is a decent effort to compile and then install. That, and it has dependencies. And those dependencies have dependencies.Trying to install all them without a repo would be a pain.

On another note, if you can't go to the mountain, you can always bring the mountain to you. You could host your own repo on your local network. I've looked into it but Kali looks after it a little different to other distros where you can just clone them with rsync. If you had a local repo, you won't need the internet anymore. This clearly isn't the solution for everyone....

In short, I don't really have the time (and maybe not the skill!) to document the requirements for this as an offline install. Although, I'm about to type up the CUDA6 and NVIDIA 340.24 version and with the exception of bumblebee (not bumblebee-nvidia) it is an offline install. It's easier to install than what I already wrote as it does not need manual modifications to nvidia-uvm.ko.

staticn0de
2014-07-13, 10:12
The following will install the latest at the time (340.24) NVIDIA driver and latest CUDA (version 6) on Kali with
Bumblebee for Optimus laptops. Usual notes about clean installs and selecting either 32bit or 64bit depending on your
needs from the first page still apply.

First, update and upgrade Kali to latest
apt-get update && apt-get upgrade && apt-get dist-upgrade

Download VirtualGL
http://downloads.sourceforge.net/project/virtualgl/2.3.3/virtualgl_2.3.3_amd64.deb?r=http%3A%2F%2Fsourcefor ge.net%2Fprojects%2Fvirtualgl%2Ffiles%2F2.3.3%2F&ts=1404718514&use_mirror=ufpr

Download CUDA (this is V6 64bit)
http://developer.download.nvidia.com/compute/cuda/6_0/rel/installers/cuda_6.0.37_linux_64.run

Download the nvidia*.run driver. Follow the bouncing ball to get what you need for your hardware
http://www.nvidia.com/Download/index.aspx?lang=en-us

Install VirtualGL
cd ~
dpkg -i virtualgl*.deb

Add the path for VirtualGL to .bashrc
nano ~/.bashrc
Add a line somewhere near the top that reads:
export PATH=$PATH:/opt/VirtualGL/bin

Export the path so we don't have to log out and in. Run the following from terminal
export PATH=$PATH:/opt/VirtualGL/bin

Install the linux headers
apt-get install linux-headers-$(uname -r)

Some dependencies for CUDA later
apt-get install freeglut3-dev libxmu-dev


Add the wheezy backports Repo (yes, still needed for bumblebee but not the NVIDIA driver)
nano /etc/apt/sources.list
Add the following line to the file and then save
deb http://ftp.debian.org/debian wheezy-backports main contrib non-free
apt-get update

Install bumblebee (not bumblebee-nvidia)
apt-get install bumblebee primus

Edit the bumblebee.conf file
nano /etc/bumblebee/bumblebee.conf

Change line 22 so it reads:
Driver=nvidia

We do not need to edit line 55 as the module the nvidia installer will build is called nvidia and not nvidia-current.

Save and close.

Run the following and record your PCI address for your video card. It will look similar to 03:00.0
lspci | egrep 'VGA|3D'

Edit xorg.conf.nvidia and add a line under the 'Section "Device"' area so that is matches what is shown below. Change the bus ID to match what you recorded previously and take note that you recored a . before the last number and it is now a ':'. You need the ':'.
Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:03:00:0"


Change NVIDIA installer permissions
cd ~
chmod +x NVIDIA*.run

You now need to close gdm3 because it can't be running for the driver install. Record what you need now. If you don't get a login screen when you close gdm3, press control + alt + F1
/etc/init.d/gdm3 stop

Now the install
cd ~
./NVIDIA*.run --dkms -z

Accept the EULA
Select yes to register the kernel module with DKMS
No to libs (unless you want them)
Ok to acknowledge the website libs
The install will take place
Do not run X-Config. Select NO.
The installer will close.

Restart kali with
shutdown -r now

When rebooted, run optirun glxspheres64 and confirm it's working. A 'modinfo nvidia' will show that you now have the 340.24 module loaded.

To install CUDA, chmod the installer first
cd ~
chmod +x cuda*.run

And now to install
./cuda*.run

Accept the EULA
Select yes to unsupporrted configuration
No to graphics driver
Yes to the toolkit
Accept default location
Yes to symbolic link
Yes to samples
Yes to default samples location
The toolkit will install

For the path, we will add a little more to what we defined for VirtualGL. It should look like this in your bashrc file
nano ~./bashrc
export PATH=$PATH:/opt/VirtualGL/bin:/usr/local/cuda-6.0/bin

Run the following so we don't have to log out
export PATH=$PATH:/opt/VirtualGL/bin:/usr/local/cuda-6.0/bin

Edit the following file so the contents match those shown below
nano /etc/ld.so.conf


include /etc/ld.so.conf.d/*.conf
/usr/local/cuda-6.0/lib64

Save and close

Run:
ldconfig

Build the nvidia samples

cd /root/NVIDIA_CUDA-6.0_Samples
make

Follow the steps from the second post to run the CUDA deviceQuery script and you should see pass.

Remember to remove or comment out the wheezy backports repo

Quest
2014-07-14, 16:21
root@kali:~/NVIDIA_CUDA-6.0_Samples/1_Utilities/deviceQuery# optirun ./deviceQuery
./deviceQuery Starting...

CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: "GeForce GT 630M"
CUDA Driver Version / Runtime Version 6.5 / 6.0
CUDA Capability Major/Minor version number: 2.1
Total amount of global memory: 2048 MBytes (2147155968 bytes)
( 2) Multiprocessors, ( 48) CUDA Cores/MP: 96 CUDA Cores
GPU Clock rate: 950 MHz (0.95 GHz)
Memory Clock rate: 900 Mhz
Memory Bus Width: 128-bit
L2 Cache Size: 131072 bytes
Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65535), 3D=(2048, 2048, 2048)
Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers
Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total number of registers available per block: 32768
Warp size: 32
Maximum number of threads per multiprocessor: 1536
Maximum number of threads per block: 1024
Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
Max dimension size of a grid size (x,y,z): (65535, 65535, 65535)
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Concurrent copy and kernel execution: Yes with 1 copy engine(s)
Run time limit on kernels: Yes
Integrated GPU sharing Host Memory: No
Support host page-locked memory mapping: Yes
Alignment requirement for Surfaces: Yes
Device has ECC support: Disabled
Device supports Unified Addressing (UVA): Yes
Device PCI Bus ID / PCI location ID: 1 / 0
Compute Mode:
< Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 6.5, CUDA Runtime Version = 6.0, NumDevs = 1, Device0 = GeForce GT 630M
Result = PASS
root@kali:~/NVIDIA_CUDA-6.0_Samples/1_Utilities/deviceQuery#


i have to tell ya, I've been meaning to do this now for over 7 months with a week of intense web search, and that last Howto above f i n a l l y did it!

Many thanks staticn0de ! =]

staticn0de
2014-07-14, 19:51
Hi Quest,

I'm happy to hear that. I'll update the first post so others know the newer drivers may work in lieu of the old.

Thanks for posting to let everyone know it worked for you.

Quest
2014-07-16, 14:09
That's my 'dummyproof' edited version of your guide.


Update and upgrade Kali to latest

apt-get update && apt-get upgrade && apt-get dist-upgrade

Downloads
You will need the files below (64 bit) I always go with 64bit as I am on Kali 64bit. Download in the Home folder or place them in the Home folder after.


CUDA 6.0.37 for Ubuntu 12.04 64Bit
http://developer.download.nvidia.com/compute/cuda/6_0/rel/installers/cuda_6.0.37_linux_64.run
VirtualGL 2.3.3_amd64 for 64Bit
http://downloads.sourceforge.net/project/virtualgl/2.3.3/virtualgl_2.3.3_amd64.deb?r=http%3A%2F%2Fsourcefor ge.net%2Fprojects%2Fvirtualgl%2Ffiles%2F2.3.3%2F&ts=1404718514&use_mirror=ufpr
Nvidia 340.24
http://www.nvidia.com/Download/index.aspx?lang=en-us


Install VirtualGL
cd ~

dpkg -i virtualgl*.deb

Add the path for VirtualGL to .bashrc

nano ~/.bashrc

Add a line somewhere at the top that reads:
export PATH=$PATH:/opt/VirtualGL/bin

Save the file(Ctrl+x, then Y, then Enter)

Export the path so we don't have to log out and in.

export PATH=$PATH:/opt/VirtualGL/bin

Install the linux headers

apt-get install linux-headers-$(uname -r)

Some dependencies for CUDA for later

apt-get install freeglut3-dev libxmu-dev

Add the wheezy backports Repo (yes, still needed for bumblebee but not the NVIDIA driver)
Go to Computer > File System > etc > apt > souces.list, and open it with Leafpad, and add the following line to the file and then save.
deb http://ftp.debian.org/debian wheezy-backports main contrib non-free

apt-get update

Install bumblebee (not bumblebee-nvidia)

apt-get install bumblebee primus

Edit the bumblebee.conf file

nano /etc/bumblebee/bumblebee.conf

Change line 22 so it reads:
Driver=nvidia

Run the following and record your PCI address for your video card. It will look similar to 03:00.0 (yours might be different)

lspci | egrep 'VGA|3D'

Edit xorg.conf.nvidia

nano /etc/bumblebee/xorg.conf.nvidia

add a line under the 'Section "Device"' area so that is matches what is shown below. Change the bus ID to match what you recorded previously and take note that you recored a . before the last number and it is now a ':'. You need the ':'.

Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:03:00:0"

Restart bumblebee with the following and ignore any ERROR/FAIL warnings

/etc/init.d/bumblebeed restart

Change NVIDIA installer permissions
cd ~

chmod +x NVIDIA*.run

You now need to close gdm3 because it can't be running for the driver install.
Record what you need now. If you don't get a login screen when you close gdm3, press control + alt + F1

/etc/init.d/gdm3 stop

Now the NVIDIA install
cd ~

./NVIDIA*.run --dkms -z

-Accept the EULA
-Select yes to register the kernel module with DKMS
-No to libs (unless you want them)
-Ok to acknowledge the website libs
The install will take place...
-Do not run X-Config. Select NO.
The installer will close.

Restart kali with

shutdown -r now

or Ctrl+Alt+Del

When rebooted, run

optirun glxspheres64

A 'modinfo nvidia' will show that you now have the 340.24 module loaded.

modinfo nvidia

To install CUDA, chmod the installer first
cd ~

chmod +x cuda*.run

And now to install CUDA

./cuda*.run

-Accept the EULA (Tab then, accept)
-Select yes to unsupported configuration
-No to graphics driver
-Yes to the toolkit
-Accept default location (press Enter only)
-Yes to symbolic link
-Yes to samples
-Yes to default samples location (press Enter only)
The toolkit will install...

For the path, we will add a little more to what we defined for VirtualGL earlier.

nano ~/.bashrc

It should look like this in your bashrc file
export PATH=$PATH:/opt/VirtualGL/bin:/usr/local/cuda-6.0/bin

Run the following so we don't have to log out

export PATH=$PATH:/opt/VirtualGL/bin:/usr/local/cuda-6.0/bin

Edit the following file so the contents match those shown below

nano /etc/ld.so.conf

Contents:
include /etc/ld.so.conf.d/*.conf
add /usr/local/cuda-6.0/lib64

Save and close

Run

ldconfig

Build the nvidia samples

cd /root/NVIDIA_CUDA-6.0_Samples

make

cd 1_Utilities/deviceQuery

optirun ./deviceQuery

You should see Result = PASS!

Now, I know you want to see it in action so the next part we'll install Pyrit.

First, remove the Wheezy repo.
You may either comment out the line we added or delete it.
Computer > File System > etc > apt > souces.list,
Save the file.

apt-get update

Checkout Pyrit

svn checkout http://pyrit.googlecode.com/svn/trunk/ pyrit_svn

Install required libraries and add CUDA support

apt-get install libpcap-dev

cd pyrit_svn/pyrit/

python setup.py build

python setup.py install

cd ../cpyrit_cuda/

python setup.py build

python setup.py install

Now, what we have been waiting for this entire time. Lets see it work.

optirun pyrit benchmark

:D

as a side note, after all this my Kali installation went from a little less then 8Gb to 11Gb. Interesting...

barni123
2014-07-18, 12:15
Run the command below to confirm that bumblebee is working
optirun glxspheres64


Hi,
I have the following problem: when I enter this last command optirun glxspheres64, my screen goes totally black and my nvidia vgas start to run on full speed (vents go on full throttle) and after 20s my laptop shuts down. I suppose my hardware causes the peoblem, I have 3VGAs: the integrated intel hd4400, and 2 nvidia gt750M. I don't want to use SLI, I only want to use one VGA which makes me able to change the kali's resolution to fullhd.

johnnyinc
2014-07-19, 11:15
Hi staticn0de and all,

I have problems with bumblebee, my gear is: Lenovo thinkpad T440p with geforce 730m card.

My source.list file:

## Regular Updates
deb http://http.kali.org/kali kali main non-free contrib
deb http://security.kali.org/kali-security kali/updates main contrib non-free

## Source Updates
deb-src http://http.kali.org/kali kali main non-free contrib
deb-src http://security.kali.org/kali-security kali/updates main contrib non-free

## Bumblebee
#deb http://ftp.debian.org/debian wheezy-blackports main contrib non-free

The last entry is commented out I'm deleting the comment before installing bumblebee primus and apt-get update

With above configuration of source list I have an error while apt-get update && apt-get upgrade -y && apt-get dist-update -y:

Errors were encountered while processing:
Linux-image-3.14-kali1-amd64
extlinux
E: Sub-process /usr/bin/dpkg returned an error code (1)

After Configuring bumblebee.conf and xorg.conf.nvidia and restarting bumblebeed service which fails I did /etc/init.d/gdm3 stop and i receive the following error:

bash: /etc/init.d/gdm3: cannot execute binary file

I need to hard restart the laptop and after this me kali installation totally breaks. I have an error while booting:

The root filesystem is currently mounted in read-only mode. A maintenece will now be started. After performing system maintenance, press Ctrl+D to terminate the maintenance shell and restart the system...

If You need more additional info on the behavior or configuration files please let me know.
If you have any ideas whats wrong Please let me know

staticn0de
2014-07-20, 00:21
Hi,
I have the following problem: when I enter this last command optirun glxspheres64, my screen goes totally black and my nvidia vgas start to run on full speed (vents go on full throttle) and after 20s my laptop shuts down. I suppose my hardware causes the peoblem, I have 3VGAs: the integrated intel hd4400, and 2 nvidia gt750M. I don't want to use SLI, I only want to use one VGA which makes me able to change the kali's resolution to fullhd.

Hi there,

I've been doing some reading on SLI (I have just about the cheapest laptop I could buy so I don't have it) and it requires a little extra configuration in the /etc/bumblebee/xorg.conf.nvidia file.

So, when you run the command:

lspci | grep VGA

You should see two nvidia cards with two BusID. You will need to configure both within the /etc/bumblebee/xorg.conf.nvidia file.

So, within that file, add those BusIDs under the Device section. After that, you need to find the section which includes a bunch of "Option" settings (bottom of the file). Add a new line with:

Option "SLI" "AA"

Read more about it here, it's writen for arch but the config files are the same. https://wiki.archlinux.org/index.php/NVIDIA#Enabling_SLI

Did you use the latest Nvidia 340 drivers or did you install the ones from the first post? If you tried the first post, try the latest drivers.

staticn0de
2014-07-20, 00:45
Hi staticn0de and all,

I have problems with bumblebee, my gear is: Lenovo thinkpad T440p with geforce 730m card.

My source.list file:

## Regular Updates
deb http://http.kali.org/kali kali main non-free contrib
deb http://security.kali.org/kali-security kali/updates main contrib non-free

## Source Updates
deb-src http://http.kali.org/kali kali main non-free contrib
deb-src http://security.kali.org/kali-security kali/updates main contrib non-free

## Bumblebee
#deb http://ftp.debian.org/debian wheezy-blackports main contrib non-free

The last entry is commented out I'm deleting the comment before installing bumblebee primus and apt-get update

With above configuration of source list I have an error while apt-get update && apt-get upgrade -y && apt-get dist-update -y:

Errors were encountered while processing:
Linux-image-3.14-kali1-amd64
extlinux
E: Sub-process /usr/bin/dpkg returned an error code (1)

After Configuring bumblebee.conf and xorg.conf.nvidia and restarting bumblebeed service which fails I did /etc/init.d/gdm3 stop and i receive the following error:

bash: /etc/init.d/gdm3: cannot execute binary file

I need to hard restart the laptop and after this me kali installation totally breaks. I have an error while booting:

The root filesystem is currently mounted in read-only mode. A maintenece will now be started. After performing system maintenance, press Ctrl+D to terminate the maintenance shell and restart the system...

If You need more additional info on the behavior or configuration files please let me know.
If you have any ideas whats wrong Please let me know

Edit Again: After all that is below, I did reinstall the packages autoremove removed with the exception of libplrpc-perl as it was not in the repo.

apt-get install libnet-daemon-perl memtest86+ syslinux-themes-debian syslinux-themes-debian-wheezy

Everything works with the exception of memtest86 (but that is a known bug as I am EFI booting)

Edit:

Ok, so I an update (see next post) and had the same error. It's not related to bumblebee or nvidia (it's a repo issue)

Boot into Kali recovery mode and run:

apt-get autoremove

After that, reboot. Should be back in Kali.

Run

apt-get update && apt-get upgrade and you should have no more errors.

The following are the packages which were removed under my apt-get autoremove. I have not tried reinstalling them yet.

libnet-daemon-perl libplrpc-perl memtest86+ syslinux-themes-debian syslinux-themes-debian-wheezy

From looking at the packages which were updated just before all this happened, I'd hazard a guess and say updating either of the following caused the broken package

syslinux or syslinux-common

staticn0de
2014-07-20, 04:06
Edit: Sorted in previous post


I just ran an apt-get upgrade and received the same:

Setting up syslinux-common (3:6.03~pre1+dfsg-1kali3) ...
Setting up syslinux (3:6.03~pre1+dfsg-1kali3) ...
Setting up extlinux (3:6.03~pre1+dfsg-1kali3) ...
P: Checking for EXTLINUX directory... found.
/boot/vmlinuz-3.14-kali1-amd64
P: Writing config for /boot/vmlinuz-3.14-kali1-amd64...
P: Updating /boot/extlinux/linux.cfg...
I: os-proper disabled in /etc/default/extlinux: Skipping /boot/extlinux/os-proper.cfg
E: /usr/share/EXTLINUX/themes/debian: No such file or directory
dpkg: error processing extlinux (--configure):
subprocess installed post-installation script returned error exit status 1

Errors were encountered while processing:
extlinux
E: Sub-process /usr/bin/dpkg returned an error code (1)

Seems like the repo has bad packages

johnnyinc
2014-07-23, 07:32
Thank You staticn0de

apt-get autoremove cleared the issue but it still not resolve the bumblebee problem. I have now the following problems:

After stoping gdm3 I receive the following error messages non stop:
[ 835.063840] ata6.00: status: { DRDY }
[ 835.638286] ata6.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
[ 835.736372] ata6.00: irq_stat 0x40000001
[ 835.762738] ata6.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 30
[ 835.638286] res 50/00:03:00:12:00/00:00:00:00:00/a0 Emask 0x1 (device error)
[ 837.036379] ata6.00: status: { DRDY }
And so on and so on

I have rebooted the laptop and install nVidia driver in recovery mode after install and reboot i have issued the command: optirun glxspheres64 and receive the following error:
[ 42.235078] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver
[ 42.235176] [ERROR]Aborting because fallback start is disabled

Do You have any ideas whats the case ?
Thank You so much for Your help.

staticn0de
2014-07-23, 10:38
Thank You staticn0de

apt-get autoremove cleared the issue but it still not resolve the bumblebee problem. I have now the following problems:

After stoping gdm3 I receive the following error messages non stop:
[ 835.063840] ata6.00: status: { DRDY }
[ 835.638286] ata6.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
[ 835.736372] ata6.00: irq_stat 0x40000001
[ 835.762738] ata6.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 30
[ 835.638286] res 50/00:03:00:12:00/00:00:00:00:00/a0 Emask 0x1 (device error)
[ 837.036379] ata6.00: status: { DRDY }
And so on and so on

I have rebooted the laptop and install nVidia driver in recovery mode after install and reboot i have issued the command: optirun glxspheres64 and receive the following error:
[ 42.235078] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver
[ 42.235176] [ERROR]Aborting because fallback start is disabled

Do You have any ideas whats the case ?
Thank You so much for Your help.

Few things,

That may be a hard drive error. Check your hard drive smart stats and run a test.

Otherwise, did bumblebee install correctly?

I'll need some information. Post the results of the following commands


uname -r


cat /etc/modprobe.d/bumblebee.conf

Run optirun glxspheres64 and then run

dmesg


lspci | egrep 'VGA|3D'

What version of Kali are you using?

Are you 32bit or 64bit?

The important part is you have this in your /etc/modprobe.d/bumblebee.conf file

blacklist nouveau

Rarity
2014-07-25, 08:07
Hey n0de, thanks for this write up! There's one problem I'm experiencing:

The drivers are correctly installed when I check 'modinfo nvidia', but when I run the command 'optirun glxspheres64' I get the error:


[ 2037.152986] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please

[ 2037.153044] [ERROR]Aborting because fallback start is disabled.


When I check lspci | egrep "VGA|3D" it comes back as a 3D controller, not VGA. Not sure if that matters when configuring /etc/bumblebee/xorg.conf.nvidia

Also, I noticed in your updated post you didn't include


Now install the nvidia drivers
apt-get install nvidia-glx

Are there not certain dependencies needed from this? Cause even when I run glxspheres64 I get


Polygons in scene: 62464
Xlib: extension "GLX" missing on display ":0.0".
ERROR (603): Could not obtain RGB visual with requested properties


Thanks again!! I'm looking forward to finally getting my video card recognized.

staticn0de
2014-07-25, 09:48
Hey n0de, thanks for this write up! There's one problem I'm experiencing:

The drivers are correctly installed when I check 'modinfo nvidia', but when I run the command 'optirun glxspheres64' I get the error:


[ 2037.152986] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please

[ 2037.153044] [ERROR]Aborting because fallback start is disabled.


When I check lspci | egrep "VGA|3D" it comes back as a 3D controller, not VGA. Not sure if that matters when configuring /etc/bumblebee/xorg.conf.nvidia

Also, I noticed in your updated post you didn't include



Are there not certain dependencies needed from this? Cause even when I run glxspheres64 I get


Polygons in scene: 62464
Xlib: extension "GLX" missing on display ":0.0".
ERROR (603): Could not obtain RGB visual with requested properties


Thanks again!! I'm looking forward to finally getting my video card recognized.

Hey there,

nvidia-glx is not required for the second install. This is a transitional package to install the older drivers.

That being said, i'm going to need a lot more information from you to help.

use the
brackets to paste the output of commands (the code close bracket is a [*/CODE] without the *. Put all the text between them.

run optirun glxspheres64 and then paste the output of the command below. The last 30 lines or so.
[CODE]dmesg

Paste your /etc/bumblebee/bumblebee.conf

Paste your /etc/bumblebee/xorg.nvidia.conf

Paste the output of

lspci | egrep 'VGA|3D'

Paste the output of

modinfo nvidia

and


modinfo nvidia-uvm

and


echo $PATH

Paste the output of

find 2> /dev/null / -name nvidia*.ko

That should do for a start

Rarity
2014-07-25, 16:40
Thanks for the quick reply, but I won't be able to respond until later tonight. I'll edit this once I can.

Quest
2014-07-28, 16:15
Hi staticn0de!

so everything was working fine, but then when I tried to use cowpatty/pyrit/crunch with FrankenScript, I get an error..
"ERROR: could not insert 'nvidia': No such device"

So then I ran some tests, and I cannot run optirun glxspheres64 anymore!? Here are the outputs...

root@kali:~# optirun glxspheres64
[ 3086.847274] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 3086.847338] [ERROR]Aborting because fallback start is disabled.
root@kali:~# dmesg
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Initializing cgroup subsys cpuacct
[ 0.000000] Linux version 3.14-kali1-amd64 (debian-kernel@lists.debian.org) (gcc version 4.7.2 (Debian 4.7.2-5) ) #1 SMP Debian 3.14.5-1kali1 (2014-06-07)
[ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.14-kali1-amd64 root=UUID=df2555ed-577b-46d4-b82c-bae880f39864 ro quiet
[ 0.000000] e820: BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: [mem 0x0000000000000000-0x000000000009d7ff] usable
SNIP
[ 2809.151223] [<ffffffff814efb08>] ? page_fault+0x28/0x30
[ 2809.151228] [<ffffffff810d81e1>] ? SyS_init_module+0xb1/0xe0
[ 2809.151234] [<ffffffff814f7879>] ? system_call_fastpath+0x16/0x1b
[ 2809.151237] ---[ end trace a26dc4680320df79 ]---
[ 2809.151431] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns =none
[ 2809.151474] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0de9)
[ 2809.151474] NVRM: installed in this system is not supported by the 340.24
[ 2809.151474] NVRM: NVIDIA Linux driver release. Please see 'Appendix
[ 2809.151474] NVRM: A - Supported NVIDIA GPU Products' in this release's
[ 2809.151474] NVRM: README, available on the Linux driver download page
[ 2809.151474] NVRM: at www.nvidia.com.
[ 2809.151553] nvidia: probe of 0000:01:00.0 failed with error -1
[ 2809.151961] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 2809.151964] NVRM: None of the NVIDIA graphics adapters were initialized!
[ 2809.151966] [drm] Module unloaded
[ 2809.152095] NVRM: NVIDIA init module failed!
[ 3085.254654] ------------[ cut here ]------------
[ 3085.254666] WARNING: CPU: 4 PID: 6853 at /build/kalibuild-linux_3.14.5-1kali2-amd64-igeTGG/linux-3.14.5/fs/proc/generic.c:315 proc_register+0xd8/0x170()
[ 3085.254669] proc_dir_entry 'driver/nvidia' already registered
[ 3085.254670] Modules linked in: nvidia(PO+) nls_utf8 nls_cp437 vfat fat ctr ccm nfnetlink_log nfnetlink bbswitch(O) binfmt_misc loop
SNIP
[ 3085.254767] CPU: 4 PID: 6853 Comm: modprobe Tainted: P W O 3.14-kali1-amd64 #1 Debian 3.14.5-1kali1
[ 3085.254769] Hardware name: TOSHIBA Satellite P850/QFKAA, BIOS 1.90 08/21/2012
[ 3085.254771] 0000000000000000 0000000000000009 ffffffff814e9b1e ffff8802235afbe8
[ 3085.254776] ffffffff810639d6 ffff880224ed9680 ffff8802230a2175 ffff8802230a2100
[ 3085.254780] ffff880226501b80 0000000000000000 ffffffff81063ab5 ffffffff81718cc0
[ 3085.254784] Call Trace:
[ 3085.254795] [<ffffffff814e9b1e>] ? dump_stack+0x41/0x51
[ 3085.254802] [<ffffffff810639d6>] ? warn_slowpath_common+0x86/0xb0
[ 3085.254807] [<ffffffff81063ab5>] ? warn_slowpath_fmt+0x45/0x50
[ 3085.254813] [<ffffffff811fe238>] ? proc_register+0xd8/0x170
[ 3085.254819] [<ffffffff811fe3db>] ? proc_mkdir_data+0x4b/0x70
[ 3085.254925] [<ffffffffa0d764f9>] ? nv_register_procfs+0x39/0x1b0 [nvidia]
[ 3085.254994] [<ffffffffa1c06286>] ? nvidia_init_module+0x286/0x79d [nvidia]
[ 3085.255061] [<ffffffffa1c067ac>] ? nv_drm_init+0xf/0xf [nvidia]
[ 3085.255126] [<ffffffffa1c067ac>] ? nv_drm_init+0xf/0xf [nvidia]
[ 3085.255191] [<ffffffffa1c0682e>] ? nvidia_frontend_init_module+0x82/0x854 [nvidia]
[ 3085.255198] [<ffffffff8100218a>] ? do_one_initcall+0x10a/0x160
[ 3085.255203] [<ffffffff81057b74>] ? set_memory_nx+0x44/0x50
[ 3085.255210] [<ffffffff810d7903>] ? load_module+0x1ac3/0x22f0
[ 3085.255215] [<ffffffff810d3d90>] ? show_initstate+0x50/0x50
[ 3085.255221] [<ffffffff811668b5>] ? map_vm_area+0x25/0x40
[ 3085.255229] [<ffffffff814efb08>] ? page_fault+0x28/0x30
[ 3085.255234] [<ffffffff810d81e1>] ? SyS_init_module+0xb1/0xe0
[ 3085.255240] [<ffffffff814f7879>] ? system_call_fastpath+0x16/0x1b
[ 3085.255242] ---[ end trace a26dc4680320df7a ]---
[ 3085.255404] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns =none
[ 3085.255442] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0de9)
[ 3085.255442] NVRM: installed in this system is not supported by the 340.24 <---!? all tests were fine before
[ 3085.255442] NVRM: NVIDIA Linux driver release. Please see 'Appendix
[ 3085.255442] NVRM: A - Supported NVIDIA GPU Products' in this release's
[ 3085.255442] NVRM: README, available on the Linux driver download page
[ 3085.255442] NVRM: at www.nvidia.com.
[ 3085.255501] nvidia: probe of 0000:01:00.0 failed with error -1
[ 3085.256058] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 3085.256064] NVRM: None of the NVIDIA graphics adapters were initialized!
[ 3085.256067] [drm] Module unloaded
[ 3085.256272] NVRM: NVIDIA init module failed!
root@kali:~# lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 630M] (rev a1)
root@kali:~# modinfo nvidia
filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
alias: char-major-195-*
version: 340.24
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias: pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias: pci:v000010DEd*sv*sd*bc03sc02i00*
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
depends: drm,i2c-core
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
parm: NVreg_ModifyDeviceFiles:int
parm: NVreg_DeviceFileUID:int
parm: NVreg_DeviceFileGID:int
parm: NVreg_DeviceFileMode:int
parm: NVreg_RemapLimit:int
parm: NVreg_UpdateMemoryTypes:int
parm: NVreg_InitializeSystemMemoryAllocations:int
parm: NVreg_RMEdgeIntrCheck:int
parm: NVreg_UsePageAttributeTable:int
parm: NVreg_MapRegistersEarly:int
parm: NVreg_RegisterForACPIEvents:int
parm: NVreg_CheckPCIConfigSpace:int
parm: NVreg_EnablePCIeGen3:int
parm: NVreg_EnableMSI:int
parm: NVreg_MemoryPoolSize:int
parm: NVreg_RegistryDwords:charp
parm: NVreg_RmMsg:charp
parm: NVreg_AssignGpus:charp
root@kali:~# modinfo nvidia-uvm
filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko
supported: external
license: MIT
depends: nvidia
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions
root@kali:~# echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/VirtualGL/bin:/usr/local/cuda-6.0/bin
root@kali:~# find 2> /dev/null / -name nvidia*.ko
/lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
/lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko
/var/lib/dkms/nvidia/340.24/3.14-kali1-amd64/x86_64/module/nvidia.ko
/var/lib/dkms/nvidia/340.24/3.14-kali1-amd64/x86_64/module/nvidia-uvm.ko
root@kali:~#


Edit:


root@kali:~# modprobe nvidia
ERROR: could not insert 'nvidia': No such device
root@kali:~#


root@kali:~# optirun pyrit benchmark
[ 5141.410827] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 5141.410896] [ERROR]Aborting because fallback start is disabled.


so it would appear that nothing works, when everything was working before. weird

Edit2:

Nevermind. I've reinstalled the image of my Kali installation, and all tests passed like before. A likely reason for the above problems is that I set my swapiness to 0 after the installation(?) I cannot see anything else that might have caused that.

Now I will do tests to try to make cowpatty/pyrit/crunch work in real life...

Edit3: Everything works, and swapiness set to 0 had nothing to do with my previous problems. So I have no idea what caused it. I'm suspecting an update(?)

cru-z
2014-07-29, 14:28
Dude u are the best, perfect tut!!!!

go ahead dude!

love u!

Quest
2014-07-30, 18:24
yes really, he saved me from 2months of searching/testing. Good to know that there are ppl like that outhere. Sharp contrast with the rest. "linux community" is an oxymoron.



For those who want to install oclHashcat

Download oclHashcat 1.01 (508Mb) to your Home folder.
http://ftp.tku.edu.tw/kali/pool/non-free/o/oclhashcat/

Install oclHashcat

dpkg -i oclhashcat*.deb

Test CudaHashcat(GeForce)

cd /usr/share/oclhashcat/

./cudaHashcat.bin -t 32 -a 7 example0.hash ?a?a?a?a example.dict

staticn0de
2014-07-30, 22:57
yes really, he saved me from 2months of searching/testing. Good to know that there are ppl like that outhere. Sharp contrast with the rest. "linux community" is an oxymoron.



For those who want to install oclHashcat

Download oclHashcat 1.01 (508Mb) to your Home folder.
http://ftp.tku.edu.tw/kali/pool/non-free/o/oclhashcat/

Install oclHashcat

dpkg -i oclhashcat*.deb

Test CudaHashcat(GeForce)

cd /usr/share/oclhashcat/

./cudaHashcat.bin -t 32 -a 7 example0.hash ?a?a?a?a example.dict

Hey there quest,

oclhashcat is in the kali repos (version 1.01) so there is no need to download the .deb file.

oclhashcat from the repo also includes the cudahashcat which is what all us nvidia users are after anyway.

I'm currently trying to get the new hashcat working on kali but it has this habit of breaking other things when I get it to work....

Quest
2014-07-31, 00:48
Hi friend,

Yes it's in the Kali repo root@kali:~# apt-get install oclhashcat but that is still 508Mb to download every time for every installation. I much prefer to get it once and keep it, otherwise it never ends.

Speaking of. My Kali installation is now at 14Gb with all this. So this howto alone(including Kali updates) gets about 5Gb of archives if I'm not mistaken.

Good luck with the R&D :)

staticn0de
2014-07-31, 01:08
Hi friend,

Yes it's in the Kali repo root@kali:~# apt-get install oclhashcat but that is still 508Mb to download every time for every installation. I much prefer to get it once and keep it, otherwise it never ends.

Speaking of. My Kali installation is now at 14Gb with all this. So this howto alone(including Kali updates) gets about 5Gb of archives if I'm not mistaken.

Good luck with the R&D :)

If you have a computer that stays on all the time, like a media server - take a look at apt-cacher.

It stores stuff that is downloaded from a repo locally. This way, you don't have to download it from the repo each time as it will come from your local server. A lot easier and faster than trying to mirror the repo.

nekromantik
2014-08-02, 22:00
Used this guide and installed bumblebee and cuda with pyrit. thanks
but now I have issue, after restarting laptop (dual boot 1.08 with win 8.1) I choose Kali or Kali recovery in grub and it stays on blank screen.
Cant boot into kali only windows.

staticn0de
2014-08-03, 01:54
Used this guide and installed bumblebee and cuda with pyrit. thanks
but now I have issue, after restarting laptop (dual boot 1.08 with win 8.1) I choose Kali or Kali recovery in grub and it stays on blank screen.
Cant boot into kali only windows.


Used this guide and installed bumblebee and cuda with pyrit. thanks
but now I have issue, after restarting laptop (dual boot 1.08 with win 8.1) I choose Kali or Kali recovery in grub and it stays on blank screen.
Cant boot into kali only windows.

Hi there,

Can you press CTRL + ALT + F1 and reach a terminal?

Is it blank screen or do you have a blinking cursor?

That is the typical symptom for if the laptop was not restarted after installing the NVIDIA drivers (after stopping gdm3) or x-config was run. I say this because you should not have been able to install CUDA without a restart and you have said you installed everything up to pyrit and then could not restart without a blank screen.

If you can reach terminal, run

cd ~
./NVIDIA*.run --uninstall

and then apt-get purge nvidia* bumblebee* primus*

and restart

nekromantik
2014-08-03, 09:12
Hi there,

Can you press CTRL + ALT + F1 and reach a terminal?

Is it blank screen or do you have a blinking cursor?

That is the typical symptom for if the laptop was not restarted after installing the NVIDIA drivers (after stopping gdm3) or x-config was run. I say this because you should not have been able to install CUDA without a restart and you have said you installed everything up to pyrit and then could not restart without a blank screen.

If you can reach terminal, run

cd ~
./NVIDIA*.run --uninstall

and then apt-get purge nvidia* bumblebee* primus*

and restart

Hi

No I dont get a blinking cursor.
So ctl alt F1 dont work.

Can only access grub menu and edit grub parameters pressing e key.

nab
2014-08-06, 17:22
Hi staticn0de!
First, thank for your guide. it helped me a lot. The result show pass.
But i don't know is it working? I see in system setting->details: it don't show graphics driver!
Then i tried test:
glxinfo | grep -i "direct rendering"
It show:
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".

Is it problem?

staticn0de
2014-08-07, 01:58
Hi staticn0de!
First, thank for your guide. it helped me a lot. The result show pass.
But i don't know is it working? I see in system setting->details: it don't show graphics driver!
Then i tried test:
glxinfo | grep -i "direct rendering"
It show:
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".

Is it problem?

Hi there,

Prefix your command with optirun.

If you have a pass from the cuda device detect script the driver is working. You must prefix commands which require the driver to be loaded with optirun.

The nvidia card is disabled during normal use to save power. Optirun enables it for the duration the program running needs it

nab
2014-08-07, 03:12
Hi there,

Prefix your command with optirun.

If you have a pass from the cuda device detect script the driver is working. You must prefix commands which require the driver to be loaded with optirun.

The nvidia card is disabled during normal use to save power. Optirun enables it for the duration the program running needs it

Oh, it working. thank you.
And one more thing i can't understand. nvidia-settings require me do nvdia-xconfig. If i do , X server can't start and i have to remove xorg.conf. it like cycle! (sr my bad english)

weak_superhero
2014-08-07, 19:05
Hi static, first, thanks for taking me further along the road to installing my cuda drivers than I had thought possible, outstanding instructions. Like the fellow above me, when I run "optirun glxinfo | grep -i "direct rendering"", I get the following:

[ 205.729643] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please

[ 205.729694] [ERROR]Aborting because fallback start is disabled.


Dual boot win7/ kali 1.08 AMD64, lenovo w530

Bumblebee isn't starting for whatever reason. Any thoughts? Thanks.

shagelito
2014-08-07, 19:19
Greetings,

I'm fighting for a good 2 months trying to install bumblebee properly on my laptop, to enable my Nvidia 650m :mad: .

I've been following this guide step by step, and i'm stuck at the 'optirun glxspheres64' part. My computer simply shutdown without any warnings, as soon as I hit 'Enter' in the prompt :confused: .

I did install the 340 driver correctly, and i can tell it's loaded as it should, thanks to the "modinfo nvidia" command.

Here is what 'uname -r' returns :


3.14-kali1-amd64

Here is my xorg.conf.nvidia :


Section "ServerLayout"
Identifier "Layout0"
Option "AutoAddDevices" "false"
Option "AutoAddGPU" "false"
EndSection

Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:01:00:0"

# If the X server does not automatically detect your VGA device,
# you can manually set it here.
# To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
# as you see in the commented example.
# This Setting may be needed in some platforms with more than one
# nvidia card, which may confuse the proprietary driver (e.g.,
# trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
# BusID "PCI:01:00:0"

# Setting ProbeAllGpus to false prevents the new proprietary driver
# instance spawned to try to control the integrated graphics card,
# which is already being managed outside bumblebee.
# This option doesn't hurt and it is required on platforms running
# more than one nvidia graphics card with the proprietary driver.
# (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
# If this option is not set, the new Xorg may blacken the screen and
# render it unusable (unless you have some way to run killall Xorg).
Option "ProbeAllGpus" "false"

Option "NoLogo" "true"
Option "UseEDID" "false"
Option "UseDisplayDevice" "none"
EndSection

Here is my bumblebee.conf :


# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/$
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
# bbswitch - new in BB 3, recommended if available
# switcheroo - vga_switcheroo method, use at your own risk
# none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

Here is what 'modinfo nvidia' returns :


filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
alias: char-major-195-*
version: 340.24
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias: pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias: pci:v000010DEd*sv*sd*bc03sc02i00*
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
depends: drm,i2c-core
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
parm: NVreg_ModifyDeviceFiles:int
parm: NVreg_DeviceFileUID:int
parm: NVreg_DeviceFileGID:int
parm: NVreg_DeviceFileMode:int
parm: NVreg_RemapLimit:int
parm: NVreg_UpdateMemoryTypes:int
parm: NVreg_InitializeSystemMemoryAllocations:int
parm: NVreg_RMEdgeIntrCheck:int
parm: NVreg_UsePageAttributeTable:int
parm: NVreg_MapRegistersEarly:int
parm: NVreg_RegisterForACPIEvents:int
parm: NVreg_CheckPCIConfigSpace:int
parm: NVreg_EnablePCIeGen3:int
parm: NVreg_EnableMSI:int
parm: NVreg_MemoryPoolSize:int
parm: NVreg_RegistryDwords:charp
parm: NVreg_RmMsg:charp
parm: NVreg_AssignGpus:charp

Here is what 'modinfo nvidia-uvm' returns :


filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko
supported: external
license: MIT
depends: nvidia
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions

Here is what 'echo $PATH' returns :


/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/VirtualGL/bin

Here is what 'find 2> /dev/null / -name nvidia*.ko' returns :


/var/lib/dkms/nvidia/340.24/3.14-kali1-amd64/x86_64/module/nvidia.ko
/var/lib/dkms/nvidia/340.24/3.14-kali1-amd64/x86_64/module/nvidia-uvm.ko
/lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
/lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko

nekromantik
2014-08-07, 23:27
I followed latest instructions using latest Nvidia drivers but now my Nvidia card is running all the time.
It wont switch to Intel. Also should we not be installing bumblebee-nvidia as we are now using official drivers?
Kali boots using Intel and as soon as you use optirun or primerun it loads Nvidia and then never switches it off.

weak_superhero
2014-08-08, 22:56
Hi static0de, thanks for your excellent instructional post!

I've gotten pretty close to having functioning CUDA (i think), but running 'optirun glxinfo | grep -i "direct rendering"' gets me the following:

[ 3383.079730] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please

[ 3383.079810] [ERROR]Aborting because fallback start is disabled.

dmesg gives me the following info:

475.365641] bbswitch: enabling discrete graphics
[ 475.612133] thinkpad_acpi: EC reports that Thermal Table has changed
[ 475.880304] nvidia: module license 'NVIDIA' taints kernel.
[ 475.880312] Disabling lock debugging due to kernel taint
[ 475.893068] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:ow ns=none
[ 475.893576] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 1
[ 475.893586] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 340.24 Wed Jul 2 14:24:20 PDT 2014
[ 476.103074] nvidia 0000:01:00.0: irq 48 for MSI/MSI-X
[ 476.111216] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 476.111432] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 476.111591] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 476.111754] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 476.111917] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 476.112465] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 476.112993] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 476.113149] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 490.533192] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 490.559213] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[ 490.595710] NVRM: RmInitAdapter failed! (0x25:0x28:1181)
[ 490.595722] NVRM: rm_init_adapter failed for device bearing minor number 0
[ 490.595746] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error

Kernel taint! I generally only have that after a huge feeding of corn!

I'm a complete n00b with linux, having last monkeyed with unix systems during my university days in the early 90's, before the internet had a GUI. Any help you can give me would be appreciated. If you need any further info, let me know. Thanks!

staticn0de
2014-08-09, 23:50
I followed latest instructions using latest Nvidia drivers but now my Nvidia card is running all the time.
It wont switch to Intel. Also should we not be installing bumblebee-nvidia as we are now using official drivers?
Kali boots using Intel and as soon as you use optirun or primerun it loads Nvidia and then never switches it off.


Please post the output of

lsmod

and

cat /proc/acpi/bbswitch

No. bumblebee-nvidia is a meta package which installs both the bumbelbee and nvidia-driver packages. The nvidia-driver package in the repo is old and not supported by many modern graphics cards. That is why the driver package is downloaded from the nvidia website.

If you are stuck on the nvidia driver and will not swap to the power saving one, try

service bumblebeed restart

and

service bumblebeed status

Also, how do you know the driver is being loaded and not being switched off?

For example, run


optirun glxspheres64

and then run


glxspheres64

Did the second command work without optirun?

Xperianist
2014-08-10, 18:48
Even I am experiencing the same problem!! I am a new member to this forum and kali linux too, so forgive me if there are any mistakes.
the second command works fine (the one without optirun)
for me the optirun glxspheres64 returns

[ 3224.482379] [ERROR]Cannot access secondary GPU - error: X did not start properly

[ 3224.482467] [ERROR]Aborting because fallback start is disabled.

weak_superhero
2014-08-11, 00:29
I've opted to just go into my bios and disable optimus and the integrated graphics, and will install my vendor drivers and CUDA the old fashioned way - without bumbling with bumblebee. thanks for your help. if anything, this entire experience has helped me along the road that much closer to understanding the workings of debian linux.

staticn0de
2014-08-11, 08:54
I've opted to just go into my bios and disable optimus and the integrated graphics, and will install my vendor drivers and CUDA the old fashioned way - without bumbling with bumblebee. thanks for your help. if anything, this entire experience has helped me along the road that much closer to understanding the workings of debian linux.

Hi there,

I'm sorry I missed your post above asking for help. If you change your mind and try and get it working again, send me a message.

staticn0de
2014-08-11, 09:03
Even I am experiencing the same problem!! I am a new member to this forum and kali linux too, so forgive me if there are any mistakes.
the second command works fine (the one without optirun)
for me the optirun glxspheres64 returns

[ 3224.482379] [ERROR]Cannot access secondary GPU - error: X did not start properly

[ 3224.482467] [ERROR]Aborting because fallback start is disabled.


Hi there,

Please try the following commands one after each other and post all the output


lspci | egrep 'VGA|3D'


echo ON >> /proc/acpi/bbswitch

modprobe nvidia

modprobe nvidia-uvm

optirun glxspheres64

dmesg | tail -n 100


echo $PATH


cat /etc/bumblebee/bumblebee.conf


cat /etc/bumblebee/xorg.conf.nvidia


service bumblebeed restart

Steffen025
2014-08-11, 09:51
The following will install the latest at the time (340.24) NVIDIA driver and latest CUDA (version 6) on Kali with
Bumblebee for Optimus laptops. Usual notes about clean installs and selecting either 32bit or 64bit depending on your
needs from the first page still apply.

First, update and upgrade Kali to latest
apt-get update && apt-get upgrade && apt-get dist-upgrade

Download VirtualGL
http://downloads.sourceforge.net/project/virtualgl/2.3.3/virtualgl_2.3.3_amd64.deb?r=http%3A%2F%2Fsourcefor ge.net%2Fprojects%2Fvirtualgl%2Ffiles%2F2.3.3%2F&ts=1404718514&use_mirror=ufpr

Download CUDA (this is V6 64bit)
http://developer.download.nvidia.com/compute/cuda/6_0/rel/installers/cuda_6.0.37_linux_64.run

Download the nvidia*.run driver. Follow the bouncing ball to get what you need for your hardware
http://www.nvidia.com/Download/index.aspx?lang=en-us

Install VirtualGL
cd ~
dpkg -i virtualgl*.deb

Add the path for VirtualGL to .bashrc
nano ~/.bashrc
Add a line somewhere near the top that reads:
export PATH=$PATH:/opt/VirtualGL/bin

Export the path so we don't have to log out and in. Run the following from terminal
export PATH=$PATH:/opt/VirtualGL/bin

Install the linux headers
apt-get install linux-headers-$(uname -r)

Some dependencies for CUDA later
apt-get install freeglut3-dev libxmu-dev


Add the wheezy backports Repo (yes, still needed for bumblebee but not the NVIDIA driver)
nano /etc/apt/sources.list
Add the following line to the file and then save
deb http://ftp.debian.org/debian wheezy-backports main contrib non-free
apt-get update

Install bumblebee (not bumblebee-nvidia)
apt-get install bumblebee primus

Edit the bumblebee.conf file
nano /etc/bumblebee/bumblebee.conf

Change line 22 so it reads:
Driver=nvidia

We do not need to edit line 55 as the module the nvidia installer will build is called nvidia and not nvidia-current.

Save and close.

Run the following and record your PCI address for your video card. It will look similar to 03:00.0
lspci | egrep 'VGA|3D'

Edit xorg.conf.nvidia and add a line under the 'Section "Device"' area so that is matches what is shown below. Change the bus ID to match what you recorded previously and take note that you recored a . before the last number and it is now a ':'. You need the ':'.
Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:03:00:0"

Restart bumblebee with the following and ignore any warnings
/etc/init.d/bumblebeed restart


Change NVIDIA installer permissions
cd ~
chmod +x NVIDIA*.run

You now need to close gdm3 because it can't be running for the driver install. Record what you need now. If you don't get a login screen when you close gdm3, press control + alt + F1
/etc/init.d/gdm3 stop

Now the install
cd ~
./NVIDIA*.run --dkms -z

Accept the EULA
Select yes to register the kernel module with DKMS
No to libs (unless you want them)
Ok to acknowledge the website libs
The install will take place
Do not run X-Config. Select NO.
The installer will close.

Restart kali with
shutdown -r now

When rebooted, run optirun glxspheres64 and confirm it's working. A 'modinfo nvidia' will show that you now have the 340.24 module loaded.

To install CUDA, chmod the installer first
cd ~
chmod +x cuda*.run

And now to install
./cuda*.run

Accept the EULA
Select yes to unsupporrted configuration
No to graphics driver
Yes to the toolkit
Accept default location
Yes to symbolic link
Yes to samples
Yes to default samples location
The toolkit will install

For the path, we will add a little more to what we defined for VirtualGL. It should look like this in your bashrc file
nano ~./bashrc
export PATH=$PATH:/opt/VirtualGL/bin:/usr/local/cuda-6.0/bin

Run the following so we don't have to log out
export PATH=$PATH:/opt/VirtualGL/bin:/usr/local/cuda-6.0/bin

Edit the following file so the contents match those shown below
nano /etc/ld.so.conf


include /etc/ld.so.conf.d/*.conf
/usr/local/cuda-6.0/lib64

Save and close

Run:
ldconfig

Build the nvidia samples

cd /root/NVIDIA_CUDA-6.0_Samples
make

Follow the steps from the second post to run the CUDA deviceQuery script and you should see pass.

Remember to remove or comment out the wheezy backports repo

Hi Static,

first things first: Sorry for my english, im German ^^

thx a lot for your How-To!

I have a Lenovo Y500 Ideapad with 2 GT650m SLI, 16GB RAM, Intel i7.
I have several Problems getting my GPU's to run properly with the Nvidia Driver.
Is there any way you can help me - i mean to chat with you over Whatsapp or something like that, sendind you Images from my Screen and having a real time help?
I am willing to pay for your efforts.

As I checked my Hardware in Windows there are only the both Nvidia GPU's listed, no Intel onboard GPU.
The Cards support Optimus technology, following the Nvidia Website, but do i really need Optimus, if there is no Intel onboard GPU?

Following your How-To step by step i get stuck after editing the Bumblebee .conf, i added both BusID's of the GPU's and the SLI Option

Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:01:00:0"
BusID "PCI:02:00:0"
and activating the SLI in the Options.

After restarting bumblebee and stopping the GDM3 Service i get a black Screen with blinking cursor -> no way to get to TTY1 with "ALT CTRL F1", nor any other Hotkeys working.
I worked around that booting in the Recovery Mode in Console.

In Recovery mode its no Problem stopping the GDM3 and installing Nvidia.
After rebooting i tried the optirun glxspheres64 -> Error.

I also tried an other How-To without Bumblebee:
http://www.blackmoreops.com/2014/03/13/install-proprietary-nvidia-driver-kali-linux/

-> eveything worked fine (yeah, i edited the Xorg.conf with both BusID's and SLI and MultiGPU Option) until step 6
In booting process after the boot information "GDM3 start", my screens gets Black, flashing one time for a second, getting black again, then both GT650m's Fans getting full thrust (airflow getting very hot) and after 30 secs or something the Laptopn shuts down - no way to get to TTY1 or anything -> no way to have any influence after the GDM3 starts.

After reading many many Hours in Forums, HOW-To's, the Nvidia Support section, and the official Nvidia Documentation i have no Clue what to do.

Would be nice to get an answer from You.

Xperianist
2014-08-11, 13:39
Thanks for the reply!


lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
0a:00.0 3D controller: NVIDIA Corporation Device 1292 (rev ff)




root@Kali:~# echo ON >> /proc/acpi/bbswitch
root@Kali:~# modprobe nvidia
root@Kali:~# modprobe nvidia-uvm
root@Kali:~# optirun glxspheres64
[ 196.534830] [ERROR]Cannot access secondary GPU - error: X did not start properly

[ 196.534915] [ERROR]Aborting because fallback start is disabled.



root@Kali:~# dmesg | tail -n 100
[ 7.833718] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 7.977371] uvcvideo: Found UVC 1.00 device HP Truevision HD (04f2:b40d)
[ 7.986270] input: HP Truevision HD as /devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.0/input/input10
[ 7.986450] usbcore: registered new interface driver uvcvideo
[ 7.986451] USB Video Class driver (1.1.1)
[ 8.115977] usb 1-2: ath9k_htc: Firmware htc_9271.fw requested
[ 8.116096] usbcore: registered new interface driver ath9k_htc
[ 8.375737] cfg80211: World regulatory domain updated:
[ 8.375741] cfg80211: DFS Master region: unset
[ 8.375741] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 8.375745] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 8.375746] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 8.375748] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm)
[ 8.375749] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm)
[ 8.375751] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm)
[ 8.375752] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm)
[ 8.512885] usb 1-2: firmware: direct-loading firmware htc_9271.fw
[ 8.746372] Console: switching to colour frame buffer device 170x48
[ 8.752407] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[ 8.752410] i915 0000:00:02.0: registered panic notifier
[ 8.753259] [Firmware Bug]: ACPI(PEGP) defines _DOD but not _DOS
[ 8.753984] ACPI: Video Device [PEGP] (multi-head: yes rom: yes post: no)
[ 8.754174] ACPI Error: [\_SB_.PCI0.GFX0.DD02._BCL] Namespace lookup failure, AE_NOT_FOUND (20131218/psargs-359)
[ 8.754184] ACPI Error: Method parse/execution failed [\_SB_.PCI0.RP05.PEGP.DD02._BCL] (Node ffff88015e8806f0), AE_NOT_FOUND (20131218/psparse-536)
[ 8.754299] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/device:19/LNXVIDEO:00/input/input11
[ 8.795342] usb 1-2: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
[ 8.796068] [drm] Enabling RC6 states: RC6 on, RC6p off, RC6pp off
[ 8.799829] ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)
[ 8.844430] acpi device:3b: registered as cooling_device5
[ 8.844704] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:01/input/input12
[ 8.844935] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[ 8.846918] snd_hda_intel 0000:00:1b.0: irq 61 for MSI/MSI-X
[ 8.852338] snd_hda_intel 0000:00:03.0: irq 62 for MSI/MSI-X
[ 8.997402] input: HDA Intel HDMI HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/sound/card0/input15
[ 8.997663] input: HDA Intel HDMI HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/sound/card0/input14
[ 8.997888] input: HDA Intel HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/sound/card0/input13
[ 9.026024] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card1/input17
[ 9.026238] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1b.0/sound/card1/input16
[ 9.032636] ath9k_htc 1-2:1.0: ath9k_htc: HTC initialized with 33 credits
[ 9.298616] ath9k_htc 1-2:1.0: ath9k_htc: FW Version: 1.3
[ 9.298623] ath: EEPROM regdomain: 0x809c
[ 9.298626] ath: EEPROM indicates we should expect a country code
[ 9.298629] ath: doing EEPROM country->regdmn map search
[ 9.298631] ath: country maps to regdmn code: 0x52
[ 9.298635] ath: Country alpha2 being used: CN
[ 9.298637] ath: Regpair used: 0x52
[ 9.303397] ieee80211 phy1: Atheros AR9271 Rev:1
[ 9.303431] cfg80211: Calling CRDA for country: CN
[ 9.310588] cfg80211: Regulatory domain changed to country: CN
[ 9.310596] cfg80211: DFS Master region: unset
[ 9.310599] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 9.310603] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 9.310606] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2300 mBm)
[ 9.310609] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2300 mBm)
[ 9.310612] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm)
[ 9.310615] cfg80211: (57240000 KHz - 59400000 KHz @ 2160000 KHz), (N/A, 2800 mBm)
[ 9.310618] cfg80211: (59400000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4400 mBm)
[ 9.310620] cfg80211: (63720000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 2800 mBm)
[ 11.865869] EXT4-fs (sda5): re-mounted. Opts: (null)
[ 15.144614] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro
[ 15.589589] loop: module loaded
[ 19.478453] Netfilter messages via NETLINK v0.30.
[ 19.547083] bbswitch: version 0.8
[ 19.547099] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[ 19.547111] bbswitch: Found discrete VGA device 0000:0a:00.0: \_SB_.PCI0.RP05.PEGP
[ 19.547131] ACPI Warning: \_SB_.PCI0.RP05.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 19.547286] bbswitch: detected an Optimus _DSM function
[ 19.547311] pci 0000:0a:00.0: enabling device (0006 -> 0007)
[ 19.547418] bbswitch: Succesfully loaded. Discrete card 0000:0a:00.0 is on
[ 19.552195] bbswitch: disabling discrete graphics
[ 19.552222] ACPI Warning: \_SB_.PCI0.RP05.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 25.557236] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[ 31.072128] r8169 0000:09:00.0: firmware: direct-loading firmware rtl_nic/rtl8106e-2.fw
[ 31.105575] r8169 0000:09:00.0 eth0: link down
[ 31.105630] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 35.640636] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[ 36.758510] r8169 0000:09:00.0 eth0: link down
[ 36.758584] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 37.367795] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[ 41.386377] wlan1: authenticate with 9c:8e:dc:1d:35:8c
[ 41.677621] wlan1: send auth to 9c:8e:dc:1d:35:8c (try 1/3)
[ 41.679346] wlan1: authenticated
[ 41.681608] wlan1: associate with 9c:8e:dc:1d:35:8c (try 1/3)
[ 41.685362] wlan1: RX AssocResp from 9c:8e:dc:1d:35:8c (capab=0x411 status=0 aid=1)
[ 41.695106] wlan1: associated
[ 41.695139] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[ 41.695214] cfg80211: Calling CRDA for country: TW
[ 41.702625] cfg80211: Regulatory domain changed to country: TW
[ 41.702632] cfg80211: DFS Master region: unset
[ 41.702635] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 41.702640] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm)
[ 41.702643] cfg80211: (5270000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 1700 mBm)
[ 41.702646] cfg80211: (5490000 KHz - 5590000 KHz @ 80000 KHz), (N/A, 3000 mBm)
[ 41.702648] cfg80211: (5650000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 3000 mBm)
[ 41.702651] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm)
[ 181.701038] bbswitch: enabling discrete graphics
[ 192.293592] nvidia: module license 'NVIDIA' taints kernel.
[ 192.293599] Disabling lock debugging due to kernel taint
[ 192.314235] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 331.67 Fri Apr 4 13:48:39 PDT 2014
[ 192.410048] nvidia_uvm: Loaded the UVM driver, major device number 249



root@Kali:~# echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/VirtualGL/bin:/opt/VirtualGL

Xperianist
2014-08-11, 13:41
root@Kali:~# cat /etc/bumblebee/bumblebee.conf
# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
# bbswitch - new in BB 3, recommended if available
# switcheroo - vga_switcheroo method, use at your own risk
# none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia-current
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau



root@Kali:~# cat /etc/bumblebee/xorg.conf.nvidia
Section "ServerLayout"
Identifier "Layout0"
Option "AutoAddDevices" "false"
Option "AutoAddGPU" "false"
EndSection

Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:0a:00:0"
# If the X server does not automatically detect your VGA device,
# you can manually set it here.
# To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
# as you see in the commented example.
# This Setting may be needed in some platforms with more than one
# nvidia card, which may confuse the proprietary driver (e.g.,
# trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
# BusID "PCI:01:00:0"

# Setting ProbeAllGpus to false prevents the new proprietary driver
# instance spawned to try to control the integrated graphics card,
# which is already being managed outside bumblebee.
# This option doesn't hurt and it is required on platforms running
# more than one nvidia graphics card with the proprietary driver.
# (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
# If this option is not set, the new Xorg may blacken the screen and
# render it unusable (unless you have some way to run killall Xorg).
Option "ProbeAllGpus" "false"

Option "NoLogo" "true"
Option "UseEDID" "false"
Option "UseDisplayDevice" "none"
EndSection

nekromantik
2014-08-11, 18:32
Please post the output of

lsmod

and

cat /proc/acpi/bbswitch

No. bumblebee-nvidia is a meta package which installs both the bumbelbee and nvidia-driver packages. The nvidia-driver package in the repo is old and not supported by many modern graphics cards. That is why the driver package is downloaded from the nvidia website.

If you are stuck on the nvidia driver and will not swap to the power saving one, try

service bumblebeed restart

and

service bumblebeed status

Also, how do you know the driver is being loaded and not being switched off?

For example, run


optirun glxspheres64

and then run


glxspheres64

Did the second command work without optirun?

It seems like bbswitch was not installed by default.
I installed it and now it switches fine.
Thanks

staticn0de
2014-08-13, 10:37
@Xperianist

For your path, you don't need the second /opt/VirtualGL (you have it at the end) as there is no bins in that folder. Additonal paths can break your install.

That being said, I don't think that is the issue. I can see you have installed the older drivers. I have left those there for a kind of legacy reason but you should use the latest drivers which start at post 25.

I know it is most likely not what you are looking for but the newer drivers will most likely fix your issue ( as they have for quite a few people now)

As for your partiular fault, do you have an Nvidia GT750M?

staticn0de
2014-08-13, 10:49
Hi Static,

first things first: Sorry for my english, im German ^^

thx a lot for your How-To!

I have a Lenovo Y500 Ideapad with 2 GT650m SLI, 16GB RAM, Intel i7.
I have several Problems getting my GPU's to run properly with the Nvidia Driver.
Is there any way you can help me - i mean to chat with you over Whatsapp or something like that, sendind you Images from my Screen and having a real time help?
I am willing to pay for your efforts.

As I checked my Hardware in Windows there are only the both Nvidia GPU's listed, no Intel onboard GPU.
The Cards support Optimus technology, following the Nvidia Website, but do i really need Optimus, if there is no Intel onboard GPU?

Following your How-To step by step i get stuck after editing the Bumblebee .conf, i added both BusID's of the GPU's and the SLI Option

Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:01:00:0"
BusID "PCI:02:00:0"
and activating the SLI in the Options.

After restarting bumblebee and stopping the GDM3 Service i get a black Screen with blinking cursor -> no way to get to TTY1 with "ALT CTRL F1", nor any other Hotkeys working.
I worked around that booting in the Recovery Mode in Console.

In Recovery mode its no Problem stopping the GDM3 and installing Nvidia.
After rebooting i tried the optirun glxspheres64 -> Error.

I also tried an other How-To without Bumblebee:
http://www.blackmoreops.com/2014/03/13/install-proprietary-nvidia-driver-kali-linux/

-> eveything worked fine (yeah, i edited the Xorg.conf with both BusID's and SLI and MultiGPU Option) until step 6
In booting process after the boot information "GDM3 start", my screens gets Black, flashing one time for a second, getting black again, then both GT650m's Fans getting full thrust (airflow getting very hot) and after 30 secs or something the Laptopn shuts down - no way to get to TTY1 or anything -> no way to have any influence after the GDM3 starts.

After reading many many Hours in Forums, HOW-To's, the Nvidia Support section, and the official Nvidia Documentation i have no Clue what to do.

Would be nice to get an answer from You.

Hi there,

I don't have SLI in my laptop so this is not somehting I have worked with. Another forum member had issues with SLI and I replied with some information I found and they never came back, it was either very useful or not useful at all so give it a try.

First, post the output of the following so I can tell you if you need optimus at all


lspci | egrep 'VGA|3D'

This is the post I replied about SLI

https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=35604&viewfull=1#post35604

If you don't have the onboard intel you do not need optimus. If it's just enabling SLI, it should be as *easy* as installing NVIDIA, enabling SLI in XORG and rebooting. Lets see how we go.

If you don't need optimus and installed bumblebee, it would do an awesome job at killing your graphics.

tonrin
2014-08-17, 13:06
hello, I have a problem after installing the nvidia driver (which works apparently correct, because there is no error and 'modinfo nvidia' shows version 340.24)
after rebooting, I use "optirun glxspheres64" but i get this error message and my fans going crazy (maximum speed):

optirun glxspheres64
[ 1492.076369] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please

[ 1492.076523] [ERROR]Aborting because fallback start is disabled.

Maybe you could help me with this issue?
I'll give you some information about my system:

uname -r

3.14-kali1-amd64


cat /etc/modprobe.d/bumblebee.conf

# installed by bumblebee-nvidia

# do not automatically load nouveau as it may prevent nvidia from loading
blacklist nouveau
# do not automatically load nvidia as it's unloaded anyway when bumblebeed
# starts and may fail bumblebeed to disable the card in a race condition.
blacklist nvidia
blacklist nvidia-current
blacklist nvidia-current-updates
# 304
blacklist nvidia-304
blacklist nvidia-304-updates
blacklist nvidia-experimental-304
# 310
blacklist nvidia-310
blacklist nvidia-310-updates
blacklist nvidia-experimental-310
# 313
blacklist nvidia-313
blacklist nvidia-313-updates
blacklist nvidia-experimental-313
# 319
blacklist nvidia-319
blacklist nvidia-319-updates
blacklist nvidia-experimental-319
# 325
blacklist nvidia-325
blacklist nvidia-325-updates
blacklist nvidia-experimental-325


dmesg (bbswitch can't "enable discrete graphics", maybe this is the problem?)

dmesg

[ 7.331956] Console: switching to colour frame buffer device 240x67
[ 7.340826] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[ 7.340829] i915 0000:00:02.0: registered panic notifier
[ 7.341167] ACPI Exception: AE_NOT_FOUND, Evaluating _DOD (20131218/video-1245)
[ 7.341418] ACPI: Video Device [PEGP] (multi-head: no rom: yes post: no)
[ 7.341835] acpi device:38: registered as cooling_device5
[ 7.341913] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/device:36/LNXVIDEO:00/input/input12
[ 7.359788] ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)
[ 7.360290] acpi device:44: registered as cooling_device6
[ 7.360511] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:01/input/input13
[ 7.360745] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[ 7.361764] snd_hda_intel 0000:00:1b.0: irq 46 for MSI/MSI-X
[ 7.606402] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/input/input14
[ 7.765829] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input17
[ 7.766024] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input16
[ 7.766179] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input15
[ 7.811610] [drm] Enabling RC6 states: RC6 on, RC6p on, RC6pp off
[ 9.639508] Adding 1413116k swap on /dev/sda6. Priority:-1 extents:1 across:1413116k
[ 9.658588] EXT4-fs (sda5): re-mounted. Opts: (null)
[ 9.906212] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro
[ 10.352065] loop: module loaded
[ 12.470646] atl1c 0000:0e:00.0: irq 47 for MSI/MSI-X
[ 12.471338] atl1c 0000:0e:00.0: atl1c: eth0 NIC Link is Up<100 Mbps Full Duplex>
[ 14.629139] bbswitch: version 0.8
[ 14.629154] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[ 14.629163] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[ 14.629188] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 14.629343] bbswitch: detected an Optimus _DSM function
[ 14.629366] pci 0000:01:00.0: enabling device (0006 -> 0007)
[ 14.629451] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on
[ 14.633271] bbswitch: disabling discrete graphics
[ 14.633294] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 14.925969] Netfilter messages via NETLINK v0.30.
[ 18.198246] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 482.635755] bbswitch: enabling discrete graphics
[ 483.339458] nvidia: module license 'NVIDIA' taints kernel.
[ 483.339466] Disabling lock debugging due to kernel taint
[ 483.353271] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:ow ns=none
[ 483.353819] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 1
[ 483.353829] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 340.24 Wed Jul 2 14:24:20 PDT 2014
[ 483.627585] nvidia 0000:01:00.0: irq 48 for MSI/MSI-X
[ 483.635720] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 483.635781] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 483.635809] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 483.635834] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 483.635859] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 483.635884] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 483.635967] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 483.635993] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 501.309962] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 501.336065] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[ 501.336100] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[ 501.368958] NVRM: RmInitAdapter failed! (0x25:0x28:1181)
[ 501.368970] NVRM: rm_init_adapter failed for device bearing minor number 0
[ 501.368995] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5
[ 935.094761] bbswitch: enabling discrete graphics
[ 1493.777226] bbswitch: enabling discrete graphics
[ 1493.792829] nvidia 0000:01:00.0: Refused to change power state, currently in D3
[ 2000.720559] bbswitch: enabling discrete graphics
[ 2000.736015] nvidia 0000:01:00.0: Refused to change power state, currently in D3


lspci | egrep 'VGA|3D'

lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GT 650M] (rev ff)


modinfo nvidia

modinfo nvidia
filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
alias: char-major-195-*
version: 340.24
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias: pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias: pci:v000010DEd*sv*sd*bc03sc02i00*
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
depends: drm,i2c-core
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
parm: NVreg_ModifyDeviceFiles:int
parm: NVreg_DeviceFileUID:int
parm: NVreg_DeviceFileGID:int
parm: NVreg_DeviceFileMode:int
parm: NVreg_RemapLimit:int
parm: NVreg_UpdateMemoryTypes:int
parm: NVreg_InitializeSystemMemoryAllocations:int
parm: NVreg_RMEdgeIntrCheck:int
parm: NVreg_UsePageAttributeTable:int
parm: NVreg_MapRegistersEarly:int
parm: NVreg_RegisterForACPIEvents:int
parm: NVreg_CheckPCIConfigSpace:int
parm: NVreg_EnablePCIeGen3:int
parm: NVreg_EnableMSI:int
parm: NVreg_MemoryPoolSize:int
parm: NVreg_RegistryDwords:charp
parm: NVreg_RmMsg:charp
parm: NVreg_AssignGpus:charp


modinfo nvidia-uvm

modinfo nvidia-uvm
filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko
supported: external
license: MIT
depends: nvidia
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions


echo $PATH

echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/VirtualGL/bin:/usr/local/cuda-6.0/bin

tonrin
2014-08-17, 13:08
find 2> /dev/null / -name nvidia*.ko

find 2> /dev/null / -name nvidia*.ko
/lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko
/lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
/var/lib/dkms/nvidia/340.24/3.14-kali1-amd64/x86_64/module/nvidia-uvm.ko
/var/lib/dkms/nvidia/340.24/3.14-kali1-amd64/x86_64/module/nvidia.ko


/etc/bumblebee/xorg.nvidia.conf

/etc/bumblebee/xorg.nvidia.conf
bash: /etc/bumblebee/xorg.nvidia.conf: No such file or directory


/etc/bumblebee/bumblebee.conf

# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
# bbswitch - new in BB 3, recommended if available
# switcheroo - vga_switcheroo method, use at your own risk
# none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau






I hope someone can help me, please
thx

tonrin
2014-08-18, 05:01
ERROR: Failed to initialize the NVIDIA GPU at PCI:1:0:0

solution found on this site:
https://github.com/Bumblebee-Project/Bumblebee/issues/542

changing
GRUB_CMDLINE_LINUX_DEFAULT="quiet" to
GRUB_CMDLINE_LINUX_DEFAULT="quiet rcutree.rcu_idle_gp_delay=1" in /etc/default/grub.
I tried it and it worked

staticn0de
2014-08-18, 09:12
ERROR: Failed to initialize the NVIDIA GPU at PCI:1:0:0

solution found on this site:
https://github.com/Bumblebee-Project/Bumblebee/issues/542

changing
GRUB_CMDLINE_LINUX_DEFAULT="quiet" to
GRUB_CMDLINE_LINUX_DEFAULT="quiet rcutree.rcu_idle_gp_delay=1" in /etc/default/grub.
I tried it and it worked

Hi tonrin!

Thanks for sharing your fix, I know a lot of users will appreciate it.

For anyone using this fix, make sure you run an update-grub after making changes.

To see if this will work for you as a fix before modifying that file and running update-grub, you can run the following (I can't credit the original creator as this has been posted on about 40 different sites in relation to this fix)


sudo tee /sys/module/rcutree/parameters/rcu_idle_gp_delay <<<1

and then try optirun glxspheres64

If that fixes it, you should update the grub file.

johnnyinc
2014-08-20, 19:46
Hey all,

I have a problem with the following:

root@kali:~# optirun glxspheres64
[ 347.923592] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 347.923672] [ERROR]Could not connect to bumblebee daemon - is it running?



root@kali:~# dmesg | tail -n 30
[ 5.971403] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 5.971960] bbswitch: detected an Optimus _DSM function
[ 5.971977] pci 0000:02:00.0: enabling device (0004 -> 0007)
[ 5.972028] bbswitch: Succesfully loaded. Discrete card 0000:02:00.0 is on
[ 6.106233] Netfilter messages via NETLINK v0.30.
[ 6.226566] e1000e 0000:00:19.0: irq 43 for MSI/MSI-X
[ 6.329054] e1000e 0000:00:19.0: irq 43 for MSI/MSI-X
[ 6.329158] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 6.330542] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S
[ 6.330782] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S
[ 6.343007] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 6.620947] psmouse serio2: trackpoint: IBM TrackPoint firmware: 0x0e, buttons: 3/3
[ 6.820633] input: TPPS/2 IBM TrackPoint as /devices/platform/i8042/serio1/serio2/input/input10
[ 13.634626] wlan0: authenticate with 24:a2:e1:ec:af:5a
[ 13.638425] wlan0: send auth to 24:a2:e1:ec:af:5a (try 1/3)
[ 13.640307] wlan0: authenticated
[ 13.641771] wlan0: associate with 24:a2:e1:ec:af:5a (try 1/3)
[ 13.645717] wlan0: RX AssocResp from 24:a2:e1:ec:af:5a (capab=0x1411 status=0 aid=1)
[ 13.647617] wlan0: associated
[ 13.647676] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 13.647758] cfg80211: Calling CRDA for country: PL
[ 13.655344] cfg80211: Regulatory domain changed to country: PL
[ 13.655351] cfg80211: DFS Master region: unset
[ 13.655354] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 13.655359] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 13.655362] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm)
[ 13.655365] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2000 mBm)
[ 13.655368] cfg80211: (5490000 KHz - 5710000 KHz @ 80000 KHz), (N/A, 2700 mBm)
[ 13.655371] cfg80211: (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
[ 13.691353] wlan0: Limiting TX power to 20 (20 - 0) dBm as advertised by 24:a2:e1:ec:af:5a


Do you have any ideas ?
if more info needed please let me know

staticn0de
2014-08-21, 09:35
Hey all,

I have a problem with the following:

root@kali:~# optirun glxspheres64
[ 347.923592] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 347.923672] [ERROR]Could not connect to bumblebee daemon - is it running?



root@kali:~# dmesg | tail -n 30
[ 5.971403] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 5.971960] bbswitch: detected an Optimus _DSM function
[ 5.971977] pci 0000:02:00.0: enabling device (0004 -> 0007)
[ 5.972028] bbswitch: Succesfully loaded. Discrete card 0000:02:00.0 is on
[ 6.106233] Netfilter messages via NETLINK v0.30.
[ 6.226566] e1000e 0000:00:19.0: irq 43 for MSI/MSI-X
[ 6.329054] e1000e 0000:00:19.0: irq 43 for MSI/MSI-X
[ 6.329158] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 6.330542] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S
[ 6.330782] iwlwifi 0000:04:00.0: L1 Enabled; Disabling L0S
[ 6.343007] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 6.620947] psmouse serio2: trackpoint: IBM TrackPoint firmware: 0x0e, buttons: 3/3
[ 6.820633] input: TPPS/2 IBM TrackPoint as /devices/platform/i8042/serio1/serio2/input/input10
[ 13.634626] wlan0: authenticate with 24:a2:e1:ec:af:5a
[ 13.638425] wlan0: send auth to 24:a2:e1:ec:af:5a (try 1/3)
[ 13.640307] wlan0: authenticated
[ 13.641771] wlan0: associate with 24:a2:e1:ec:af:5a (try 1/3)
[ 13.645717] wlan0: RX AssocResp from 24:a2:e1:ec:af:5a (capab=0x1411 status=0 aid=1)
[ 13.647617] wlan0: associated
[ 13.647676] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 13.647758] cfg80211: Calling CRDA for country: PL
[ 13.655344] cfg80211: Regulatory domain changed to country: PL
[ 13.655351] cfg80211: DFS Master region: unset
[ 13.655354] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 13.655359] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 13.655362] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm)
[ 13.655365] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2000 mBm)
[ 13.655368] cfg80211: (5490000 KHz - 5710000 KHz @ 80000 KHz), (N/A, 2700 mBm)
[ 13.655371] cfg80211: (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
[ 13.691353] wlan0: Limiting TX power to 20 (20 - 0) dBm as advertised by 24:a2:e1:ec:af:5a


Do you have any ideas ?
if more info needed please let me know

Try the following

/etc/init.d/bumblebeed start

If that fails, I would guess that bbswitch failed to install correctly.

Try :

apt-get install linux-headers-$(uname -r)
apt-get install --reinstall bbswitch
/etc/init.d/bumblebeed start

Edit: try optirun -vv glxspheres64

The above will give more debugging info. With dmesg, try -n 100 so it has some more info in it.

Quest
2014-08-23, 23:04
Hashcat 1.30 seems to be out http://ftp.tku.edu.tw/kali/pool/non-free/o/oclhashcat/

oclhashcat_1.30-0kali1_amd64.deb 2014-08-22 21:36 120M

Any theory as to why the new package is now 120Mb instead of 508Mb !?



Sincerely,

Seriously Confused

staticn0de
2014-08-24, 07:53
Hashcat 1.30 seems to be out http://ftp.tku.edu.tw/kali/pool/non-free/o/oclhashcat/


Any theory as to why the new package is now 120Mb instead of 508Mb !?



Sincerely,

Seriously Confused

Hey Quest,

The obvious changes are that the cudahashcat binary has been removed (no large change in file size there)

The other one is that the 4318 folder within usr/share/kernels has been removed. That was a very large folder and accounts for the size difference.

On the + the change log says support for 340.24 has been added :)

Quest
2014-08-24, 13:58
Thanks again friend. Good to have someone onboard that understand these things =]

How did you go about installing 1.30 (I presume you did install it) ? Did you uninstall 1.01 first? If so what is the alchemical formula? How many dead frogs and bats will I need to upgrade to 1.30, or do I simply install on top of 1.01?

icexx
2014-08-24, 18:40
Many thanks man! it's work very nice for me :D


CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: "GeForce GTX 870M"
CUDA Driver Version / Runtime Version 6.5 / 6.0
CUDA Capability Major/Minor version number: 3.0
Total amount of global memory: 3072 MBytes (3221028864 bytes)
( 7) Multiprocessors, (192) CUDA Cores/MP: 1344 CUDA Cores
GPU Clock rate: 967 MHz (0.97 GHz)
Memory Clock rate: 2500 Mhz
Memory Bus Width: 192-bit
L2 Cache Size: 393216 bytes
Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096)
Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers
Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total number of registers available per block: 65536
Warp size: 32
Maximum number of threads per multiprocessor: 2048
Maximum number of threads per block: 1024
Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535)
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Concurrent copy and kernel execution: Yes with 1 copy engine(s)
Run time limit on kernels: Yes
Integrated GPU sharing Host Memory: No
Support host page-locked memory mapping: Yes
Alignment requirement for Surfaces: Yes
Device has ECC support: Disabled
Device supports Unified Addressing (UVA): Yes
Device PCI Bus ID / PCI location ID: 1 / 0
Compute Mode:
< Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 6.5, CUDA Runtime Version = 6.0, NumDevs = 1, Device0 = GeForce GTX 870M
Result = PASS

staticn0de
2014-08-25, 02:01
Thanks again friend. Good to have someone onboard that understand these things =]

How did you go about installing 1.30 (I presume you did install it) ? Did you uninstall 1.01 first? If so what is the alchemical formula? How many dead frogs and bats will I need to upgrade to 1.30, or do I simply install on top of 1.01?

I have not installed it yet, I downloaded and unpacked the .debs and ran them through some compare software.

at a guess, I would say

apt-get remove --purge oclhashcat && apt-get install oclhashcat

I'll try soon though and post how it goes

Quest
2014-08-25, 03:11
ehh, something funky is going on. After uninstall 1.01 and installing 1.30, using the test command

./cudaHashcat.bin -t 32 -a 7 example0.hash ?a?a?a?a example.dict does not work.




./oclHashcat.bin -t 32 -a 7 example0.hash ?a?a?a?a example.dict rturns:

ERROR: No AMD/SDS compatible platform found

root@kali:/usr/share/oclhashcat#


could this be a AMD only release?


Edit:


apt-get install oclhashcat

returns:

http://http.kali.org/kali/ kali/non-free oclhashcat amd64 1.01-1kali2 [533 MB]

so I do not know what that oclHashcat 1.30 package is.

staticn0de
2014-08-25, 08:50
ehh, something funky is going on. After uninstall 1.01 and installing 1.30, using the test command
does not work.



rturns:



could this be a AMD only release?


Edit:


apt-get install oclhashcat

returns:


so I do not know what that oclHashcat 1.30 package is.

Well, you are right. That is an AMD only release.

The good news is, cudahashcat 1.30 does work on Kali (I just crunched that example hash). The bad news is, it is not in the repo and I had to install it manually (first world problems, right?)

I'm trying my hand at making my own .deb which will install 1.30 on Kali. I've never done that before so I have no ETA. May be easier to extract hashcat and my soft links to the .bin.

staticn0de
2014-08-25, 10:55
ehh, something funky is going on. After uninstall 1.01 and installing 1.30, using the test command
does not work.



rturns:



could this be a AMD only release?


Edit:


apt-get install oclhashcat

returns:


so I do not know what that oclHashcat 1.30 package is.

Amazingly, my deb works.



root@kali:~# dpkg -i cudaHashcat-1.30.deb
Selecting previously unselected package cudahashcat-1.30.
(Reading database ... 349321 files and directories currently installed.)
Unpacking cudahashcat-1.30 (from cudaHashcat-1.30.deb) ...
Setting up cudahashcat-1.30 (1.30) ...
root@kali:~# optirun cudahashcat64 -t 32 -a 7 example0.hash ?a?a?a?a example.dict
cudaHashcat v1.30 starting...


I have taken the archive from the hashcat site and modified it under section 6 of their EULA. The deb installs the program is /usr/share/cudahashcat and places scripts in /usr/bin which calls hashcat like any other command.

I'll upload it tonight for anyone that wants to use it. Provided as is with no expectation it will work and it may cause damages including death and your wife leaving you (tic) but you get the idea.

Weighs in at 172mb

Edit:

Download link:
https://www.mirrorcreator.com/files/WURGDJKL/cudaHashcat-1.30.deb_links

SHA1SUM
f2c0d96c75d1c186b48e11c5b399f3e2ccc5e459

when installed, its called with 'cudahashcat64' for 64bit or 'cudahashcat32' for 32 bit.

Quest
2014-08-25, 13:56
Thanks staticn0de!

What a bizarre file naming convention. They seem to have enormous difficulties identifying their own creation... And now I'm abit suspicious about the file size difference between 1.01/1.30 What else are we missing?

I cannot try it now, and I have very little experience with Hashcat anyways, but something tells me that 1.30 is missing a few feathers...



Edit:

Works bro! :cool:

Not much difference (for this test). Actually I'm now 2mins slower than I was with 1.01


===============================CudaHashcat 1.01:

Session.Name...: cudaHashcat
Status.........: Exhausted
Input.Base.....: Mask (?a?a?a?a) [4]
Input.Mod......: File (example.dict)
Hash.Target....: File (example0.hash)
Hash.Type......: MD5
Time.Started...: Mon Jul 28 18:22:33 2014 (12 mins, 7 secs)
Time.Estimated.: 0 secs
Speed.GPU.#1...: 187.9 MH/s
Recovered......: 2190/6494 (33.72%) Digests, 0/1 (0.00%) Salts
Progress.......: 136302297088/136302297088 (100.00%)
Rejected.......: 0/136302297088 (0.00%)
HWMon.GPU.#1...: -1% Util, 69c Temp, -1% Fan

Started: Mon Jul 28 18:22:33 2014
Stopped: Mon Jul 28 18:34:46 2014 (12mins)



===============================CudaHashcat 1.30:

Session.Name...: cudaHashcat
Status.........: Exhausted
Input.Base.....: Mask (?a?a?a?a) [4]
Input.Mod......: File (example.dict)
Hash.Target....: File (example0.hash)
Hash.Type......: MD5
Time.Started...: 0 secs
Time.Estimated.: 0 secs
Speed.GPU.#1...: 41304.2 kH/s
Recovered......: 2190/6494 (33.72%) Digests, 0/1 (0.00%) Salts
Progress.......: 136302297088/136302297088 (100.00%)
Skipped........: 0/136302297088 (0.00%)
Rejected.......: 0/136302297088 (0.00%)
HWMon.GPU.#1...: -1% Util, 66c Temp, -1% Fan

Started: Mon Aug 25 20:44:03 2014
Stopped: Mon Aug 25 20:58:04 2014 (14mins)

Regardless, your .deb works!

staticn0de
2014-08-26, 01:47
Thanks staticn0de!

What a bizarre file naming convention. They seem to have enormous difficulties identifying their own creation... And now I'm abit suspicious about the file size difference between 1.01/1.30 What else are we missing?

I cannot try it now, and I have very little experience with Hashcat anyways, but something tells me that 1.30 is missing a few feathers...



Edit:

Works bro! :cool:

Not much difference (for this test). Actually I'm now 2mins slower than I was with 1.01


===============================CudaHashcat 1.01:

Session.Name...: cudaHashcat
Status.........: Exhausted
Input.Base.....: Mask (?a?a?a?a) [4]
Input.Mod......: File (example.dict)
Hash.Target....: File (example0.hash)
Hash.Type......: MD5
Time.Started...: Mon Jul 28 18:22:33 2014 (12 mins, 7 secs)
Time.Estimated.: 0 secs
Speed.GPU.#1...: 187.9 MH/s
Recovered......: 2190/6494 (33.72%) Digests, 0/1 (0.00%) Salts
Progress.......: 136302297088/136302297088 (100.00%)
Rejected.......: 0/136302297088 (0.00%)
HWMon.GPU.#1...: -1% Util, 69c Temp, -1% Fan

Started: Mon Jul 28 18:22:33 2014
Stopped: Mon Jul 28 18:34:46 2014 (12mins)



===============================CudaHashcat 1.30:

Session.Name...: cudaHashcat
Status.........: Exhausted
Input.Base.....: Mask (?a?a?a?a) [4]
Input.Mod......: File (example.dict)
Hash.Target....: File (example0.hash)
Hash.Type......: MD5
Time.Started...: 0 secs
Time.Estimated.: 0 secs
Speed.GPU.#1...: 41304.2 kH/s
Recovered......: 2190/6494 (33.72%) Digests, 0/1 (0.00%) Salts
Progress.......: 136302297088/136302297088 (100.00%)
Skipped........: 0/136302297088 (0.00%)
Rejected.......: 0/136302297088 (0.00%)
HWMon.GPU.#1...: -1% Util, 66c Temp, -1% Fan

Started: Mon Aug 25 20:44:03 2014
Stopped: Mon Aug 25 20:58:04 2014 (14mins)

Regardless, your .deb works!

Hey Quest,

Thanks for trying it, you can unpack it manually and see how I did it with the 'ar' command.

Regards to what else we are missing, it's all kernel files. At a guess I would say they are no longer supported. When they are unpacked they take up huge amounts of disk space.

ryuga
2014-08-29, 03:22
Hi,I am setting up bumblebee for my GT 650M following the guide on post #25 but when I run optirun glxspheres64 my laptop suddenly shutdown. Here's some command returns:


# lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GT 650M] (rev ff)



modinfo nvidia
filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
alias: char-major-195-*
version: 340.32
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias: pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias: pci:v000010DEd*sv*sd*bc03sc02i00*
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
depends: drm,i2c-core
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
parm: NVreg_ModifyDeviceFiles:int
parm: NVreg_DeviceFileUID:int
parm: NVreg_DeviceFileGID:int
parm: NVreg_DeviceFileMode:int
parm: NVreg_RemapLimit:int
parm: NVreg_UpdateMemoryTypes:int
parm: NVreg_InitializeSystemMemoryAllocations:int
parm: NVreg_UsePageAttributeTable:int
parm: NVreg_MapRegistersEarly:int
parm: NVreg_RegisterForACPIEvents:int
parm: NVreg_CheckPCIConfigSpace:int
parm: NVreg_EnablePCIeGen3:int
parm: NVreg_EnableMSI:int
parm: NVreg_MemoryPoolSize:int
parm: NVreg_RegistryDwords:charp
parm: NVreg_RmMsg:charp
parm: NVreg_AssignGpus:charp


Thanks in advance.

staticn0de
2014-08-29, 09:06
Hi,I am setting up bumblebee for my GT 650M following the guide on post #25 but when I run optirun glxspheres64 my laptop suddenly shutdown. Here's some command returns:


# lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GT 650M] (rev ff)



modinfo nvidia
filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
alias: char-major-195-*
version: 340.32
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias: pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias: pci:v000010DEd*sv*sd*bc03sc02i00*
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
depends: drm,i2c-core
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
parm: NVreg_ModifyDeviceFiles:int
parm: NVreg_DeviceFileUID:int
parm: NVreg_DeviceFileGID:int
parm: NVreg_DeviceFileMode:int
parm: NVreg_RemapLimit:int
parm: NVreg_UpdateMemoryTypes:int
parm: NVreg_InitializeSystemMemoryAllocations:int
parm: NVreg_UsePageAttributeTable:int
parm: NVreg_MapRegistersEarly:int
parm: NVreg_RegisterForACPIEvents:int
parm: NVreg_CheckPCIConfigSpace:int
parm: NVreg_EnablePCIeGen3:int
parm: NVreg_EnableMSI:int
parm: NVreg_MemoryPoolSize:int
parm: NVreg_RegistryDwords:charp
parm: NVreg_RmMsg:charp
parm: NVreg_AssignGpus:charp


Thanks in advance.

Hi there,

Try this from terminal and then run glxspheres64 with optirun


sudo tee /sys/module/rcutree/parameters/rcu_idle_gp_delay <<<1

If that works, follow this post to make the change permanent

https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=36390&viewfull=1#post36390

Yerlan
2014-08-29, 17:46
Hi staticn0de! Greate job. thank you.
excuse me for my English.
i did everything like 25 post suggests. and use last version of driver from nvidia
but have the same problem with "optirun glxspheres" like Xperianist

my HW
HP Pavilion 15-n060er with Intel and Nvidia GeForce 750M VGA
do you know how can i configure the system to use only discrete VGA?

Maybe Xperianist solved this problem? if you did please share solution

Any ideas? please help me with this. waiting for your answer

Rarity
2014-08-29, 20:05
Hey there,

nvidia-glx is not required for the second install. This is a transitional package to install the older drivers.

That being said, i'm going to need a lot more information from you to help.

-snip-

That should do for a start

Okay, here we go! About time, right? Lol.

dmesg after running optirun glxspheres64:

[ 239.050292] nvidia: module license 'NVIDIA' taints kernel.
[ 239.050298] Disabling lock debugging due to kernel taint
[ 239.620698] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
[ 239.620969] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 1
[ 239.620973] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 340.32 Tue Aug 5 20:58:26 PDT 2014
[ 303.632166] vgaarb: this pci device is not a vga device
[ 303.633346] nvidia 0000:01:00.0: irq 54 for MSI/MSI-X
[ 303.646647] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 303.646790] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 303.646873] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 303.646950] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 303.647024] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 303.647098] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 303.647214] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 303.647290] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 309.149085] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 309.150859] NVRM: RmInitAdapter failed! (0x24:0x38:1170)
[ 309.150873] NVRM: rm_init_adapter failed for device bearing minor number 0
[ 309.150909] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5


/etc/bumblebee/bumblebee.conf


# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
# bbswitch - new in BB 3, recommended if available
# switcheroo - vga_switcheroo method, use at your own risk
# none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau


/etc/bumblebee/xorg.conf.nvidia


Section "ServerLayout"
Identifier "Layout0"
Option "AutoAddDevices" "false"
Option "AutoAddGPU" "false"
EndSection

Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:01:00:0"

# If the X server does not automatically detect your VGA device,
# you can manually set it here.
# To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
# as you see in the commented example.
# This Setting may be needed in some platforms with more than one
# nvidia card, which may confuse the proprietary driver (e.g.,
# trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
# BusID "PCI:01:00:0"

# Setting ProbeAllGpus to false prevents the new proprietary driver
# instance spawned to try to control the integrated graphics card,
# which is already being managed outside bumblebee.
# This option doesn't hurt and it is required on platforms running
# more than one nvidia graphics card with the proprietary driver.
# (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
# If this option is not set, the new Xorg may blacken the screen and
# render it unusable (unless you have some way to run killall Xorg).
Option "ProbeAllGpus" "false"

Option "NoLogo" "true"
Option "UseEDID" "false"
Option "UseDisplayDevice" "none"
EndSection


lspci | egrep 'VGA|3D'


00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation Device 0fe4 (rev a1)


modinfo nvidia

filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
alias: char-major-195-*
version: 340.32
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias: pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias: pci:v000010DEd*sv*sd*bc03sc02i00*
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
depends: drm,i2c-core
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
parm: NVreg_ModifyDeviceFiles:int
parm: NVreg_DeviceFileUID:int
parm: NVreg_DeviceFileGID:int
parm: NVreg_DeviceFileMode:int
parm: NVreg_RemapLimit:int
parm: NVreg_UpdateMemoryTypes:int
parm: NVreg_InitializeSystemMemoryAllocations:int
parm: NVreg_UsePageAttributeTable:int
parm: NVreg_MapRegistersEarly:int
parm: NVreg_RegisterForACPIEvents:int
parm: NVreg_CheckPCIConfigSpace:int
parm: NVreg_EnablePCIeGen3:int
parm: NVreg_EnableMSI:int
parm: NVreg_MemoryPoolSize:int
parm: NVreg_RegistryDwords:charp
parm: NVreg_RmMsg:charp
parm: NVreg_AssignGpus:charp

modinfo nvidia-uvm

filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko
supported: external
license: MIT
depends: nvidia
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions

echo $PATH

/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/VirtualGL/bin:/usr/local/cuda-6.5/bin


find 2> /dev/null / -name nvidia*.ko

/var/lib/dkms/nvidia/340.32/3.14-kali1-amd64/x86_64/module/nvidia.ko
/var/lib/dkms/nvidia/340.32/3.14-kali1-amd64/x86_64/module/nvidia-uvm.ko
/lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
/lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko

Rarity
2014-08-29, 20:05
One more thing.. I realized that if I edit /etc/bumblebee/xorg.conf.nvidia and don't run the /etc/init.d/bumblebee restart command after, optirun glxspherest64 works, but only once. Here's the optirun and dmesg after it works for the first time.

optirun glxspheres64

Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: GeForce GT 750M/PCIe/SSE2


dmesg

[ 1219.791269] vgaarb: this pci device is not a vga device
[ 1219.791988] nvidia 0000:01:00.0: irq 54 for MSI/MSI-X
[ 1219.801105] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 1219.801210] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 1219.801273] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 1219.801331] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 1219.801386] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 1219.801441] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 1219.801529] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 1219.801585] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 1219.802873] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 1220.019129] vgaarb: this pci device is not a vga device
[ 1265.335361] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 1265.345654] [drm] Module unloaded
[ 1265.347855] bbswitch: disabling discrete graphics
[ 1265.347873] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 1265.364199] pci 0000:01:00.0: Refused to change power state, currently in D0


Everything after the second "this pci device is not a vga device" ([ 1220.019129]) is after I close out of the glxsphere window.
Thanks for your help!

edit:

I had thought I read all of the posts before posting but it seems I may have missed one.

Using the solution tonrin (https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=36387&viewfull=1#post36387) posted worked for me too!

Still lots of errors in dmesg but deviceQuery results in a pass!

staticn0de
2014-09-06, 03:28
This section is dedicated to common issues users experience and will be updated as more errors are reported

ERROR: could not insert 'nvidia_uvm': No such device

If you are receiving this error, be sure to run dmesg and post the output on the forums. This is normally caused because the driver the driver can not identify the hardware or be loaded by the kernel. Try the latest version of the driver if you are using a more modern graphics card.

I restarted the computer and I have a blank screen / screen with a solid cursor in the corner

I told you not to run nvidia-xconfig, didn't I?. Boot into recovery mode or use a live USB. Mount your file system and delete the xrog configuration file generated that nvidia-xconfig created.

/etc/init.d/bumbelbeed status shows that it is not running and it fails to restart

If you did not install linux-headers-$(uname -r) at the start, bbswitch can not be built and as a result, you can not swap between drivers and bumblebee can't load. Install the headers and reinstall bbswitch-dkms

When I run 'optirun glxspheres64' my screen goes black and the fans run at full speed. During my ensuing heart attack, the computer turns off. What do i do? OR alternatively, optirun glxspheres64 fails the first time I run it but works every second time.

This is a problem across all distributions using bumblebee. However, it is an easy fix. You may also see errors like that below:


[ 3224.482379] [ERROR]Cannot access secondary GPU - error: X did not start properly

[ 3224.482467] [ERROR]Aborting because fallback start is disabled.

or


ERROR: Failed to initialize the NVIDIA GPU at PCI:1:0:0


To see if this fix will work for you before modifying grub, you can run the following:


sudo tee /sys/module/rcutree/parameters/rcu_idle_gp_delay <<<1

If that fixed it, edit /etc/default/grub and change:

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

To


GRUB_CMDLINE_LINUX_DEFAULT="quiet rcutree.rcu_idle_gp_delay=1"

and run 'update-grub' and restart.

staticn0de
2014-09-06, 04:32
For anyone interested, this guide will work with the newer CUDA 6.5 and NVIDIA 340.32 drivers.

Albeit, it's a bit slower. My pyrit benchmark has gone from ~11000 on CUDA 6.0 and NVIDIA 340.24 to ~7800 with the drivers mentioned above.

Quest
2014-09-09, 15:23
Thanks for the "common issues" guide and the new driver heads up... I wish I could say "can't stop progress", but that drop in performance is anything but. Sabotage might be a more appropriate term?

reintakura
2014-09-09, 23:45
Now, I know you want to see it in action so the next part will install pryit.

First, remove the wheezy repo. You may either comment out the line we added or delete it.
nano /etc/apt/sources.list
Save the file
apt-get update

The following instructions are slightly modified from the pyrit google code page here. Give them all your love.
https://code.google.com/p/pyrit/wiki/Installation

Moving to home directory as I'm installing there
cd ~

Checkout pyrit
svn checkout http://pyrit.googlecode.com/svn/trunk/ pyrit_svn

Install required libraries
apt-get install libpcap-dev

cd pyrit_svn/pyrit/
python setup.py build
python setup.py install

Now to add CUDA support
cd ../cpyrit_cuda/
python setup.py build
python setup.py install

Now, what we have been waiting for this entire time. Lets see it work.
optirun pyrit benchmark

And we are done.

Who had problem when issued command #python setup.py build and screen give output like this

root@kali:~/pyrit-0.4.0# python setup.py build
svn: '.' is not a working copy
running build
running build_py
creating build
creating build/lib.linux-x86_64-2.7
copying pyrit_cli.py -> build/lib.linux-x86_64-2.7
creating build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/__init__.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/cpyrit.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/util.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/pckttools.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/config.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/network.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/storage.py -> build/lib.linux-x86_64-2.7/cpyrit
running build_ext
building 'cpyrit._cpyrit_cpu' extension
creating build/temp.linux-x86_64-2.7
creating build/temp.linux-x86_64-2.7/cpyrit
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -I/usr/include/python2.7 -c cpyrit/_cpyrit_cpu.c -o build/temp.linux-x86_64-2.7/cpyrit/_cpyrit_cpu.o -Wall -fno-strict-aliasing -DVERSION="0.4.0"
cpyrit/_cpyrit_cpu.c:32:20: fatal error: Python.h: No such file or directory
compilation terminated.
error: command 'gcc' failed with exit status 1

Solution :

#apt-get install build-essential python-dev libssl-dev

and it should be works now

reintakura
2014-09-09, 23:48
Now, I know you want to see it in action so the next part will install pryit.

First, remove the wheezy repo. You may either comment out the line we added or delete it.
nano /etc/apt/sources.list
Save the file
apt-get update

The following instructions are slightly modified from the pyrit google code page here. Give them all your love.
https://code.google.com/p/pyrit/wiki/Installation

Moving to home directory as I'm installing there
cd ~

Checkout pyrit
svn checkout http://pyrit.googlecode.com/svn/trunk/ pyrit_svn

Install required libraries
apt-get install libpcap-dev

cd pyrit_svn/pyrit/
python setup.py build
python setup.py install

Now to add CUDA support
cd ../cpyrit_cuda/
python setup.py build
python setup.py install

Now, what we have been waiting for this entire time. Lets see it work.
optirun pyrit benchmark

And we are done.

Who had problem like me when issued command #phyton setup.py build , and your screen give output like this


root@kali:~/pyrit-0.4.0# python setup.py build
svn: '.' is not a working copy
running build
running build_py
creating build
creating build/lib.linux-x86_64-2.7
copying pyrit_cli.py -> build/lib.linux-x86_64-2.7
creating build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/__init__.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/cpyrit.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/util.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/pckttools.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/config.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/network.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/storage.py -> build/lib.linux-x86_64-2.7/cpyrit
running build_ext
building 'cpyrit._cpyrit_cpu' extension
creating build/temp.linux-x86_64-2.7
creating build/temp.linux-x86_64-2.7/cpyrit
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -I/usr/include/python2.7 -c cpyrit/_cpyrit_cpu.c -o build/temp.linux-x86_64-2.7/cpyrit/_cpyrit_cpu.o -Wall -fno-strict-aliasing -DVERSION="0.4.0"
cpyrit/_cpyrit_cpu.c:32:20: fatal error: Python.h: No such file or directory
compilation terminated.
error: command 'gcc' failed with exit status 1


this command should fix it

#apt-get install build-essential python-dev libssl-dev

reintakura
2014-09-10, 00:06
Now, I know you want to see it in action so the next part will install pryit.

First, remove the wheezy repo. You may either comment out the line we added or delete it.
nano /etc/apt/sources.list
Save the file
apt-get update

The following instructions are slightly modified from the pyrit google code page here. Give them all your love.
https://code.google.com/p/pyrit/wiki/Installation

Moving to home directory as I'm installing there
cd ~

Checkout pyrit
svn checkout http://pyrit.googlecode.com/svn/trunk/ pyrit_svn

Install required libraries
apt-get install libpcap-dev

cd pyrit_svn/pyrit/
python setup.py build
python setup.py install

Now to add CUDA support
cd ../cpyrit_cuda/
python setup.py build
python setup.py install

Now, what we have been waiting for this entire time. Lets see it work.
optirun pyrit benchmark

And we are done.

Who had problem like me when issued command #phyton setup.py build , and your screen give output like this


root@kali:~/pyrit-0.4.0# python setup.py build
svn: '.' is not a working copy
running build
running build_py
creating build
creating build/lib.linux-x86_64-2.7
copying pyrit_cli.py -> build/lib.linux-x86_64-2.7
creating build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/__init__.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/cpyrit.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/util.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/pckttools.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/config.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/network.py -> build/lib.linux-x86_64-2.7/cpyrit
copying cpyrit/storage.py -> build/lib.linux-x86_64-2.7/cpyrit
running build_ext
building 'cpyrit._cpyrit_cpu' extension
creating build/temp.linux-x86_64-2.7
creating build/temp.linux-x86_64-2.7/cpyrit
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -I/usr/include/python2.7 -c cpyrit/_cpyrit_cpu.c -o build/temp.linux-x86_64-2.7/cpyrit/_cpyrit_cpu.o -Wall -fno-strict-aliasing -DVERSION="0.4.0"
cpyrit/_cpyrit_cpu.c:32:20: fatal error: Python.h: No such file or directory
compilation terminated.
error: command 'gcc' failed with exit status 1


this command should fix it

#apt-get install build-essential python-dev libssl-dev

Quest
2014-09-12, 15:57
interesting Voodoo stuff..

I have to run
optirun pyrit benchmark right after booting into Kali for my nVidia to 'wakeup'.
If I wait more than 5mins after booting, no nVidia related operations work.


root@kali:~# optirun pyrit benchmark
[11828.399100] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[11828.399158] [ERROR]Aborting because fallback start is disabled.
root@kali:~#

It doesn't matter what I try. I have to restart the computer, then run optirun pyrit benchmark

Davide3i
2014-09-13, 14:26
Hi. :)
I've been trying to make Bumblebee work since yesterday, but with no luck.
QUOTING: "/etc/init.d/bumbelbeed status shows that it is not running and it fails to restart". I've exactly this problem, but I've installed linux-headers and bbswitch-dkms (and followed all the guide in post #25 until the instruction "/etc/init.d/bumblebeed restart
").

Any hint? I don't know which log I've to post here, so let me know.
Thank you all.

staticn0de
2014-09-14, 10:14
Hi. :)
I've been trying to make Bumblebee work since yesterday, but with no luck.
QUOTING: "/etc/init.d/bumbelbeed status shows that it is not running and it fails to restart". I've exactly this problem, but I've installed linux-headers and bbswitch-dkms (and followed all the guide in post #25 until the instruction "/etc/init.d/bumblebeed restart
").

Any hint? I don't know which log I've to post here, so let me know.
Thank you all.

Hey there,

This will most likely be something simple.

Post the output of:

use the
brackets to paste the output of commands (the code close bracket is a [*/CODE] without the *. Put all the text between them.

run optirun glxspheres64 and then paste the output of the command below. The last 30 lines or so.
[CODE]dmesg

Paste your /etc/bumblebee/bumblebee.conf

Paste your /etc/bumblebee/xorg.nvidia.conf

Paste the output of

lspci | egrep 'VGA|3D'

Paste the output of

modinfo nvidia

and


modinfo nvidia-uvm

and


lsmod

and


cat /proc/acpi/bbswitch

and


echo $PATH

Paste the output of

find 2> /dev/null / -name nvidia*.ko

I know it's a lot, but as you are a new user it saves the turn around for your posts to get on the forum.

also, try apt-get install linux-headers-$(uname -r) && apt-get install --reinstall bbswitch-dkms

Davide3i
2014-09-19, 07:13
After some more struggling, I've managed to make it work.
Thank you for your guide.

staticn0de
2014-09-19, 09:11
After some more struggling, I've managed to make it work.
Thank you for your guide.

You're most welcome. I'm glad it worked for you.

in10se
2014-09-25, 20:09
I need some help I have been trying to fix this for the longest finally got Bumblebee installed and ti run smoothly. The problem is when I get to the CUDA installation it does not ask me about Samples but instead during the instalation asks me only about the direcroty and if I want to create a symbolic file.


The next command will have no errors if all went well
modprobe nvidia-uvm //// I GET THIS WITH NO ERRORS ...

Now to make the CUDA samples and confirm it works! This make will take a little while... /// CANNOT FIND SAMPLES ANYWHERE. REINSTALLED CUDA AND NOTHING...
cd ~/NVIDIA_CUDA-5.5_Samples/NVIDIA_CUDA-5.5_Samples/
make


I unistalled by using purge nvidia-*
then uninstalled bumblebee
and started the process again ...

Everything goes fine but still cant get to install the samples I get the following

Driver: Not Selected
Toolkit: Installed in /usr/local/cuda-6.5
Samples: Not Supported


Thanks,

staticn0de
2014-09-26, 22:51
I need some help I have been trying to fix this for the longest finally got Bumblebee installed and ti run smoothly. The problem is when I get to the CUDA installation it does not ask me about Samples but instead during the instalation asks me only about the direcroty and if I want to create a symbolic file.


The next command will have no errors if all went well
modprobe nvidia-uvm //// I GET THIS WITH NO ERRORS ...

Now to make the CUDA samples and confirm it works! This make will take a little while... /// CANNOT FIND SAMPLES ANYWHERE. REINSTALLED CUDA AND NOTHING...
cd ~/NVIDIA_CUDA-5.5_Samples/NVIDIA_CUDA-5.5_Samples/
make


I unistalled by using purge nvidia-*
then uninstalled bumblebee
and started the process again ...

Everything goes fine but still cant get to install the samples I get the following

Driver: Not Selected
Toolkit: Installed in /usr/local/cuda-6.5
Samples: Not Supported


Thanks,

Hi there,

I see a couple of problems with your setup.

First:


The next command will have no errors if all went well
modprobe nvidia-uvm //// I GET THIS WITH NO ERRORS ...

Now to make the CUDA samples and confirm it works! This make will take a little while... /// CANNOT FIND SAMPLES ANYWHERE. REINSTALLED CUDA AND NOTHING...
cd ~/NVIDIA_CUDA-5.5_Samples/NVIDIA_CUDA-5.5_Samples/
make


You are following the first guide, not post 25 as recommended.

Second


Toolkit: Installed in /usr/local/cuda-6.5


You are installing the bleeding edge cuda 6.5 (which is not bad) but you have not altered the commands in the guide to suit the new directories.

Two guides are in this thread. The guide starting at post 2 will install CUDA 5.5 and the nvidia drivers from the wheezy repo.

The guide starting at post 25 (the one which should be followed) will install NVIDIA 340.24 and CUDA 6.

Follow the guide at post 25 and if you decide to mix and match versions and parts of guides, you will need to amend the commands entered to match.

warrenBufferzz
2014-10-06, 07:29
Thank you very much staticn0de for your time to make this post, everything went smooth and right now im all set up!! :)

and thanks to reintakura for that solution!

Filip0913
2014-10-15, 08:39
Hi,
I have the following problem: when I enter this last command
optirun glxspheres64, my screen goes totally black and my nvidia vgas start to run on full speed (vents go on full throttle) and after 20s my laptop shuts down. I suppose my hardware causes the peoblem, I have 3VGAs: the integrated intel hd4400, and 2 nvidia gt750M.
I know that this problem was mention here, but I did everything what staticn0de recomend, but nothing change.
dmesg has to long output. What you need exactly? I also erase comments from files for the same reason.

/etc/bumblebee/bumblebee.conf


[bumblebeed]
VirtualDisplay=:8
KeepUnusedXServer=false
ServerGroup=bumblebee
TurnCardOffAtExit=false
NoEcoModeOverride=false
Driver=nvidia
XorgConfDir=/etc/bumblebee/xorg.conf.d

[optirun]
Bridge=auto
VGLTransport=proxy
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
AllowFallbackToIGC=false

[driver-nvidia]
KernelDriver=nvidia
PMMethod=auto
LibraryPath=/usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
XorgModulePath=/usr/lib/nvidia,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau


/etc/bumblebee/xorg.conf.nvidia


Section "ServerLayout"
Identifier "Layout0"
Option "AutoAddDevices" "false"
Option "AutoAddGPU" "false"
EndSection

Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:01:00:0"
BusID "PCI:07:00:0"

Option "ProbeAllGpus" "false"

Option "NoLogo" "true"
Option "UseEDID" "false"
Option "UseDisplayDevice" "none"
Option "SLI" "AA"
EndSection


lspci | egrep 'VGA|3D'


root@kali:~# lspci | egrep 'VGA|3D'
01:00.0 VGA compatible controller: NVIDIA Corporation Device 0fe4 (rev a1)
07:00.0 3D controller: NVIDIA Corporation Device 0fe4 (rev a1)


modinfo nvidia


root@kali:~# modinfo nvidia
filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
alias: char-major-195-*
version: 340.46
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias: pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias: pci:v000010DEd*sv*sd*bc03sc02i00*
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
depends: drm,i2c-core
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
parm: NVreg_ModifyDeviceFiles:int
parm: NVreg_DeviceFileUID:int
parm: NVreg_DeviceFileGID:int
parm: NVreg_DeviceFileMode:int
parm: NVreg_RemapLimit:int
parm: NVreg_UpdateMemoryTypes:int
parm: NVreg_InitializeSystemMemoryAllocations:int
parm: NVreg_UsePageAttributeTable:int
parm: NVreg_MapRegistersEarly:int
parm: NVreg_RegisterForACPIEvents:int
parm: NVreg_CheckPCIConfigSpace:int
parm: NVreg_EnablePCIeGen3:int
parm: NVreg_EnableMSI:int
parm: NVreg_MemoryPoolSize:int
parm: NVreg_RegistryDwords:charp
parm: NVreg_RmMsg:charp
parm: NVreg_AssignGpus:charp


modinfo nvidia-uvm


root@kali:~# modinfo nvidia-uvm
filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko
supported: external
license: MIT
depends: nvidia
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions


lsmod


root@kali:~# lsmod
Module Size Used by
nls_utf8 12456 1
nls_cp437 16553 1
vfat 17185 1
fat 57965 1 vfat
nouveau 1053347 0
ttm 69667 1 nouveau
drm_kms_helper 39998 1 nouveau
drm 240557 3 ttm,drm_kms_helper,nouveau
i2c_algo_bit 12751 1 nouveau
nfnetlink_log 17241 0
nfnetlink 12989 1 nfnetlink_log
binfmt_misc 16949 1
loop 26605 0
dm_crypt 22731 0
snd_hda_codec_hdmi 45004 1
arc4 12543 2
iwldvm 130998 0
mac80211 488308 1 iwldvm
snd_hda_codec_realtek 54360 1
snd_hda_codec_generic 59079 1 snd_hda_codec_realtek
uvcvideo 78910 0
iTCO_wdt 12831 0
videobuf2_vmalloc 12816 1 uvcvideo
iTCO_vendor_support 12649 1 iTCO_wdt
videobuf2_memops 12519 1 videobuf2_vmalloc
videobuf2_core 35348 1 uvcvideo
videodev 122088 2 uvcvideo,videobuf2_core
usb_storage 52037 1
media 18303 2 uvcvideo,videodev
joydev 17108 0
x86_pkg_temp_thermal 12965 0
intel_powerclamp 17159 0
coretemp 12854 0
kvm_intel 138949 0
mxm_wmi 12515 1 nouveau
kvm 404503 1 kvm_intel
snd_hda_intel 39656 5
iwlwifi 87784 1 iwldvm
btusb 25619 0
snd_hda_codec 99921 4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_c odec_generic,snd_hda_intel
bluetooth 243618 2 btusb
psmouse 86464 0
snd_hwdep 13148 1 snd_hda_codec
ideapad_laptop 17499 0
sparse_keymap 12760 1 ideapad_laptop
cfg80211 436618 3 iwlwifi,mac80211,iwldvm
6lowpan_iphc 16588 1 bluetooth
snd_pcm 88538 3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
serio_raw 12849 0
lpc_ich 20768 0
snd_timer 26606 1 snd_pcm
i2c_i801 16963 0
mfd_core 12601 1 lpc_ich
evdev 17489 9
snd 61039 18 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_ codec_hdmi,snd_pcm,snd_hda_codec_generic,snd_hda_c odec,snd_hda_intel
i2c_core 24265 6 drm,i2c_i801,drm_kms_helper,i2c_algo_bit,nouveau,v ideodev
mei_me 13446 0
rfkill 18902 4 cfg80211,ideapad_laptop,bluetooth
soundcore 13026 1 snd
mei 50039 1 mei_me
ac 12678 0
battery 13101 0
wmi 17339 2 mxm_wmi,nouveau
video 17804 1 nouveau
processor 28221 0
button 12944 1 nouveau
ext4 489943 1
crc16 12343 2 ext4,bluetooth
mbcache 13082 1 ext4
jbd2 86788 1 ext4
dm_mod 89276 1 dm_crypt
hid_generic 12393 0
usbhid 44481 0
hid 94062 2 hid_generic,usbhid
sg 30043 0
sd_mod 44346 5
crc_t10dif 12431 1 sd_mod
crct10dif_pclmul 13348 1
crct10dif_common 12356 2 crct10dif_pclmul,crc_t10dif
crc32_pclmul 12915 0
crc32c_intel 21809 0
ghash_clmulni_intel 12978 0
aesni_intel 151423 0
aes_x86_64 16719 1 aesni_intel
lrw 12757 1 aesni_intel
gf128mul 12970 1 lrw
glue_helper 12690 1 aesni_intel
ablk_helper 12572 1 aesni_intel
cryptd 14560 3 ghash_clmulni_intel,aesni_intel,ablk_helper
xhci_hcd 111830 0
ahci 29195 2
libahci 27103 1 ahci
alx 36175 0
mdio 12599 1 alx
ehci_pci 12472 0
ehci_hcd 48517 1 ehci_pci
libata 169163 2 ahci,libahci
scsi_mod 186841 4 sg,usb_storage,libata,sd_mod
usbcore 166472 8 btusb,uvcvideo,usb_storage,ehci_hcd,ehci_pci,usbhi d,xhci_hcd
usb_common 12440 1 usbcore
thermal 17468 0
thermal_sys 27685 5 video,intel_powerclamp,thermal,processor,x86_pkg_t emp_thermal


cat /proc/acpi/bbswitch


root@kali:~# cat /proc/acpi/bbswitch
cat: /proc/acpi/bbswitch: No such file or directory


echo $PATH


root@kali:~# echo $PATH
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/VirtualGL/bin


find 2> /dev/null / -name nvidia*.ko


root@kali:~# find 2> /dev/null / -name nvidia*.ko
/var/lib/dkms/nvidia/340.46/3.14-kali1-amd64/x86_64/module/nvidia.ko
/var/lib/dkms/nvidia/340.46/3.14-kali1-amd64/x86_64/module/nvidia-uvm.ko
/lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
/lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko


Thak you for help

Filip0913
2014-10-15, 08:45
Sorry, now the output is


root@kali:~# optirun glxspheres64
[ 3199.014506] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!

[ 3199.014616] [ERROR]Aborting because fallback start is disabled.

nikkipolya
2014-11-06, 09:19
I followed all the steps given by staticn0de in Post 25. After installing the NVIDIA drivers, I rebooted my machine. And X does not start anymore. If I change the Driver to intel and comment out the BusID "PCI:01:00:0" line, then X starts. I have an intel HD4000 along with NVidia 720M in my laptop (ASUS X550CC).

My Xorg.0.log give me the following:



Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.1.log" for additional information.


What could be wrong?

EDIT:
I found that the nvidia module was not loaded. I did a modprobe to load nvidia_uvm. Also, I removed the the xorg.conf file from /etc/X11/xorg.conf. It seems like I have made some progress but I have a different situation now. NVidia graphics does not seem to be working:



root@kali:~# grep EE /var/log/Xorg.0.log.old
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 58.071] (II) Loading extension MIT-SCREEN-SAVER
[ 58.179] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[ 58.180] (EE) NVIDIA(0): log file that the GLX module has been loaded in your X
[ 58.180] (EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
[ 58.180] (EE) NVIDIA(0): you continue to encounter problems, Please try
[ 58.180] (EE) NVIDIA(0): reinstalling the NVIDIA driver.
[ 63.816] (EE) NVIDIA(0): Failed to initiate mode change.
[ 63.817] (EE) NVIDIA(0): Failed to complete mode change
[ 103.649] (EE) NVIDIA(0): Failed to initiate mode change.
[ 103.649] (EE) NVIDIA(0): Failed to complete mode change
[ 112.896] (EE) NVIDIA(0): Failed to initiate mode change.
[ 112.896] (EE) NVIDIA(0): Failed to complete mode change
[ 119.568] (EE) NVIDIA(0): Failed to initiate mode change.
[ 119.569] (EE) NVIDIA(0): Failed to complete mode change
[ 1301.003] (EE) NVIDIA(0): Failed to initiate mode change.
[ 1301.003] (EE) NVIDIA(0): Failed to complete mode change
[ 1307.356] (EE) NVIDIA(0): Failed to initiate mode change.
[ 1307.356] (EE) NVIDIA(0): Failed to complete mode change




root@kali:~# glxspheres64
Polygons in scene: 62464
Visual ID of window: 0x95
Context is Direct
OpenGL Renderer: Mesa DRI Intel(R) Ivybridge Mobile
60.561352 frames/sec - 50.915140 Mpixels/sec
60.224465 frames/sec - 50.631912 Mpixels/sec
60.468060 frames/sec - 50.836707 Mpixels/sec

root@kali:~# optirun glxspheres64
Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: Gallium 0.4 on llvmpipe (LLVM 0x209)
10.274823 frames/sec - 8.638249 Mpixels/sec
10.256073 frames/sec - 8.622486 Mpixels/sec
10.965270 frames/sec - 9.218722 Mpixels/sec
9.337846 frames/sec - 7.850514 Mpixels/sec
9.863799 frames/sec - 8.292693 Mpixels/sec

root@kali:~# dmesg|grep -i bbsw
[ 16.506061] bbswitch: version 0.8
[ 16.506085] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[ 16.506096] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[ 16.506434] bbswitch: detected an Optimus _DSM function
[ 16.506653] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on
[ 16.512184] bbswitch: disabling discrete graphics
root@kali:~#




root@kali:~# optirun -vv glxspheres64
[ 195.766002] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 195.766908] [INFO]Configured driver: nvidia
[ 195.767264] [DEBUG]optirun version 3.2.1 starting...
[ 195.767307] [DEBUG]Active configuration:
[ 195.767329] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 195.767350] [DEBUG] X display: :8
[ 195.767373] [DEBUG] LD_LIBRARY_PATH: /usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
[ 195.767393] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 195.767413] [DEBUG] Accel/display bridge: auto
[ 195.767433] [DEBUG] VGL Compression: proxy
[ 195.767452] [DEBUG] VGLrun extra options:
[ 195.767477] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
[ 195.767633] [DEBUG]Using auto-detected bridge virtualgl
[ 203.267664] [INFO]Response: Yes. X is active.

[ 203.267701] [INFO]Running application using virtualgl.
[ 203.267911] [DEBUG]Process vglrun started, PID 4424.
Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: Gallium 0.4 on llvmpipe (LLVM 0x209)
12.681075 frames/sec - 10.661233 Mpixels/sec
10.998630 frames/sec - 9.246768 Mpixels/sec
10.563611 frames/sec - 8.881039 Mpixels/sec
11.111996 frames/sec - 9.342077 Mpixels/sec
[ 212.685700] [DEBUG]SIGCHILD received, but wait failed with No child processes
[ 212.685776] [DEBUG]Socket closed.
[ 212.685814] [DEBUG]Killing all remaining processes.
root@kali:~#


What could be going wrong? Any help would be appreciated. Thanks in advance!!

nikkipolya
2014-11-08, 07:45
I followed Post 25 to download and install the nvidia-drivers from nvidia's website. Now, each time I run 'apt-get install' to install something, apt-get asks me to run 'nvidia-installer --uninstall'. Do you folks also face the same issue? I have commented out the wheezy-backport from sources.list but still the problem persists.



│ │
│ The nvidia-installer program was found on this system. This is probably left over from an earlier installation of the non-free │
│ NVIDIA graphics driver, installed using the NVIDIA *.run file directly. This installation is incompatible with the Debian │
│ packages. To install the Debian packages safely, it is therefore necessary to undo the changes performed by nvidia-installer. │
│ │
│ Run "nvidia-installer --uninstall"?
│ <Yes> <No> │

nikkipolya
2014-11-08, 09:48
Ok, I've solved the 'nvidia-installer --uninstall' problem. There was the nvidia-installer-cleanup package in 'iF' status. Doing the following solved the problem:


apt-get purge nvidia-installer-cleanup

nikkipolya
2014-11-08, 16:52
Hi static0node,

Here's my configuration:



root@kali:~# cat /etc/bumblebee/bumblebee.conf
# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
# bbswitch - new in BB 3, recommended if available
# switcheroo - vga_switcheroo method, use at your own risk
# none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

root@kali:~#

And strangely, none of the colon separated directories in my 'LibraryPath' exist!


root@kali:~# cd /usr/lib/x86_64-linux-gnu/nvidia
bash: cd: /usr/lib/x86_64-linux-gnu/nvidia: No such file or directory
root@kali:~# cd /usr/lib/i386-linux-gnu/nvidia
bash: cd: /usr/lib/i386-linux-gnu/nvidia: No such file or directory
root@kali:~# cd /usr/lib/nvidia
bash: cd: /usr/lib/nvidia: No such file or directory
root@kali:~#



I see that nVidia libraries are in /usr/lib. If I include that in my LibraryPath, then optirun glxgears dumps.


/usr/lib/libkwinnvidiahack.so.4
/usr/lib/libkwinnvidiahack.so.4.8.0
/usr/lib/libnvidia-cfg.so
/usr/lib/libnvidia-cfg.so.1
/usr/lib/libnvidia-cfg.so.340.46
/usr/lib/libnvidia-compiler.so.340.46
/usr/lib/libnvidia-eglcore.so.340.46
/usr/lib/libnvidia-encode.so
/usr/lib/libnvidia-encode.so.1
/usr/lib/libnvidia-encode.so.340.46
/usr/lib/libnvidia-fbc.so
/usr/lib/libnvidia-fbc.so.1
/usr/lib/libnvidia-fbc.so.340.46
/usr/lib/libnvidia-glcore.so.340.46
/usr/lib/libnvidia-glsi.so.340.46
/usr/lib/libnvidia-ifr.so
/usr/lib/libnvidia-ifr.so.1



root@kali:~# optirun -vv glxgears
[22184.002479] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[22184.003239] [INFO]Configured driver: nvidia
[22184.003544] [DEBUG]optirun version 3.2.1 starting...
[22184.003587] [DEBUG]Active configuration:
[22184.003621] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[22184.003658] [DEBUG] X display: :8
[22184.003692] [DEBUG] LD_LIBRARY_PATH: /usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia:/usr/lib
[22184.003729] [DEBUG] Socket path: /var/run/bumblebee.socket
[22184.003762] [DEBUG] Accel/display bridge: auto
[22184.003797] [DEBUG] VGL Compression: proxy
[22184.003829] [DEBUG] VGLrun extra options:
[22184.003863] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
[22184.003969] [DEBUG]Using auto-detected bridge virtualgl
[22191.468977] [INFO]Response: Yes. X is active.

[22191.469014] [INFO]Running application using virtualgl.
[22191.469293] [DEBUG]Process vglrun started, PID 5223.
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 137 (NV-GLX)
Minor opcode of failed request: 4 ()
Resource id in failed request: 0x200002
Serial number of failed request: 38
Current serial number in output stream: 38
[22191.630283] [DEBUG]SIGCHILD received, but wait failed with No child processes
[22191.630313] [DEBUG]Socket closed.
[22191.630332] [DEBUG]Killing all remaining processes.
root@kali:~# optirun -b primus -vv glxgears
[22199.144120] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[22199.144849] [INFO]Configured driver: nvidia
[22199.145104] [DEBUG]optirun version 3.2.1 starting...
[22199.145143] [DEBUG]Active configuration:
[22199.145164] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[22199.145184] [DEBUG] X display: :8
[22199.145205] [DEBUG] LD_LIBRARY_PATH: /usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia:/usr/lib
[22199.145226] [DEBUG] Socket path: /var/run/bumblebee.socket
[22199.145247] [DEBUG] Accel/display bridge: primus
[22199.145268] [DEBUG] VGL Compression: proxy
[22199.145292] [DEBUG] VGLrun extra options:
[22199.145311] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
[22207.331180] [INFO]Response: Yes. X is active.

[22207.331221] [INFO]Running application using primus.
[22207.331496] [DEBUG]Process glxgears started, PID 5250.
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 137 (NV-GLX)
Minor opcode of failed request: 4 ()
Resource id in failed request: 0x200002
Serial number of failed request: 38
Current serial number in output stream: 38
[22207.434966] [DEBUG]SIGCHILD received, but wait failed with No child processes
[22207.434987] [DEBUG]Socket closed.
[22207.435001] [DEBUG]Killing all remaining processes.
root@kali:~#

nikkipolya
2014-11-09, 05:20
I think I have a better bumblebee.conf file now. I now have a different error, after doing the following:


root@kali:~# mkdir -p /usr/lib/nvidia
root@kali:~# mv /usr/lib/libGL* /usr/lib/nvidia
root@kali:~# cat /etc/bumblebee/bumblebee.conf
# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
# bbswitch - new in BB 3, recommended if available
# switcheroo - vga_switcheroo method, use at your own risk
# none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
# XorgModulePath=/usr/lib/nvidia,/usr/lib/xorg/modules
XorgModulePath=/usr/lib/xorg/modules/drivers,/usr/lib/xorg/modules/extensions
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau




root@kali:~# optirun glxspheres64
[ 3856.451352] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[ 3856.451431] [ERROR]Aborting because fallback start is disabled.
root@kali:~#

nikkipolya
2014-11-10, 16:29
Great! Everything works fine now. I am able to run both with my integrated intel graphics and nvidia graphics. My CUDA tests PASS too!! Thanks to all of you, and most importantly to static0node for the excellent howto.

In case somebody faces the same problem as I did, here's what I did:

bumblebee's log at /var/log/Xorg.8.log gave me all the info I needed to correct my problems. Alternatively, you can stop bumblebee with '/etc/init.d/bumblebee stop' command. Then you can manually launch the daemon by issuing 'bumblebeed -vv' from a console. Note: that is two consecutive 'v's.

I figured out from the log file that the Xorg server for my nvidia card was using the libglx.so library built by "X.org Foundation" and not the one supplied by NVIDIA. The one supplied by NVIDIA was located in '/usr/lib/xorg/modules/extensions' and was named as 'libglx.so.340.46'. I made a backup of my libglx.so in that directory and renamed libglx.so.340.46 to libglx.so. And tried to relaunch bumblebee, and lo and behold, it all worked like a charm. But when I restarted my X server, my intel glx stopped working. Predictably. Long story short, here is what I effectively did:



root@kali:~# cd /usr/lib/xorg
root@kali:/usr/lib/xorg# mkdir -p nvidia
root@kali:/usr/lib/xorg# cp -R modules/* nvidia/
root@kali:/usr/lib/xorg# cd nvidia/extensions/
root@kali:/usr/lib/xorg/nvidia/extensions# mv libglx.so.340.46 libglx.so


And here's my bumblebee.conf


root@kali:~# cat /etc/bumblebee/bumblebee.conf
# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
# bbswitch - new in BB 3, recommended if available
# switcheroo - vga_switcheroo method, use at your own risk
# none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
KernelDriver=nvidia
PMMethod=auto
# colon-separated path to the nvidia libraries
LibraryPath=/usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia

# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/xorg/nvidia/drivers,/usr/lib/xorg/nvidia
# XorgModulePath=
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

root@kali:~#



That was it. Every thing work fine now! Both OpenGL and CUDA apps use my nvidia 720m card.



root@kali:/opt/cuda/NVIDIA_CUDA-6.0_Samples/bin/x86_64/linux/release# optirun ./deviceQuery
./deviceQuery Starting...

CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: "GeForce GT 720M"
CUDA Driver Version / Runtime Version 6.5 / 6.0
CUDA Capability Major/Minor version number: 3.5
Total amount of global memory: 2048 MBytes (2147352576 bytes)
( 1) Multiprocessors, (192) CUDA Cores/MP: 192 CUDA Cores
GPU Clock rate: 758 MHz (0.76 GHz)
Memory Clock rate: 800 Mhz
Memory Bus Width: 64-bit
L2 Cache Size: 524288 bytes
Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096)
Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers
Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total number of registers available per block: 65536
Warp size: 32
Maximum number of threads per multiprocessor: 2048
Maximum number of threads per block: 1024
Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535)
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Concurrent copy and kernel execution: Yes with 1 copy engine(s)
Run time limit on kernels: Yes
Integrated GPU sharing Host Memory: No
Support host page-locked memory mapping: Yes
Alignment requirement for Surfaces: Yes
Device has ECC support: Disabled
Device supports Unified Addressing (UVA): Yes
Device PCI Bus ID / PCI location ID: 1 / 0
Compute Mode:
< Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 6.5, CUDA Runtime Version = 6.0, NumDevs = 1, Device0 = GeForce GT 720M
Result = PASS


My laptop is an ASUS X550CC with ETPS/2 Elantech Touchpad. My CUDA driver and run-time don't match. I will try upgrading to CUDA 6.5 and see what happens later on.



root@kali:~# optirun glxspheres64
Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: GeForce GT 720M/PCIe/SSE2
126.708808 frames/sec - 123.235973 Mpixels/sec
126.436952 frames/sec - 122.971568 Mpixels/sec
125.862084 frames/sec - 122.412456 Mpixels/sec
128.373977 frames/sec - 124.855503 Mpixels/sec
126.762602 frames/sec - 123.288292 Mpixels/sec
128.711295 frames/sec - 125.183576 Mpixels/sec
root@kali:~#

nikkipolya
2014-11-12, 18:00
Hi Filip0913,

launch optirun -vv glxspheres64 and then paste here the output from /var/log/Xorg.8.log (assuming a new instance of X launches on tty 8)




optirun -vv glxspheres64




cat /var/log/Xorg.8.log

bahha
2014-11-17, 21:20
Thank you . your thread helped me a lot.
I had done it successfully before without cuda only I could run apps with optirun. after a re-installation of kali I followed your post and here are the result : deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 6.5, CUDA Runtime Version = 6.5, NumDevs = 1, Device0 = GeForce GT 740M
Result = PASS

rego
2014-11-23, 22:28
Hi,
i have the following problem:

i followed the guide and i arrived at the step in which i have to edit xorg.conf.nvidia


Edit xorg.conf.nvidia and add a line under the 'Section "Device"' area so that is matches what is shown below. Change the bus ID to match what you recorded previously and take note that you recored a . before the last number and it is now a ':'. You need the ':'.
Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:03:00:0"

i don't have that file (is it supposed to be in /etc/X11 ? ) so i could create it and the only content would be that in quote tag.. is that correct?

Quest
2014-11-24, 14:22
open a console >
nano /etc/bumblebee/xorg.conf.nvidia

bahha
2014-11-25, 15:47
I'm having a strange issue.
first as I stated before in a reply everything worked well. I even proceeded and tried pyrit and cudahashcat on a wpa2 handshake it worked well I successfully cracked my own wpa2 password with both methods.
got a problem then i fixed it with grub . I got another one with nvidia-uvm so I compiled it and replaced it in dkms/ .

now when I restart and run modprobe nvidia or modprobe nvidia-uvm I get no such device. so I checked the Cuda devicequery test to see if still passes which it did , suddenly the modprobe worked again
I restarted the same thing happened it only works after I do the cuda test . I checked my paths in bashrc everything is right in it. what could be the problem ?

Quest
2014-11-25, 16:45
- can you copy/paste the error message here.

- run
optirun pyrit benchmarkright after having booted on to Kali(don't wait too long after having booted, or it might not work).

bahha
2014-11-25, 19:42
here is my pyrit benchmark and cores


# optirun pyrit list_cores

Pyrit 0.4.0 (C) 2008-2011 Lukas Lueg http://pyrit.googlecode.com
This code is distributed under the GNU General Public License v3+

The following cores seem available...
#1: 'CPU-Core (SSE2)'
#2: 'CPU-Core (SSE2)'
#3: 'CPU-Core (SSE2)'
#4: 'CPU-Core (SSE2)'
#5: 'CPU-Core (SSE2)'
#6: 'CPU-Core (SSE2)'
#7: 'CPU-Core (SSE2)'
#8: 'CPU-Core (SSE2)
It's clear No GPU is detected even if i used optirun

optirun pyrit benchmark
Pyrit 0.4.0 (C) 2008-2011 Lukas Lueg http://pyrit.googlecode.com
This code is distributed under the GNU General Public License v3+

Running benchmark (2922.3 PMKs/s)... /

Computed 2922.27 PMKs/s total.
#1: 'CPU-Core (SSE2)': 389.2 PMKs/s (RTT 3.3)
#2: 'CPU-Core (SSE2)': 384.7 PMKs/s (RTT 3.3)
#3: 'CPU-Core (SSE2)': 402.0 PMKs/s (RTT 3.3)
#4: 'CPU-Core (SSE2)': 394.1 PMKs/s (RTT 3.3)
#5: 'CPU-Core (SSE2)': 401.3 PMKs/s (RTT 3.2)
#6: 'CPU-Core (SSE2)': 395.2 PMKs/s (RTT 3.3)
#7: 'CPU-Core (SSE2)': 401.6 PMKs/s (RTT 3.2)
#8: 'CPU-Core (SSE2)': 395.8 PMKs/s (RTT 3.3)

no GPU .

But for cudahashcat it detects GPU
here is MD5 test


Speed.GPU.#1.: 1875.2 MH/s

Hashtype: MD5
Workload: 1024 loops, 256 accel

I'm using pyrit that comes preinstalled with Kali 1.0.9 I checked it's the same version that exist in the dev site
to load the modules i created an alias to run the cuda test pass everytime i restart .

rego
2014-11-25, 22:22
i followed the guide at post #25 and then i installed pyrit but when i try to benchmark i get:


[12953.257431] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please

[12953.257532] [ERROR]Aborting because fallback start is disabled.

Quest
2014-11-26, 12:54
@ bahha & rego, the only thing I can recommend is to try a fresh Kali install until staticn0de returns.

This whole installation is somewhat fragile and any subsequent modification to core files seems to mess things up. I wish to be more precise but all I know is that I have to run 'optirun pyrit benchmark' in the following minutes after booting into Kali to be able to use cudaHashcat, or else I get the same error as the above post #116, and I have to reboot.

bahha
2014-11-26, 13:53
@ Quest I did install everything after a fresh install of the Os .
everything is working except pyrit I'll try to compile it from source and see .
having to run optirun after moments of boot . I think I may make it as a start up application. so far for cuda test pass I made an alias in bashrc .

Quest
2014-11-26, 14:09
but wait, mine is exactly like yours in post #115. No mention of GPU, ever.

Your telling me that Pyrit is supposed to detect and use GPU along with CPUs? If that's the case then mine never worked.

Quest
2014-11-26, 14:20
opps actually Pyrit does detect/use my GPU..


root@kali:~# optirun pyrit benchmark
Pyrit 0.4.1-dev (svn r308) (C) 2008-2011 Lukas Lueg http://pyrit.googlecode.com
This code is distributed under the GNU General Public License v3+

Running benchmark (9002.1 PMKs/s)... -

Computed 9002.07 PMKs/s total.
#1: 'CUDA-Device #1 'GeForce GT 630M'': 5761.6 PMKs/s (RTT 2.8)
#2: 'CPU-Core (SSE2/AES)': 520.8 PMKs/s (RTT 3.0)
#3: 'CPU-Core (SSE2/AES)': 521.7 PMKs/s (RTT 3.0)
#4: 'CPU-Core (SSE2/AES)': 523.7 PMKs/s (RTT 3.0)
#5: 'CPU-Core (SSE2/AES)': 523.5 PMKs/s (RTT 3.0)
#6: 'CPU-Core (SSE2/AES)': 518.2 PMKs/s (RTT 3.0)
#7: 'CPU-Core (SSE2/AES)': 523.5 PMKs/s (RTT 3.0)
#8: 'CPU-Core (SSE2/AES)': 507.0 PMKs/s (RTT 3.0)
root@kali:~#

bahha
2014-11-26, 14:23
@ Quest yes it should show your GPU

I removed the pre-installed pyrit and installed it from source following the guide on the first page .

and it works finally


here is the output of benchmark before installing it from source, notice how there is no GPU in the list and look at the second output



optirun pyrit benchmark
Pyrit 0.4.0 (C) 2008-2011 Lukas Lueg http://pyrit.googlecode.com
This code is distributed under the GNU General Public License v3+

Running benchmark (2922.3 PMKs/s)... /

Computed 2922.27 PMKs/s total.
#1: 'CPU-Core (SSE2)': 389.2 PMKs/s (RTT 3.3)
#2: 'CPU-Core (SSE2)': 384.7 PMKs/s (RTT 3.3)
#3: 'CPU-Core (SSE2)': 402.0 PMKs/s (RTT 3.3)
#4: 'CPU-Core (SSE2)': 394.1 PMKs/s (RTT 3.3)
#5: 'CPU-Core (SSE2)': 401.3 PMKs/s (RTT 3.2)
#6: 'CPU-Core (SSE2)': 395.2 PMKs/s (RTT 3.3)
#7: 'CPU-Core (SSE2)': 401.6 PMKs/s (RTT 3.2)
#8: 'CPU-Core (SSE2)': 395.8 PMKs/s (RTT 3.3)

here is the output after installing it from source .


Computed 9013.16 PMKs/s total.
#1: 'CUDA-Device #1 'GeForce GT 740M'': 7018.6 PMKs/s (RTT 2.8)
#2: 'CPU-Core (SSE2/AES)': 408.2 PMKs/s (RTT 3.2)
#3: 'CPU-Core (SSE2/AES)': 409.0 PMKs/s (RTT 3.3)
#4: 'CPU-Core (SSE2/AES)': 411.4 PMKs/s (RTT 3.3)
#5: 'CPU-Core (SSE2/AES)': 413.1 PMKs/s (RTT 3.3)
#6: 'CPU-Core (SSE2/AES)': 413.3 PMKs/s (RTT 3.2)
#7: 'CPU-Core (SSE2/AES)': 410.9 PMKs/s (RTT 3.3)
#8: 'CPU-Core (SSE2/AES)': 412.8 PMKs/s (RTT 3.3)


look at the deference between computed PMKs/s in both outputs !

Quest
2014-11-26, 14:32
wow great!

I thought for you to install Pyrit like the guide said, because this whole installation is very tricky/complex, and if one does not follow the exact procedure then it does not work, or it partially does.

*Funny how Pyrit does not use the 8th core when it use the GPU... Anyway.

bahha
2014-11-26, 14:52
i followed the guide at post #25 and then i installed pyrit but when i try to benchmark i get:

that happened to me . I fixed it with by modifying grub

here is the guide post link (https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=36923&viewfull=1#post36923)

bahha
2014-12-09, 14:26
After I installed the nvidia proprietary driver from this post (https://forums.kali.org/showthread.php?21956-%28Guide%29-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=35420&viewfull=1#post35420) with cuda6

I found that the INTEL driver is broken and some apps need it for 3D acceleration like GDM3 or anything that can't run with optirun

so here is a fix I did after reading and searching in other places .


first : to check if your INTEL driver is broken run this command without optirun


glxgears

if it works you are good nothing to do after this if not follow next instruction


--- remove the invidia driver if you installed it from NVIDIAxxx*.run that is the one you downloaded from nvidia site.

--- remove it with nividia-intaller-cleanup just intall it and it'll prompt you to remove the driver.

--- then follow the first post (https://forums.kali.org/showthread.php?21956-%28Guide%29-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops) to install the driver from repository which is 331-xx version. don't forget to change bumblebee and xorg as mentioned in the first post, for the repo driver to work. | the first post is changed it doesn't have the repo driver anymore .| so install it by apt-get intall nvidia-glx and apt-get install nvidia alternative
it will grab everything else . or google how to install nvidia driver 331 would be better.
--- at this point you have the nvidia driver functioning with optirun but if you have cuda6-5 it won't function because it requires a higher version of driver 340.xx. at least that's what happened to me

--- to fix it remove cuda6-5 by entering the folder where you installed the NVIDIA Cuda samples, probably you installed it in root folder. then run


make clean

--- remove the samples folder

--- go to /usr/local/ and delete cudaxx and its symlink .

--- you can still use cuda6-5 if you upgrade the driver follow last lines in this post

--- if you are ok with cuda5 download cuda5.xx and install it follow the firt page (https://forums.kali.org/showthread.php?21956-%28Guide%29-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops) in this thread .

--- if you have the intel mesa driver broken still then do the next

--- download mesa-alternative-glx I often use synaptic to install my packages else apt-get from terminal .

--- when it's installed run


update-alternative --config glx

--- when you have both nvidia and intel drivers installed it will display three options

auto (with the selected driver)
manual nvidia
manual intel

--- enter the number in the far left that correspond to intel and hit Enter
--- now it will fix your intel driver. reboot and try glxgears and optirun glxgears it should work, works for me :)

--- finally if you still want to use cuda6-5 update the nvidia driver

--- *add this repo to your source.list
deb http://http.us.debian.org/debian/ sid main non-free contrib .

--- run apt-get update when done open synaptic and upgrade the nvidia driver and reboot

--- now you can install cuda6-5 again following this post (https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=35420&viewfull=1#post35420)

. don't forget to remove the repo you added to your source.list, before you break something

I hope someone will find this useful it works for me
here is glxgears with intel and nvidia notice fps and compare it with nvidia one .


glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
300 frames in 5.0 seconds = 59.828 FPS
300 frames in 5.0 seconds = 59.807 FPS

with optirun

optirun glxgears
4139 frames in 5.0 seconds = 827.670 FPS
4114 frames in 5.0 seconds = 822.686 FPS

Quest
2014-12-09, 16:30
good stuff! Thanks bahha.

My fan does not decelerate after running "optirun pyrit benchmark". I have to reboot the computer for it to normalize. So something(probly my nVidia HD 630M) stays ON long after finishing operations when should be OFF. If anyone has any ideas...

I'm suspecting Bumblebee

bahha
2014-12-10, 16:44
you can try
echo OFF >> /proc/acpi/bbswitch

then see if it works with

cat /proc/acpi/bbswitch
if says OFF then it's OFF otherwise it's refusing to unload it, because it's being used by the nvidia module
you can try to reinstall bbswitch and bumblebee

darkshadowman
2014-12-11, 09:52
Till today all working perfect!!After updating xserver-xorg-core to 2:1.12.4-6+deb7u5 now when i run "optirun glxspheres64" gives the error :

Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 137 (NV-GLX)
Minor opcode of failed request: 4 ()
Resource id in failed request: 0x200002
Serial number of failed request: 38
Current serial number in output stream: 38

if i run any other program eg "optirun pyrit" its working fine.
Any help would be appreciated.
Im using kali 1.09 3.14-kali1-amd64

Quest
2014-12-11, 10:38
Useful to know these commands, but it didn't work for me..


root@kali:~# cat /proc/acpi/bbswitch
0000:01:00.0 ON
root@kali:~# echo OFF >> /proc/acpi/bbswitch
root@kali:~# cat /proc/acpi/bbswitch
0000:01:00.0 ON
root@kali:~#


Edit:


root@kali:~# glxgears
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
root@kali:~#

Had no idea that my Intel driver was broken!! Geez what a mess...

Thanks again bahha!

darkshadowman
2014-12-11, 11:17
Till today all working perfect!!After updating xserver-xorg-core to 2:1.12.4-6+deb7u5 now when i run "optirun glxspheres64" gives the error :

Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 137 (NV-GLX)
Minor opcode of failed request: 4 ()
Resource id in failed request: 0x200002
Serial number of failed request: 38
Current serial number in output stream: 38

if i run any other program eg "optirun pyrit" its working fine.
Any help would be appreciated.
Im using kali 1.09 3.14-kali1-amd64


problem solved. what i did was :
Code:

mv /usr/lib/xorg/modules/extensions/libglx.so /usr/lib/xorg/modules/extensions/libglx.so.orig
ln -s /usr/lib/xorg/modules/extensions/libglx.so.XXX.YY /usr/lib/xorg/modules/extensions/libglx.so
where XXX.YY is your driver version

bahha
2014-12-11, 13:59
my recommendation for you is to use my post above (https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=40188&viewfull=1#post40188) too fix everything, that's what I did and everything is ok for now .

@ darkshadowman
pyrit works even without installing the nvidia driver. you can check if your driver works by :

optirun pyrit list_cores

if it lists your GPU to then it's ok , look at the example bellow


The following cores seem available...
#1: 'CUDA-Device #1 'GeForce GT 740M''
#2: 'CPU-Core (SSE2/AES)'
#3: 'CPU-Core (SSE2/AES)'
#4: 'CPU-Core (SSE2/AES)'
#5: 'CPU-Core (SSE2/AES)'
#6: 'CPU-Core (SSE2/AES)'
#7: 'CPU-Core (SSE2/AES)'
#8: 'CPU-Core (SSE2/AES)'

gp_uva
2014-12-13, 20:11
Hi everybody!
I need some help, please.
Kali -32 Bits
Nvidia card integrated on a HP notebook dv9 series with nvidia integrated.
I did a fresh install and the first thing to do was installing the graphics.
Unfortunatlly my bumblebee tells me:

[ERROR]No integrated video card found, quitting.

well the Virtualgl was instaled well, the Cuda was instaled well , and the driver Nvidia was installed well.
Everything done as static0de last update post for the 340 driver. Exception for the packages wich were i386 compatible. and one or another path I had to chage.

well the last thing I was expecting to see was no hardware found!
:)

gp_uva
2014-12-14, 13:28
Hi everybody!
I need some help, please.
Kali -32 Bits
Nvidia card integrated on a HP notebook dv9 serieswith nvidia integrated.
I did a fresh install and the first thing to do was the instalation of the graphics. well....
My bumblebee tels me:
[ERROR]No integrated video card found, quitting.
well the Virtualgl was instaled the Cuda was instaled the and the driver Nvidia was installed. Everything done with static0de last update post for the 340 driver. Exception for the packages wich were i386 compatible. and one or another path I had to chage.

well the last thing I was expecting to see is no harware found?????.
Help

Edited

here is what I am experiencing :(

root@GP-Notebook:~# modinfo nvidia
filename: /lib/modules/3.14-kali1-686-pae/updates/dkms/nvidia.ko
alias: char-major-195-*
version: 340.65
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias: pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias: pci:v000010DEd*sv*sd*bc03sc02i00*
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
depends: drm,i2c-core
vermagic: 3.14-kali1-686-pae SMP mod_unload modversions 686
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
parm: NVreg_ModifyDeviceFiles:int
parm: NVreg_DeviceFileUID:int
parm: NVreg_DeviceFileGID:int
parm: NVreg_DeviceFileMode:int
parm: NVreg_RemapLimit:int
parm: NVreg_UpdateMemoryTypes:int
parm: NVreg_InitializeSystemMemoryAllocations:int
parm: NVreg_UsePageAttributeTable:int
parm: NVreg_MapRegistersEarly:int
parm: NVreg_RegisterForACPIEvents:int
parm: NVreg_CheckPCIConfigSpace:int
parm: NVreg_EnablePCIeGen3:int
parm: NVreg_EnableMSI:int
parm: NVreg_MemoryPoolSize:int
parm: NVreg_RegistryDwords:charp
parm: NVreg_RmMsg:charp
parm: NVreg_AssignGpus:charp
root@GP-Notebook:~# optirun glxspheres64
[ 3634.315931] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 3634.316064] [ERROR]Could not connect to bumblebee daemon - is it running?
root@GP-Notebook:~# bumblebeed
[ 3818.730812] [ERROR]No integrated video card found, quitting.

Hun75m4n
2014-12-31, 19:03
First of all many thanks to staticn0de, I could not have made half the progress I have without his posts.

I really hope someone can help me with this issue. I have been struggling for days now trying to get this up and running, i.e. my Nvidia graphics card.

I have listed below all the information I think might be pertinent, maybe over kill but I didn't want to leave anything out. I am new to this so forgive me if I am on the wrong thread or have used the wrong format.

I have downloaded the NVIDIA drivers NVIDIA GeForce 610m (1GB) from the nvidia web site as directed, these are the drivers the specs for my pc state, Lenovo Ideapad U410.
I am running Kali 64 bit as my primary OS, no dual boot, kernel details are also listed below.

Below are the steps I have gone through trying to get this working: These were all done as a regular user then again as root.
-stopped gdm3 / terminal ./NVIDIA-Linux-x86_64-340.65.run -dkms -z (failed)
-stopped gdm3 /terminal ./NVIDIA-Linux-x86_64-340.65.run (failed)
-booted to command prompt ./NVIDIA-Linux-x86_64-340.65.run -dkms -z (failed)
-booted to command prompt ./NVIDIA-Linux-x86_64-340.65.run (failed)

Removed all files containing NVIDIA with Synaptic Package Manager then went through the steps listed above, same results.

Removed all files containing nouveau with Synaptic Package Manager then went through the steps listed above, same results.

I have now reinstalled the nouveau files I removed previously.

I have NOT reinstalled the nvidia files referenced to in Synaptic Package Manager.
I have included my sources list below for verification..it contains notes to myself in it as well.

I have followed the below link on what to do post Kali install
http://www.blackmoreops.com/2014/03/03/20-things-installing-kali-linux/

I followed these instructions, but lost the gui altogether. This happend a number of times and I reinstalled the OS twice before I found the xorg file and removed it...(I guess I should have read step B and saved some time)
http://www.blackmoreops.com/2014/06/27/kali-linux-1-0-7-kernel-3-14-install-proprietary-nvidia-driver/

etc/fstab/

## CD/DVD Repositories ##
#deb cdrom:[Debian GNU/Linux 7.0 _Kali_ - Official Snapshot amd64 LIVE/INSTALL Binary 20141002-11:29]/ kali contrib main non-free
#deb cdrom:[Debian GNU/Linux 7.0 _Kali_ - Official Snapshot amd64 LIVE/INSTALL Binary 20141002-11:29]/ kali contrib main non-free

## Regular Repositories ##
deb http://http.kali.org/kali kali main non-free contrib
#deb http://security.kali.org/kali-security kali/updates main contrib non-free

## Source Repositories ##
deb-src http://http.kali.org/kali kali main non-free contrib
deb-src http://security.kali.org/kali-security kali/updates main contrib non-free

## Security Updates ##
deb http://security.kali.org/kali-security kali/updates main contrib non-free

## HOWTO - Install GNS3 1.2 using Kali Linux 1.0.9 64-bit ##
## https://community.gns3.com/thread/3752 ##
## REMOVE THESE FROM SOURCES AFTER INTSLLING GNS3 SEEMED TO CAUSE PROBLEMS WITH GUI IF USED W/APT-GET UPDATE / UPGRADE ##
#deb http://http.us.debian.org/debian testing main non-free contrib
#deb-src http://http.us.debian.org/debian testing main non-free contrib


user@gabrielle:~$ lspci -vnn | grep VGA -A 12
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
Subsystem: Lenovo Device [17aa:3903]
Flags: bus master, fast devsel, latency 0, IRQ 47
Memory at eb000000 (64-bit, non-prefetchable) [size=4M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 4000 [size=64]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915

00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04) (prog-if 30 [XHCI])
Subsystem: Lenovo Device [17aa:3977]
Flags: bus master, medium devsel, latency 0, IRQ 41
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1058] (rev a1) (prog-if 00 [VGA controller])
Subsystem: Lenovo Device [17aa:3903]
Flags: bus master, fast devsel, latency 0, IRQ 46
Memory at ea000000 (32-bit, non-prefetchable) [size=16M]
Memory at e0000000 (64-bit, prefetchable) [size=128M]
Memory at e8000000 (64-bit, prefetchable) [size=32M]
I/O ports at 3000 [size=128]
Expansion ROM at <ignored> [disabled]
Capabilities: <access denied>
Kernel driver in use: nouveau

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 05)
Subsystem: Lenovo Device [17aa:3975]


user@gabrielle:~$ uname -a
Linux gabrielle 3.14-kali1-amd64 #1 SMP Debian 3.14.5-1kali1 (2014-06-07) x86_64 GNU/Linux


user@gabrielle:~$ lsmod | grep nouveau
nouveau 1053347 0
mxm_wmi 12515 1 nouveau
ttm 69667 1 nouveau
drm_kms_helper 39998 2 i915,nouveau
video 17804 2 i915,nouveau
drm 240557 5 ttm,i915,drm_kms_helper,nouveau
i2c_algo_bit 12751 2 i915,nouveau
i2c_core 24265 7 drm,i915,i2c_i801,drm_kms_helper,i2c_algo_bit,nouv eau,videodev
wmi 17339 2 mxm_wmi,nouveau
button 12944 2 i915,nouveau


user@gabrielle:/home/user# passwd -S sys | tail -1 | awk '{print $3}'
10/02/2014


user@gabrielle:/home/user# tune2fs -l /dev/sda1 | grep 'Filesystem created'
Filesystem created: Thu Dec 25 12:43:33 2014


user@gabrielle:/home/user# lscpu
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 4
On-line CPU(s) list: 0-3
Thread(s) per core: 2
Core(s) per socket: 2
Socket(s): 1
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 58
Stepping: 9
CPU MHz: 806.250
BogoMIPS: 4988.59
Virtualization: VT-x
L1d cache: 32K
L1i cache: 32K
L2 cache: 256K
L3 cache: 4096K
NUMA node0 CPU(s): 0-3


user@gabrielle:/home/user# lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1058 (rev a1)


user@gabrielle:~$ lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1058 (rev a1)

nvidia-installer log file '/var/log/nvidia-installer.log'


nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Wed Dec 31 10:46:46 2014
installer version: 340.65

PATH: /sbin:/usr/sbin:/bin:/usr/bin

nvidia-installer command line:
./nvidia-installer

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 340.65.
-> There appears to already be a driver installed on your system (version: 340.65). As part of installing this driver (version: 340.65), the existing driver will be uninstalled. Are you sure you want to continue? (Answer: Continue installation)
-> Would you like to register the kernel module sources with DKMS? This will allow DKMS to automatically build a new module, if you install a different kernel later. (Answer: Yes)
-> Installing both new and classic TLS OpenGL libraries.
-> Installing both new and classic TLS 32bit OpenGL libraries.
-> Install NVIDIA's 32-bit compatibility libraries? (Answer: No)
-> Parsing log file:
-> done.
-> Validating previous installation:
-> done.
-> Uninstalling NVIDIA Accelerated Graphics Driver for Linux-x86_64 (1.0-34065 (340.65)):
-> DKMS module detected; removing...
-> done.
-> Uninstallation of existing driver: NVIDIA Accelerated Graphics Driver for Linux-x86_64 (340.65) is complete.
-> Skipping installation of the libvdpau wrapper library.
-> Searching for conflicting X files:
-> done.
-> Searching for conflicting OpenGL files:
-> done.
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86_64' (340.65):
executing: '/sbin/ldconfig'...
-> done.
-> Driver file installation is complete.
-> Installing DKMS kernel module:
ERROR: Failed to run `/usr/sbin/dkms build -m nvidia -v 340.65 -k 3.14-kali1-amd64`:
Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.14-kali1-amd64 module KERNEL_UNAME=3.14-kali1-amd64; make -C uvm module KERNEL_UNAME=3.14-kali1-amd64 KBUILD_EXTMOD=/var/lib/dkms/nvidia/340.65/build/uvm....(bad exit status: 2)
Error! Bad return status for module build on kernel: 3.14-kali1-amd64 (x86_64)
Consult /var/lib/dkms/nvidia/340.65/build/make.log for more information.
-> error.
ERROR: Failed to install the kernel module through DKMS. No kernel module was installed; please try installing again without DKMS, or check the DKMS logs for more information.
ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

staticn0de
2015-01-01, 11:03
Hi there,

First things first, clean up the NIVIDA drivers already installed. I've added sudo for if you are a regular user

sudo ./NVIDIA-Linux-x86_64-340.65.run --uninstall

The command you linked above does not have the double - before the dkms flag. Use this below

./NVIDIA-Linux-x86_64-340.65.run --dkms -z

You don't touch the xorg.conf file at all. You don't need it and generating one under NVIDIA will break your install.

While I'm a huge fan of blackmoreops and his guides, you should not just follow them if you don't know what they are doing.

For example, his guide on NVIDIA is not for optimus platforms and it will break your install.

The easiest way would be to do a fresh install (as I don't know what you have done to your system) and then follow my guide from the start.

It would also be good to see the log here:

/var/lib/dkms/nvidia/340.65/build/make.log

Hun75m4n
2015-01-02, 13:07
Staticn0de thank you so much for you help with this. I think I may have a couple of python type errors going on as well, I will post the code from those later. I was impatient waiting for the moderators to post my thread and may have broken other "stuff" before I saw your reply. I think have answered and posted correctly below your requests, for some reason I am getting a security alert when I try to preview this so I am posing it as is.

This security site has been blocking me from posting here for the last two day...***
https://forums.kali.org/newreply.php?do=postreply&t=21956
https://sucuri.net/






First things first, clean up the NIVIDA drivers already installed. I've added sudo for if you are a regular user

sudo ./NVIDIA-Linux-x86_64-340.65.run --uninstall
Done...uninstall appeared to work.

This was reran with --dkms -z (the installation failed)


The command you linked above does not have the double - before the dkms flag. Use this below
./NVIDIA-Linux-x86_64-340.65.run --dkms -z

Before removal


user@gabrielle:/var/lib/dkms/nvidia/340.65/build$ cat make.log
DKMS make.log for nvidia-340.65 for kernel 3.14-kali1-amd64 (x86_64)
Wed Dec 31 10:47:09 MST 2014

gcc-version-check failed:

The compiler used to compile the kernel (gcc
4.7) does not exactly match the current compiler
(gcc 4.9). The Linux 2.6 kernel module loader
rejects kernel modules built with a version of gcc
that does not exactly match that of the compiler
used to build the running kernel.

If you know what you are doing and want to override
the gcc version check, you can do so by setting the
IGNORE_CC_MISMATCH environment variable to "1".

In any other case, set the CC environment variable
to the name of the compiler that was used to compile
the kernel.

*** Failed CC version check. Bailing out! ***

make: *** [build-sanity-checks] Error 1
make: Entering directory `/var/lib/dkms/nvidia/340.65/build/uvm'
cd ./..; make module SYSSRC=/lib/modules/3.14-kali1-amd64/source SYSOUT=/lib/modules/3.14-kali1-amd64/build KBUILD_EXTMOD=./..
make[1]: Entering directory `/var/lib/dkms/nvidia/340.65/build'
NVIDIA: calling KBUILD...
make[2]: Entering directory `/usr/src/linux-headers-3.14-kali1-common'
make -C /lib/modules/3.14-kali1-amd64/build \
KBUILD_SRC=/usr/src/linux-headers-3.14-kali1-common \
KBUILD_EXTMOD="./.." -f /usr/src/linux-headers-3.14-kali1-common/Makefile \
modules
test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
echo >&2; \
echo >&2 " ERROR: Kernel configuration is invalid."; \
echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
echo >&2 ; \
/bin/false)
mkdir -p ./../.tmp_versions ; rm -f ./../.tmp_versions/*
make -f /usr/src/linux-headers-3.14-kali1-common/scripts/Makefile.build obj=./..
/usr/src/linux-headers-3.14-kali1-common/scripts/Makefile.build:44: /usr/src/linux-headers-3.14-kali1-common/./../Makefile: No such file or directory
make[4]: *** No rule to make target `/usr/src/linux-headers-3.14-kali1-common/./../Makefile'. Stop.
make[3]: *** [_module_./..] Error 2
make[2]: *** [sub-make] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-3.14-kali1-common'
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [nvidia.ko] Error 1
make[1]: Leaving directory `/var/lib/dkms/nvidia/340.65/build'
make: *** [../Module.symvers] Error 2
make: Leaving directory `/var/lib/dkms/nvidia/340.65/build/uvm'
user@gabrielle:/var/lib/dkms/nvidia/340.65/build$

after...the ./NVIDIA install failed



root@gabrielle:/var/lib/dkms/nvidia/340.65/build# cat make.log
DKMS make.log for nvidia-340.65 for kernel 3.14-kali1-amd64 (x86_64)
Thu Jan 1 12:28:45 MST 2015

gcc-version-check failed:

The compiler used to compile the kernel (gcc
4.7) does not exactly match the current compiler
(gcc 4.9). The Linux 2.6 kernel module loader
rejects kernel modules built with a version of gcc
that does not exactly match that of the compiler
used to build the running kernel.

If you know what you are doing and want to override
the gcc version check, you can do so by setting the
IGNORE_CC_MISMATCH environment variable to "1".

In any other case, set the CC environment variable
to the name of the compiler that was used to compile
the kernel.

*** Failed CC version check. Bailing out! ***

make: *** [build-sanity-checks] Error 1
make: Entering directory `/var/lib/dkms/nvidia/340.65/build/uvm'
cd ./..; make module SYSSRC=/lib/modules/3.14-kali1-amd64/source SYSOUT=/lib/modules/3.14-kali1-amd64/build KBUILD_EXTMOD=./..
make[1]: Entering directory `/var/lib/dkms/nvidia/340.65/build'
NVIDIA: calling KBUILD...
make[2]: Entering directory `/usr/src/linux-headers-3.14-kali1-common'
make -C /lib/modules/3.14-kali1-amd64/build \
KBUILD_SRC=/usr/src/linux-headers-3.14-kali1-common \
KBUILD_EXTMOD="./.." -f /usr/src/linux-headers-3.14-kali1-common/Makefile \
modules
test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
echo >&2; \
echo >&2 " ERROR: Kernel configuration is invalid."; \
echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
echo >&2 ; \
/bin/false)
mkdir -p ./../.tmp_versions ; rm -f ./../.tmp_versions/*
make -f /usr/src/linux-headers-3.14-kali1-common/scripts/Makefile.build obj=./..
/usr/src/linux-headers-3.14-kali1-common/scripts/Makefile.build:44: /usr/src/linux-headers-3.14-kali1-common/./../Makefile: No such file or directory
make[4]: *** No rule to make target `/usr/src/linux-headers-3.14-kali1-common/./../Makefile'. Stop.
make[3]: *** [_module_./..] Error 2
make[2]: *** [sub-make] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-3.14-kali1-common'
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [nvidia.ko] Error 1
make[1]: Leaving directory `/var/lib/dkms/nvidia/340.65/build'
make: *** [../Module.symvers] Error 2
make: Leaving directory `/var/lib/dkms/nvidia/340.65/build/uvm'
root@gabrielle:/var/lib/dkms/nvidia/340.65/build#

Hun75m4n
2015-01-02, 16:15
I know this post has nothing to do with this thread, and for that I apologize in advance.

This is just a test
https://securi.netwebsite has been blocking my access to advanced post and "preview post" options, I tested this from three different locations on two difference pc's. The only time I did not get blocked was when I chose the "quick reply" option.

I am now connecting through tor browser and it appears to be working accept I have been asked to log in multiple times.

Hun75m4n
2015-01-03, 21:34
Staticn0de...again many thanks. I do NOT have python errors anymore, infact I just rebuilt this Kali install, 3x. I had a backup file which I used, but that failed. Anyway post 25 was followed exactly, after a clean install.

As you can see I am still having issues, and the NVIDIA drivers failed to install.



Edit xorg.conf.nvidia and add a line under the 'Section "Device"' area so that is matches what is shown below. Change the bus ID to match what you recorded previously and take note that you recored a . before the last number and it is now a ':'. You need the ':'.
Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:03:00:0"

Above directions were not compete...file xorg.conf.nvidia does not exist, see below code.


root@Debian:/var/lib/dkms/nvidia/340.65/build# locate xorg.conf.
/usr/share/X11/xorg.conf.d
/usr/share/X11/xorg.conf.d/10-evdev.conf
/usr/share/X11/xorg.conf.d/50-synaptics.conf
/usr/share/X11/xorg.conf.d/50-vmmouse.conf
/usr/share/X11/xorg.conf.d/50-wacom.conf
/usr/share/man/man5/xorg.conf.5.gz
/usr/share/man/man5/xorg.conf.d.5.gz



It would also be good to see the log here:

/var/lib/dkms/nvidia/340.65/build/make.log

The above requested file does not exist, see below.


root@Debian:/var/lib/dkms/nvidia/340.65/build# ls
conftest.sh Makefile nv-dma.c nv_gpu_ops.h nvidia-modules-common.mk nv-misc.h nv-procfs.c nv_uvm_interface.c os-interface.h os-usermap.c
cpuopsys.h nv-acpi.c nv-drm.c nvgputypes.h nv-kernel.o nv-mmap.c nv-proto.h nv_uvm_interface.h os-mlock.c rmil.h
dkms.conf nv.c nverror.h nv-gvi.c nv-linux.h nv-p2p.c nv-reg.h nv-vm.c os-pci.c rmretval.h
gcc-version-check.c nv-chrdev.c nv-frontend.c nv.h nv-memdbg.h nv-p2p.h nvtypes.h nv-vtophys.c os-registry.c uvm
g_nvreadme.h nv-cray.c nv-frontend.h nv-i2c.c nv-mempool.c nv-pat.c nv-usermap.c os-interface.c os-smp.c xapi-sdk.h
root@Debian:/var/lib/dkms/nvidia/340.65/build#

I do have this file...

root@Debian:/usr/share/doc/NVIDIA_GLX-1.0# cat README.txt

The above file had too many characters to post.

I use Kali is my primary OS, bad practice I know, but I use it with work constantly. I hope that my installing additional applications doesn't impair our working on my NVIDIA graphics driver. As you can see I am still in need of some assistance. Please let me know what files or data I can post that will help this along.


Vr/

staticn0de
2015-01-03, 22:41
@Hun75m4n,

Nothing wrong with using Kali as the primary OS.

Installing other applications is not normally the problem. Its all about how much you install from non-official repos as they will break you install very quickly.

Now, the file you are after is found in the bumblebee directory



root@kali /etc/bumblebee$ ls
bumblebee.conf xorg.conf.d xorg.conf.nouveau xorg.conf.nvidia


The two files you modify as part of my guide are bumbelbee.conf and xorg.conf.nvidia.

If you don't have this folder, you have not installed bumblebee yet. You need to add the debian repo listed in the guide and run apt-get update and then install bumblebee.

Now you have the correct file, keep following the guide and make the modifications listend. If you still can't get it to work, let me know.

Hun75m4n
2015-01-03, 23:44
@staticn0de

Thanks for pointing out the files, apprantly I don't know how to use the command 'locate'.
I have completed the install now, without error. I guess maybe I am not in the know for how NVIDIA Gforce is used. Under Applications -> System Tools -> Preferences -> NVIDIA X server settings I have the below error.


You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

Applications -> System Tools -> Preferences -> Systems Settings -> Details -> Graphics (there is no driver listed and Experience states "Fallback)

Applications -> Programming -> Nvidia Visual Profiler (not sure what this is all about, it appears to be a web page)

I guess I am confused as to what getting the NVIDIA drivers installed correctly was supposed to accomplish.

staticn0de
2015-01-04, 00:31
@staticn0de

Thanks for pointing out the files, apprantly I don't know how to use the command 'locate'.
I have completed the install now, without error. I guess maybe I am not in the know for how NVIDIA Gforce is used. Under Applications -> System Tools -> Preferences -> NVIDIA X server settings I have the below error.


You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

Applications -> System Tools -> Preferences -> Systems Settings -> Details -> Graphics (there is no driver listed and Experience states "Fallback)

Applications -> Programming -> Nvidia Visual Profiler (not sure what this is all about, it appears to be a web page)

I guess I am confused as to what getting the NVIDIA drivers installed correctly was supposed to accomplish.

The reason it is giving you an NVIDIA X driver error is because it's not loaded (the driver) unless you call it with optirun. This is a power saving feature and the entire reason we install bumblebee.

try the command below:



optirun glxspheres64


You should see a pretty window appear and terminal will be printing some FPS for you. That means the driver install worked.

If you want to use the NVIDIA card (such as in a graphics demanding application), prefix the command with optirun.

Say I wanted to run cudahashcat i would use the command



optirun cudahashcat

2Code
2015-01-04, 00:58
Hi everyone. Please help. I followed the guide from post 25 step by step till Cuda install, everything works well, no error but when i try to see if it works what have I done with optirun glxspheres64, i got 2 errors

[ 1465.806859] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

[ 1465.806942] [ERROR]Aborting because fallback start is disabled.

and for primusrun glxgears
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual

In xorg.conf.nvidia I have:

Section "ServerLayout"
Identifier "Layout0"
Option "AutoAddDevices" "false"
Option "AutoAddGPU" "false"
EndSection

Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:01:00.0"
Option "NoLogo" "true"
Option "UseEDID" "false"
Option "UseDisplayDevice" "none"
EndSection

in bumblebee.conf i changed only line 22 "Driver=nvidia"

lspci | grep 3D comand give me as a result 01:00.0 3D controller: NVIDIA Corporation Device 1292 (rev a1)

I use Nvidia 740M in an asus laptop, I just installed kali and updated&upgraded without any error after I tried to install from first post and I got
root@kali:~# modprobe nvidia-uvm
ERROR: could not insert 'nvidia_uvm': No such device but optirun glxspheres64 it worked that time.
but that time i installed and uninstalled too many times and I haven't any ideea how to solve and it was too much mess around.
Any help appreciated. Thank you in advance

Quest
2015-01-04, 01:11
and the award for Most Helpful Topic of 2014 goes to... staticn0de!

:cool:

Thanks for all the help mate!

staticn0de
2015-01-04, 02:40
and the award for Most Helpful Topic of 2014 goes to... staticn0de!

:cool:

Thanks for all the help mate!

Shucks mate, you will make me blush.

Quest
2015-01-04, 02:50
seriously they have not wrapped up a cudahashcat package yet http://git.kali.org/gitweb/?a=project_list;pf=packages , so many thanks for that .deb and this howto bro. I'd still be without my nVidia under linux without this tut. We(nVidia users) all appreciate that guide you've created here. Not that many have the knowledge and willing to help.

Cheers static!

phantom1bc
2015-01-04, 04:00
excellent stuff

staticn0de
2015-01-04, 06:49
You actually reminded me that I have been meaning to repackage the new cudahashcat 1.31. So, I went and did that. I've also changed the host because mirror creator is awful and should feel awful.

Install with:

dpkg -i cudahashcat-1.31.deb

In the future, if you want to remove it:

dpkg -r cudahashcat-1.31

If you want to make sure its completely removed, check the following and remove them:


/usr/bin/cudahashcat32
/usr/bin/cudahashcat64
/usr/share/cudahashcat


If you need to remove my old deb, run the following. Check the listings in the code block above to make sure they were removed:

dpkg -r cudahashcat-1.30

Sums for cudahashcat-1.31.deb:


md5sum = b753c393264b3c40e51f057a96f3f6e9
sha1sum = f4abc533f4ced0f7e9a82255ceecf0333c212fa2


When installed, test with the following:

optirun cudahashcat64 -t 32 -a 7 example0.hash ?a?a?a?a example.dict

The file is 475MB
https://mega.co.nz/#!kFMC2RQC!D1ccQYAwsWyGKD0CaV4W7n5Ghtc-YKFFxs7Qj1pgcw0

staticn0de
2015-01-04, 18:22
@2code

Edit xorg.conf.nvidia and adjust the line:

BusID "PCI:01:00.0"

To read

BusID "PCI:01:00:0"

And restart bumblebeed

Quest
2015-01-04, 20:20
I really like MEGA over mirror creator. Thx for that new cudahashcat 1.31 deb!

I will wait for KL 1.1.0 to install it, as will have to reinstall everything when it comes out. Tomorrow(5) me thinks.

:cool::cool:

2Code
2015-01-06, 00:34
Thank you very much staticn0de, your advice took me in the right direction and I ran optirun glxspheres64 whitout problems. But I got another error after I've installed cuda_6.0.37_linux_64 when i have run ./deviceQuery, i got
ERROR: could not insert 'nvidia': No such device
cudaGetDeviceCount returned 38
-> no CUDA-capable device is detected
Result = FAIL

modinfo nvidia filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
alias: char-major-195-*
version: 340.65
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias: pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias: pci:v000010DEd*sv*sd*bc03sc02i00*
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
depends: drm,i2c-core
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
...

Must I downgrade to an old nvidia driver version(340.24) or to upgrade cuda or a clean install again ?

modinfo nvidia-current | grep version ERROR: Module nvidia-current not found.
nvidia-smi -a ERROR: could not insert 'nvidia': No such device
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
lspci | egrep 'VGA|3D' 00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 3D controller: NVIDIA Corporation Device 1292 (rev ff)

I read on a forum that is possible to have a version mismatch between installed nvidia kernel module and libcuda1 library but I don't know if is the case and how to solve it.

Thank you for help.

staticn0de
2015-01-06, 18:21
Thank you very much staticn0de, your advice took me in the right direction and I ran optirun glxspheres64 whitout problems. But I got another error after I've installed cuda_6.0.37_linux_64 when i have run ./deviceQuery, i got
ERROR: could not insert 'nvidia': No such device
cudaGetDeviceCount returned 38
-> no CUDA-capable device is detected
Result = FAIL

modinfo nvidia filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
alias: char-major-195-*
version: 340.65
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias: pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias: pci:v000010DEd*sv*sd*bc03sc02i00*
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
depends: drm,i2c-core
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
...

Must I downgrade to an old nvidia driver version(340.24) or to upgrade cuda or a clean install again ?

modinfo nvidia-current | grep version ERROR: Module nvidia-current not found.
nvidia-smi -a ERROR: could not insert 'nvidia': No such device
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
lspci | egrep 'VGA|3D' 00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 3D controller: NVIDIA Corporation Device 1292 (rev ff)

I read on a forum that is possible to have a version mismatch between installed nvidia kernel module and libcuda1 library but I don't know if is the case and how to solve it.

Thank you for help.

After you run ./deviceQuery, capture the tail of the dmesg command and post it here

Edit: did you run optirun. /deviceQuery or just

./deviceQuery?

It needs the optirun prefix

2Code
2015-01-08, 15:52
Thank you staticn0de. Unfortunatelly before I read your message I tried to uninstall nvidia driver, everything looks ok at the first sight but unfortunatelly when i tried to install it again, i got an error like I have a nvidia driver installed and I don't know how to uninstall, here are some message which i got.
lsmod | grep video
video 17804 2 i915,asus_wmi
thermal_sys 27685 6 fan,video,intel_powerclamp,thermal,processor,x86_p kg_temp_thermal
dpkg -l | grep -i nvidia
ii bbswitch-dkms 0.8-1~bpo70+1 amd64 Interface for toggling the power on NVIDIA Optimus video cards
ii bumblebee 3.2.1-4~bpo70+1 amd64 NVIDIA Optimus support for Linux
ii nvidia-installer-cleanup 20131102+1~bpo70+1 amd64 cleanup after driver installation with the nvidia-installer
ii primus 0~20130904-1~bpo70+1 amd64 client-side GPU offloading for NVIDIA Optimus
modprobe nvidia FATAL: Module nvidia not found.

2Code
2015-01-08, 16:02
And nvidia-installer.log content:
License accepted.
-> Installing NVIDIA driver version 340.65.
-> The NVIDIA driver appears to have been installed previously using a different installer. To prevent potential conflicts, it is recommended either to update the existing installation using the same mechanism by which it was originally installed, or to uninstall the existing installation before installing this driver.
Please review the message provided by the maintainer of this alternate installation method and decide how to proceed:
Please use the Debian packages instead of the .run file.

(Answer: Abort installation)
ERROR: The installation was canceled due to the availability or presence of an alternate driver installation. Please see /var/log/nvidia-installer.log for more details.

I used NVIDIA-Linux-x86_64-340.65.run and when i tried to install i used the same method.

staticn0de
2015-01-09, 08:53
To uninstall, just use the --uninstall flag on the installer you used.

Make sure you clean up bumblebee and primus too. The command below should work but make sure you read about what you're doing first.

apt-get purge bumblebee* primus* nvidia-*

and start again

2Code
2015-01-09, 21:00
Hi and many thanks for your help but I do again something wrong, this time looks like nvidia driver doesn't load. I uninstall everything and install and configure everything again till cuda. I took some messages after:

optirun glxspheres64
Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: GeForce GT 740M/PCIe/SSE2
180.261624 frames/sec - 201.171972 Mpixels/sec

glxspheres64
Polygons in scene: 62464
Xlib: extension "GLX" missing on display ":0.0".
ERROR (603): Could not obtain RGB visual with requested properties
Xlib: extension "GLX" missing on display ":0.0".

dmesg | tail after optirun glxspheres64

ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found , ACPI requires [Package] (20131218/nsarguments-95)
[ 318.570043] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 318.570122] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 318.570175] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 328.249359] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 328.637866] vgaarb: this pci device is not a vga device
[ 335.261361] [drm] Module unloaded
[ 335.262413] bbswitch: disabling discrete graphics
[ 335.262423] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
[ 335.275710] pci 0000:01:00.0: Refused to change power state, currently in D0

lsmod | grep video
video 17804 2 i915,asus_wmi
thermal_sys 27685 6 fan,video,intel_powerclamp,thermal,processor,x86_p kg_temp_thermal

lspci -v -s 01:00.0
01:00.0 3D controller: NVIDIA Corporation Device 1292 (rev ff) (prog-if ff)
[B]!!! Unknown header type 7f

lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 3D controller: NVIDIA Corporation Device 1292 (rev ff)

Again dmesg | tail
[ 1397.746554] NVRM: immediately upstream of this GPU does not define
[ 1397.746554] NVRM: a matching prefetchable memory window.
[ 1397.746559] NVRM: This may be due to a known Linux kernel bug. Please
[ 1397.746559] NVRM: see the README section on 64-bit BARs for additional
[ 1397.746559] NVRM: information.
[ 1397.746566] nvidia: probe of 0000:01:00.0 failed with error -1
[ 1397.746922] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 1397.746926] NVRM: None of the NVIDIA graphics adapters were initialized!
[ 1397.746929] [drm] Module unloaded
[ 1397.747113] NVRM: NVIDIA init module failed!

modprobe nvidia
ERROR: could not insert 'nvidia': No such device

modinfo nvidia
filename: /lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
alias: char-major-195-*
version: 340.65
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias: pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias: pci:v000010DEd*sv*sd*bc03sc02i00*
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
depends: drm,i2c-core
vermagic: 3.14-kali1-amd64 SMP mod_unload modversions
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
parm: NVreg_ModifyDeviceFiles:int
parm: NVreg_DeviceFileUID:int
parm: NVreg_DeviceFileGID:int
parm: NVreg_DeviceFileMode:int
parm: NVreg_RemapLimit:int
parm: NVreg_UpdateMemoryTypes:int
parm: NVreg_InitializeSystemMemoryAllocations:int
parm: NVreg_UsePageAttributeTable:int
parm: NVreg_MapRegistersEarly:int
parm: NVreg_RegisterForACPIEvents:int
parm: NVreg_CheckPCIConfigSpace:int
parm: NVreg_EnablePCIeGen3:int
parm: NVreg_EnableMSI:int
parm: NVreg_MemoryPoolSize:int
parm: NVreg_RegistryDwords:charp
parm: NVreg_RmMsg:charp
parm: NVreg_AssignGpus:charp

xorg.8.log

328.346] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20130102)
[ 328.347] (II) NVIDIA(0): NVIDIA GPU GeForce GT 740M (GK208) at PCI:1:0:0 (GPU-0)
[ 328.347] (--) NVIDIA(0): Memory: 2097152 kBytes
[ 328.347] (--) NVIDIA(0): VideoBIOS: 80.28.42.00.09
[ 328.347] (II) NVIDIA(0): Detected PCI Express Link width: 8X
[ 328.347] (--) NVIDIA(0): Valid display device(s) on GeForce GT 740M at PCI:1:0:0
[ 328.347] (--) NVIDIA(0): none
[ 328.347] (II) NVIDIA(0): Validated MetaModes:
[ 328.347] (II) NVIDIA(0): "NULL"
[ 328.347] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[ 328.347] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[ 328.347] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[ 328.347] (--) Depth 24 pixmap format is 32 bpp
[ 328.347] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[ 328.347] (II) NVIDIA: access.
[ 328.420] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[ 328.420] (II) NVIDIA(0): may not be running or the "AcpidSocketPath" X
[ 328.420] (II) NVIDIA(0): configuration option may not be set correctly. When the
[ 328.420] (II) NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
[ 328.420] (II) NVIDIA(0): try to use it to receive ACPI event notifications. For
[ 328.420] (II) NVIDIA(0): details, please see the "ConnectToAcpid" and
[ 328.420] (II) NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
[ 328.420] (II) NVIDIA(0): Config Options in the README.
[ 328.421] (II) NVIDIA(0): Setting mode "NULL"
[ 328.421] (EE) NVIDIA(0): Failed to initiate mode change.
[ 328.421] (EE) NVIDIA(0): Failed to complete mode change
[ 328.438] (II) Loading extension NV-GLX
[ 328.443] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 328.443] (==) NVIDIA(0): Backing store disabled
[ 328.443] (==) NVIDIA(0): Silken mouse enabled
[ 328.443] (==) NVIDIA(0): DPMS enabled

find 2> /dev/null / -name nvidia*.ko
/var/lib/dkms/nvidia/340.65/3.14-kali1-amd64/x86_64/module/nvidia.ko
/var/lib/dkms/nvidia/340.65/3.14-kali1-amd64/x86_64/module/nvidia-uvm.ko
/lib/modules/3.14-kali1-amd64/updates/dkms/nvidia.ko
/lib/modules/3.14-kali1-amd64/updates/dkms/nvidia-uvm.ko

service bumblebeed status
[ ok ] bumblebeed is running.

nvidia.installer.log looks ok.
No other chance than install again, or can I do something to get loaded nvidia ?

johnnyinc
2015-02-09, 19:00
Hi,

New Kali Linux 1.1 is up. One of the festures is NVIDIA Optimus hardware support. Can You tell me if the installation proces is the same or some things changes with Kali 1.1 ?

johnnyinc
2015-02-10, 08:03
Dear all,
New Kali 1.1 is up. One of the features is Nvidia Optimus hardware support. Please can You tell me if the installation is the same or it's different from instruction couple pages back ?

Do You have any expirience in performance boost on Kali 1.1 ?

Quest
2015-02-10, 10:14
Thanks for the headsup johnnyinc.


Dear all,
New Kali 1.1 is up. One of the features is Nvidia Optimus hardware support. Please can You tell me if the installation is the same or it's different from instruction couple pages back ?

I have the same question.

stryngs
2015-02-10, 17:11
Hi,

With your laptop on, and not plugged in, and not being used for 1 or 2 mins, can you perform the following?

upower -d

Please post the results. I've been dealing with nvidia and optimus and cuda since 2011, and some of the steps you did seem a bit unnecessary.

Thanks

staticn0de
2015-02-11, 08:17
Hey guys! Exciting news about nvidia optimus in 1.1.

Bad news is, I've just moved house and won't have internet for up to 20 days. I can't test it!

If someone else can have a go, be sure to post back

anton
2015-02-12, 01:08
I'm using VMware® Workstation v7.0.1 build-227600, I've installed it on my Win8.1 x64
I've installed Kali Linux 9.10 on VMware

Whenever I've posted lspci | grep VGA in Linux Terminal the following info has showed :
00:0f.0 VGA compatible controller: VMware SVGA II Adapter
Is it possible to install Video Card Driver in Linux this situation ?
i havet instal linux from vmware with tools bat a cannt see nvidia hardwer

BTW, My video card is NVIDIA GeForce GT 740M

I FOLOW INSTRUCTION BAT I CANT INSTAL GRAFIC DRIVER

blackMORE
2015-02-12, 05:59
First of all, I would like to thank staticn0de (https://forums.kali.org/member.php?23325-staticn0de) for starting this thread. Optimus users should stick with this thread. Also thanks to Quest (https://forums.kali.org/member.php?18099-Quest) for his solutions that kept this thread up-to-date.

Users, I see a lot of posts regarding failed installation and errors. Let me clarify few things

Mix-matching NVIDIA repo driver and NVIDIA site driver will BREAK your GUI and in most cases you will end up reinstalling.
I've added a new guide for Kali Linux 1.1.0 kernel 3.18 (http://www.blackmoreops.com/2015/02/12/kali-linux-1-1-0-kernel-3-18-install-proprietary-nvidia-driver/). This guide also works fine on a new installation. Again do not mix match 2 sets of drivers.
If GPU processing is what you're after, perhaps Debian/Kali is not the best distro (incoming flame! :rolleyes:)
Both guides will work flawlessly in new installation where users didn't muck around with Display drivers. Choose one and stick with it.


Btw, staticn0de (https://forums.kali.org/member.php?23325-staticn0de) why VirtualGL?
I thought it only helps to run OpenGL applications with full 3D hardware acceleration remotely! So if I am only after GPU processing, I don't need it. If I want to run an application with 3D acceleration movie at work (hmm, I shouldn't) over vnc from my home PC, then I go install it? Right?

Quest
2015-02-12, 12:23
This whole installation is about 3Gb. So at 1,3Mb, If one will go trough the circus of installing the whole shlabang, then I think the answer is 'so that everything will work if ever called upon from an application'?

Hi blackMORE and thanks for the updated guide over at http://www.blackmoreops.com

Maybe you can give me an answer to my question?


The new release runs a 3.18 kernel, patched for wireless injection attacks.
Our ISO build systems are now running off live-build 4.x.
Improved wireless driver support, due to both kernel and firmware upgrades.
NVIDIA Optimus hardware support.
Updated virtualbox-tool, openvm-tools and vmware-tools packages and instructions.
A whole bunch of fixes and updates from our bug-tracker changelog.
And most importantly, we changed grub screens and wallpapers!
What does the above mean exactly? This installation worked with previous version of Kali, and now we still have to install everything, so what is different with 1.1.0?

Cheers!

staticn0de
2015-02-12, 18:41
First of all, I would like to thank staticn0de (https://forums.kali.org/member.php?23325-staticn0de) for starting this thread. Optimus users should stick with this thread. Also thanks to Quest (https://forums.kali.org/member.php?18099-Quest) for his solutions that kept this thread up-to-date.

Users, I see a lot of posts regarding failed installation and errors. Let me clarify few things

Mix-matching NVIDIA repo driver and NVIDIA site driver will BREAK your GUI and in most cases you will end up reinstalling.
I've added a new guide for Kali Linux 1.1.0 kernel 3.18 (http://www.blackmoreops.com/2015/02/12/kali-linux-1-1-0-kernel-3-18-install-proprietary-nvidia-driver/). This guide also works fine on a new installation. Again do not mix match 2 sets of drivers.
If GPU processing is what you're after, perhaps Debian/Kali is not the best distro (incoming flame! :rolleyes:)
Both guides will work flawlessly in new installation where users didn't muck around with Display drivers. Choose one and stick with it.


Btw, staticn0de (https://forums.kali.org/member.php?23325-staticn0de) why VirtualGL?
I thought it only helps to run OpenGL applications with full 3D hardware acceleration remotely! So if I am only after GPU processing, I don't need it. If I want to run an application with 3D acceleration movie at work (hmm, I shouldn't) over vnc from my home PC, then I go install it? Right?

Hi blackmore,

I wrote it a while ago, but if I remember right (without Kali in front of me) I included it as it installed glxspheres64 for testing the driver.

Quest
2015-02-12, 20:53
IMPORTANT

must add some repos in, File System/etc/apt/sources.list (Thanks blackMORE).

## Regular repositories
deb http://http.kali.org/kali kali main non-free contrib
deb http://security.kali.org/kali-security kali/updates main contrib non-free
## Source repositories
deb-src http://http.kali.org/kali kali main non-free contrib
deb-src http://security.kali.org/kali-security kali/updates main contrib non-free
Then..

apt-get update && apt-get upgrade && apt-get dist-upgradebefore Installing the Linux headers, or it won't work. Returns

root@kali:~# apt-get install linux-headers-$(uname -r)
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-headers-3.18.0-kali1-amd64
E: Couldn't find any package by regex 'linux-headers-3.18.0-kali1-amd64'
I'm installing now and will edit this post if something else comes up.


EDIT: The following lines will have to be modified if using CUDA 6.5 from this howto..


For the path, we will add a little more to what we defined for VirtualGL earlier. It should look like this in your bashrc file
nano ~/.bashrc
export PATH=$PATH:/opt/VirtualGL/bin:/usr/local/cuda-6.5/bin
Run the following so we don't have to log out
export PATH=$PATH:/opt/VirtualGL/bin:/usr/local/cuda-6.5/bin
Edit the following file so the contents match those shown below
nano /etc/ld.so.conf
Contents:
include /etc/ld.so.conf.d/*.conf
add /usr/local/cuda-6.5/lib64
Save and close


Run
ldconfig
Build the nVidia samples
cd /root/NVIDIA_CUDA-6.5_Samples
make



Everything worked well as before, with all the latest versions, CUDA 6.5.14, VirtualGL 2.4, nVidia 346.35, CudaHashcat 1.31.

..will post the links later. Thanks guys!! :cool:

max_034
2015-02-12, 23:35
Hello everyone, I'm having trouble getting my nvidia drivers to work. I have a laptop with 2 gt 750m graphics card with SLI. In addition i'm running the latest kali linux 1.1.0 kernel 3.18. I have tried the post by blackMORE but ended with gdm3 not working after setting up the xorg.conf file. So I decided to follow this guide but I encountered an error. The error comes up while trying to install the official nvidia drivers. When I run the installer it gives me an error "unable to load kernel module" this is the full log.

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Feb 12 15:09:17 2015
installer version: 346.35

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/VirtualGL/bin:/usr/local/cuda-6.5/bin

nvidia-installer command line:
./nvidia-installer
--dkms
-z

Using: nvidia-installer ncurses user interface
-> Detected 8 CPUs online; setting concurrency level to 8.
-> License accepted.
-> Installing NVIDIA driver version 346.35.
-> Would you like to register the kernel module sources with DKMS? This will allow DKMS to automatically build a new module, if you install a different kernel later. (Answer: Yes)
-> Installing both new and classic TLS OpenGL libraries.
-> Installing classic TLS 32bit OpenGL libraries.
WARNING: Unable to find a suitable destination to install 32-bit compatibility libraries. Your system may not be set up for 32-bit compatibility. 32-bit compatibility files will not be installed; if you wish to install them, re-run the installation and set a valid directory with the --compat32-libdir option.
-> nvidia-installer will install the libvdpau and libvdpau_trace libraries that were included with this installer package. These libraries are available separately through the libvdpau project and will be removed from the NVIDIA Linux driver installer package in the future, so it is recommended that VDPAU users install libvdpau separately, e.g. by using packages available from their distributions, or by building from the sources available at:

http://people.freedesktop.org/~aplattner/vdpau
-> Searching for conflicting files:
-> done.
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86_64' (346.35):
executing: '/sbin/ldconfig'...
-> done.
-> Driver file installation is complete.
-> Installing DKMS kernel module:
-> done.
ERROR: Unable to load the kernel module.
ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.


I tried to install with and without the lines that Quest suggested but the same thing shows up. Any ideas?

Quest
2015-02-12, 23:51
CUDA 6.5.14 -Get the RUN for Ubuntu 12.04 x64 or i386
https://developer.nvidia.com/cuda-downloads

VirtualGL 2.4 amd64 for 64Bit or i386 for 32Bit system.
http://sourceforge.net/projects/virtualgl/files/2.4/

nVidia 346.35
http://www.nvidia.com/Download/index.aspx?lang=en-us

CudaHashcat 1.31
https://mega.co.nz/#!kFMC2RQC!D1ccQYAwsWyGKD0CaV4W7n5Ghtc-YKFFxs7Qj1pgcw0 thanks static!!

Quest
2015-02-13, 12:30
Hi max_034,

https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=35604&viewfull=1#post35604 ??

max_034
2015-02-14, 01:18
Hi max_034,

https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=35604&viewfull=1#post35604 ??

Thanks for the reply Quest, but unfortunately I had already tried that and didn't work. I tried it again today and I still couldn't get the nvidia drivers to install properly. This is how my xorg.conf.nvidia file looks like



Section "ServerLayout"
Identifier "Layout0"
Option "AutoAddDevices" "false"
Option "AutoAddGPU" "false"
EndSection

Section "Device"
Identifier "DiscreteNvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:01:00:0"
BusID "PCI:07:00:0"


Option "NoLogo" "true"
Option "UseEDID" "false"
Option "UseDisplayDevice" "none"
Option "SLI" "AA"
EndSection



Also when I run " lspci | egrep 'VGA|3D' " I don't think it detects my second graphics card as it only displays two. Here is what I get



root@kali:~# lspci | egrep 'VGA|3D'
01:00.0 VGA compatible controller: NVIDIA Corporation Device 0fe4 (rev a1)
07:00.0 3D controller: NVIDIA Corporation Device 0fe4 (rev a1)


I'm not sure what's wrong.:confused:

Quest
2015-02-14, 15:25
Most of us don't have SLI, so that is a problem, but https://devtalk.nvidia.com/default/board/98/linux/ that board might be useful.

Let me just understand something with your first post..
I have tried the post by blackMORE but ended with gdm3 not working after setting up the xorg.conf file. So I decided to follow this guide but I encountered an error. The error comes up while trying to install the official nvidia drivers. When I run the installer it gives me an error "unable to load kernel module" Are you saying that you could install your nVidia drivers with blackMORE tut? If so, did you do a fresh Kali install before following this guide? Just making sure here.

anton
2015-02-14, 18:23
I'm using VMware® Workstation v7.0.1 build-227600, I've installed it on my Win8.1 x64
I've installed Kali Linux 9.10 on VMware

Whenever I've posted lspci | grep VGA in Linux Terminal the following info has showed :
00:0f.0 VGA compatible controller: VMware SVGA II Adapter
Is it possible to install Video Card Driver in Linux this situation ?
i havet instal linux from vmware with tools bat a cannt see nvidia hardwer

BTW, My video card is NVIDIA GeForce GT 740M

I FOLOW INSTRUCTION BAT I CANT INSTAL GRAFIC DRIVER

max_034
2015-02-15, 03:24
Most of us don't have SLI, so that is a problem, but https://devtalk.nvidia.com/default/board/98/linux/ that board might be useful.

Let me just understand something with your first post.. Are you saying that you could install your nVidia drivers with blackMORE tut? If so, did you do a fresh Kali install before following this guide? Just making sure here.

Once again thanks for the help Quest. Now regarding the SLI configuration, I don't think that's what's causing the problem as the second graphics card is removable and not soldered into the main board as the primary is. As to your question I did make a fresh installation of Kali before trying this guide. I have actually reinstalled Kali multiple times to try this method (and others) several times without luck. I usually end up with gdm3 not working or the driver not installing. In addition, I have also followed the tutorial using the two graphics cards listed - separately and together. I'm not sure as to what is causing the problem.

staticn0de
2015-02-15, 04:10
Hey guys,

This built in support for Nvidia + Optimus looks repo based.

I've noticed that you do not need to add the debian wheezy repo anymore in order to install bumbelbee and primus. The latest versions are already within the kali repo.

Quest
2015-02-15, 12:32
AH! I've been looking for an answer for a week! Makes sense.


Once again thanks for the help Quest. Now regarding the SLI configuration, I don't think that's what's causing the problem as the second graphics card is removable and not soldered into the main board as the primary is. As to your question I did make a fresh installation of Kali before trying this guide. I have actually reinstalled Kali multiple times to try this method (and others) several times without luck. I usually end up with gdm3 not working or the driver not installing. In addition, I have also followed the tutorial using the two graphics cards listed - separately and together. I'm not sure as to what is causing the problem.

https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=40188&viewfull=1#post40188 maybe?

Static, since things have changed a little since the first post, maybe do a re-write of that first post? If you could incorporate the howto above(fix broken Intel driver from bahha) so that ppl can use gdm3? Just thinking.

anton
2015-02-15, 20:50
I'm using VMware® Workstation v7.0.1 build-227600, I've installed it on my Win8.1 x64
I've installed Kali Linux 9.10 on VMware

Whenever I've posted lspci | grep VGA in Linux Terminal the following info has showed :
00:0f.0 VGA compatible controller: VMware SVGA II Adapter
Is it possible to install Video Card Driver in Linux this situation ?
i havet instal linux from vmware with tools bat a cannt see nvidia hardwer

BTW, My video card is NVIDIA GeForce GT 740M

I FOLOW INSTRUCTION BAT I CANT INSTAL GRAFIC DRIVER

blackMORE
2015-02-16, 00:15
The new release runs a 3.18 kernel, patched for wireless injection attacks.
Our ISO build systems are now running off live-build 4.x.
Improved wireless driver support, due to both kernel and firmware upgrades.
NVIDIA Optimus hardware support.
Updated virtualbox-tool, openvm-tools and vmware-tools packages and instructions.
A whole bunch of fixes and updates from our bug-tracker changelog.
And most importantly, we changed grub screens and wallpapers!

All it means that now Optimus driver's should work directly from Repo. So more pretty desktops.
It doesn't say if cudahashcat issue been fixed. The bug report (https://bugs.kali.org/view.php?id=1756) I raised for cudahashcat is still open, with normal priority and minor severity.

staticn0de
2015-02-16, 04:21
I'm using VMware® Workstation v7.0.1 build-227600, I've installed it on my Win8.1 x64
I've installed Kali Linux 9.10 on VMware

Whenever I've posted lspci | grep VGA in Linux Terminal the following info has showed :
00:0f.0 VGA compatible controller: VMware SVGA II Adapter
Is it possible to install Video Card Driver in Linux this situation ?
i havet instal linux from vmware with tools bat a cannt see nvidia hardwer

BTW, My video card is NVIDIA GeForce GT 740M

I FOLOW INSTRUCTION BAT I CANT INSTAL GRAFIC DRIVER

This guide and all graphics card related processing will not work under any circumstance with vmware, virtual box or any other virtualisation based set up.

Install bare metal if you want it to work, try dual boot.

staticn0de
2015-02-16, 04:22
AH! I've been looking for an answer for a week! Makes sense.



https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=40188&viewfull=1#post40188 maybe?

Static, since things have changed a little since the first post, maybe do a re-write of that first post? If you could incorporate the howto above(fix broken Intel driver from bahha) so that ppl can use gdm3? Just thinking.

Hey quest,

Yeah mate, this thread is a mess. I'll start a rewrite tonight and try to get it done soon.

Edit: people can't use gdm3? I didn't notice it was broken.

max_034
2015-02-16, 08:03
AH! I've been looking for an answer for a week! Makes sense.



https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=40188&viewfull=1#post40188 maybe?

Static, since things have changed a little since the first post, maybe do a re-write of that first post? If you could incorporate the howto above(fix broken Intel driver from bahha) so that ppl can use gdm3? Just thinking.

That is a good idea, but the problem is that I can't install the NVIDIA drivers at all. The first error I get occurs after I run:

./NVIDIA*.run --dkms -z

So the NVIDIA driver never gets properly installed. Maybe if I use blackMORE's tutorial and then the fix you provided, there might be a possibility, but the fix is specific for this tutorial. I guess I have to keep looking.

stiadmin
2015-02-18, 22:10
Hey Guys, I have followed the tutorial but am still having a problem getting things to work with my GeForce GT 650M. After following the directions and rebooting after step 14 I lost my GUI. I still had access to the console via Alt+F1 so I continued to finish via console through step 21. I can't seem to restore my GUI and step 21 comes back with errors.

It doesn't look like the logs are going to fit so I threw it in PastBin: http://pastebin.com/6g8Hiy8k

Quest
2015-02-21, 21:30
Doesn't work anymore. Driver won't install. It was working earlier this week. I did a bunch of benchmark under 1.1.0. Weird.

I guess will have to wait until nVidia makes another driver that supports kernel 3.18, or for Static to pull another rabbit out to save us all, again.

For those who have it working don't do any updates.
2015. Welcome to the Flintstones.



@Static, found a typo in post #1 step 7 (not that it matters at this point).

root@kali:~# nano ~./bashrc
root@kali:~# nano ~/.bashrc



- Missing a step between 12 and 13?

From the first version...

Restart bumblebee with the following and ignore any ERROR/FAIL warnings

/etc/init.d/bumblebeed restart

Quest
2015-02-21, 23:49
I got it to work, like earlier this week, by not installing the linux headers now.


root@kali:~/NVIDIA_CUDA-6.5_Samples/1_Utilities/deviceQuery# optirun ./deviceQuery
./deviceQuery Starting...

CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: "GeForce GT 630M"
CUDA Driver Version / Runtime Version 7.0 / 6.5
CUDA Capability Major/Minor version number: 2.1
Total amount of global memory: 2048 MBytes (2147155968 bytes)
( 2) Multiprocessors, ( 48) CUDA Cores/MP: 96 CUDA Cores
GPU Clock rate: 950 MHz (0.95 GHz)
Memory Clock rate: 900 Mhz
Memory Bus Width: 128-bit
L2 Cache Size: 131072 bytes
Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65535), 3D=(2048, 2048, 2048)
Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers
Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total number of registers available per block: 32768
Warp size: 32
Maximum number of threads per multiprocessor: 1536
Maximum number of threads per block: 1024
Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
Max dimension size of a grid size (x,y,z): (65535, 65535, 65535)
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Concurrent copy and kernel execution: Yes with 1 copy engine(s)
Run time limit on kernels: Yes
Integrated GPU sharing Host Memory: No
Support host page-locked memory mapping: Yes
Alignment requirement for Surfaces: Yes
Device has ECC support: Disabled
Device supports Unified Addressing (UVA): Yes
Device PCI Bus ID / PCI location ID: 1 / 0
Compute Mode:
< Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 7.0, CUDA Runtime Version = 6.5, NumDevs = 1, Device0 = GeForce GT 630M
Result = PASS





root@kali:~/pyrit_svn/cpyrit_cuda# optirun pyrit benchmark
Pyrit 0.4.1-dev (svn r308) (C) 2008-2011 Lukas Lueg http://pyrit.googlecode.com
This code is distributed under the GNU General Public License v3+

Running benchmark (10664.1 PMKs/s)... \

Computed 10664.15 PMKs/s total.
#1: 'CUDA-Device #1 'GeForce GT 630M'': 7530.0 PMKs/s (RTT 2.8)
#2: 'CPU-Core (SSE2/AES)': 520.8 PMKs/s (RTT 3.0)
#3: 'CPU-Core (SSE2/AES)': 523.4 PMKs/s (RTT 3.0)
#4: 'CPU-Core (SSE2/AES)': 520.0 PMKs/s (RTT 3.0)
#5: 'CPU-Core (SSE2/AES)': 523.1 PMKs/s (RTT 3.0)
#6: 'CPU-Core (SSE2/AES)': 536.0 PMKs/s (RTT 3.0)
#7: 'CPU-Core (SSE2/AES)': 521.2 PMKs/s (RTT 3.0)
#8: 'CPU-Core (SSE2/AES)': 522.2 PMKs/s (RTT 3.0)




Session.Name...: cudaHashcat
Status.........: Exhausted
Input.Base.....: Mask (?a?a?a?a) [4]
Input.Mod......: File (example.dict)
Hash.Target....: File (example0.hash)
Hash.Type......: MD5
Time.Started...: 0 secs
Time.Estimated.: 0 secs
Speed.GPU.#1...: 40758.5 kH/s
Recovered......: 2190/6494 (33.72%) Digests, 0/1 (0.00%) Salts
Progress.......: 136302297088/136302297088 (100.00%)
Skipped........: 0/136302297088 (0.00%)
Rejected.......: 0/136302297088 (0.00%)
HWMon.GPU.#1...: -1% Util, 67c Temp, -1% Fan

Started: Sat Feb 21 20:19:07 2015
Stopped: Sat Feb 21 20:33:10 2015

all that is missing is a voodoo doll to make this really weird.

staticn0de
2015-02-22, 21:27
Hey Quest,

Thanks for picking up those typos. I've gone and fixed them now.

Edit: Also, I just saw that hashcat 1.33 is out now. I'll make a new deb today and upload it for anyone interested. It's a shame it has not been put in the repo yet. That, and the repo has 1.31 for oclhashcat (amd).

Quest
2015-02-22, 21:34
I'm doing some experimenting to get the Intel 3D acceleration to work after this install, and no luck so far.

The nVidia driver and the glx-alternative-mesa_0.5.1 cannot coexist. One wants to uninstall the other. Ah well :)

Quest
2015-02-22, 21:37
so no need to restart Bumblebee between steps 12 and 13?

Quest
2015-02-23, 01:24
Hey Quest,

Edit: Also, I just saw that hashcat 1.33 is out now. I'll make a new deb today and upload it for anyone interested. It's a shame it has not been put in the repo yet. That, and the repo has 1.31 for oclhashcat (amd).

Great!

There's a bug in 1.33 http://hashcat.net/forum/thread-4085-page-2.html but it only affect PDF password cracking.

staticn0de
2015-02-23, 01:40
so no need to restart Bumblebee between steps 12 and 13?

Hey mate,

No. That is not needed.

I had no problems at all installing anything using the steps of the first page. I even installed the headers you had to leave out.

I'm curious, the latest version of the driver prompts users to run NVIDIA-XCONFIG. Did you happen to run it? or others who had a black screen may have. That command kills bumblebee.



root@kali:~/NVIDIA_CUDA-6.5_Samples/1_Utilities/deviceQuery# optirun ./deviceQuery
./deviceQuery Starting...

CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: "GeForce GT 740M"
CUDA Driver Version / Runtime Version 7.0 / 6.5
CUDA Capability Major/Minor version number: 3.5
Total amount of global memory: 2048 MBytes (2147352576 bytes)
( 2) Multiprocessors, (192) CUDA Cores/MP: 384 CUDA Cores
GPU Clock rate: 1032 MHz (1.03 GHz)
Memory Clock rate: 900 Mhz
Memory Bus Width: 64-bit
L2 Cache Size: 524288 bytes
Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096)
Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers
Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total number of registers available per block: 65536
Warp size: 32
Maximum number of threads per multiprocessor: 2048
Maximum number of threads per block: 1024
Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535)
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Concurrent copy and kernel execution: Yes with 1 copy engine(s)
Run time limit on kernels: Yes
Integrated GPU sharing Host Memory: No
Support host page-locked memory mapping: Yes
Alignment requirement for Surfaces: Yes
Device has ECC support: Disabled
Device supports Unified Addressing (UVA): Yes
Device PCI Bus ID / PCI location ID: 3 / 0
Compute Mode:
< Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 7.0, CUDA Runtime Version = 6.5, NumDevs = 1, Device0 = GeForce GT 740M
Result = PASS

staticn0de
2015-02-23, 01:43
Great!

There's a bug in 1.33 http://hashcat.net/forum/thread-4085-page-2.html but it only affect PDF password cracking.

Ahh. That's a pain. I've already packed it and started an upload.

I'll start again lol. I'll build the fix into the deb.

Quest
2015-02-23, 01:51
Cool thank you :cool:

That 1.33 seems to be a great version. Alot of work was done.


This version 1.33 is the finalized version of what v1.32 should have been.

There's not much to see from the changelog but there was a ton of changes in the inner working which make this release is really a good one. http://hashcat.net/forum/thread-4085.html



I'm curious, the latest version of the driver prompts users to run NVIDIA-XCONFIG. Did you happen to run it? or others who had a black screen may have. That command kills bumblebee. **** no, I did that only once by mistake and yup, black screen.

I did try to install numerous time yesterday with the headers, it was not working, when it was working before. I tell ya this is weird.

And had similar issues earlier this week where the header would not install. Had to add some repos for it to work. I will reinstall everything(for the 15th time) again with your new cudaHashcat .deb, and I will remove those repos just to see.

Btw it was not the updates that was causing my problems(like I thought before) but only the header.

staticn0de
2015-02-23, 02:04
Cool thank you :cool:

That 1.33 seems to be a great version. Alot of work was done.

http://hashcat.net/forum/thread-4085.html


**** no, I did that only once by mistake and yup, black screen.

I did try to install numerous time yesterday with the headers, it was not working, when it was working before. I tell ya this is weird.

And had similar issues earlier this week where the header would not install. Had to add some repos for it to work. I will reinstall everything(for the 15th time) again with your new cudaHashcat .deb, and I will remove those repos just to see.

Btw it was not the updates that was causing my problems(like I thought before) but only the header.

I had a look at a couple of repos last night. Out of the 10 I looked at, only two were current (this is for the kali-security repo).

That could cause some serious problems if your geo-location is connecting you to an out-of-date repo. Maybe that has something to do with it.

Quest
2015-02-23, 02:13
yes that would explain some of my paranormal experience.



## Regular repositories
deb http://http.kali.org/kali kali main non-free contrib
deb http://security.kali.org/kali-security kali/updates main contrib non-free
## Source repositories
deb-src http://http.kali.org/kali kali main non-free contrib
deb-src http://security.kali.org/kali-security kali/updates main contrib non-free


I didn't have a choice as the headers would not install without those. But now that's probly my problem. Go figure.

staticn0de
2015-02-23, 02:28
Edit: cudahashcat deb updated to 1.33 and includes PDF fix

https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=35240&viewfull=1#post35240

Quest
2015-02-23, 15:10
Hey Quest,

Edit: Also, I just saw that hashcat 1.33 is out now. I'll make a new deb today and upload it for anyone interested. It's a shame it has not been put in the repo yet. That, and the repo has 1.31 for oclhashcat (amd).

and your .deb is superior to the source itself as it is contains the patch. I just find the whole thing quite bizarre. Not your service to the community, but the saga.

Will install everything later, minus the added repos to see if it 1. accepts the headers and 2. if the nVidia driver install with the headers. I could not do both since 1.1.0 came out.

I will also attempt to install everything off-line. If it works I will post all DL links.

Cheers Static!

Quest
2015-02-25, 03:47
===============================CudaHashcat 1.31:
Session.Name...: cudaHashcat
Status.........: Exhausted
Input.Base.....: Mask (?a?a?a?a) [4]
Input.Mod......: File (example.dict)
Hash.Target....: File (example0.hash)
Hash.Type......: MD5
Time.Started...: 0 secs
Time.Estimated.: 0 secs
Speed.GPU.#1...: 41186.6 kH/s
Recovered......: 2190/6494 (33.72%) Digests, 0/1 (0.00%) Salts
Progress.......: 136302297088/136302297088 (100.00%)
Skipped........: 0/136302297088 (0.00%)
Rejected.......: 0/136302297088 (0.00%)
HWMon.GPU.#1...: -1% Util, 65c Temp, -1% Fan

Started: Thu Feb 19 22:09:59 2015
Stopped: Thu Feb 19 22:24:07 2015 <---- = 14mins


===============================CudaHashcat 1.33:

Session.Name...: cudaHashcat
Status.........: Exhausted
Input.Left.....: Mask (?a?a?a?a) [4]
Input.Right....: File (example.dict)
Hash.Target....: File (example0.hash)
Hash.Type......: MD5
Time.Started...: Tue Feb 24 23:59:16 2015 (27 mins, 22 secs)
Time.Estimated.: 0 secs
Speed.GPU.#1...: 83355.9 kH/s <--- wut???
Recovered......: 2190/6494 (33.72%) Digests, 0/1 (0.00%) Salts
Progress.......: 136302297088/136302297088 (100.00%)
Skipped........: 0/136302297088 (0.00%)
Rejected.......: 0/136302297088 (0.00%)
HWMon.GPU.#1...: -1% Util, 71c Temp, -1% Fan

Started: Tue Feb 24 23:59:16 2015
Stopped: Wed Feb 25 00:26:49 2015 <---- = 27mins

:confused:

staticn0de
2015-02-25, 08:54
===============================CudaHashcat 1.31:
Session.Name...: cudaHashcat
Status.........: Exhausted
Input.Base.....: Mask (?a?a?a?a) [4]
Input.Mod......: File (example.dict)
Hash.Target....: File (example0.hash)
Hash.Type......: MD5
Time.Started...: 0 secs
Time.Estimated.: 0 secs
Speed.GPU.#1...: 41186.6 kH/s
Recovered......: 2190/6494 (33.72%) Digests, 0/1 (0.00%) Salts
Progress.......: 136302297088/136302297088 (100.00%)
Skipped........: 0/136302297088 (0.00%)
Rejected.......: 0/136302297088 (0.00%)
HWMon.GPU.#1...: -1% Util, 65c Temp, -1% Fan

Started: Thu Feb 19 22:09:59 2015
Stopped: Thu Feb 19 22:24:07 2015 <---- = 14mins


===============================CudaHashcat 1.33:

Session.Name...: cudaHashcat
Status.........: Exhausted
Input.Left.....: Mask (?a?a?a?a) [4]
Input.Right....: File (example.dict)
Hash.Target....: File (example0.hash)
Hash.Type......: MD5
Time.Started...: Tue Feb 24 23:59:16 2015 (27 mins, 22 secs)
Time.Estimated.: 0 secs
Speed.GPU.#1...: 83355.9 kH/s <--- wut???
Recovered......: 2190/6494 (33.72%) Digests, 0/1 (0.00%) Salts
Progress.......: 136302297088/136302297088 (100.00%)
Skipped........: 0/136302297088 (0.00%)
Rejected.......: 0/136302297088 (0.00%)
HWMon.GPU.#1...: -1% Util, 71c Temp, -1% Fan

Started: Tue Feb 24 23:59:16 2015
Stopped: Wed Feb 25 00:26:49 2015 <---- = 27mins

:confused:

Well,

Thanks.... unique? Unless my math is a bit off :)

I'll have a go when I finally get my pi 2 image to compile and see what I get.

Quest
2015-02-25, 23:35
so needless to say that I reverted back to 1.31 ;)


... in other X-files news ...

- I still have to populate my sources.list file with official repos, to install the headers, or I get this
root@kali:~# apt-get install linux-headers-$(uname -r)
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-headers-3.18.0-kali1-amd64
E: Couldn't find any package by regex 'linux-headers-3.18.0-kali1-amd64'

- but when installed, the NVIDIA driver stops halfway with the message "unable to load kernel modules".

... the good news...

I will edit post#4 https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=35270&viewfull=1#post35270 with a mini howtoo do a OFF-Line installation with all links to the packages.

staticn0de
2015-02-26, 00:06
so needless to say that I reverted back to 1.31 ;)


... in other X-files news ...

- I still have to populate my sources.list file with official repos, to install the headers, or I get this
- but when installed, the NVIDIA driver stops halfway with the message "unable to load kernel modules".

... the good news...

I will edit post#4 https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=35270&viewfull=1#post35270 with a mini howtoo do a OFF-Line installation with all links to the packages.

Good call on reverting. I still haven't tested it.

I suffer huge losses in speed with the newer CUDA myself, not so much anything else.

You must have an out of date repo. The headers install fine for me, without them it is no surprise that your modules won't build.

Go over to the Kali Linux mirror list and manually point at one which had the headers in it. I went looking and found one (I have my own local repo I use) so I often search for the up to date ones to mirror.

Quest
2015-02-26, 00:37
I installed Kali with no Internet connection, so that is why I have to populate the sources.list with official repos. So I don't know what's up with that. I will try some other stuff eventually. Now I'm just sick of reinstalling(though I don't need the guide anymore lolll).

post #4 https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=35270&viewfull=1#post35270 edited with download links. Still will have to test all of it whenever I get sorted out, as I could only test parts of it at a time.

Quest
2015-02-26, 17:06
standby to wrapup another .deb friend http://hashcat.net/forum/thread-4085-post-23493.html#pid23493

Edit:

oye, now moved my posts to http://hashcat.net/forum/thread-4130.html

No fix, as it is "optimized for fast systems" !?

and that's me confused more then ever--------> :confused:

Quest
2015-02-26, 18:43
From the hashcat forum
IOW, replace example.dict with rockyou and everything is fine

Lobster
2015-02-28, 17:43
I'm having the "Unable to load kernel module" error when (trying numerous times) to install my Geforce GT 640M drivers on my laptop.

Attempting to install the driver version 346.47 on kernel 3.18.0, Kali 1.1.0.

I have followed every guide, to the word and freshly installed way to many times to retain 100% of my sanity. Should I wait for a new driver to be produced, or try something else?

Quest
2015-03-01, 01:55
Hi Lobster,

Try again and don't install the linux headers (step #5). It did work for me.

If not then, welcome to the nut house! ;)

staticn0de
2015-03-01, 04:06
Installing the headers should not be an issue. There has been a few posts lately about failed installs and 404 errors with the repos. I'm thinking that a few of the mirrors are out of date and this is causing some partial installs or some failed installs.

The thing about uname -r to install a kernel is that is checks the current running kernel and installs the header based on that.

if you updated from an older kernal and didn't reboot, the command linux-headers-$(uname -r) will install the headers for the older kernel.

What do you see if you run any of the following

apt-get install --dry-run linux-headers-3.18.0-kali1-amd64
apt-cache search linux-headers

Quest
2015-03-01, 16:28
root@kali:~# apt-get install --dry-run linux-headers-3.18.0-kali1-amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-headers-3.18.0-kali1-amd64 is already the newest version.
linux-headers-3.18.0-kali1-amd64 set to manually installed.
The following package was automatically installed and is no longer required:
libafpclient0
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.



root@kali:~# apt-cache search linux-headers
linux-headers-3.18.0-kali1-all - All header files for Linux 3.18 (meta-package)
linux-headers-3.18.0-kali1-all-amd64 - All header files for Linux 3.18 (meta-package)
linux-headers-3.18.0-kali1-amd64 - Header files for Linux 3.18.0-kali1-amd64
linux-headers-3.18.0-kali1-common - Common header files for Linux 3.18.0-kali1
linux-headers-amd64 - Header files for Linux amd64 configuration (meta-package)


I'm thinking about butting out and jump a version or two untill 2.0 ... Anyways let me know if you want me to checkout anything friend :)

staticn0de
2015-03-02, 12:59
I ran into that "Unable to load kernel module" from the NVIDIA installer (completely randomly)

Looks like it's an issue with the installer not unloading the nouveau module.

Unload it yourself after stopping the gdm3 service with:

modprobe -r nouveau

and then run

./NVIDIA-Linux-x86_64-346.47.run --dkms -Z (note the big Z)

Quest
2015-03-03, 00:16
Works :cool:

I should have known. Especially since the NVIDIA install was warning me(sometimes) about nouveau.

That unsolved mystery solved, what is your take on the new cudaHashcat? I'm very skeptical about the makers(atom) claim that it works better and that everything is "fine", when the benchmark takes twice as long as before.

If anyone has comparative benchmark(any) between 1.31 and 1.33 please share. Still waiting for anyone saying that 1.33 runs better than 1.31 :confused:

staticn0de
2015-03-03, 02:50
Works :cool:

I should have known. Especially since the NVIDIA install was warning me(sometimes) about nouveau.

That unsolved mystery solved, what is your take on the new cudaHashcat? I'm very skeptical about the makers(atom) claim that it works better and that everything is "fine", when the benchmark takes twice as long as before.

If anyone has comparative benchmark(any) between 1.31 and 1.33 please share. Still waiting for anyone saying that 1.33 runs better than 1.31 :confused:

Here is my comparision



cudahashcat 1.31 example wordlist.

Session.Name...: cudaHashcat
Status.........: Exhausted
Input.Base.....: Mask (?a?a?a?a) [4]
Input.Mod......: File (example.dict)
Hash.Target....: File (example0.hash)
Hash.Type......: MD5
Time.Started...: 0 secs
Time.Estimated.: 0 secs
Speed.GPU.#1...: 62193.8 kH/s
Recovered......: 2190/6494 (33.72%) Digests, 0/1 (0.00%) Salts
Progress.......: 136302297088/136302297088 (100.00%)
Skipped........: 0/136302297088 (0.00%)
Rejected.......: 0/136302297088 (0.00%)
HWMon.GPU.#1...: -1% Util, 70c Temp, -1% Fan

Started: Tue Mar 3 13:18:58 2015
Stopped: Tue Mar 3 13:25:21 2015


cudahashcat 1.33

Session.Name...: cudaHashcat
Status.........: Exhausted
Input.Left.....: Mask (?a?a?a?a) [4]
Input.Right....: File (example.dict)
Hash.Target....: File (example0.hash)
Hash.Type......: MD5
Time.Started...: Tue Mar 3 13:28:33 2015 (12 mins, 15 secs)
Time.Estimated.: 0 secs
Speed.GPU.#1...: 185.8 MH/s
Recovered......: 2190/6494 (33.72%) Digests, 0/1 (0.00%) Salts
Progress.......: 136302297088/136302297088 (100.00%)
Skipped........: 0/136302297088 (0.00%)
Rejected.......: 0/136302297088 (0.00%)
HWMon.GPU.#1...: -1% Util, 66c Temp, -1% Fan

Started: Tue Mar 3 13:28:33 2015
Stopped: Tue Mar 3 13:40:52 2015


Decent difference there. It's clear that 1.31 is much faster than 1.33.

I'm using CUDA 6.0 and the latest NVIDIA driver (I get better performance on the older CUDA)

I'll put the 1.31 link back up again.

Lobster
2015-03-03, 13:01
Thank you staticn0de & Quest, I got it installed and it was the nouveau module causing the problem, I appreciate the help greatly.

I can now concentrate on obtaining my sanity once again!

Quest
2015-03-03, 14:52
atom basically says that 1.33 is faster in real life. When pointed out that a benchmark IS real life, he replied that it's just a script. Unfortunately I was never successful cracking a .hccap file with cudaHashcat, so I cannot compare the two versions. If someone does have such comparative sessions please post. I asked over at http://hashcat.net/ for anyone to post comparative benchmarks. No one did.

Ok you have me doubting about 6.5 now. What is your benchmark to test CUDA? The one we usually do with the "Result = PASS" ?

Quest
2015-03-03, 15:26
but wait... now that everything seems to be back to normal for installing the headers and NVIDIA, the GRUB boot menu has 4 entries..


Kali GNU/Linux, with Linux 3.18.0-kali3-amd64
Kali GNU/Linux, with Linux 3.18.0-kali3-amd64 (recovery mode)
Kali GNU/Linux, with Linux 3.18.0-kali1-amd64
Kali GNU/Linux, with Linux 3.18.0-kali1-amd64 (recovery mode)

can anyone point me to the form to signup for the nut house please?

Quest
2015-03-03, 15:55
Record what you need now. If you don't get a login screen when you close gdm3, press [Ctrl]+[Alt]+[F1]

/etc/init.d/gdm3 stop
Unload the Nouveau module after stopping the gdm3 service with:

modprobe -r nouveau
Now the NVIDIA install.
cd ~

./NVIDIA*.run --dkms -Z<--Cap [Z]



- Accept the EULA
- Nouveau disabled Yes
- Files written Ok
- Register the kernel Yes
- WARNING 32-bit libraries Ok
- Install the libvdpau libraries Ok
…the install will take place
x Run the nvidia-xconfig No
- Installation complete Ok


shutdown -r now or [Ctrl]+[Alt]+[Del]

staticn0de
2015-03-04, 02:45
but wait... now that everything seems to be back to normal for installing the headers and NVIDIA, the GRUB boot menu has 4 entries..



can anyone point me to the form to signup for the nut house please?

No need for the nut house, run the following to remove the older entries.



apt-get remove --purge linux-headers-3.18.0-kali1-amd64 linux-headers-3.18.0-kali1-common linux-image-3.18.0-kali1-amd64

Quest
2015-03-06, 19:35
https://hashcat.net/forum/thread-4161.html


How to deal with small wordlists

With oclHashcat v1.32 we added the AMP kernel that compute the password candidates on GPU. That had one advantage and one disadvantage.

The advantage was that you can now get full cracking speed even for the faster ones of the slow hashes like md5crypt because there's no bottleneck on the candidate generator engine.

...


http://hashcat.net/forum/thread-4162.html


I've reproduced the case, it's actually slower. Thanks for reporting!

But no worries, I already found the reason and fixed it. The bitmaps were optimized to run faster on a different hashlist size (much smaller one), but I an see that hashlist size around 500k is what we deal most of the time.

so i dunno. Confusing. Went from "everything is normal" to "actually slower". Hopefully they will get it sorted out with 1.34

freestaff
2015-03-07, 13:13
modprobe -r nouveau
FATAL: nouveau is in use

how can i ?

Quest
2015-03-15, 02:45
so v1.1.0a solved all my kernel problems. All is back to normal.

Now we seem to have a new error message after running modprobe -r nouveau (with gdm3 being shut down)..


[ 872.758616] nouveau E[ PFIFO] [0000:01:00.0] SCHED_ERROR [ UNK00 ]
[ 872.758698] nouveau E[ PFIFO] [0000:01:00.0] ...
... no consequence though. Everything installed :cool:



- Post#4 (off-line install) is good.
- Waiting for cHc 1.34. No one has reported better performances under 1.33 so that's an X-file :confused:

Quest
2015-03-16, 02:03
...in the latest news...

no one knows how to install or run maskprocessor/linux over @ http://hashcat.net/forum/ :D and their wiki is useless.

If anyone knows how to install maskprocessor in kali, let me know.

staticn0de
2015-03-16, 04:03
Hey quest, what fails for you when you try and install?

Quest
2015-03-16, 05:02
hi friend!

actually it's not to install it(like previously thought), but it's a dependency problem..


:~# cd /usr/share/cudahashcat/ && ./mp64.bin -q 3 -r 4 ?d?d?d?d?d?d?d?d?d?dreturns

./mp64.bin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./mp64.bin)

further inquiry indicates that wheezy uses 2.13. So I will try to modify my sources.list with a jessie repo to get libc6_2.19-15_amd64.deb and libc6-dev_2.19-15_amd64.deb, because to install those package manually got ugly.

I thought I was out of the woods with 1.1.0a... Never a dull moment i tell ya.

staticn0de
2015-03-16, 05:23
Try my custom deb:

https://mega.co.nz/#!NIslBaaL!tHP5tIWyU09gaXh6VBVcX_1AyOrJvEnq8LzoEHI ape8

test it with

mp64 -q 3 -r 4 ?d?d?d?d?d?d?d?d?d?d

Quest
2015-03-16, 05:34
it works, but why is it, if I move the mp64.bin into the cudahashcat dir I get this..


~# cd /usr/share/maskprocessor-0.73 && ./mp64.bin -q 3 -r 4 ?d?d?d?d?d?d?d?d?d
./mp64.bin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./mp64.bin)

That's my problem.

staticn0de
2015-03-16, 05:37
Why are you moving it into a new directory? The directory "cd /usr/share/maskprocessor-0.73" is not where that deb installs it

I move my mp64.bin file all over the place and it works fine each time. I compiled it with the kali native glibc.

If you are seeing that error, are you sure that you are using the file from my deb, and not the binary you can download off the web?

Quest
2015-03-16, 13:35
what I'm trying to do:

markov chains is very efficient at creating words, but still spews out things like "arocassse" or with numbers "aroca7999". The odds of 3 repetitions for a human generated password are slim to none. I'm trying to eliminate those useless words using maskprocessor with the arguments '-q' and '-r' as those options are not included with cudahashcat.

-q 3 = no more than 1 repetition. Ex: aa
-r 4 = no more than 3 of the same char. Ex: aXaXa

ok so it's pretty simple, but when trying to pipe maskprocessor in cudahashcat it doesn't work in linux.

One solution proposed was to place mp64 in the cudahashcat dir. That is why I was trying that.

That was my original syntax, and since I've tried many..

cd /usr/share/cudahashcat/usr/share/maskprocessor && ./mp64.bin -q 3 -r 4 ?d?d?d?d?d?d?d?d?d?d | cd /usr/share/cudahashcat/ && ./cudaHashcat64.bin -w 3 -t 10 -m 2500 /root/capture.hccap -a 3

staticn0de
2015-03-17, 05:20
what I'm trying to do:

markov chains is very efficient at creating words, but still spews out things like "arocassse" or with numbers "aroca7999". The odds of 3 repetitions for a human generated password are slim to none. I'm trying to eliminate those useless words using maskprocessor with the arguments '-q' and '-r' as those options are not included with cudahashcat.

-q 3 = no more than 1 repetition. Ex: aa
-r 4 = no more than 3 of the same char. Ex: aXaXa

ok so it's pretty simple, but when trying to pipe maskprocessor in cudahashcat it doesn't work in linux.

One solution proposed was to place mp64 in the cudahashcat dir. That is why I was trying that.

That was my original syntax, and since I've tried many..

cd /usr/share/cudahashcat/usr/share/maskprocessor && ./mp64.bin -q 3 -r 4 ?d?d?d?d?d?d?d?d?d?d | cd /usr/share/cudahashcat/ && ./cudaHashcat64.bin -w 3 -t 10 -m 2500 /root/capture.hccap -a 3

Works here with the following syntax. Also, I saw your other thread about handshakes and I captured mine as soon as the deauth packet was sent so I don't know why you are having problems.



root@kali ~$ mp64 -q 3 -r 4 ?d?d?d?d?d?d?d?d?d?d | optirun cudahashcat64 -m 2500 ~/out.hccap 2 ↵
cudaHashcat v1.31 starting...

Device #1: GeForce GT 740M, 2047MB, 1032Mhz, 2MCU
Device #1: WARNING! Kernel exec timeout is not disabled, it might cause you errors of code 702

Hashes: 1 hashes; 1 unique digests, 1 unique salts
Bitmaps: 8 bits, 256 entries, 0x000000ff mask, 1024 bytes
Rules: 1
Applicable Optimizers:
* Zero-Byte
* Single-Hash
* Single-Salt
Watchdog: Temperature abort trigger set to 90c
Watchdog: Temperature retain trigger set to 80c
Device #1: Kernel ./kernels/4318/m02500.sm_35.64.ptx
Device #1: Kernel ./kernels/4318/bzero.64.ptx

Starting attack in stdin mode...


Session.Name...: cudaHashcat
Status.........: Running
Input.Mode.....: Pipe
Hash.Target....: TESTROUTER IM:AM:AC:AD:DR <-> SE:CE:RE:T:MA:CC)
Hash.Type......: WPA/WPA2
Time.Started...: Tue Mar 17 16:14:19 2015 (9 secs)
Speed.GPU.#1...: 15393 H/s
Recovered......: 0/1 (0.00%) Digests, 0/1 (0.00%) Salts
Progress.......: 151552
Skipped........: 0
Rejected.......: 0
HWMon.GPU.#1...: -1% Util, 71c Temp, -1% Fan


Session.Name...: cudaHashcat
Status.........: Running
Input.Mode.....: Pipe
Hash.Target....: TESTROUTER IM:AM:AC:AD:DR <-> SE:CE:RE:T:MA:CC)
Hash.Type......: WPA/WPA2
Time.Started...: Tue Mar 17 16:14:19 2015 (19 secs)
Speed.GPU.#1...: 15435 H/s
Recovered......: 0/1 (0.00%) Digests, 0/1 (0.00%) Salts
Progress.......: 303104
Skipped........: 0
Rejected.......: 0
HWMon.GPU.#1...: -1% Util, 75c Temp, -1% Fan

Session.Name...: cudaHashcat
Status.........: Aborted
Input.Mode.....: Pipe
Hash.Target....: TESTROUTER IM:AM:AC:AD:DR <-> SE:CE:RE:T:MA:CC)
Hash.Type......: WPA/WPA2
Time.Started...: Tue Mar 17 16:14:19 2015 (24 secs)
Speed.GPU.#1...: 15420 H/s
Recovered......: 0/1 (0.00%) Digests, 0/1 (0.00%) Salts
Progress.......: 352256
Skipped........: 0
Rejected.......: 0
HWMon.GPU.#1...: -1% Util, 68c Temp, -1% Fan

Started: Tue Mar 17 16:14:19 2015
Stopped: Tue Mar 17 16:14:43 2015

g0tmi1k
2015-03-17, 09:46
Great guide - keep up the good work.

upinarms247365
2015-03-17, 22:34
I have a new system that I plan to run the latest Kali 1.1.0, which has installed the GeForce GTX 970. This guide looks like a great reference for getting started, but considering this isn't a laptop with Optimus enabled I'm not sure this will work for me. I tried following blackmoreops instructions http://www.blackmoreops.com/2015/02/12/kali-linux-1-1-0-kernel-3-18-install-proprietary-nvidia-driver/#comment-2758 , but keep getting a solid black screen w/o the cursor after my reboot (see comments in the link for reference to my comments there).

Has anyone been successful on a non-optimus with these instructions or have a different resource for the proper instructions? My Google-foo did not produce anything worth-while.

Quest
2015-03-18, 03:37
Great guide - keep up the good work.:)


Works here with the following syntax.
yes and thanks. Basically I was trying to make it do something that it was not supposed to do, which is to keep the '-t' argument and limit char recurrence with 'r' and 'q'. That failed. The rest of my problems were just me having another linux esoteric experience.


Also, I saw your other thread about handshakes.. that's another can of worms. Just read the last post from mmusket33. He's having a linux paranormal experience of his own :D

meh, it's interesting, and the nurses here in the nuthouse are nice..

staticn0de
2015-03-19, 09:26
I have a new system that I plan to run the latest Kali 1.1.0, which has installed the GeForce GTX 970. This guide looks like a great reference for getting started, but considering this isn't a laptop with Optimus enabled I'm not sure this will work for me. I tried following blackmoreops instructions http://www.blackmoreops.com/2015/02/12/kali-linux-1-1-0-kernel-3-18-install-proprietary-nvidia-driver/#comment-2758 , but keep getting a solid black screen w/o the cursor after my reboot (see comments in the link for reference to my comments there).

Has anyone been successful on a non-optimus with these instructions or have a different resource for the proper instructions? My Google-foo did not produce anything worth-while.

Hi there,

I don't have any nvidia cards in my desktop installs so I can't write a guide for you.

It should be much the same. As in, update fully, Install Kali Linux headers, chmod the nvidia installer, install the driver and then actually run nvidia-xconfig.

Include the - - dkms and - Z flag on the installer.

Edit: I had a look at BMO guide, without checking it is possible that the drivers from the repo are too old for your modern card.

Hit control + all + f2 for another console and check dmesg when it tries to load your nvidia module.

Otherwise, grab the nvidia installer from the nvidia website like the guide here uses.

Quest
2015-03-21, 20:30
1.34 http://hashcat.net/oclhashcat/ :)

ZeroTrace
2015-03-21, 21:11
Hello, I'm having some issues that I'm not entirely sure are actual issues. I've followed the install procedure to the letter, and glxspheres64 runs without issue. However When I reach the final step I reach an impasse. I've created a pastebin account, and did the troubleshooting steps (find it here: http://pastebin.com/cwpA6XNz )

Hardware:
Lenovo ideapad y580
Intel HD4000 integrated
Nvidia gtx 660M
Intel I7 quad core 64 bit

I'm assuming I could continue with the optional installs, however I'm loathe to continue without having dealt with the errors. Any assistance would be appreciated greatly.

Thank you

ZeroTrace
2015-03-21, 21:59
*Couldn't delete*

ZeroTrace
2015-03-21, 22:01
*Couldn't delete*

staticn0de
2015-03-21, 23:13
Great guide - keep up the good work.

Thanks g0tmi1k, I do appreciate the comment.

staticn0de
2015-03-21, 23:13
1.34 http://hashcat.net/oclhashcat/ :)

Thanks for linking Quest, I'm uploading a new deb now.

Edit:

Uploaded:

https://mega.co.nz/#!0Z9DHBob!0QA3clJqszGEExTKlKTBPLJEoDvXIiBwBepiYgW Zbew

MD5
e611e16ab1f3c42c5e98d3ef615a0cd4

Quest
2015-03-22, 03:31
well thank you...

Are you sitting down right now? http://hashcat.net/oclhashcat/

:p

staticn0de
2015-03-22, 03:40
well thank you...

Are you sitting down right now? http://hashcat.net/oclhashcat/

:p

And.... done! again.

On the plus side, I changed the compression type and reduced the file size by 20% which is awesome.

https://mega.co.nz/#!dN8ESI7D!-jxoTZBwVddzKZ2r0MuQ5T4sDJZ5NSOnkrNvxpDuNNg

md5sum

ccdc7ebf4c4a947d14fa663a982e3c10

Quest
2015-03-22, 11:05
xD

AH YES 100mb smaller! Downloading now. :cool: Thank you.

TheSeed
2015-03-22, 18:17
Hey, I have a problem with installing CUDA. I'm trying this with package for ubuntu 14.04 and 12.04 but for both I got the same warning massage:

***WARNING: Incomplete installation! This installation did not install the CUDA Driver. A driver of version at least 346.00 is required for CUDA 7.0 functionality to work.
To install the driver using this installer, run the following command, replacing <CudaInstaller> with the name of this run file:
sudo <CudaInstaller>.run -silent -driver


You wrote to grab x64 package, but in table i see only Linux x86, maby thats the point.
There is my test

Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: GeForce GT 740M/PCIe/SSE2
253.956557 frames/sec - 213.506356 Mpixels/sec
253.252170 frames/sec - 212.914165 Mpixels/sec
254.893954 frames/sec - 214.294445 Mpixels/sec
254.001783 frames/sec - 213.544379 Mpixels/sec
254.973161 frames/sec - 214.361036 Mpixels/sec
254.204086 frames/sec - 213.714460 Mpixels/sec
254.366610 frames/sec - 213.851096 Mpixels/sec
254.329671 frames/sec - 213.820041 Mpixels/sec
253.751591 frames/sec - 213.334037 Mpixels/sec
254.276085 frames/sec - 213.774990 Mpixels/sec


There is my modinfo

filename: /lib/modules/3.18.0-kali3-amd64/kernel/drivers/video/nvidia.ko
alias: char-major-195-*
version: 346.47
supported: external
license: NVIDIA
alias: pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias: pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias: pci:v000010DEd*sv*sd*bc03sc02i00*
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
depends: drm,i2c-core
vermagic: 3.18.0-kali3-amd64 SMP mod_unload modversions
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
parm: NVreg_ModifyDeviceFiles:int
parm: NVreg_DeviceFileUID:int
parm: NVreg_DeviceFileGID:int
parm: NVreg_DeviceFileMode:int
parm: NVreg_RemapLimit:int
parm: NVreg_UpdateMemoryTypes:int
parm: NVreg_InitializeSystemMemoryAllocations:int
parm: NVreg_UsePageAttributeTable:int
parm: NVreg_MapRegistersEarly:int
parm: NVreg_RegisterForACPIEvents:int
parm: NVreg_CheckPCIConfigSpace:int
parm: NVreg_EnablePCIeGen3:int
parm: NVreg_EnableMSI:int
parm: NVreg_MemoryPoolSize:int
parm: NVreg_RegistryDwords:charp
parm: NVreg_RmMsg:charp
parm: NVreg_AssignGpus:charp


I checked gcc version:
gcc (Debian 4.7.2-5) 4.7.2
So i should be abble to run this 12.04 package.

I'm w8ing for your opinions about this problem and hope some solutions.

staticn0de
2015-03-23, 10:19
Hey, I have a problem with installing CUDA. I'm trying this with package for ubuntu 14.04 and 12.04 but for both I got the same warning massage:

***WARNING: Incomplete installation! This installation did not install the CUDA Driver. A driver of version at least 346.00 is required for CUDA 7.0 functionality to work.
To install the driver using this installer, run the following command, replacing <CudaInstaller> with the name of this run file:
sudo <CudaInstaller>.run -silent -driver


Hi there and welcome to the forum.

I'm taking a wild guess that you are trying to install the latest CUDA (version 7). Did you happen to use this link?

http://developer.download.nvidia.com/compute/cuda/7_0/Prod/local_installers/cuda_7.0.28_linux.run

CUDA can't find the version of the driver you currently have installed.

Did you follow the message provided by the installer?

You don't want to use the --driver flag as it will already be installed if you followed the guide.

I haven't downloaded the CUDA 7.0 installer yet (it's going now). Try the --help flag on your cuda*.run installer and look for a flag that will disable the driver check.

If you can't find one, --override should do it.

Edit: If you see that message at the end of the install (as in CUDA has installed samples and all that goodness) just ignore the message. You didn't really post what you were doing at the time so I'm not sure how to help.

TheSeed
2015-03-23, 15:31
Thanks, staticn0de, for respond. Sorry for uncomplet description of problem, I'm going to suplement this now.


I'm taking a wild guess that you are trying to install the latest CUDA (version 7). Did you happen to use this link?

http://developer.download.nvidia.com...0.28_linux.run

CUDA can't find the version of the driver you currently have installed.

Did you follow the message provided by the installer?

You don't want to use the --driver flag as it will already be installed if you followed the guide.

I haven't downloaded the CUDA 7.0 installer yet (it's going now). Try the --help flag on your cuda*.run installer and look for a flag that will disable the driver check.

If you can't find one, --override should do it.

Yes, I was running exactly step by step through your guide till moment of CUDA installation. And I'm trying to do so with latest (cuda-7.0). Now with installer from your link. I understand that i don't need to use --driver. I was looking for flag to disable the driver check, but i didn't find any. Also tried --override, but this didn't help me.


Edit: If you see that message at the end of the install (as in CUDA has installed samples and all that goodness) just ignore the message. You didn't really post what you were doing at the time so I'm not sure how to help.

Yes, this message appears at the end of installation. I'm new in useing CUDA technology, so for me message: "This installation did not install the CUDA Driver." is critical, and i received "CUDA Driver" as critical part of installation, meaning, for me, that I can't use this technology. So I started to find the way out.
But if you suggests me to ignore this message, as it appears at the end of installation informations, I'll set up dynamic linker for CUDA and try to build some samples to check it out.

I'll notify the results here soon.

staticn0de
2015-03-24, 18:39
No worries TheSeed.

You don't need CUDA to ins the driver as we already installed it. All we need from CUDA is the toolkit and the samples.

ZeroTrace
2015-03-25, 05:32
Sorry guys, didn't realize there was moderator approval for posts and didn't mean to post 3 times. lesson learned lol

Ramrsoccer
2015-03-26, 04:07
I'm a very new to linux and am trying to learn i have some of the basics down and an ready to go in to more "harder" territories. I have been trying to get this to work for about 4 days and have reinstalled kali about 7 times because i just couldn't get past it.
I followed this guide and actually got GDM3 to work, (unkike other times i have tried), after installing i installed pyrit, and tried to use it, At first i used the pyrit benchmark but i saw my speeds were slower than my aircrack speeds, this puzzled me because i saw people getting hudge speeds with far less advanced GPU than mine. (I am using a GTX 860m, with 640 Cuda cores)
http://pastebin.com/DScfwXAJ
Any suggestions? I'm coming to my wits end.

Rarity
2015-03-28, 22:12
staticn0de, not sure if I can thank you enough for all the effort you put into this.

Out of curiosity, is there a way to perform these installations without breaking the Intel driver (https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=40188&viewfull=1#post40188) as bahha pointed out?
(And maybe update his method of how to fix it?)

Thanks!

staticn0de
2015-03-29, 03:22
I'm a very new to linux and am trying to learn i have some of the basics down and an ready to go in to more "harder" territories. I have been trying to get this to work for about 4 days and have reinstalled kali about 7 times because i just couldn't get past it.
I followed this guide and actually got GDM3 to work, (unkike other times i have tried), after installing i installed pyrit, and tried to use it, At first i used the pyrit benchmark but i saw my speeds were slower than my aircrack speeds, this puzzled me because i saw people getting hudge speeds with far less advanced GPU than mine. (I am using a GTX 860m, with 640 Cuda cores)
http://pastebin.com/DScfwXAJ
Any suggestions? I'm coming to my wits end.

Hi there,

If the driver installed correctly and you don't get errors I would need to see your aircrack and pyrit speeds. Have you tried asking on the aircrack or pyrit forums?

staticn0de
2015-03-29, 03:23
staticn0de, not sure if I can thank you enough for all the effort you put into this.

Out of curiosity, is there a way to perform these installations without breaking the Intel driver (https://forums.kali.org/showthread.php?21956-(Guide)-Installing-Nvidia-Bumblebee-CUDA-for-Optimus-enabled-Laptops&p=40188&viewfull=1#post40188) as bahha pointed out?
(And maybe update his method of how to fix it?)

Thanks!

I've never had the Intel driver break. Have you tried this install with Kali 1.1.0?

Have you had the driver break on you? if it does, please post output from dmesg

staticn0de
2015-03-29, 03:27
Hello, I'm having some issues that I'm not entirely sure are actual issues. I've followed the install procedure to the letter, and glxspheres64 runs without issue. However When I reach the final step I reach an impasse. I've created a pastebin account, and did the troubleshooting steps (find it here: http://pastebin.com/cwpA6XNz )

Hardware:
Lenovo ideapad y580
Intel HD4000 integrated
Nvidia gtx 660M
Intel I7 quad core 64 bit

I'm assuming I could continue with the optional installs, however I'm loathe to continue without having dealt with the errors. Any assistance would be appreciated greatly.

Thank you

Try editing your /etc/default/grub file to include this line (it will already be there but update it so it matches)

GRUB_CMDLINE_LINUX_DEFAULT="quiet rcutree.rcu_idle_gp_delay=1"

and then run "update-grub" and restart

Rarity
2015-03-29, 06:38
I've never had the Intel driver break. Have you tried this install with Kali 1.1.0?

Have you had the driver break on you? if it does, please post output from dmesg

Yes, I just performed the install on 1.1.0a before posting this. Optirun works as it should but when I run glxgears I get this error:


Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
dmesg output:

[ 9760.524958] nvidia 0000:01:00.0: irq 38 for MSI/MSI-X
[ 9760.526928] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140926/nsarguments-95)
[ 9760.526970] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140926/nsarguments-95)
[ 9760.526993] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140926/nsarguments-95)
[ 9760.527013] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140926/nsarguments-95)
[ 9760.527033] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140926/nsarguments-95)
[ 9760.527053] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140926/nsarguments-95)
[ 9760.527085] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140926/nsarguments-95)
[ 9760.527105] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140926/nsarguments-95)
[ 9760.527451] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140926/nsarguments-95)
[ 9760.711896] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140926/nsarguments-95)

staticn0de
2015-03-29, 07:05
@Rarity

What are the contents of your /etc/bumblebee/xorg.conf.nvidia file?

Do you have any other monitors connected to your laptop?

Toggle bumblebee with the following and post dmesg

# tee /proc/acpi/bbswitch <<<OFF
# tee /proc/acpi/bbswitch <<<ON

Did you use option glxspheres?

What version of CUDA are you running?

Ramrsoccer
2015-03-30, 00:24
My aircrack was approximately 3,000 K/s, and then the pyrit was appoxamatly 1,000 PMk/s

HackerChai
2015-04-04, 04:01
Hi staticn0de, I have ran into a similar problem but your solution did not seem to resolve it.

As I got the error "Unable to load kernel module", I decided to load the module myself which resulted in this:

modprobe -vv nvidia

insmod /lib/modules/3.18.0-kali3-amd64/kernel/drivers/video/nvidia.ko
libkmod: INFO ../libkmod/libkmod-module.c:829 kmod_module_insert_module: Failed to insert module '/lib/modules/3.18.0-kali3-amd64/kernel/drivers/video/nvidia.ko': No such device
ERROR: could not insert 'nvidia': No such device
libkmod: INFO ../libkmod/libkmod.c:319 kmod_unref: context 0x7f7bcd4a22c0 released

Do you have any idea what is wrong? :confused: I have succeeded installing nvidia before so I think this is not a problem with having the wrong installer.

HackerChai
2015-04-04, 04:26
Ignore this duplicate