View Full Version : ETA on OTG N7 2013 fix

2014-09-26, 17:55
Hey guys
Great effort on nethunter just wandering when the hotfix/patch will come out to fix the reboot when the OTG cable is plugged into N7 2013 model


Just an update on this
When i plug in my alfa it restarts my system
Ive tried various cables, some restart some dont
The ones that dont ,don't even detect the alfa even with lsusb.or airmon command


2014-09-30, 21:10
Same problem for me... no 2013 wifi

It reboots using alfa awus036h ... no problem with a tplink wifi dongle.

My OTG Y cable isn't charging too... don't know if the problem is related to OTG driver

2014-10-01, 11:56
There's no ETA on this. You can find a walk-around here - https://forums.kali.org/showthread.php?22975-system-crashes-on-usb-wifi-unplug

2014-10-01, 12:23

In order for the tablet not to freeze and reboot before you unplug the Wifi dongles, close all the processes that are using the wifi (e.g airodump, aireplay and so on) and issue "ifconfig wlanX down"

It worked for me

2014-10-01, 12:27

I made some other tests today about the reboot problem when using Wifi. I came to conclusion that the problem is also occurring when you are using a not suitable power supply.
My test was done as follows: N7-2013 + Alfa RTL8187 chipset + a not stable power supply.
The wifi was switched to monitor mode and I made a WPS attack.
When the wifi started to send packets the N7 did reboot due the insufficient power to supply to Alfa.

2014-10-01, 17:49
Agreed I was using a powersupply kind of like this one http://www.scan.co.uk/products/lms-data-3000mah-mobile-power-bank-usb-portable-charger-black - it was very unstable and rebooting a whole bunch - it was actually more stable without the power pack (I was using an Alfa too).

2014-10-02, 03:38
This is a currently known problem on MSM (flo/deb) kernel branch mr2 and mr1. It was previously working on mr0 but there was a switch to new wifi firmware which may be related to the problem.

At the moment we are still researching the issue when time permits. No ETA at the moment but some work arounds are mentioned above that may help.

2014-10-05, 04:19

This is a currently known problem on MSM (flo/deb) kernel branch mr2 and mr1. It was previously working on mr0 but there was a switch to new wifi firmware which may be related to the problem.

At the moment we are still researching the issue when time permits. No ETA at the moment but some work arounds are mentioned above that may help.

While some users are getting "different results" using the above workarounds;there is always pretty normal spotty behavior like this;and it is definitely as you have stated.Software not hardware, and definitely not related to power/voltage. It is not a problem directly caused by any specific wifi interface or other steps taken. Most of the interfaces I have connected to the n7 so far do not even make it to a voluntary reboot or disconnect, they cause reboot with some randomness; and then usually just bootloop after the first reboot.

I did a few tests and did not use the Y-Cable most users have been trying to maybe eliminate a few "unknown" factors. Instead just using a standard OTG-Usb Female connector. I have tried with standard alfa Awus036H. multiple cable connection setups. Linksys AE1200 Usb-Ethernet wireless card. (not supported, I know) and this also induces bootloop, and with no driver and definitely not because it is voltage hungry like the alfas. I then checked another USB-Ethernet interface Belkin Mimo G with Ralink 2573 USB RT73usb. Same lockup, reboot and bootloop pattern as the others. I also connected the JuicePack battery for my Pineapple to the Alfa when using the stock Y 2 usb male connector cable, and it did the same thing. This is not a question of power/voltage drawn by the devices. Could it be increased resistance caused by the cables we are all using? Seems like a *very* long shot. I tested using every available and sometimes laughable cabling "flow" I could in the 3 above tests. Connected an Iphone 4s to it and it did not cause any rebooting, no matter how unceremoniously it was unplugged from the N7. Of those 3 devices, only the iphone would be considered remotely close to the Alfa in power demanded.

2014-10-06, 06:59

I don't think it's a cabling or voltage issue. The problem, I believe, comes from the network stack. If you were to plug in a regular usb thumb drive OTG is fine. It seems that 4.4.3+ does not play well with OTG network devices. It will however play fine on kitkat 4.4.2. The only thing I can see that changed on the network side is the PRIMA firmware related to the wifi card.

But I could also be completely wrong and I'm open to ideas.

2014-10-10, 07:10
Do we think it is worth flashing backwards to 4.4.2 and then installing Nethunter to see if there are the same power/rebooting issues? If so I am game. Three votes for yes and I'm on it. First post so I gotta say thank to all the people that have worked to make this distro happen. In spite of these random issues I am totally loving it.

2014-10-13, 19:30
wwflynndo - That was something debated on. I'm curious to see if these issues will be resolved with Android L. For now we are not looking to go backwards, but it's possible.

2014-10-15, 14:02
Same problem for me... no 2013 wifi

It reboots using alfa awus036h ... no problem with a tplink wifi dongle.

My OTG Y cable isn't charging too... don't know if the problem is related to OTG driver

I am also having the same issue with Nexus 7 2013 wifi not reporting charging but it seems like it is and have had reboots when removing power from the OTG cable but leaving my TP Link dongle plugged in.

2014-10-19, 22:12
In the process of flashing to 4.4.2 on Nexus 7 2013 Wifi, I face issues with the external wifi except it reboots simply launching wifite with the alfa plugged it. This could be an issue caused by a cheaply made otg-y cable from amazon. I have made otg-y cables in the past with regular otg cables but this was before nethunter and I could never get the kernel/pwnpad to accept the y cable as connected let alone any otg devices.

Will update when everything has been tied up and tested.

2014-10-19, 22:52
4.4.2 doesn't reboot the nexus 7 2013 upon disconnect, however, whether it my power block or my shotty OTG-y cable, it does not stay connected for very long. I am able to see the "Bus 001 Device 002: ID obda:8187 Realtek......RTL8187" when I use lsusb and iwcconfig shows wlan0 only a few seconds when the external power has just been connected. If I use a wall block for the power source the alfa 036h actually lights up for a second before being disconnected.

Ill keep tinkering.

2014-10-22, 16:38
I have been having the same issue with my Alfa. I have a TP link tl-722n that works happily on nethunter, at least until my tablet decides to reboot...

2014-10-23, 14:14
Some additional observations:

4.4.2 on Nexus 7 + NH - OTG disconnect does not present itself but native (i.e. built-in) WiFi does not work upon NH install at all. Not an option.
4.4.3/4 on Nexus 7 + NH - OTG disconnect issue is present. The workaround to do an "ifconfig wlan1 down" and wait for 10 secs or so does not work for me. Bump.

2014-10-24, 19:44
I noticed this as well, but putting the interface down didn't seem to help for me on 4.4.4. I will have to give it a try again and see if waiting for longer does the trick. The thing that kills me is when I accidentally bump my otg cable enough to 'disconnect' it. Crossing my fingers that this is resolved in Android L!

2014-11-28, 21:52
I have troubleshooted this issue with the nexus 7 and the alfa.... I have figured out it is a power issue causing the device to reboot.... it cant crank enough power for the alfa and s**t's itself.... basically when I try to use OTG cables that inject power with the nexus I have no luck.... I have tried several diff brands of cable... what I was able to figure out was that if i took a regular usb otg cable and a split usb cable (one with two usb ends) I can inject power that way... it actually charges the tablet as well and the device does not reboot and completes its attacks....
since its not really ideal to have it pluged into the corner of the wall in some spot.... I tried using a USB external power bank and was able to get successful results that way as well (it outputs at 5v 1000ma... have not tested with 500ma stuff) the only thing is it still reboots after unhooking the alfa and that I have yet to look into.... hope this was helpful.

2014-12-01, 21:13
I'm using the Nexus 7 2013 too.

I got some stability out of my Alfa cards using a y-cable OTG with power attached from a dual port USB external battery pack,
and another USB hub with its own y-cable usb auxiliary power with the aux attached to the second port of the USB external battery pack. Seems like overkill but it was the only setup I've used that allows me to run any WiFi attacks without reboots.
But this is incredibly cumbersome and if I so much as bump the OTG y-cable at the Nexus port something loosens and I get a freeze followed by a reboot! Very frustrating.
I am able to use a Edimax nanao USB WiFi dongle with the y-cable OTG and no aux power at all with the attacks and no reboots/freezes but again if that cable comes loose for a second at either point I get a freeze and reboot :(

2014-12-11, 11:14
I'm experiencing the same issues as the previous posters, using a Nexus 7 2013 flo 4.4.4 with a TP-Link WLAN dongle. If I unplug the dongle the tablet freezes for a few seconds then it reboots.

2015-01-16, 03:20
This may be some good news. On a Nexus 7 2013 LTE:

1. Ensure that you have the most up-to-date Kali via apt-get upgrade / dist-upgrade
2. Disable Wi-Fi via Settings GUI and reboot
3. Get into terminal and check that you don't have any wireless interfaces
4. Plug in your dongle and do stuff
5. Unplug... no reboot!

It appears that having the "native" active wlan interface switched on is the culprit. Which is probably an ok workaround if you have an LTE version on 3G/4G depending on what your needs are.

2015-09-18, 02:45
Was hoping this would work. While wireless card still dead as a doornail on my Nexus 7 2013. No one else have any luck? Running 5.1

2015-10-14, 16:00
I have to say i experience the same issue on only on my Nexus 7 2013 Wifi and One Plus Phone, but it's very stable on my Nexus 7 2012 Wifi, which is the same Android version 4.4.4.

2016-04-03, 14:14
Hello, i dont see interface wlan1 using Nethunter 3.0 and android 6.0.1 kernel version 3.4.0-g8ba2631 with TP linkWn722N card, anyone having the same issue ?