View Full Version : Flashed NetHunter - No WiFi, No HID, No fun :(

2014-09-27, 12:37
Bought a 2013 Wifi Nexus 7 after seeing the Nethunter release.

Arrived yesterday. Didn't think it made sense to do the multiple Android updates so left those alone and tried to flash.

Lots of driver faff and no luck, updated Nexus to 4.4.2, PdaNet drivers worked and flashing worked, got a lovely Kali background on my Nexus now.

Unfortunately that's about all I've got. Built in wifi isn't working - I don't mean for doing random hackery I mean for anything. Attempting to turn wifi on in the normal way just results in a screen stuck on "Turning on Wifi"

HID attacks, as per the you tube videos don't work - I know metasploit needs a receiver out on the net I'm talking about that, I should be able to run the attack and see the commands enter on the target system I'm plugged into via the OTG cable but I get nothing. I plugged the cable into my mac too with terminal running to see if there was any keyboard input coming from the Nexus when I attempted to run it. Nothing happened.

I am a sad panda.

2014-09-27, 14:05
Thats what you get for not following installation instructions. You *should* have updated to latest 4.4.4 as instructed. Re-flash and start over using NRT.

2014-09-27, 15:40
I used the Nexus Root Toolkit to set the nexus back to stock but this time using the 4.4.4 image.

Then followed the nethunter installation tutorial again from the start, continuing to use the pdanet drivers.

It's working correctly now. My advice to others, make sure your Nexus is up to date before you try to install

2014-09-27, 19:12
NetHunter need 4.4.3 or 4.4.4 rom !


2014-09-27, 23:16
i think kali NetHunter works only on 4.4.3 ~ 4.4.4 based ROMS

2014-09-28, 02:29
You should be using 4.4.4. Different firmware for wifi drivers in 4.4.2 and below.