View Full Version : Sound in VNC Kali Desktop

2014-10-08, 06:29
This was submitted by 0E800:

In case you want to have sound work on the Kali Xfce Desktop here is fix / work-around.

The short of it is I could not get pulseaudio to work. Some error in main.c and the daemon not being able to run.

You will have to install iceweasel and vlc. You will need to remove pulseaudio and install alsatools instead. You will need to change the vlc settings to use alsa mixer as default.

Info adapted from: http://linuxg.net/how-to-properly-replace-pulseaudio-with-alsa-on-crunchbag-linux-and-debian-squeeze/

From Kali terminal (no need to do this from within vnc)
killall pulseaudio
apt-get remove pulseaudio pulseaudio-utils gstreamer0.10-pulseaudio libpulse-browse0 paman pavumeter pavucontrol
(some packages might not be installed so wont be removed)
rm ~/.pulse-cookie
rm -r ~/.pulse
apt-get install alsa-base alsa-tools alsa-tools-gui alsa-utils alsa-oss alsamixergui libalsaplayer0 iceweasel vlc

Make VLC run as root:
sed -i 's/geteuid/getppid/g' /usr/bin/vlc

Reboot device

Open VNC connection to Kali Xfce Desktop
Open VLC
Goto Tools -> Preferences
Click on Audio tab/button
Change Output module dropdown to: ALSA audio output
Change Device dropdown to: tegra rt5640 Default Audio Device
Exit Vlc.
(might need to restart device)
Audio should now play through speakers.

This has only been tested on Nexus 7 - 2012. It should work for other devices, however Device might vary.


0E 800
2014-10-08, 19:41
I notice that using Iceweasel that there still is no sound in youtube. Above works for getting sounds to work in vlc.

ding( . Y . ) dongle
2014-11-07, 01:05
I have the same question. My previous phone was a pantech 9070, and I could run backtrack 5 on it through vnc. Had touch screen desktop. I haven't been able to do that with nethunter. Maybe I'm missing an image file