View Full Version : Kismet and gps

2014-10-12, 08:36
Had a little problem getting internal gps to work on nexus 7 2013 Lte with kismet, not sure if its an issue or user error on my part. Incase it helps any one else out after googling around i found that in root terminal. gpsd -N -n -D5 tcp://localhost:4352 . And then launching kismet enabled me to get a lockon and use gps.

2014-10-12, 08:41
i got this error

root@kali:~# gpsd -N -n D5 tcp://localhost:4352
gpsd:ERROR: unable to connect to the DBUS system bus
gpsd:ERROR: device open failed: No such file or directory - retrying read-only
gpsd:ERROR: read-only device open failed: No such file or directory
gpsd:ERROR: initial GPS device D5 open failed
gpsd:ERROR: TCP device open error can't connect to host/port pair.
gpsd:ERROR: initial GPS device tcp://localhost:4352 open failed

2014-10-13, 19:28
To get GPS you need to start Bluenmea with bluetooth enabled. Then you can run from kalimenu (under wireless).

2014-10-13, 19:42
For me nexus7 2013 lte.
1. Make sure location is set to device only and is on.
2. Plug external wifi in(Alfa AWUS036NHA in my case)
3. Open BlueNMEA (havent tried sequence with out opening, so might not be needed)
4. Open kali shell in terminal from kali launcher and enter command gpsd -N -n -D5 tcp://localhost:4352
5. Open kismet from kali launcher. -kali menu in terminal - wireless attacks - kismet.

I have to follow these steps exactly in this order to get gps to work in kismet, sure a more knowledgeable person might have a simpler way. :-)
P.s i found this method on a few different sites aimed at the pawn pad, each version slightly different.

ignore-- this i broke something again. Binky is as always correct. On other nexus it works fine. On this one not so good.