View Full Version : Persistence not working

2013-04-16, 19:44
I found FIXME document which is located from /lib/live/boot and it says in ;


live-boot is moving from a monolithic script into a proper
plugin architecture for better maintenance and customization.

Additionally, this will allow us to abstract initramfs-tools
integration to also support other initrd generators, such as

Unfortunately, from a developers point of view, we could no
finish this in time for wheezy, but we will finish this for
jessie. Please excuse the sorry state of the 9990-* scripts.
From a users point of view, it doesn't matter at all though.

Scripts overview

00xx initramfs "bootstrapping"

0xxx live-boot internals

1xxx find and mount rootfs

2xxx find and mount persistence

3xxx anything after that involves read or write access to the rootfs

9xxx FIXME

Have you any idea about this thanks?

2013-04-18, 18:24
Ok, i found that in commands df; and create related missing files, finally thats ok. Every settings, and created documentations were there,fine; but i'll try to setting laptop keyboard settings command which is setxkbmap tr ( done with sudo). If it will ok, i'll inform asap. Thanks

2013-04-18, 18:37
Ok i tried keyboard config settings; but unfortunately just keyboard settings haven't saved. Ofcourse i dont want to every time set from terminal, and still looking related salvations.

2013-04-18, 23:32
Still i couldnt find resolve of that problem about setxkbmap tr command, i would like to use it default settings; but still continue like previous settings. By the way, ive written down related resolves of that persistence problem, but system didnt post that. So im writing again,

Check first from terminal which code must be, df> than you can see related problems such as missing files etc. After that, you go to the File system> root > create "lib" file > create "live" > create "mount" > create "overlay", "persistence" and finally "rootfs" files > go to first persistence file > than create again two files which must be "sdb1" and "sdb2" > than go back to rootfs file > create "filesystem.squashfs". Thats all. And you can check again from terminal with df command, and you will see no missing files, and problems; and also im still waiting this keyboard problem what i couldnt set default "setxkbmap tr" command every boot and From system settings > regional settings which is Turkish.( This Language problem doesnt save when i go back regarded side) Thank you.