View Full Version : Problem copying files to root, also aircrack-ng related problem.

2014-10-24, 21:13
Okay, so I had some .cap files from using airodump-ng on my laptop and wanted to transfer them to the Kali NetHunter root directory. However, it says I have no permissions to do so. I've tried editing folder permissions but that doesn't work either.

I had to end up settling and copying them to /sdcard/Download/files.cap

This is related to aircrack-ng because when I try to point towards those .cap files in the Download folder, it gives me an error "network could not be found, check your bssid", but the bssid is correct. If I point aircrack-ng to the Kali NetHunter root directory where the cap files are automatically stored, it works fine, no bssid error. So I know the bssid isn't the problem.

So, any way to copy the files to Kali NetHunter root? Or make aircrack not give an error when pointing to a different filesystem?

Thanks, Tortimer

2014-10-25, 19:11
You failed to mention to *where* you tried to copy the files originally. The Kali chroot is at /data/local/kali-armhf/

2014-10-25, 23:53
I tried copying the files to the /root directory of Kali Nethunter. I was using the file manager interface to do this, however, and no files were shown and copying wouldn't work. While booted into Kali Nethunter /root is the same directory as the one you provided. When I view the files with 'ls' they are the same.

I didn't try copying the files to /data/local/kali-armhf/ while not booted into kali nh, as I fixed the problem a different way, but that could work as well.

Maybe I wasn't booted into Kali Nethunter in the terminal so the filesystems weren't mounted thus I couldn't see or copy to the root directory.

I ended up fixing it by booting into Kali Nethunter in a terminal, and using the 'cp' command to copy the files from /sdcard/Download/files.cap to /root , now I can 'ls' and see the files present in my root directory of Kali Nethunter.

Aircrack-ng should work now, I will test later this evening to confirm the error has been fixed.

Thanks for the help.

2014-10-31, 23:21
Aircrack-ng did indeed work after successfully moving the .cap files to the appropriate (root) directory of Kali Nethunter, which is /data/local/kali-armhf/ if you aren't booted into Kali Nethunter, or just /root if you are already booted into it. I successfully cracked my network password with the .cap files so all is well now!

Hopefully if someone else encounters a similar issue this can help a bit.


2017-01-02, 14:43
If anyone want to use /root browser with the pre-installed File Manager PCManFM...then, open the start menu and then System Tools then right click on File Manager PCManFM and then choose properties and then open Desktop Entry and then modify the command and add "sudo -i" at the starting of the default command...there you have a root browser with no need to download anything.😎