View Full Version : Edimax EW-7811UN

2013-04-17, 13:50
I'm having a really difficult time getting my Edimax EW-7811UN wifi USB card to work correctly with Kali Linux. It sees the wireless networks but when I attempt to connect it hangs, and ultimately disconnects. Also - the availability of wireless networks is inconsistent. One minute it shows 3, the next none, and then just one.

Message while it's connecting/hanging: requesting a wireless network address for **insert wireless network name**

I'm running Kali as VM using VMWare Fusion on a Mac and set everything up so that it doesn't use the Mac's wifi connection in bridged mode.

I verified that Kali recognizes the USB card by comparing my wireless options in network manager when it was plugged in/out. Everything checks out.

The Edimax manual is nothing short of useless. Opinions on the web seem mixed - some people recommend downloading the drivers from Realtek's website, others recommend various utilities and/or restarting network manager. The card seems fairly popular with Backtrack, as well as other distros.

I tried restarting network manager. Restart went fine but it didn't change anything. The card is recognized, so I don't think it's a driver issue.

my iwconfig readout:
IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thr=2347 B Fragment the:off
Encryption key:off
Power Management:off

Airmon-ng start wlan0 readout: interface: wlan0 chipset: unknown driver: rtl8192cu - [phy4] (monitor mode enabled on mon0)

2013-04-18, 01:43
This is not an answer to your question, but there is an onkyo branded ar9271 about the same size as edimax in Amazon for about $14. Best of all, it's plug and play out of the box with Kali. Just something to consider

2013-04-18, 10:37
Thanks Clearday.

Problem solved & fixed. Remove network-manager and replace it with wicd. Found my answer here: http://www.cianmcgovern.com/getting-the-edimax-ew-7811un-working-on-linux/

The trick is to apt-get remove as well as purge any trace of network-manager (including pptp & gnome variants) and to replace that with wicd. The second step is to download the drivers from the realtek site (www.realtek.com.tw). Initially I had issues with my WPA2 being invalid but that was before I removed and purged network-manager. Network-manager prevents logging on with a WPA2 password. I see a lot of people just downgraded their passwords to WEP in order to fix that - FAIL!

When all is said & done, I had some issues but a combination of restarting wicd multiple times as well as rebooting the system several times did the trick. My Edimax card is connected to the guest OS only - no more need to bridge it.

I have a spare laptop I installed Kali on as well (natively) and the card worked out of the box using WICD. The only thing I had to do was to manually configure the preferences in the app (not the config file) and indicate my preferred wireless card as being wlan0, and not eth1 (which is was my built in wifi).

One last thing: I did add the following to my interface files on both machines:

nano /etc/network/interfaces

auto eth0
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet dhcp

2013-04-20, 20:24
Hey av3,

Are you using the edimax with aircrack? I've had heck of a time getting the 8192 driver to work. It's detected by kali when I type in lsusb and modprobe, but not in iwconfig. Is this true for you as well, or did that tip from the link you provided fixed it?

2014-04-24, 17:39
it seems like iwconfig sees the adapter but I cannot use it in airmon-ng. Running "airmon-ng start wlan0" shows no monitoring interface:
# airmon-ng start wlan0

Found 3 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!
PID Name
1507 dhclient
1905 NetworkManager
2214 dhclient

Interface Chipset Driver