View Full Version : Installing through Virtualbox?

2015-01-08, 22:58
edit: maybe this should be moved to the installation board.

Greetings everyone.

So I just acquired a second hand Nexus 7 GSM (2012) model.

I'm relatively noobish, but I think I followed the instructions. I'm in dev mode, have USB debugging enabled, MTP and PTP are off.
I don't have Kali installed "physically", only Ubuntu, XP and 8.1, but I have a Kali VBox for learning purposes.
Long story short: it seems many people have driver issues with the Nexus and I ran into it as well. (on XP and 8.1)

I reckon I could try it with a live Kali, but apparently all available flash media in the house is unreliable and I don't want to risk damaging eithe my PC or my tablet.
Now, VirtualBox has this ability to let virtual machines access USB devices directly, but my tablet is not showing up.

I know this is not the nicest workaround, but I'm pretty short on cash and can't buy memory right now. Also, figuring this out is much more fun :D

2015-01-09, 09:47
Raingloom, do you mean problems with the the windows nethunter installer or the root kit?

2015-01-09, 23:36
The recommended Nexus Root Toolkit. It does not recognize the device at all. I can connect it on any OS using MTP. (haven't tried PTP)
It does show up in the Device Manager (as "Nexus 7"), it also shows in lsusb. I did some further thinking though and maybe I could install it through Ubuntu if I had the right packages. Ofc, I'd prefer Kali for this, but I made 2 live USBs installs (both onto a microSDHC card, once with a cable extender, once without), neither booted, even though I managed to boot it before on the same PC.

2015-01-09, 23:39
In the meantime I've found this.
Is this enough for Nethunter? Do I need the exact same packages as Kali provides?

2015-01-10, 13:40
I'm using Kali with VMware Player and it works perfectly to detect my Nexus 7 2013 flo (using different versions of Windows, but it works on my Kali install without vmware as well).

2015-01-11, 00:18
Maybe it's not VirtualBox's fault. I re-checked it and Ubuntu is not working either. Maybe it's the Nexus's fault after all. Is it factory reset time?