View Full Version : MITMf Error

2015-02-03, 02:30
This is what I get when I try to start MITMf from the Kali NetHunter Menu in Terminal....

Enter Interface: wlan0
Enter Gateway IP:
Enter Target IP:
Beef-xss is running. Will load autobeef...
/usr/bin/kalimenu: line 469: cd: /opt/MITMf: No such file or directory
Logs saved to /captures/sslstrip/mitmf.log

python: can't open file 'mitmf.py': [Errno 2] No such file or directory
2|u0_a155@flo:/ $

If anyone knows how to fix this than please post a response. I checked the directory and there is most definitely not a directory named MITMf in /opt. I went as far to edit the kalimenu file and switch it to use MITMf in /usr/bin or /sbin and changed the command line to just MITMf and not MITMf.py. Also had to change some of the switches because it did not recognize some of them, such as --iface and -w I think it was, but in the end it failed (not at my nexus at the moment, sorry for some of the guessing).

2015-08-20, 03:13
I get the same error, you solved? Someone?

2015-09-11, 05:21
I am also having problems getting mitm going. Can anyone clue me in?

2015-09-11, 18:05
Says something about magic domain. And install cert on client machine???

2020-01-13, 10:36
create folder "logs" in the mitmf folder.