View Full Version : update kali chroot error: postgresql service start fail!

2015-02-07, 15:25
in Kali Launcher --> Update Kali chroot, everything is OK, except postgresql and metasploit
At first, it says directory "/var/lib/postgresql/9.1/main" has group or world access, permissions should be u=rwx.

Then I change the permission to 700: chmod -R 700 main, still fail. It says: /usr/lib/postgresql/9.1/bin/pg_ctl start ... FAIL!!

What's the problem? Anyone knows?

2015-02-13, 02:25
Idk what causes the issue but I run into it every time there's a metasploit update. If it happens in the future, after you get the error run "service postgresql start" then "apt-get upgrade -y" and it should work fine. Like I said it happens to me every time msf updates but this works for me every time. Good luck.

2015-04-16, 07:22
I literally had to flash Nethunter 3-4 times before postgresql started to work.

2015-04-16, 20:44
Just do a:

service postgresql start

Then run chroot update again.

That should fix it. It did mine :)