View Full Version : mana-toolkit not working - no ssl logs

2015-02-11, 06:11
I'm running into some issues with mana-toolkit that I would really appreciate any insight into.

I have a fresh install of nethunter 1.10 installed on a fresh install of android 4.4.4 on my nexus 7 2013 with a TL-WN722N adapter. I have followed the instructions exactly and have also ran the Update Kali chroot when it was finished. Also, I am booting the device, then plugging in the wifi adapter. I found that if I boot it with the adapter already plugged in it has wlan0 and wlan1 switched.

I modified the following files using the Nethunter app:

interface: wlan1
SSID: Internet


When launching "Start mana" from the app, I do see the "Internet" SSID on my other devices. On my nethunter I do not see anything in the /var/lib/mana-toolkit/sslstrip.log or sslsplit-connect.log, nor anything in the lamb_braai or sslsplit folders.

I then tried to manually launch the tool.

I modified the following files on the cli:



I then started it by running "./usr/share/mana-toolkit/run-mana/start-nat-full.sh". I found the same result as before. The "Internet" SSID is broadcast. And there is nothing in the /var/lib/mana-toolkit/sslstrip.log or sslsplit-connect.log, nor anything in the lamb_braai or sslsplit folders. Also, I've noticed that it seems to be "stuck" on on STA were it will show the normal broadcast response and generated SSID response, but it only shows 1 MAC address... I am testing this in a room that has about 5 or 6 different wifi devices in use.

If you have any ideas, please let me know. I have a feeling that it's some noob mistake I'm making somewhere.


2015-02-23, 00:02
EXACTLY the same with me ..... i hope someone help..............

2015-04-13, 12:16

This is Dominic, one of the creators of MANA. I'm a little unsure of what interfaces you have going on, you seem to use eth0, wlan0, and wlan1 all at the same time. As far as I know nethunter shouldn't give you an eth0 which may be your first problem?

In general, when debugging, what helps is to run start-noupstream.sh first and see if you can get that working. As an aside, if you edit the start-*.sh file it will make the appropriate interface changes in the hostapd configuration for you.

MANA doesn't always grab every device in the vicinity depending on what the device is, what it's PNL contains, and what the user is doing at the time. Try with one device to hand connect to the Internet SSID and check if you get the captive portal with noupstream. From there try get nat-full working once you're sure of the right upstream interface (usually wlan0 on the Nexus 7).

2016-11-13, 12:26
i'm using nethunter mana on nexus 5 on wlan0 (connected to internet) and upstream to wlan1 which is a TP link dongle via OTG for rogue ap. However every time I run it I get dns2proxy error invalid argument wlan1 and unable to route ipv6. It also turns hostapd and apache off in services. Any ideas would be greatly appreciated?