View Full Version : Nexus 10 Nethunter freezeing

2015-02-18, 07:46
Well been checking out Nethunter, installed on my nexus 10 everything went smooth , but when i open a terminal and start working nethunter will freeze up and i have to reboot it,happens constantly,do i need to post any logs let me know and ill post up i just don't know i'm not receiving errors it just quits on me and freezes

or i'll have Apache , ssh and metasploit services going when i try to use open terminal cant seem to run any commands or get things started and it freezes. any ideas why this is happening thought nexus 10 could handle it.

i may have to purchase N7 N5 seems like everyone using it , and there be more support i cant find really anything on google or anywhere for answers to any of my ?'s and went to github nethunter found a few things,an

found few things on other blogs such as

fixing when you try to start a shell session on Kali NetHunter your terminal will show a prompt like this # u0_a183@hammerhead:/$
# su
# bootkali

should fix that problem.

but the freezing is another ?

2015-02-24, 21:51
results of /proc/last_kmsg >> /sdcard/crash.txt

Also when inside msf: show exploits it will load them, then freeze up and screen goes black have to hold power down for reboot.
every now and then i can get it to load up and play around with metasploit but so far only about 5mins uptime before it freeze (only sometimes) most times within 1 min or 2 ,and i get frustrated and set it down for awhile and try again search for solutions.

made a couple of vidios i will post video/videos of whats its doing shorty.
wifte wont open via terminal menu ,but will open up via gui menu, metaspoilt same thing just loads up then freeze reboot, i can vnc and play around a little longer but it will do same freeze reboot.

Binkybear ? you think i should factory reset unroot ,then start over or just wait an see hat can be done.

Here is what is happening to me on
Nexus 10
android 4.4.4
Fresh install of Nethunter
used wuggs tool kit to unlock and root
then kalinethunter nexus10 Windows installer to install ,but i skipped the unlock as i was already unlocked did everything else
followed all it said do and installed fine seems to work fine till i start trying to use nethunter tools

Nethunter has unfortunately stopped working,and will just keep saying that tll i reboot.


if i start ssh and metasploit via gui menu
then run metasploit it may or may not load if it does load it will freeze my nexus either go black and reboot or i have to reboot.

wifite will not load via terminal menu,but will load and find wifi card via gui menu.

i can vnc to a kali desktop run armitage but it to will soon freeze and have to reboot

kismit works,wifite works,most of the tools work NP im not sure if tcpdump is working it just pops up then gone instinly same for all tools in that menu.

info tools all work spiderfoot ,recon.ect

opvas don't work.

set tool kit works but did freeze once

not sure if beef is working right.

have tried open vpn yet.

and if i go to settings then create metasploit user and database, only thing i can type is exit and it starts setting up user exit ,password exit, database exit, weird as ****.

here are then newest crash logs. , Pastebin

crashlog6 http://pastebin.com/raw.php?i=FB3BUKpc

crashlog7 http://pastebin.com/raw.php?i=d6bjFm82

here is video of what its doing


ohh lol its upside down ,some of its not lol srry but it still show's whats up.

hope this was ok to post.
cr1p70 commented 12 hours ago

Just did this last night, a complete factory reset an unroot and did complete reinstall of nethunter using only the windows installer skipped all but the last option and installed + root ,went smooth ,and updated all via terminal apt-get update && apt-get upgrade && apt-get dist-upgrade all good,did chroot update all good,
started up metasploit everything good, tried to use it bam froze!

New Crash and log found errors here is log:
running out of memory how in tha!

2015-03-01, 07:18
:cool:Much Respect! and Thanks! gos out to Binkybear for the Help in Resolving this issue...


How to fix metasploit and other tools crashing on nexus 10

1-First off we follow these directions from http://www.nethunter.com/
to unlock/root/install Kali Nethunter to our Nexus 10.

Install With windows installer
2-Open installer follow directions ,Now we install Google drivers once installed properly
& you turn USB debugging "ON" Hit "about tablet,hit build number 7 times, go back open developer options check USB Debugging is ON if not check the box and a box will pop up on tablet just check that box.

3-Now go and cut "MTU OFF", on your Nexus10 go to Settings ,storage ,upper right hand corner 3 little dots click them "uncheck MTU"

Make Sure DRIVERS install correctly! an USB Debugging ON!,an MTU OFF! OR!

quoteing this pic on a tut for kalipwn on another forum,forum user posted **** was funny but true!!

Now your Install will go smooth .

4-so with that out the way we Hit Next and Follow the rest of the directions in the Installer, if you have all ready unlocked your nexus10, then you can skip UNLOCK if you are already Stock android you can skip GO BACK TO STOCK as well . & hit INSTALL+ROOT But If you are NOT unlocked an stock then you need to follow ALL instructions!

Once you Have Kali Installed,Reboot.

5-Now its time to Update,Start postgresql First before updating because of metasploit,
"Service postgresql start" then you can apt-get update && apt-get upgrade && apt-get dist-upgrade
and chroot update kali

6-OK, so that's done. now to get Metasploit and other Ram intensive Tool's to run properly we need to make a swap Partition on our Nexus10,

we open terminal type "Su" without quotes that will put us in a ADB Shell root@manta: we don't want that,
so type "bootkali" an it will put us in a Kali shell,, root@kali if it don't say root@kali you need to reboot and do it again or it wont work.

Ok Swap file is recommended to be stored in /var and we will call it : “swapnethunter.img”, also we must set file permissions to 600 so none of the other users could use or read the file, this can cause problems to the system memory.

Write following commands:

root@kali:/# cd /var
root@kali:/var# touch swapnethunter.img
root@kali:/var# chmod 600 swapnethunter.img

Step 3. Set size for the Swap file

Now you should set Swap size , Swap can be set to 1Gb, if you have 1Gb of Ram, swap can be set to 2Gb,1Gb of swap, should be enough RAM.

Now we will fill the swap file with some size,and we will fill it with 1Gb of memory, follow the commands:

root@kali:/var# dd if=/dev/zero of=/var/swapnethunter.img bs=1024k count=1000
1000+0 records in
1000+0 records out
1048576000 bytes (1.0 GB) copied, 4.0868896 s, 287 MB/s

After command, we will have to wait a minute, and we will get the results that bytes have been copied and at what speed rate.

Step 4. Initialize Swap filesystem

Follow the commands:

root@kali:/var# mkswap /var/swapnethunter.img

Setting up swapspace version 1, size = 1020 GiB
no label, UUID=72761533-4bbe-316g-v02e-c0ssbe4cfdf2

If you got similar result, it means that swap was initialized.

Step 5. Enable Swap

To enable swap we will have just to turn it on, to check if it’s enabled type "free"
root@kali:/var# swapon /var/swapnethunter.img

Now you will have to type that last command in, each and every boot till i can figure out how to auto run it for your swap file to be activated on each boot. .

Now Metasploit and few other things that had problems will work as they should without crashing,

You can also read above to be able to change the ram specs on nexus10 from 268 to 468 if you need to,
so far i changed to and have left as 468 and no problems.

any problems just post up here i'm no guru but i will do my best to help out...

By the way this my first Tutorial ever! so give me some slack if not perfect lol hope it helps someone..

Again Much Respect! and Thanks! gos out to Binkybear. for the Help in Resolving this issue.


2015-03-31, 07:01
hello excuse my English and thanks for your excellent work (only one metasploit problem)

* 1-installed Nethunter 0 problems and Nexus7 2012 wifi on kitkat 4.4.4
* 2-for then updated kali necessary (OK)

apt-key adv --keyserver hkp://keys.gnupg.net --recv-keys 7D8D0BF6(OK)

3-then I will update with 0 problems through menu launcher --- kali kali update chroot (OK)

* 4-Installing openvas

a. apt-get update && apt-get install -y openvas --force-yes

b. openvas-setup && openvas-scapdata-sync && openvas-certdata-sync && openvas-check-setup && openvas-stop

c. openvasmd --create-user=admin --role=Admin

d. openvasmd --user=admin --new-password=NEWPASSWORD

e. openvas-start

openvas perfect (OK)

* 5-Metasploit
* to start msfconsole is fully restarted Nethunter
* I do try creating swap memory(

root @ kali: / # cd / var
root @ kali: / var # touch swapnethunter.img
root @ kali: / var # chmod 600 swapnethunter.img

root@kali:/var# dd if=/dev/zero of=/var/swapnethunter.img bs=512k count=500

root@kali:/var# mkswap /var/swapnethunter.img

root@kali:/var# swapon /var/swapnethunter.img

to initiate restarts mfsconsole Nethunter (error)
starting from scratch without openvas also restarts, cm-11-20141112-SNAPSHOT-M12-grouper.zip also tested restarts, tested with different sizes of memory swap file sharing

Will there be another solution?