View Full Version : Alfa card not recognised on Nethunter running on Nexus 4

2015-02-23, 10:42
Hello Everyone,

I'm interested in hearing from those who have successfully managed to get their Alfa card to be recoginzed on a Nexus 4 and what you had to do to get it working.

I'm running the following setup:
Android version 4.4.4
Kernel: 3.4.93-hells-Core-b47-OTG

Dmesg doesn't show that the card is even recognized.


N4 Nethunter
2015-02-24, 18:30
same here i tried using TP-LINK TWN722N
airmon-ng / dmesg does not recognize it

2015-03-13, 10:45
Same TP-LINK dongle. Am I supposed to do some configuration first? Because I can't figure out any way to connect it.

2015-03-13, 11:04
So I've been able to determine through testing that there is an issue with the existing kernel recognizing a Y OTG cable. I've been reading threads online that suggest to update to Ziddey's Kernel (http://forum.xda-developers.com/nexus-4/orig-development/usb-otg-externally-powered-usb-otg-t2181820), which I've done.
While the OTG cable is now recognised, as is the Alfa card (and seen through the lsusb command), the on-board wifi has stopped working AND the new wireless Alfa card doesn't have an wireless interface.
I hope this info does help someone. If anyone can advise on how to get a wireless interface for the Alfa card, it would be much appreciated.


2015-03-13, 21:07
Related im not sure but as one of my longer distance adapters required more power and restarted my n7. I decided id be impatient and make/solder two cables together. One end that plugs into the otg adapter and then into the nexus. One end into a power adapter and the last into the wifi adapter. While i was making it i tried disconnecting the power cables coming from the nexus and just giving power from the wall adapter. As expected it needed the power cables from the nexus also. Measuring the output from the cables i was happy nothing was getting burnt out. And all was good. I suppose the hole point is raingloom how are you connecting your adapter to your n4? And roki you said the alfa card was recognised did you bring the card up? If memory serves me right, ive had other fish to fry recently and havent had the time nethunter deserves i spennd on it. Isnt there an option in the nethunter terminal to enable/disable or bring up an interface. As always im most probably rambling and quite possibly wrong. Hope It helps some how.

2015-03-15, 17:57
I'm using a regular OTG cable, not a Y. I'm not really an expert so I mostly just followed tutorials. Most people say that this model works "out of the box".
'dmesg' shows that it recognized that something was connected, but then immediately gives two error messages (something like "p2p0 config error") and I don't recognize anything in lsusb as my adapter.

I tried a guide where the op had the same adapter and they used some config file, but I got no result. Also, my original config file was different than the one in their example. Then again, it was a pretty dated tutorial, so, eh.
It uses some command called "wpa_supplicant"(?).

Afaik, my TP-LINK adapter does not need as much power as the Alfa. It also worked flawlessly on my Ubuntu desktop, I did not yet try it in Kali though.

2015-03-16, 04:17
Hello, I bought a nexus 4 last week to use nethunter with but only found out about the pathetic OTG problem when trying to get it working with nethunter. This is the kind of issue I thought reviewers might mention, but apparently not. If any devs who edit the main site are reading this it would be nice if there was a little warning next to the part where it says the Nexus 4 is supported about this hardware issue. I had dreams of a neat little otg cable with a wifi adapter strapped to the back of my phone, now if I actually get otg working I'll be walking around with a bundle of cables!

The issue doesn't seem related to nethunter because I tried flashing to stock android 4.4.4 then installing 4.4.x [aosp r7] from here. (http://forum.xda-developers.com/nexus-4/orig-development/usb-otg-externally-powered-usb-otg-t2181820)

This fixes OTG (tested using a USB drive), but breaks internal and external wifi!

On a page of the ziddey OTG fix thread (http://forum.xda-developers.com/nexus-4/orig-development/usb-otg-externally-powered-usb-otg-t2181820/page59) a guy posted this;

First I have noticed like my Wifi function had been disabled, flashed it like twice times and it fixed the wifi error.

I tried flashing the ziddey script two or three times but no success, but I'm not sure if that's what jcagara08 means. And I think that comment was posted about Android 4.2/4.3 anyway, but it sounds like the same problem.

I'm going to keep looking into this and will post here if I manage to get any further.
Please post a warning on the nethunter site so other people don't have to deal with the Nexus 4 OTG dance!

2015-03-16, 04:27
I'm using a regular OTG cable, not a Y.

Raingloom, if you are using a Nexus 4 you will have no luck with a regular OTG cable. You have to use a y cable with an external power source (I'm using a little anker external battery) and then get ziddeys hack working.

This is ziddeys thread;

Be careful, when me and roki flashed his patch it disabled wifi.


Looks like the ziddey hack was last updated just after the 4.4.2 release. Anybody looking for a quick temporary fix might be able to flash to 4.4.2 and get the hack and possibly nethunter working, but I think you will be leaving your device open to some pretty nasty SSL bugs which leave you vulnerable to MITM.

N4 Nethunter
2015-03-16, 14:06
i just bought a brand new otg cable for £5
and it doesnt work
ive tried 2 different adapters alpha and tplink

help !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

2015-03-16, 18:20
Having owned the n4 for quite a long time I will tell you this it will not provide power to devices that r OTG'd to it. How can you expect the device to work without power? You require an OTG ycabe the Y will provide power to the device you are connecting to your phone. It will not also charge your phone. A simple OTG cable will not work for N4...the end. I also thought about trying this on my n4 had just backed everything up but it seems it is not really working with this newest 1.1 version. At least it installs now but many are reporting that the tools in nethunter arent working so dont see the point. My phone is 3/4 way there already having run custom roms for ever so I hope that they continue to support n4 by fixing. Seems like an older version of nethunter was working with a custom kernel in one of the threads I found here

2015-03-16, 21:49
Come on the #nethunter freenode IRC, I'm going to attempt to get both OTG and nethunter working by trial and error.


2015-03-17, 20:26
Come on the #nethunter freenode IRC, I'm going to attempt to get both OTG and nethunter working by trial and error.


Sorry I was late to the party. Im at work currently. Any luck?

2015-03-18, 21:30
MrBones, no, I'm using the 2012 LTE Nexus 7. Idk, maybe my problem is not directly relevant to this thread?
Still, counting power issue out, it should work, right? (anywho, I don't want to derail from the title, I'll post another thread with this specific issue)

EDIT: reinstall fixed it somehow. (exact same Nethunter version)