View Full Version : (Guide) Installing fglrx 14.12 (omega) on Kali 1.1.0

2015-04-18, 00:38
Hey guys,

I was asked for a write up on installing the new(ish) omega drivers on Kali linux. There are a couple of ways to do this, the easiest I found was using the Debian experimental repo.

Now, everyone should know just how bad using a non-kali repo is. It's made much, much worse by using an experimental repo. This repo can and will break your install. Don't say I didn't warn you.

Lets get started.

1. Update Kali. If a new kernel is installed, reboot after this command.

apt-get clean && apt-get update && apt-get upgrade && apt-get dist-upgrade

2. Install headers

apt-get install linux-headers-$(uname -r)

3. Add the debian experimental repo

nano /etc/apt/sources.list

add the line:

deb http://ftp.debian.org/debian experimental main contrib non-free

4. Update

apt-get update

5. Install the driver (notice that apt-get is a little different when using an experimetal repo)

apt-get -t experimental install fglrx-driver fglrx-atieventsd fglrx-control

6. You're going to see an error, it will fail to build. You would also get this (amoungst others) if you tried to install from the driver on the ATI website.

Error during install:
Building initial module for 3.18.0-kali3-amd64
Error! Bad return status for module build on kernel: 3.18.0-kali3-amd64 (x86_64)
Consult /var/lib/dkms/fglrx/14.12/build/make.log for more information.

7. Lets fix that error

nano +834 /var/lib/dkms/fglrx/14.12/build/kcl_acpi.c

change the line so it reads what is below. Make sure you keep the leading #


8. Rebuild the module

cd /var/lib/dkms/fglrx/14.12/build


cp /var/lib/dkms/fglrx/14.12/build/fglrx.ko /lib/modules/3.18.0-kali3-amd64/kernel/drivers/video/

9. Update module dependencies and the such

depmod -a

update-initramfs -u

aticonfig --initial

10. Remove the debian experimetal repo

nano /etc/apt/sources.list

remove the line:

deb http://ftp.debian.org/debian experimental main contrib non-free

11. Clean up

apt-get clean && apt-get update

12. Reboot

shutdown -r now

13. If you open the amd control center from the menu, you should see 14.501 (which is omega) loaded on the information screen.

2015-04-19, 07:51
and i try to solve that problem by:

sudo apt-get remove systemsettings
sudo apt-get install systemsettings

with no luck please i need help brother

2015-04-20, 17:24
nice tutorial to install fglrx driver.Thank you:):)
but system settings are not working,if you could provide a fix for that that would be great:(:(
Thumbs up

2015-04-20, 19:57
Hey guys,

I need error messages, screen captures and output of dmesg. I can't really help if all I'm told is that it won't work.

2015-04-21, 04:38
I am new to kali and dont understand advanced stuff(like what you asked for :P).To my knowledge i'am providing screenshots of system-settings

tell me what to do to get you error messages and get you those screenshots!!

2015-06-24, 13:38
Before I try this, would it matter if I'm on a laptop with a hybrid ATI/Intel GPU set up? I have a full install on an SSD. Its an intel and Radeon 8790M gpu. In case anyone out there is curious. ..don't get a laptop with this set up.

2015-07-27, 04:50
First thank you for the detailed write up. I have a dell Inspiron 15 3000 series that is an AMD A6 box. I have Kali 1.1 up and goign but I have thus far had nothing but issues in trying to get any accerlated driver going.

A few questions. I followed the instructions. In Step 6 I never got an error. The built went through.

Additonally, this concerns me "3.246723] platform microcode: firmware: failed to load amd-ucode/microcode_amd_fam16h.bin (-2)"

yes I have gone through apt-get purge fglrx* several times. On boot however I get nothing but a cursor and No X.

I am curious if we are not supposed to unload or blacklist another driver prior to this?

I have tried the Kali rep fglrx set, The offical driver from ATI/AMD and your process. What is interseting is the driver seems to be loaded however again no X and I get errors related to aticonfig --initial that state no supported driver.

So what am really running?

VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Device 9851

From what I can see , as long as I have a clean slate to start with YOUR process should work correctly however oddly it does not.

Cleanup does not remove dkms or libfglrx:i386 so I am not sure if I am in a loop with that or the firmware issue???

Any suggestions?

2015-08-14, 18:57
Hey can you post the same tutorial for Kali 2.0??

2015-08-14, 23:06
Hi, thanks you for this tutorial !

Can you help us with the same tutorial but for the Kali V2.0 ?

I tried to install my GPU but got the problem : '' Your adapter is not supported by this driver ... ''


2015-08-21, 05:45
Hi, thanks you for this tutorial !

Can you help us with the same tutorial but for the Kali V2.0 ?

I tried to install my GPU but got the problem : '' Your adapter is not supported by this driver ... ''

use http://unix.stackexchange.com/questions/222661/how-to-install-amd-catalyst-15-7-fglrx-15-20-1046-on-kali-2-0-sana