View Full Version : Terminal wont go into root!?

2015-05-21, 02:43
For some reason when i open up the shell, it is not in root. when i open the shell from the nethunter menu, it is still not in root. Before it said: root@kali and now it says u0_a81@grouper:/ $. Everything was working before. I tired running sudo su but nothing happened. How can i change back to root?

2015-05-22, 01:54
If you open the terminal from outside the Nethunter app you will always see u0_a81@grouper:/ $. because when the Nethunter app launches the terminal shell, it automatically boots the Kali chroot and grants super user permission.

What you need to do is type:

bootkali <--- This will take you to root@kali
kalimenu <--- This will take you to the Kali menu

If you tried that and it's not working, reboot your nexus 7.

2015-05-31, 21:59
I am also facing same issue.tried above commands but not worked.
Show message :
tmp-mksh:kalimenu: not found

2015-06-01, 18:10
do it this way :

first write :

su root
and press enter

then write only in terminal :

and press enter

then let us know what happened

2015-06-02, 12:32
u0_a85@grouper:/ $ su root
root@grouper:/ # bootkali
root@grouper:/ # kalimenu
tmp-mksh: kalimenu: not found
127|root@grouper:/ #

2015-06-02, 17:12
if you have any terminal app on your device then try this :

cd system/bin

2015-06-04, 13:52
Thanks a lot pedropt for your reply..
Unfortunately it is still not resolved.
u0_a85@grouper:/ $ su
root@grouper:/ # cd system/bin
root@grouper:/system/bin # bootkali
root@grouper:/system/bin # kalimenu
tmp-mksh: kalimenu: not found

Please help me and get me out of this issue.

2015-06-06, 17:54
I am trying to figure out if your kali installation is completely wiped or just the start up scripts .

Check if you have this directory structure in your device .
http://s16.postimg.org/k2nmmjywh/hunter1.jpg (http://postimg.org/image/k2nmmjywh/)
http://s15.postimg.org/il7hz3wg7/hunter2.jpg (http://postimg.org/image/il7hz3wg7/)

in case you have then for some reason the startup scripts could be missing from your bin folder .

Get a file explorer to check if you still hve nethunter in your device .

2020-07-01, 08:27
I had the same problem too but with a bit of trail and error and a bit of thought. I tried this:

sudo su

It worked! Let me know if it does for you too.

2020-07-13, 17:09
Maybe this helps. I installed Magisk Manager. From there, I can provide superuser permissions to Terminal.