View Full Version : Kali 2.0: Config Armitage, Cobaltstrike, Beef to run without Errors romote & hprciot

2015-08-17, 17:54

A Video Howto over

- Config Beef to run with Metasploit
- Eliminate Error's by insert Cortana Script "beef_strike.cna" Error: /beef/remote & hpricot
- Config Armitage / Cobaltstrike to use Beef
- smal demo

I recommend you them others Videos they show how to use Cobaltstrke with Beef to pentest

Video: Config Armitage, Cobaltstrike and Beef to run without Errors


Video: Pentest with Cobaltstrike, Beef and Subterfuge Part 1


Video: Pentest with Cobaltstrike, Beef and Subterfuge Part 2



2015-08-18, 08:04
Thanks ozzy, great work.

2015-08-20, 01:09
Ozzy, How Can I Install Subterfuge on kali 2.0?

2015-08-20, 16:48
Ozzy, How Can I Install Subterfuge on kali 2.0?

Suberfuge need Jango 1.5, kali have installed ver. jango 1.7
I have not tried it on 1.7 to get started, I have only now fast tried to run Subterfuge! (on kali 2.0)

Install Subterfuge:



dpkg -i subterfuge_1.0-1_all.deb

apt-get update && apt-get -f install

pip uninstall django==1.7

- Rename the folder jango to jango_ORG in /usr/lib/python2.7/dist-packages

pip install django==1.5

I have not tested whether the other Progs run right! But you can unstinstall 1.5 an install 1.7


2015-08-20, 23:11
Thank you for that and for tutorial, its works for me.
But i have a little problem with Armitage, when i load any script Armitage stucks.

2015-08-24, 16:37
Thank you for that and for tutorial, its works for me.
But i have a little problem with Armitage, when i load any script Armitage stucks.

Hi Jacky

these are almost too many infos to help you.. but I will try it

Go to /????/cortana-scripts-master/beef_strike -> open beef_strike.cna with a editor, on the top of beef_strike.cna you have some "import ....blabla... .jar
Download the jar.Pack here http://ow.ly/JMx09 place the files at the right place or change the path to the rigt place of the jar scripts.

i hope this help you


2015-08-27, 08:44
Hi ozzy,

this time in english :)

i have some issues with this, too
I use Kali 2.0 with Armitage or Cobalstrike

I did the same thing as you in your video with the script from https://github.com/rsmudge/cortana-scripts/tree/master/beef_strike
Also corrected the paths at the beginning from the script to the files from http://ow.ly/JMx09

I made some Screenshots:

When i load the msgrpc i get the first error at the cobaltstrike console. At the gui it says that the msgrpc started.
After that i start the beef server. all good at this time
Now i switch to cobaltstrike back to enter load beef, beef_connect ... and beef_online. After that i go up to the menu tab and go to connect.
Then i recieve a message that this action can take some minutes. Cobaltstrike freeze at this point.
I can see at the console from cobaltstrike (in the background) that he has got problems with a JSON object.

I cant figure it out whats the problem here. I think we have different beef_strike.cna scripts. I also have a extra menu tab and a different script header.

Do you have an idea?

thank you very much

Many greetings and Servus ;)



2015-08-27, 18:46
Hi Kellerkind

Yes i have in the Video a older ver. of Cortana Script, but i have testet also with new version...

sorry you have right the new ver. of Cortana Script make error, i have testet it for a week without this errors and now a have the errors too, i wait for cobaltstrike 3.0 that appear end of november 2015. Until now i have no solution for this errors.

I would have gladly helped more

cheers an Servus ozzy

2015-08-28, 06:48
Hi ozzy,
thanks for you fast answer.

I figured out a way with the new script: Only interact with the gui. Means you must not enter load beef, beef_connect ... and beef_online and also dont load the msgrpc at the begining.

Just start cobaltstrike --> then go to the menutab BEef --> Start --> Control BEef service --> START
Then open a console --> cd /usr/share/beef-xss and start beef with ./beef -x -v
Then go to cobalstrike back Menutab BEef --> connect and enter the ip , beef, beef
After that you can see in the cobalstrike console (in the background) the same error BUT you will notice that the beef console will load the modules. After 20-30 sec you will get the feedback that all files are loaded.

The api key will entered by itself by the way.

Cheers and Servus