PDA

View Full Version : Problem with sound



kaju666
2013-03-13, 17:15
Today i installed Kali amd64 and sound is not working corectly.
when i run some movie in vlc i hear distorted and breaking sound.

i'm on Acer Aspire V5-571G

any help?

balding_parrot
2013-03-13, 22:10
You need to provide alot more info than that to get any kind of meaningful reply

alist3r
2013-03-14, 03:42
kaju666

try issuing this command in a console:


lspci -vv -m -k

paste it inside a pastebin.com paste bin and share the link w/us.

I would kike to check it out in order to discard any known kernel module / hardware issues currently unsolved in kernel or something like that.

kaju666
2013-03-15, 13:43
ok here you are: http://paste.org/62618

im not using vlc but i cant even use temaspeak or watch youtube.

// Edit: in some weird way sound just start working corectly

wurmt0ngue
2013-03-18, 14:39
I have a very similair issue on an Acer Aspire 5742-6814

From power on and for about 5-10 minutes, I get crackling in my speakers . It continues if I toggle mute on and off and also if I adjust the volume to 0. Its not a huge problem but its about 10 minutes of annoyance.

http://pastebin.com/iwcH2N2H

this is what my lspci printout looks like

Psychotogen
2013-03-18, 22:01
I'm having a similar issue with an Aspire, I have sound and video though. My video is through mirrored HDMI, but the sound is still coming from the laptop. I looked for an HDMI sound extention and couldn't find anything. Is this just the wrong driver maybe? When I go into sound configuration, it lets me choose between the headphone jack and the internal speaker of the laptop. There should be another option in there, I think.

Malachai
2013-03-19, 23:32
I had the same issue I hear something but you can't make sense .. it breaks up and choppy...

I have the intel Cor 80801aa ac'97 audio controller (rev 01)

Nerdra9e
2013-03-23, 04:38
1. Fix problems with Glitches, voice skips and crackling In file /etc/pulse/default.pa its necessery to substitute the line;

load-module module-udev-detect

with

load-module module-udev-detect tsched=0

Nerdra9e
2013-03-23, 13:09
1. Fix problems with Glitches, voice skips and crackling In file /etc/pulse/default.pa its necessery to substitute the line;

load-module module-udev-detect

with

load-module module-udev-detect tsched=0

Coolworld9
2013-04-22, 11:59
Problme:
Im using Kali, and was having problems with Sound in VLC - Glitches, voice skips and crackling " Extremely Distorted Audio "
I found that for some reason if i muted and unmuted the sound after i began playback it fixed the audio distortion.. But that gets annoying real quick!
I tryed:
#1:
"sudo gvim /etc/pulse/default.pa"
then used Find/Replace to change " load-module module-udev-detect" with " load-module module-udev-detect tsched=0 "
Save & Exit

This Fixed the static, Distortion, Echo, dramticly. However I still had speaker Crackles.
Also I read that this fix can possibly break sound for other applications ( like "Wine")

I also Tryed:
#2
"sudo gvim /etc/pulse/daemon.conf"
then used Find/Replace to change "; enable-remixing = yes" with "enable-remixing = yes"
(removing the comment out)
Save & Exit

This had Absolutly no effect on my system
So anyways I Changed both files back to thier original.

Heres How i fixed the issue with vlc ( maybee it will help someone else)
My VlC Sound now works 90% of the time perfect.
Sometimes it still Lightly crackles but so far it always fixes itself in shorter then 15 seconds..i think i can live with this.

Opened VLC
and then "Tools" then "Prefrences" Then "Audio"
Went to "Output Module" and experimented with each option "closing and re-opining vlc each time."
"Open Sound System" is what worked for me..

This is the best working fix I've found on my "HP Pavilion Dv7" with
Device: 00:14.2
Class: Audio device
Vendor: Advanced Micro Devices [AMD]
Device: FCH Azalia Controller
SVendor: Hewlett-Packard Company
SDevice: Device 3591
Rev: 01
Driver: snd_hda_intel

I hope this Information helps someone out there.
If anyone finds a "Real","Complete" Fix I Would be Gratefull for a "Msg / Email"

--Good Luck--

Ramachandran
2013-05-28, 08:38
hey actually i too had a same problem ,but now there is no crack no noise or no disturbances...Actually i had made some changes to my etc/pulse files a while ago.. but i dont remember what changes i had actually done...anyway i am giving out the links from pastebin for each file in etc/pulse which u can copy directly to your mentioned folder (After taking backup of your original files),if u want u can compare the changes i have made later,for your understanding sake.. :) here are the files:-

client.conf - http://pastebin.com/r30rekNG
daemon.conf - http://pastebin.com/kPNzbJEt
default.pa - http://pastebin.com/KUdnCA7J
system.pa - http://pastebin.com/cPjn5S6U

And ya do tell if u are facing any problems :) :D have a great day

Napi
2013-07-30, 01:17
It works!

Thank you very much for your help. From the onset, I couldn't find why Kal Linux sounded sooo overmodulated/clipped in any audio app.


1. Fix problems with Glitches, voice skips and crackling In file /etc/pulse/default.pa its necessery to substitute the line;

load-module module-udev-detect

with

load-module module-udev-detect tsched=0

Balaji Akurati
2013-12-29, 15:06
Resolve this
goto Applications-->System Tools-->Preferences-->Startup Applications-->Add-->Name: Pulseaudio-->Command: /usr/bin/pulseaudio-->Comment: Start the sound | save it
Now redoot the system It works

tr00n3r
2014-01-15, 20:55
EXCELLENT!!!!
Thanks for this fix! annoying cracking is gone!


1. Fix problems with Glitches, voice skips and crackling In file /etc/pulse/default.pa its necessery to substitute the line;

load-module module-udev-detect

with

load-module module-udev-detect tsched=0

bond benz
2014-01-16, 15:44
You need to install your driver first in your os , if don't found in google snd_hda_intel for linux , you can install it from software center
apt-get install software-center
then search for snd_hda_intel and install it
then
reboot , choose your output driver in sound Preference , with right click on sound icon and it's okay.

rsj5277
2014-06-11, 07:53
currently i am using Hp pavilion 15-e026ax notebook.

I have Kali 1.0.7 with 64 bit arch.

now my problem is when i play any song, videos etc.

i heard a irritated sound by the speaker or in my headphone.and after few second everything is OK.

and when i fast-forward the video or song the same sound came for few second.

every time when i do this the same sound came forward.

so plz help me to solve that problem.

hear i paste some information link http://pastebin.com/2hCs96Ur

Thanks in advance

my mail id is sun5277@mail.com

hashmaster
2014-06-30, 05:24
hey actually i too had a same problem ,but now there is no crack no noise or no disturbances...Actually i had made some changes to my etc/pulse files a while ago.. but i dont remember what changes i had actually done...anyway i am giving out the links from pastebin for each file in etc/pulse which u can copy directly to your mentioned folder (After taking backup of your original files),if u want u can compare the changes i have made later,for your understanding sake.. :) here are the files:-

client.conf - http://pastebin.com/r30rekNG
daemon.conf - http://pastebin.com/kPNzbJEt
default.pa - http://pastebin.com/KUdnCA7J
system.pa - http://pastebin.com/cPjn5S6U

And ya do tell if u are facing any problems :) :D have a great day

Got a cheap mini dell 1010 from work because the windows was corrupt. Decided to put kali linux on it and the sound was super choppy. It was on and off like every half second. this made it so much better. Sound play back is normal now. Thank you.

Kip_Hackman
2014-07-03, 03:30
Hey guys, I've been struggling with this issue for several hours over the course of the last couple nights - I have sound, but it's really distorted and every sound effect seems to echo/repeat. I'm using the on-board sound card on my asrock z97 mobo, Realtek ALC892. The sound works fine when I boot kali on my Dell laptop.

When I go to System Settings > Sound > Hardware and select Built-in Audio, click "Test Speakers", then click the "Test" button under either the Front Left or Front Right speaker, I hear "FRONTFRONTFRONT LEFTLEFTLEFT" and it's really choppy. Normal notification tones like when I should get a beep from the terminal sound like sound effects from an original NES game. I've tried everything in this post along with a bunch of other suggestions I found by googling which I didn't document because I was being impatient. I tried to install the latest drivers from the Realtek site, but after getting past the errors about not having installed kernel sources/headers I started getting more vague errors that I couldn't figure out.

Can anyone put me on the path to my next troubleshooting step?

cokis
2015-01-16, 17:59
I made the two steps and I reboot my laptop, and now it does not sound bad or cut. It sounds great. :D
My laptop it's an Asus EeePC 1201HA http://www.paste.org/76888
A lot of thanks Coolworld9 you realy help me.
Good luck. ;)

Roguenite
2016-12-14, 21:06
For anyone who comes here for answers, I managed to redirect sounds from laptop to hdmi output by just going to Control panel->Sound settings and selecting hdmi instead of laptop speakers.

raitu
2016-12-27, 17:17
lspci -vv -m -k


I got this as output for the command

Device: 00:14.2
Class: Audio device
Vendor: Advanced Micro Devices, Inc. [AMD]
Device: FCH Azalia Controller
SVendor: Hewlett-Packard Company
SDevice: FCH Azalia Controller
Rev: 01
Module: snd_hda_intel

I tried commands like systemctl --user enable pulseaudio && systemctl --user start pulseaudio
still no sound.. Please help