View Full Version : Anyone using RTL8192CU-based USB WiFi with aircrack/wifite in Kali Linux?

2013-04-26, 02:23
If so, which linux/compat wireless driver are you using? I am asking because while the RTL8192CU is detected and wifite is running, WEP cracking is slow and does not complete, and WPA handshake are not happening.

When testing with RTL8187 and AR9271 based USB WiFi, WEP cracking happens within minutes and WPA handshakes almost instantaneously, so clearly it is a driver issue.

If you use the RTL8192CU (EDIMAX 7811, ALFA AWUS036NHR) are you using the default drivers in Kali or have you downloaded and installed an alternate driver to make aircrack/wifite work with it? If so, which version and download link?

I'm kind of surprised that the RLT8192CU has been out for quite awhile, and yet it is still not completely working with pen testing tools in Backtrack or Kali.

2013-05-04, 13:41
I am having the same problem.

I downloaded a driver from Realtek... 8192cu... I am able to connect to my network.

But it's not working with airmon-ng.

Does anyone make it work with RTL8192CU ?????

I am using ALFA AWUS036NHR

2014-02-26, 06:59
Any update to this clearday?

I would like to know the answer to this as well. It seems like ubuntu has no problem compiling the driver provided by realtek. However, not so much with Kali/backtrack

2014-03-04, 22:07
I'm using Edimax EW-7811UN with Kali on Raspberry Pi, the problem is that airmon-ng shows nothing.
Any ideas?

2014-03-09, 02:47
I'm using Edimax EW-7811UN with Kali on Raspberry Pi, the problem is that airmon-ng shows nothing.
Any ideas?

I am so glad this was already posted!
I, too, have the Realtek USB dongle (tee-hee) and while my host will recognize it as a valid connection (Mint Debian), my Kali-in-a-box will not.
I've tried multiple drivers from different sources.
Airmon-ng gives me nil.
Wicd gives me nil.
Even the box settings themselves seem to bug out about it.

So, I guess I just feel like I am missing an obvious step and it's driving me nutso!

2014-05-18, 22:04
hello mate i got same eproblem about awus036nhr v2 on kali too working inside vmwae ... i see it and its unknown same as i sow in your info you shared .... my question brother did you found a soluton for it mate plz reply me .... if you got solution iam searching about 4 dasy and no solution for it ....