View Full Version : build.py and the release option

Bob The Marauder
2016-10-03, 14:43
I am trying to breathe NetHunter Life into an old Nexus 7 2012 tablet I plan to use for a few wifi jobs and some bash scripting fu plus possible VNC. If I install Lollipop 5.1.1 and the latest NetHunter image, I have time to go and make cups of coffee between tapping the screen and something useful happening. As this is not practical, I want to run Kitkat 4.4.4 as the reaction time is actually fast enough to stop me needing to get my laptop out whenever I want to do something involving more than three taps.

Problem is, there is no image listed for Kitkat any more. Nevermind I thought, I'll just build it myself and sure enough, after cloning the kaliNethunter git repo (including bootstrap.sh for all the historic versions), I was able to build and flash the latest version of NetHunter to Kitkat using
python build.py -d grouper -kk --rootfs minimal. Apps such as csploit seem to work fine which is great. What is not great is that Kali Terminal does not open. Well, it does open but then dies immediately with 'FATAL Kernel too old'.

Tried again, this time with
python build.py -d grouper -kk --rootfs minimal --release 3.0
Same error, so tried with
--release 2.0 then
--release 1.21 and finally
--release 1.0 but I get the same version of NetHunter every time.

Looking at the source code for build.py, I only find references to "release" here https://github.com/offensive-security/kali-nethunter/blob/master/nethunter-installer/build.py#L480-482 and here https://github.com/offensive-security/kali-nethunter/blob/master/nethunter-installer/build.py#L515-516 which suggests that "release" is only used for naming purposes and is not tied in any way to actual releases of NetHunter.

Does anybody know either how to build a previous version of NetHunter or where I can get previous images of NetHunter from for KitKat my Nexus 7 2012 wifi model, please?

Just for reference, the tablet will have no personal information on it, so even with the security issues in KitKat, I don't care. The functions I need to run are really simple and have been present since version 1.21 of NetHunter if not earlier. For such simple tasks, I do not want to go out and buy a new tablet when I have this sitting around gathering dust and know that had I installed a few years ago, it would have worked!

Bob The Marauder
2016-10-25, 14:02

After experimenting with compiling my own kernel and failing due to some github download never completing, I tried different ROMs and managed to hit success with Cyanogen Mod 12.1 coupled with the Pico size version of gapps (http://opengapps.org/) for the 5.1 ARM kernel. After installing these, I was able to get a reasonably snappy version of Android that essentially runs the 5.1 (Lollipop) kernel underneath.

After that, I simply downloaded the Lollipop version of NetHunter for my Nexus 7 2012 (wifi) from https://www.offensive-security.com/kali-linux-nethunter-download/ and installed via TWRP.

For full details, I followed the Cyanogen Mod guide for installing on my Nexus 7 https://wiki.cyanogenmod.org/w/Install_CM_for_grouper but when it suggests adding the gapps zip file to the device, I also sent across the NetHunter one.

When installing, only install CyanogenMod and gapps, then boot into Cyanogen and set up the tablet.

After that, go back to recovery mode and choose to install the NetHunter zip and, once in the installer, be sure to check the box for SuperSU (after you have finished making your choices, the rest takes quite a long time to finish, especially when creating rootfs for NetHunter, so be patient).

After your device reboots, click on the NetHunter app, grant it superuser permissions, set up the Hacker's Keyboard and NetHunter terminal (another grant superuser) and then you are good to go.

Unfortunately my story has a sad ending. After days of messing around with different ROMs, my Nexus 7 decided that it didn't want to charge any more. If I plugged it in to power, it would maintain its current battery level but that was all. I could unplug it and use it but any drop in battery charge was permanent even with vanilla installs of Lollipop or KitKat. I tried the "turn off, connect to power, boot to recovery mode, select power off, disconnect charger then reconnect power" trick a few times but no joy. Last week, I re-installed Cyanogen Mod 12.1, Gapps Pico and Nethunter, then let the remaining 2% of the battery drain and finally put it to rest.