View Full Version : How to start Android tools like adb and fastboot?

2013-04-27, 10:00
Hey guys,

I installed Kali last week to play with it. It runs pretty well, it feels very solid. And it is Debian :-) My last OS was Linux Mint (Nadja). I had the Android SDK installed lately, using adb and fastboot as root straight out of their folder. Now with Kali they won't start. Nowhere.

I tried most I could think of: I updated and upgraded, I went into the platform-tools directory tried starting them from there, I tried with and without ./ as root and not as root... Nothing happend, it's always a No such file or directory error.
Somewhere, I read that both .bashrc file(s) can fulfil my wettest dreams ;) but after I put this line at the end, nothing happens:

export PATH=${PATH}:/usr/share/android-sdk/tools:/usr/share/android-sdk/platform-tools

This is actually the path where adb hangs around.

Here's something funny:

root@host:/usr/share/android-sdk/platform-tools# adb
bash: /usr/share/android-sdk/platform-tools/adb: No such file or directory
root@host:/usr/share/android-sdk/platform-tools# ls
aapt aidl dexdump fastboot llvm-rs-cc renderscript
adb api dx lib NOTICE.txt source.properties

What do I have to do?
I can't start adb from the folder neither as user nor as root. I'm sure I missed something...

2013-04-27, 16:14
Ah, meanwhile I figured it out. It wasn't my fault, here (http://bugs.kali.org/view.php?id=135) ist the Bug an a solution by glavcho in the bugtracker. Simply put this in the Terminal:

dpkg --add-architecture i386
apt-get update
apt-get install ia32-libs
apt-get install lib32ncurses5

adb does work then. However, I encountered an error while pushing a custom ROM to my Nexus 7. It won't push when I was in the bootloader/fastboot mode, the error message was, that there is no such device. Since fastboot devices showed it, I booted in the TeamWin Recovery Project mod (http://teamw.in/project/twrp). Then I could adb push <zip> /sdcard/ - install it and boot the system.

Maybe this helps someone else too :D

2013-04-27, 19:41
LOL ran into same problem. lmk whats up?