View Full Version : Live USB creation for 8,2 Macbook Pro, EFI problems

2013-04-29, 03:21
Kali Version


8,2 Macbook pro

Notable Software


Hello everybody, I attempting to make a bootable live Kali USB drive for my Mac. I am aware that Apples Proprietary version of EFI makes any attempts to boot anything essentially a living ****. First I tried using DD from the terminal in OSX. The files were successfully copied over but my machine could not recognize nor boot from the device. I then reformatted the flash drive and attempted to use unetbootin, this also did not yield a bootable drive. Refit did show a USB device with linux but simply hangs when I select it. Next, I tried the instructions from this site http://forums.kali.org/showthread.php?271-How-to-EFI-install-Kali-Linux. When I simply used the bootx64.efi file in addition to my grub.cfg (I used his provided code) I received an image not found error very similar to this:

rEFInd - Booting OS

Starting bootx64.efi
Using load options ' '
Failed to open \EFI\BOOT\grubx64.efi - B00000000000000E
Failed to load image
Failed to open \EFI\BOOT\MokManager.efi - B00000000000000E
Failed to load image
Error: Not Found returned from bootx64.efi

* Hit any key to continue *

Accepting this would just throw me back to the Refit screen. Following this attempt I added Mokmanager.efi and grubx64.efi to the /EFI/Boot/ folder as well. Now when I selected the bootx64.efi option in refit I would be taken to a grub shell and I am not familiar with navigating one of those so that held me up, selecting grubx64.efi would also drop me into a grub shell and Mokmanager would simply present me three options (I apologize but I do not remember them) and all three simply returned me to the refit screen. This entire time Refit also showed a linux device on USB but would hang if that was selected. Lastly, if it matters once I added bootx64.efi and Mokmanager.efi if I held in the option key the Mac bootloader would show a EFI device but would simply drop me to a grub shell if I selected it. Sorry if this is overly wordy, I appreciate any help that can be provided and together I hope maybe we can find a solution so that those of us foolish enough to by macs (like myself) can still enjoy this very useful OS.

2013-08-24, 00:43
i'm having the exact same problem, toshiba satellite (newer model). i'm gonna try to download those 2 files its complaining about from ftp://mirrors.kernel.org/fedora/releases/18/Fedora/x86_64/os/EFI/BOOT/ and put them in /efi/boot/ and see if it works - ill let you know...

2013-08-24, 01:00
yeah, it didn't work, but it DID get me further, however, i could gave gotten there just as easily from copying the /efi/boot/ from debians net installer or xubuntu's installer. i get dropped to a grub prompt now, which is another topic, so, no need to continue it here. fwiw, i also copied debian's /boot/ directory to the kali usb, and actually got a boot screen, but, it was a debian menu with a kali background image - it didn't work. good luck, and check out that main thread here: http://forums.kali.org/showthread.php?271-How-to-EFI-install-Kali-Linux