View Full Version : Another VirtualBox problem

2013-03-20, 19:59
Hello Foks :D

First to say, congrats on the Kali, it rocks :cool:

I managed to install virtualBox but when i run it (inside terminal to see the warning messages) it launches the gui successfully and do the usual tasks, but it gives me the following warning:

WARNING: The character device /dev/vboxdrv does not exist.
Please install the virtualbox-ose-dkms package and the appropriate
headers, most likely linux-headers-686.

You will not be able to start VMs until this problem is fixed.

The thing is that i can't do any task, no adding new vm successfully neither launching an old one that i have, ofcourse i tried to do what the warning message told me to do, so what i did is:

1- when checking the device mentioned it isn't there --> /dev/vboxdvr
2- when i try to install virtualbox-ose-dkms it tells me that it's the newest version
3- the linux headers 686 also are the newest version

so basiclly i did nothing :( ,i just got stuck !

What to do now ? do i delete it ? :D